DM3068数字万用表编程手册

DM3068 Digital Multimeter Programming Guide

This manual is used to guide users to program and control DM3068 digital multimeter using SCPI commands via remote interfaces.

DM3068 digital multimeter can communicate with the PC through various remote interfaces such as USB, LAN, RS232 and GPIB. For more information of the usage of each remote interface, refer to User's Guide for DM3068.
Note: the end mark of the command sent through RS232 interface is "\r\n".

Contents of this Manual

  • Introduction to the SCPI Language : introduce the syntax, meaning of symbols, parameter types and abbreviation rules of SCPI commands.

  • Command System: introduce in detail all the commands supported by DM3068.

  • Programming Demos: introduce how to write remote operation program using Visual C++, Visual Basic and LabVIEW development languages to control the multimeter to realize common functions using SCPI commands.

  • Command Quick Reference A-Z : list all the commands supported by DM3068 in alphabetical order to facilitate user's quick search.

  • Appendix: list those commands in Agilent34401A and Fluke45 Command Set that are not compatible with DM3068.

  • Contact Us

Declaration

RIGOL products are protected by patent law in and outside of P.R.C.

RIGOL reserves the right to modify or change parts of or all the specifications and pricing policies at company’s sole decision.

Information in this publication replaces all previously corresponding material.

RIGOL shall not be liable for losses caused by either incidental or consequential in connection with the furnishing, use or performance of this manual as well as any information contained.

Any part of this document is forbidden to copied or photocopied or rearrange without prior written approval of RIGOL.

© 2010 RIGOL Technologies, Inc. All Rights Reserved.


SCPI简介

Introduction to the SCPI Language

Syntax

Symbol Description

Parameter Type

Command Abbreviation


命令格式

Syntax

SCPI commands present a hierarchical tree structure and contain multiple sub-systems, each of which is made up of a root keyword and one or more sub-keywords. The command string usually starts with ":", the keywords are separated by ":" and are followed by the parameter settings available, "?" is added at the end of the command string to indicate query and the command and parameter are separated by "space".

For example,

:TRIGger:AUTO:INTErval?
:TRIGger:AUTO:INTErval <value>

 TRIGger is the root keyword of the command. AUTO and INTErval are the second-level and third-level keywords respectively. The command string starts with ":" which separates the multiple-level keywords. "?" represents query and <value> represents parameters available for setting. The command :TRIGger:AUTO:INTErval and parameter <value> are separated by "space". The form of representation and the type of the parameter are different in different commands. For detailed information, refer to the introductions in Symbol Description and Parameter Type.


符号说明

Symbol Description

1. Braces { }

The parameters enclosed in the braces are optional and are usually separated by the vertical bar "|". When using the command, one of the parameters must be selected. The braces are not sent with the command.

2. Vertical Bar |

The vertical bar is used to separate multiple parameters and one of the parameters must be selected when using the command. The vertical bar is not sent with the command.

3. Square Brackets [ ]

The content (parameter or keywords) in the square brackets can be omitted. If the parameter is omitted, the instrument sets the parameter to its default value. The square brackets are not sent with the command.

4. Triangle Brackets < >

The parameter enclosed in the triangle brackets must be replaced by an effective value. The triangle brackets are not sent with the command.


参数类型

Parameter Type

1. Bool

The parameter could be "OFF", "ON", "0" or "1". For example,

:CALCulate:PF:STATe <bool>

:CALCulate:PF:STATe?

Wherein,

<bool> can be set to {{0|OFF}|{1|ON}}

The query returns "0" or "1".

2. Discrete

The parameter should be one of the values listed. For example,

:CALCulate:FUNCtion <math>

:CALCulate:FUNCtion?

Wherein,

<math> can be set to NONE|REL|DB|DBM|MIN|MAX|AVERAGE|TOTAL|PF

The query returns "NONE", "REL", "DB", "DBM", "MIN", "MAX", "AVERAGE", "TOTAL" or "PF".

3. Integer

Unless otherwise noted, the parameter can be any integer within the effective value range. Note that do not set the parameter to a decimal, otherwise errors will occur. For example,

:UTILity:INTErface:GPIB:ADDRess <gpib_addr>

:UTILity:INTErface:GPIB:ADDRess?

Wherein,

<gpib_addr> can be set to any integer between 0 and 30.

The query returns any integer between 0 and 30.

4. Real

The parameter can be any real number within the effective value range and the real parameters can be decimal, scientific notation, MIN, MAX or DEF. For example,

:CALCulate:DB:REFErence {<value>|MIN|MAX|DEF}

:CALCulate:DB:REFErence?

Wherein,

<value> can be set to any real number between -120 to +120 or be set to MIN, MAX or DEF.

The query returns a real number in scientific notation.

5. ASCII String

The parameter should be the combinations of ASCII characters. For example,

:UTILity:INTErface:LAN:MASK <ip_address>

:UTILity:INTErface:LAN:MASK?

Wherein,

<ip_address> can be set to nnn.nnn.nnn.nnn, wherein, nnn is any number between 000 and 255.

The query returns ASCII character string.


命令缩写

Command Abbreviation

Since all commands are case-insensitive, you can use any of them. But if abbreviation is used, all the capital letters in the command must be written completely. For example,

:FUNCtion:RESistance

can be abbreviated to

:FUNC:RES

For commands containing number, the abbreviation rule is: input the corresponding number after inputting all the capital letters. For example,

:FUNCtion2:VALUe1?

can be abbreviated to

:FUNC2:VALU1?


命令系统

Command System

DM3068 digital multimeter supports RIGOL DM3068 command set and is compatible with Agilent and Fluke command sets. Wherein, Agilent command set contains Agilent34401A command set and its expanded command set; Fluke command set refers to Fluke45 command set. You can use the CMDSet command to switch among those command sets. For detailed method, refer to CMDSet.

Common Command Set

RIGOL Command Set

Compatible Agilent Command Set

Expanded Agilent Command Set

Compatible Fluke Command Set

Note:

Unless otherwise noted, commands relating to instrument parameter setting in this manual do not support setting parameters with units.

Besides, explanations about parameter range and default value in this manual are based on the current software version (refer to the *IDN? command) and are subject to changes without further notice.


通用命令集

Common Command Set

Users can use commands in the common command set to perform corresponding operations no matter which command set (RIGOL DM3068 Command Set, Agilent Command Set or Fluke Command Set) is currently selected. Common command set contains IEEE 488.2 common commands, STATus commands and SYSTem commands. Besides, the CMDSet command used to switch among those command sets is also included.

CMDSet

IEEE 488.2 Common Commands

STATus Common Commands Subsystem

SYSTem Common Commands Subsystem

A part of the commands in the common commands are mainly used to set, query and operate the status register. The status register is composed of Questionable Status Register, Operation Status Register, Standard Event Status Register and Status Byte Register, as well as Output Buffer and Error Queue and its principle is as shown in the figure below. Some commands in IEEE488.2 and SYSTem subsystems can be used to perform corresponding operations on Standard Event Status Register, Status Byte Register, Output Buffer and Error Queue. Commands in STATus subsystem can be used to set and query Questionable Status Register and Operation Status Register.


CMDSet

Syntax

CMDSet {RIGOL|AGILENT|FLUKE}

CMDSet?

Description

This command is used to switch among the command sets of the multimeter.

The query command queries the command set currently used by the multimeter.

Parameter

Parameter | Command Set
RIGOL | RIGOL DM3068 Command Set
AGILENT | Agilent34401A Command Set
FLUKE | Fluke45 Command Set

Return Format

The query returns the name of the command set currently used: RIGOL, AGILENT or FLUKE.

Example

The query below returns RIGOL.

CMDS?

The following command selects Fluke45 command set for DM3068.

CMDS FLUKE


IEEE 488.2通用命令

IEEE 488.2 Common Commands

*CLS
*ESE
*ESR?
*IDN?
*OPC
*OPC ?

*PSC

*RST
*SRE
*STB?
*TRG

*TST?

*WAI


*CLS

Syntax

*CLS

Description

This command clears the event registers in all the register sets and clear the error queue.


*ESE

Syntax

*ESE <value>

*ESE?

Description

This command sets the value of the enable register of the standard event status register.

The query command queries the value of the enable register of the standard event status register.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 0 to 255 | 0

Explanation

The definition of each bit in the standard event status register is as shown in the table below, wherein, bit 1 and bit 6 are not used and are always treated as 0, therefore, the range of <value> are the decimal numbers corresponding to the binary numbers ranging from 00000000 (0 in decimal) to 11111111 (255 in decimal) and of which the bit 1 and bit 6 are 0.

Bit | Weights | Name | Enable
7 | 128 | PON | Power On
6 | Not Used | -- | Not Used
5 | 32 | CME | Command Error
4 | 16 | EXE | Execution Error
3 | 8 | DOE | Device-Specific Error
2 | 4 | QYE | Query Error
1 | Not Used | -- | Not Used
0 | 1 | OPC | Operation Complete

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 144 if bit 4 (16 in decimal) and bit 7 (128 in decimal) are enabled.

Example

The command below enables bit 4 (16 in decimal) of the enable register.

*ESE 16

The query below returns 16.

*ESE?


*ESR?

Syntax

*ESR?

Description

This command queries the value of the event register for the standard event status register set.

Explanation

The definition of each bit in the standard event status register is as shown in the table below, wherein, bit 1 and bit 6 are not used and are always treated as 0, therefore, the query returns the decimal numbers corresponding to the binary numbers ranging from 00000000 (0 in decimal) to 11111111 (255 in decimal) and of which the bit 1 and bit 6 are 0.

Bit | Weights | Name | Enable
7 | 128 | PON | Power On
6 | Not Used | -- | Not Used
5 | 32 | CME | Command Error
4 | 16 | EXE | Execution Error
3 | 8 | DOE | Device-Specific Error
2 | 4 | QYE | Query Error
1 | Not Used | -- | Not Used
0 | 1 | OPC | Operation Complete

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 144 if bit 4 (16 in decimal) and bit 7 (128 in decimal) are enabled.

Example

The query below returns 24 (bit 3 and bit 4 have already been set).

*ESR?


*IDN?

Syntax

*IDN?

Description

This command queries the ID character string of the instrument.

Return Format

The query returns Rigol Technologies,<model>,<serial number>,XX.XX.XX
Wherein, <model> is the model number of the instrument; <serial number> is the serial number of the instrument; XX.XX.XX is the software version of the instrument.

Example

The query below returns:
Rigol Technologies,DM3068,DM3A020100823,01.01.00.01.01.00

*IDN?

Related Commands

:SYSTem:EDITion?
:SYSTem:SERIal?
:SYSTem:TYPE?

SERIAL?（FLUKE）


*OPC

Syntax

*OPC

Description

This command sets the "Operation Complete" bit (bit 0) in the standard event status register to 1 after the current operation is finished.

Related Command

*OPC?


*OPC?

Syntax

*OPC?

Description

This command queries whether the current operation is finished.

Return Format

The query returns 1 if the current operation is finished, otherwise returns 0.

Related Command

*OPC


*PSC

Syntax

*PSC {0|1}

*PSC?

Description

This command sets the power-on status of the enable register.

The query command queries the power-on status of the enable register.

Parameter

Parameter Value | Power-on Status
0 | The enable registers are not cleared at power-on.
1 | The enable registers are cleared at power-on.

Return Format

The query returns 0 or 1.

Example

The command below sets the instrument to do not clear the enable bit of the register at power-on.

*PSC 0

The query below returns 0.

*PSC?


*RST

Syntax

*RST

Description

This command restores the instrument to its default value.


*SRE

Syntax

*SRE <value>
*SRE?

Description

This command sets enable register for the status byte register to generate a service request.

The query command queries the enable register for the status byte register.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 0 to 255 | 0

Explanation

The definition of each bit in the status byte register is as shown in the table below. Wherein, bit 0 and bit 1 are not used and are always treated as 0, bit 6 is no need to set, therefore, the range of <value> are the decimal numbers corresponding to the binary numbers ranging from 00000000 (0 in decimal) to 11111111 (255 in decimal) and of which the bit 0, bit 1 and bit 6 are 0.

Bit | Weights | 名称 | Enable
7 | 128 | OPE | Standard Operation Summary
6 | 64 | RQS | Request Service
5 | 32 | ESB | Standard Event Summary
4 | 16 | MAV | Message Available Summary
3 | 8 | QUES | Questionable Data Summary
2 | 4 | EQ | Error Queue
1 | Not Used | -- | Not Used
0 | Not Used | -- | Not Used

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 144 if bit 4 (16 in decimal) and bit 7 (128 in decimal) are enabled.

Example

The command below enables bit 4 (16 in decimal) of the enable register.

 *SRE 16

The query below returns 16.

 *SRE?


*STB?

Syntax

*STB?

Description

This command queries the value of the event register for the status byte register.

Explanation

The definition of each bit in the status byte register is as shown in the table below, wherein, bit 0 and bit 1 are not used and are always treated as 0.

Bit | Weights | 名称 | Enable
7 | 128 | OPE | Standard Operation Summary
6 | 64 | RQS | Request Service
5 | 32 | ESB | Standard Event Summary
4 | 16 | MAV | Message Available Summary
3 | 8 | QUES | Questionable Data Summary
2 | 4 | EQ | Error Queue
1 | Not Used | -- | Not Used
0 | Not Used | -- | Not Used

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 40 if bit 3 (8 in decimal) and bit 5 (32 in decimal) are enabled.

Example

The query below returns 40 (bit 3 and bit 5 have already been set).

 *STB?


*TRG

Syntax

*TRG

Description

This command g enerates a trigger when the instrument is in "Wait-for-trigger" state.


*TST?

Syntax

*TST?

Description

This command controls the instrument to perform a self-test and return the self-test result.

Return Format

The query returns 0 if the instrument passes the self-test, otherwise returns 1.


*WAI

Syntax

*WAI

Description

This command controls the instrument to wait for the finish of the operation.

Related Command

*OPC


STATus通用命令子系统

STATus Common Command Subsystem

STATus:OPERation:CONDition?
STATus:OPERation:ENABle

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?
STATus:QUEStionable:ENABle

STATus:QUEStionable[:EVENt]?


STATus:OPERation:CONDition?

Syntax

STATus:OPERation:CONDition?

Description

The command queries the value of the condition register for the operation status register.

Explanation

The definition of each bit in the operation status register is as shown in the table below, wherein, bit 1 to bit 3, bit 6, bit 7 and bit 11 to bit 15 are not used and are always treated as 0.

Bit | Weights | Name | Enable
11-15 | Not Used | -- | Not Used
10 | 1024 | LOCK | Instrument Locked
9 | 512 | MTHR | Memory Threshold
8 | 256 | CONF | Configuration Change
6-7 | Not Used | -- | Not Used
5 | 32 | TRIG | Waiting for Trigger
4 | 16 | MEAS | Measuring
1-3 | Not Used | -- | Not Used
0 | 1 | CAL | Calibration in Progress

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 528 if bit 4 (16 in decimal) and bit 9 (512 in decimal) are enabled.

Example

The query below returns 256 (bit 8 has already been set).

STAT:OPER:COND?

Related Commands

STATus:OPERation:ENABle

STATus:OPERation[:EVENt]?


STATus:OPERation:ENABle

Syntax

STATus:OPERation:ENABle <value>

STATus:OPERation:ENABle?

Description

This command sets the value of the enable register for the operation status register.

The query command queries the value of the enable register for the operation status register.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 0 to 65535 | 0

Explanation

The definition of each bit in the operation status register is as shown in the table below, wherein, bit 1 to bit 3, bit 6, bit 7 and bit 11 to bit 15 are not used and are always treated as 0, therefore, the range of <value> are the decimal numbers corresponding to the binary numbers ranging from 0000000000000000 (0 in decimal) to 1111111111111111 (65535 in decimal) and of which the bit 1 to bit 3, bit 6, bit 7 and bit 11 to bit 15 are 0.

Bit | Weights | Name | Enable
11-15 | Not Used | -- | Not Used
10 | 1024 | LOCK | Instrument Locked
9 | 512 | MTHR | Memory Threshold
8 | 256 | CONF | Configuration Change
6-7 | Not Used | -- | Not Used
5 | 32 | TRIG | Waiting for Trigger
4 | 16 | MEAS | Measuring
1-3 | Not Used | -- | Not Used
0 | 1 | CAL | Calibration in Progress

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 528 if bit 4 (16 in decimal) and bit 9 (512 in decimal) are enabled.

Example

The command below enables bit 4 (16 in decimal) of the enable register.

 STAT:OPER:ENAB 16

The query below returns 16.

 STAT:OPER:ENAB?

Related Commands

STATus:OPERation:CONDition?
STATus:OPERation[:EVENt]?

STATus:PRESet


STATus:OPERation[:EVENt]?

Syntax

STATus:OPERation[:EVENt]?

Description

This command queries the value of the event register for the operation status register.

Explanation

The definition of each bit in the operation status register is as shown in the table below, wherein, bit 1 to bit 3, bit 6, bit 7 and bit 11 to bit 15 are not used and are always treated as 0.

Bit | Weights | Name | Enable
11-15 | Not Used | -- | Not Used
10 | 1024 | LOCK | Instrument Locked
9 | 512 | MTHR | Memory Threshold
8 | 256 | CONF | Configuration Change
6-7 | Not Used | -- | Not Used
5 | 32 | TRIG | Waiting for Trigger
4 | 16 | MEAS | Measuring
1-3 | Not Used | -- | Not Used
0 | 1 | CAL | Calibration in Progress

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 528 if bit 4 (16 in decimal) and bit 9 (512 in decimal) are enabled.

Example

The query below returns 256 (bit 8 has already been set).

STAT:OPER?

Related Command

STATus:OPERation:ENABle


STATus:PRESet

Syntax

STATus:PRESet

Description

This command clears the enable registers for the operation status register and questionable status register.


STATus:QUEStionable:CONDition?

Syntax

STATus:QUEStionable:CONDition?

Description

This command queries the value of the condition register for the questionable data register.

Explanation

The definition of each bit in the questionable data register is as shown in the table below, wherein, bit 3, bit 6, bit 7, bit 13 and bit 15 are not used and are always treated as 0.

Bit | Weights | Name | Enable
15 | Not Used | -- | Not Used
14 | 16384 | MEM | Memory Overflow
13 | Not Used | -- | Not Used
12 | 4096 | ULIM | Upper Limit Failed
11 | 2048 | LLIM | Lower Limit Failed
10 | 1024 | CAP | Capacitance Overload/Underflow
9 | 512 | RES | Resistance Overload
8 | 256 | CAL | Calibration Corrupt
6-7 | Not Used | -- | Not Used
5 | 32 | FREQ | Frequency Overload/Underflow
4 | 16 | TEMP | Temperature Overload
3 | Not Used | -- | Not Used
2 | 4 | TIME | Sample Timing Violation
1 | 2 | CURR | Current Overload
0 | 1 | VOLT | Voltage Overload

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 528 if bit 4 (16 in decimal) and bit 9 (512 in decimal) are enabled.

Example

The query below returns 256 (bit 8 has already been set).

STAT:QUES:COND?

Related Commands

STATus:QUEStionable:ENABle

STATus:QUEStionable[:EVENt]?


STATus:QUEStionable:ENABle

Syntax

STATus:QUEStionable:ENABle <value>

STATus:QUEStionable:ENABle?

Description

This command sets enable register for the questionable data register.

The query command queries the value of the enable register for the questionable data register.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 0 to 65535 | 0

Explanation

The definition of each bit in the questionable data register is as shown in the table below, wherein, bit 3, bit 6, bit 7, bit 13 and bit 15 are not used and are always treated as 0, therefore, the range of <value> are the decimal numbers corresponding to the binary numbers ranging from 0000000000000000 (0 in decimal) to 1111111111111111 (65535 in decimal) and of which the bit 3, bit 6, bit 7, bit 13 and bit 15 are 0.

Bit | Weights | Name | Enable
15 | Not Used | -- | Not Used
14 | 16384 | MEM | Memory Overflow
13 | Not Used | -- | Not Used
12 | 4096 | ULIM | Upper Limit Failed
11 | 2048 | LLIM | Lower Limit Failed
10 | 1024 | CAP | Capacitance Overload/Underflow
9 | 512 | RES | Resistance Overload
8 | 256 | CAL | Calibration Corrupt
6-7 | Not Used | -- | Not Used
5 | 32 | FREQ | Frequency Overload/Underflow
4 | 16 | TEMP | Temperature Overload
3 | Not Used | -- | Not Used
2 | 4 | TIME | Sample Timing Violation
1 | 2 | CURR | Current Overload
0 | 1 | VOLT | Voltage Overload

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 528 if bit 4 (16 in decimal) and bit 9 (512 in decimal) are enabled.

Example

The command below enables bit 14 (16384 in decimal) of the enable register.

 STAT:QUES:ENAB 16384

The query below returns 16384.

 STAT:QUES:ENAB?

Related Commands

STATus:PRESet


STATus:QUEStionable[:EVENt]?

Syntax

STATus:QUEStionable[:EVENt]?

Description

This command queries the value of the event register for the questionable data register.

Explanation

The definition of each bit in the questionable data register is as shown in the table below, wherein, bit 3, bit 6, bit 7, bit 13 and bit 15 are not used and are always treated as 0.

Bit | Weights | Name | Enable
15 | Not Used | -- | Not Used
14 | 16384 | MEM | Memory Overflow
13 | Not Used | -- | Not Used
12 | 4096 | ULIM | Upper Limit Failed
11 | 2048 | LLIM | Lower Limit Failed
10 | 1024 | CAP | Capacitance Overload/Underflow
9 | 512 | RES | Resistance Overload
8 | 256 | CAL | Calibration Corrupt
6-7 | Not Used | -- | Not Used
5 | 32 | FREQ | Frequency Overload/Underflow
4 | 16 | TEMP | Temperature Overload
3 | Not Used | -- | Not Used
2 | 4 | TIME | Sample Timing Violation
1 | 2 | CURR | Current Overload
0 | 1 | VOLT | Voltage Overload

Return Format

The query returns an integer which equals to the sum of the weights of all the bits that have already been set in the register. For example, the query returns 528 if bit 4 (16 in decimal) and bit 9 (512 in decimal) are enabled.

Example

The query below returns 512 (bit 9 has already been set).

STAT:QUES?

Related Commands


SYSTem通用命令子系统

SYSTem Common Command Subsystem


SYSTem:ERRor?

Syntax

SYSTem:ERRor?

Description

This command queries the error information of the error queue.

Return Format

The query returns the error information in the format: error number, "error character string".

Example

The query below returns -113,"Undefined header; keyword cannot be found".

SYST:ERR?


SYSTem:VERSion?

Syntax

SYSTem:VERSion?

Description

This command queries the SCPI version number applicable to the instrument.

Return Format

The query returns the character string representing the SCPI version number in the format "YYYY.V", wherein, "YYYY" represents the publication year of the version and "V" represents the number of the version of that year.

Example

The query below returns 1999.0.

SYST:VERS?


RIGOL命令集

RIGOL Command Set

:CALCulate Command Subsystem

:FUNCtion2 Command Subsystem

:FUNCtion Command Subsystem

:MEASure Command Subsystem

:RATE Command Subsystem

:SYSTem Command Subsystem

:TRIGger Command Subsystem

:UTILity Command Subsystem


:CALCulate命令子系统

:CALCulate Command Subsystem

:CALCulate:DB:REFErence
:CALCulate:DB:STATe

:CALCulate:DB?

:CALCulate:DBM:REFErence

:CALCulate:DBM:STATe

:CALCulate:DBM?
:CALCulate:FUNCtion

:CALCulate:PF:LOWEr

:CALCulate:PF:STATe

:CALCulate:PF:UPPEr

:CALCulate:PF?
:CALCulate:REL:OFFSet
:CALCulate:REL:STATe

:CALCulate:STATistic:AVERage?
:CALCulate:STATistic:COUNt?

:CALCulate:STATistic:MAX?


:CALCulate:DB:REFErence

Syntax

:CALCulate:DB:REFErence {<value>|MIN|MAX|DEF}

:CALCulate:DB:REFErence?

Description

This command sets the reference value of dB operation.

The query command queries the reference value of dB operation.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Real | -120dBm to +120dBm | 0dBm

Return Format

The query returns the current reference value of dB operation in scientific notation.

Example

The command below sets the reference value of dB operation to 10dBm (under DCV measurement function).

 :CALC:DB:REFE 10

The query below returns 1.000000E+01.

 :CALC:DB:REFE?

Related Commands

:CALCulate:DB?

:CALCulate:DB:STATe

:CALCulate:FUNCtion


:CALCulate:DB:STATe

Syntax

:CALCulate:DB:STATe <bool>

:CALCulate:DB:STATe?

Description

This command enables or disables dB operation.

The query command queries the current status of dB operation.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 0|OFF

Explanation

This command is only available under measurement functions supporting dB operation.

If the :CALCulate:FUNCtion command selects dB operation, the query returns ON.

Return Format

The query returns ON or OFF.

Example

The command below enables dB operation.

:CALC:DB:STAT 1

The query below returns ON.

 :CALC:DB:STAT?

Related Commands

:CALCulate:DB?

:CALCulate:DB:REFErence

:CALCulate:FUNCtion


:CALCulate:DB?

Syntax

:CALCulate:DB?

Description

This command queries the dB value of the current measurement reading.

Explanation

This command is only available under measurement functions supporting dB operation and when dB operation is enabled.

Return Format

The query returns the dB value of the current measurement value in scientific notation.

Example

The query below returns -5.776204E+01.

 :CALC:DB?

Related Commands

:CALCulate:DB:REFErence
:CALCulate:DB:STATe

:CALCulate:FUNCtion


:CALCulate:DBM:REFErence

Syntax

:CALCulate:DBM:REFErence {<value>|MIN|MAX|DEF}

:CALCulate:DBM:REFErence?

Description

This command sets the dBm reference resistance.

The query command queries the dBm reference resistance.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Integer | 2Ω to 8000Ω | 600Ω

Return Format

The query returns the current dBm reference resistance in scientific notation.

Example

The command below sets the dBm reference resistance (under DCV measurement function).

 :CALC:DBM:REFE 100

The query below returns 1.000000E+02.

 :CALC:DBM:REFE?

Related Commands

:CALCulate:DBM?
:CALCulate:DBM:STATe

:CALCulate:FUNCtion


:CALCulate:DBM:STATe

Syntax

:CALCulate:DBM:STATe <bool>

:CALCulate:DBM:STATe?

Description

This command enables or disables dBm operation.

The query command queries the current status of dBm operation.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 0|OFF

Explanation

This command is only available under measurement functions supporting dBm operation.

If the :CALCulate:FUNCtion command selects dBm operation, the query returns ON.

Return Format

The query returns ON or OFF.

Example

The command below enables dBm operation.

:CALC:DBM:STAT 1

The query below returns ON.

 :CALC:DBM:STAT?

Related Commands

:CALCulate:DBM?
:CALCulate:DBM:REFErence

:CALCulate:FUNCtion


:CALCulate:DBM?

Syntax

:CALCulate:DBM?

Description

This command queries the dBm value of the current measurement reading.

Explanation

This command is only available under measurement functions supporting dBm operation and when dBm operation is enabled.

Return Format

The query returns the dBm value of the current measurement value in scientific notation.

Example

The query below returns -5.760298E+01.

 :CALC:DBM?

Related Commands

:CALCulate:DBM:REFErence

:CALCulate:DBM:STATe

:CALCulate:FUNCtion


:CALCulate:FUNCtion

Syntax

:CALCulate:FUNCtion <math>

:CALCulate:FUNCtion?

Description

This command selects the type of math operation or disables math operation function.

The query command queries the type of the math operation currently selected.

Parameter

Name | Type | Range | Default Value
<math> | Discrete | NONE|REL|DB|DBM|MIN|MAX|AVERAGE|TOTAL|PF | NONE

Explanation

The values of the parameter <math>, their corresponding math operations and measurement functions which support them are as shown in the table below.

Parameter | Definition |  | Measurement Functions
NONE | Disable the operation |  | All functions
REL | Relative operation |  | DCV/ACV/DCI/ACI/OHM/CAP/FREQ/SENSOR
DB | dB operation |  | DCV/ACV
DBM | dBm operation |  | DCV/ACV
MIN | Minimum | Statistic operations | DCV/ACV/DCI/ACI/OHM/CAP/FREQ/SENSOR
MAX | Maximum |  | DCV/ACV/DCI/ACI/OHM/CAP/FREQ/SENSOR
AVERAGE | Average value |  | DCV/ACV/DCI/ACI/OHM/CAP/FREQ/SENSOR
TOTAL | Enable MIN, MAX and AVERAGE at the same time |  | DCV/ACV/DCI/ACI/OHM/CAP/FREQ/SENSOR
PF | Limit operation |  | DCV/ACV/DCI/ACI/OHM/CAP/FREQ/SENSOR

Return Format

The query returns REL, DB, DBM, MIN, MAX, AVERAGE, TOTAL or PF, returns a combination such as REL+PF when multiple operation functions are enabled at the same time and returns NONE when all the operation functions are disabled.

Example

The command below enables PF operation.

 :CALC:FUNC PF

The query below returns PF.

 :CALC:FUNC?

The command below enables REL operation.

:CALC:FUNC REL

The query below returns PF + REL.

 :CALC:FUNC?

Related Commands

:CALCulate:DB:STATe

:CALCulate:DBM:STATe

:CALCulate:PF:STATe

:CALCulate:REL:STATe

:CALCulate:STATistic:STATe


:CALCulate:PF:LOWEr

Syntax

:CALCulate:PF:LOWEr {<value>|MIN|MAX|DEF}

:CALCulate:PF:LOWEr?

Description

This command sets the lower limit of P/F operation.

The query command queries the lower limit of P/F operation.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Real | -110% to +110% of the maximum range of the measurement function currently selected | 0

Explanation

The lower limit can not be higher than the current upper limit and the unit is determined by the current measurement function.

Return Format

The query returns the lower limit of P/F operation in scientific notation.

Example

The command below sets the lower limit of P/F operation (under DCV measurement function).

 :CALC:PF:LOWE -10

The query below returns -1.000000E+01.

 :CALC:PF:LOWE?

Related Commands

:CALCulate:FUNCtion

:CALCulate:PF:UPPEr


:CALCulate:PF:STATe

Syntax

:CALCulate:PF:STATe <bool>

:CALCulate:PF:STATe?

Description

This command enables or disables P/F operation.

The query command queries the current status of P/F operation.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 0|OFF

Return Format

The query returns ON or OFF.

Explanation

The command is only available under measurement functions supporting P/F operation.

If the :CALCulate:FUNCtion command selects P/F operation, the query returns ON.

Example

The command below enables P/F operation.

:CALC:PF:STAT 1

The query below returns ON.

 :CALC:PF:STAT?

Related Command

:CALCulate:FUNCtion


:CALCulate:PF:UPPEr

Syntax

:CALCulate:PF:UPPEr {<value>|MIN|MAX|DEF}

:CALCulate:PF:UPPEr?

Description

This command sets the upper limit of P/F operation.

The query command queries the upper limit of P/F operation.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Real | -110% to +110% of t he maximum range of the measurement function currently selected | 0

Explanation

The upper limit can not be lower than the current lower limit and the unit is determined by the current measurement function.

Return Format

The query returns the upper limit of P/F operation in scientific notation.

Example

The command below sets the upper limit of P/F operation (under DCV measurement function).

 :CALC:PF:UPPE 10

The query below returns -1.000000E+01.

 :CALC:PF:UPPE?

Related Commands

:CALCulate:FUNCtion

:CALCulate:PF:LOWEr


:CALCulate:PF?

Syntax

:CALCulate:PF?

Description

This command queries the result of P/F operation.

Explanation

The command is only available under measurement functions supporting P/F operation.

The result of P/F operation is PASS when the measurement result is between the preset upper and lower limits, otherwise, it is failed (HI or LO).

Return Format

The query returns the P/F operation result (PASS, HI or LO) when P/F operation is enabled and returns OFF when P/F operation is disabled.

Related Commands

:CALCulate:FUNCtion

:CALCulate:PF:STATe


:CALCulate:REL:OFFSet

Syntax

:CALCulate:REL:OFFSet {<value>|MIN|MAX|DEF}

:CALCulate:REL:OFFSet?

Description

This command sets the offset of REL operation.

The query command queries the offset of REL operation.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Real | -110% to +110% of the maximum range of the measurement function currently selected | 0

Explanation

The unit of the offset is determined by the current measurement function.

Return Format

The query returns the offset of REL operation in scientific notation.

Example

The command below sets the offset of REL operation (under DCV measurement function).

:CALC:REL:OFFS 10

The query below returns 1.000000E+01.

 :CALC:REL:OFFS?

Related Commands

:CALCulate:FUNCtion

:CALCulate:REL:STATe


:CALCulate:REL:STATe

Syntax

:CALCulate:REL:STATe <bool>

:CALCulate:REL:STATe?

Description

This command enables or disables REL operation.

The query command queries the current status of REL operation.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 0|OFF

Explanation

This command is only available under measurement functions supporting REL operation.

If the :CALCulate:FUNCtion command selects REL operation, the query returns ON.

Return Format

The query returns ON or OFF.

Example

The command below enables REL operation.

:CALC:REL:STAT 1

The query below returns ON.

 :CALC:REL:STAT?

Related Commands

:CALCulate:FUNCtion

:CALCulate:REL:OFFSet


:CALCulate:STATistic:AVERage?

Syntax

:CALCulate:STATistic:AVERage?

Description

This command queries the average value of all readings taken since statistic operations were enabled.

Explanation

This command is only available under measurement functions supporting AVERAGE operation.

Return Format

The query returns the average value in scientific notation.

Example

The query below returns 2.620000E+01.

 :CALC:STAT:AVER?

Related Commands

:CALCulate:FUNCtion

:CALCulate:STATistic:COUNt?

:CALCulate:STATistic:MAX?


:CALCulate:STATistic:COUNt?

Syntax

:CALCulate:STATistic:COUNt?

Description

This command queries the number of readings taken since statistic operations were enabled.

Explanation

This command is only available under measurement functions supporting statistic operations.

Return Format

The query returns the number in scientific notation.

Example

The query below returns 2.500000E+01.

 :CALC:STAT:COUN?

Related Commands

:CALCulate:FUNCtion


:CALCulate:STATistic:MAX?

Syntax

:CALCulate:STATistic:MAX?

Description

This command queries the maximum of all readings taken since statistic operations were enabled.

Explanation

This command is only available under measurement functions supporting MAX operation.

Return Format

The query returns the maximum in scientific notation.

Example

The query below returns 1.372000E+03.

 :CALC:STAT:MAX?

Related Commands

:CALCulate:FUNCtion


:CALCulate:STATistic:MIN?

Syntax

:CALCulate:STATistic:MIN?

Description

This command queries the minimum of all readings taken since statistic operations were enabled.

Explanation

This command is only available under measurement functions supporting MIN operation.

Return Format

The query returns the minimum in scientific notation.

Example

The query below returns 4.271000E-03.

 :CALC:STAT:MIN?

Related Commands

:CALCulate:FUNCtion

:CALCulate:STATistic:AVERage?
:CALCulate:STATistic:COUNt?

:CALCulate:STATistic:MAX?

:CALCulate:STATistic:STATe


:CALCulate:STATistic:STATe

Syntax

:CALCulate:STATistic:STATe <bool>

:CALCulate:STATistic:STATe?

Description

This command enables or disables operations (MIN, MAX, AVERAGE, TOTAL).

The query command queries the current status of statistic operations.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 0|OFF

Return Format

The query returns the current status (ON or OFF) of statistic operations.

Explanation

This command is only available under measurement functions supporting statistic operations.

If the :CALCulate:FUNCtion command selects MIN, MAX, AVERAGE or TOTAL operation, the query returns ON.

Example

The command below enables statistic operations.

:CALC:STAT:STAT 1

The query below returns ON.

 :CALC:STAT:STAT?

Related Commands

:CALCulate:FUNCtion

:CALCulate:STATistic:AVERage?
:CALCulate:STATistic:COUNt?

:CALCulate:STATistic:MAX?

:CALCulate:STATistic:MIN?


:FUNCtion2命令子系统

:FUNCtion2 Command Subsystem

The commands below are used to set or query parameters relating to the second measurement function.

:FUNCtion2:CLEar

:FUNCtion2:FREQuency

:FUNCtion2:ON?

:FUNCtion2:VALUe1?
:FUNCtion2:VALUe2?

:FUNCtion2?

Note: For DM3068, the second measurement function only refers to the second function (frequency (FREQ) measurement) under ACV and ACI measurement functions.


:FUNCtion2:CLEar

Syntax

:FUNCtion2:CLEar

Description

This command clears the readings of the second measurement function and disable the second measurement function.

Explanation

This command is only available when the second measurement function of the multimeter is enabled.

Related Commands


:FUNCtion2:FREQuency

Syntax

:FUNCtion2:FREQuency

Description

This command enables the frequency measurement function of the secondary display of the multimeter.

Explanation

This command is only available when the measurement function of the main display is ACV or ACI.

Related Commands

:FUNCtion2:CLEar

:FUNCtion2:ON?

:FUNCtion2:VALUe2?

:FUNCtion2?


:FUNCtion2:ON?

Syntax

:FUNCtion2:ON?

Description

This command queries whether the second measurement function is enabled.

Return Format

The query returns ON or OFF.

Related Command

:FUNCtion2:FREQuency


:FUNCtion2:VALUe1?

Syntax

:FUNCtion2:VALUe1?

Description

This command queries the measurement value of the main display of the multimeter.

Return Format

The query returns the current measurement value of the main display in scientific notation.

Example

The query below returns 2.809211E-03.

:FUNC2:VALU1?

Related Commands

:FUNCtion2:CLEar

:FUNCtion2:FREQuency

:FUNCtion2:ON?

:FUNCtion2:VALUe2?


:FUNCtion2:VALUe2?

Syntax

:FUNCtion2:VALUe2?

Description

This command queries the measurement value of the secondary display of the multimeter.

Explanation

This command is only available when the second measurement function is enabled.

Return Format

The query returns the current measurement value of the secondary display in scientific notation.

Example

The query below returns 1.502772E+02.

:FUNC2:VALU2?

Related Commands

:FUNCtion2:CLEar

:FUNCtion2:FREQuency

:FUNCtion2:ON?

:FUNCtion2:VALUe1?


:FUNCtion2?

Syntax

:FUNCtion2?

Description

This command queries the measurement function currently selected on the secondary display.

Return Format

The query returns the measurement function (FREQ) of the secondary display if the secondary display measurement is enabled, otherwise returns ERROR.

Related Commands

:FUNCtion2:FREQuency

:FUNCtion2:ON?


:FUNCtion命令子系统

:FUNCtion Command Subsystem

:FUNCtion:CAPacitance

:FUNCtion:CONTinuity

:FUNCtion:CURRent:AC

:FUNCtion:CURRent:DC

:FUNCtion:DIODe

:FUNCtion:FREQuency
:FUNCtion:FRESistance

:FUNCtion:PERiod
:FUNCtion:RESistance

:FUNCtion:VOLTage:AC

:FUNCtion:VOLTage:DC

:FUNCtion?


:FUNCtion:CAPacitance

Syntax

:FUNCtion:CAPacitance

Description

This command enables capacitance (CAP) measurement function.

Explanation

At this point, the query command :FUNCtion? returns CAP.

Related Command

:FUNCtion?


:FUNCtion:CONTinuity

Syntax

:FUNCtion:CONTinuity

Description

This command enables continuity (CONT) test function.

Explanation

At this point, the query command :FUNCtion? returns CONT.

Related Command

:FUNCtion?


:FUNCtion:CURRent:AC

Syntax

:FUNCtion:CURRent:AC

Description

This command enables AC current (ACI) measurement function.

Explanation

At this point, the query command :FUNCtion? returns ACI.

Related Command

:FUNCtion?


:FUNCtion:CURRent:DC

Syntax

:FUNCtion:CURRent:DC

Description

This command enables DC current (DCI) measurement function.

Explanation

At this point, the query command :FUNCtion? returns DCI.

Related Command

:FUNCtion?


:FUNCtion:DIODe

Syntax

:FUNCtion:DIODe

Description

This command queries diode (DIODE) measurement function.

Explanation

At this point, the query command :FUNCtion? returns DIODE.

Related Command

:FUNCtion?


:FUNCtion:FREQuency

Syntax

:FUNCtion:FREQuency

Description

This command queries frequency (FREQ) measurement function.

Explanation

At this point, the query command :FUNCtion? returns FREQ.

Related Command

:FUNCtion?


:FUNCtion:FRESistance

Syntax

:FUNCtion:FRESistance

Description

This command queries 4-wire resistance (4WR) measurement function.

Explanation

At this point, the query command :FUNCtion? returns 4WR.

Related Command

:FUNCtion?


:FUNCtion:PERiod

Syntax

:FUNCtion:PERiod

Description

This command queries period (PERI) measurement function.

Explanation

At this point, the query command :FUNCtion? returns PERI.

Related Command

:FUNCtion?


:FUNCtion:RESistance

Syntax

:FUNCtion:RESistance

Description

This command queries 2-wire resistance (2WR) measurement function.

Explanation

At this point, the query command :FUNCtion? returns 2WR.

Related Command

:FUNCtion?


:FUNCtion:VOLTage:AC

Syntax

:FUNCtion:VOLTage:AC

Description

This command queries AC voltage (ACV) measurement function.

Explanation

At this point, the query command :FUNCtion? returns ACV.

Related Command

:FUNCtion?


:FUNCtion:VOLTage:DC

Syntax

:FUNCtion:VOLTage:DC

Description

This command queries DC voltage (DCV) measurement function.

Explanation

At this point, the query command :FUNCtion? returns DCV.

Related Command

:FUNCtion?


:FUNCtion?

Syntax

:FUNCtion?

Description

This command queries the measurement function currently selected.

Explanation

The query returns the measurement function of the main display if the multimeter is in dual-display mode.

Return Format

The query returns DCV, ACV, DCI, ACI, 2WR, 4WR, CAP, CONT, DIODE, FREQ, PERI or SENSOR (when SENSOR function is enabled. Note SENSOR function can not be enabled by sending command.).

Example

The query below returns 2WR (2-wire resistance measurement function is enabled currently).

 :FUNC?

Related Commands

:FUNCtion:CAPacitance


:MEASure命令子系统

:MEASure Command Subsystem

:MEASure

:MEASure:CAPacitance
:MEASure:CAPacitance:RANGe?

:MEASure:CAPacitance?

:MEASure:CONTinuity

:MEASure:CONTinuity?

:MEASure:CURRent:AC
:MEASure:CURRent:AC:RANGe?

:MEASure:CURRent:AC?

:MEASure:CURRent:DC
:MEASure:CURRent:DC:RANGe?

:MEASure:CURRent:DC?

:MEASure:DIODe?

:MEASure:FREQuency
:MEASure:FREQuency:RANGe?

:MEASure:FREQuency?

:MEASure:FRESistance

:MEASure:FRESistance:RANGe?

:MEASure:FRESistance?

:MEASure:PERiod
:MEASure:PERiod:RANGe?

:MEASure:PERiod?

:MEASure:RESistance
:MEASure:RESistance:RANGe?

:MEASure:RESistance?

:MEASure:VOLTage:AC
:MEASure:VOLTage:AC:RANGe?

:MEASure:VOLTage:AC?

:MEASure:VOLTage:DC
:MEASure:VOLTage:DC:IMPEdance

:MEASure:VOLTage:DC:RANGe?

:MEASure:VOLTage:DC?

:MEASure?


:MEASure

Syntax

:MEASure {AUTO|MANU}

Description

This command sets the range setting mode of the current measurement function to Auto or Manual.

Explanation

This command is available under DCV, ACV, DCI, ACI, 2WR, 4WR, CAP, FREQ and PERIOD measurement functions.

Example

The command below sets the setting mode to manual.

:MEAS MANU

Related Commands

:MEASure:CAPacitance:RANGe?

:MEASure:CURRent:AC:RANGe?

:MEASure:CURRent:DC:RANGe?
:MEASure:FREQuency:RANGe?

:MEASure:FRESistance:RANGe?

:MEASure:PERiod:RANGe?


:MEASure:CAPacitance

Syntax

:MEASure:CAPacitance {<range>|MIN|MAX|DEF}

Description

This command sets the range for capacitance measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4|5|6|7|8 | 2

Explanation

The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:CAPacitance:RANGe? command to query the current range setting.

Parameter | Range
0 | 2nF (MIN)
1 | 20nF
2 | 200nF (DEF)
3 | 2uF
4 | 20uF
5 | 200uF
6 | 2mF
7 | 20mF
8 | 100mF (MAX)

Example

The command below sets the range to 2uF for capacitance measurement.

 :MEAS:CAP 3

Related Commands

:MEASure

:MEASure:CAPacitance:RANGe?


:MEASure:CAPacitance:RANGe?

Syntax

:MEASure:CAPacitance:RANGe?

Description

This command queries the current range for capacitance measurement.

Explanation

The corresponding relations between the return values of the queries and ranges are as shown in the table below.

Parameter | Range
0 | 2nF
1 | 20nF
2 | 200nF
3 | 2uF
4 | 20uF
5 | 200uF
6 | 2mF
7 | 20mF
8 | 100mF

Return Format

The query returns 0, 1, 2, 3, 4, 5, 6, 7 or 8.

Example

The query below returns 3 (the range for capacitance measurement is currently set to 2uF).

 :MEAS:CAP:RANG?

Related Commands

:MEASure

:MEASure:CAPacitance


:MEASure:CAPacitance?

Syntax

:MEASure:CAPacitance?

Description

This command queries the current capacitance measurement value.

Explanation

The command queries the capacitance measurement value if the instrument is under capacitance measurement function.

The command switches the instrument to capacitance measurement function and queries the capacitance measurement value if the instrument is not under capacitance measurement function currently.

Return Format

The query returns the current capacitance measurement value in scientific notation.

Example

The query below returns 1.215323E-11.

 :MEAS:CAP?

Related Commands


:MEASure:CONTinuity

Syntax

:MEASure:CONTinuity {<value>|MIN|MAX|DEF}

Description

This command sets the short-circuit resistance for continuity measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Integer | 1 Ω to 2000 Ω | 10 Ω

Example

The command below sets the short-circuit resistance to 100 Ω.

 :MEAS:CONT 100

Related Command

:MEASure:CONTinuity?


:MEASure:CONTinuity?

Syntax

:MEASure:CONTinuity?

Description

This command queries the continuity measurement result.

Explanation

This command is only available when the continuity measurement function is enabled.

When the resistance of the circuit to be tested is lower than the preset short-circuit resistance, the circuit is treated as connected, the multimeter displays the actual resistance and the beeper sounds (sound is enabled).

When the resistance of the circuit to be tested is between the preset short-circuit resistance and 2.2 kΩ, the multimeter displays the actual resistance but the beeper does not sound.

When the resistance of the circuit to be tested is higher than 2.2 kΩ, the multimeter displays "OPEN" but the beeper does not sound.

Return Format

The query returns the resistance of the circuit to be tested in scientific notation and the default unit is Ω.

Related Command

:MEASure:CONTinuity


:MEASure:CURRent:AC

Syntax

:MEASure:CURRent:AC {<range>|MIN|MAX|DEF}

Description

This command sets the range for AC current measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4|5 | 2

Explanation

The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:CURRent:AC:RANGe? command to query the current range setting.

Parameter | Range
0 | 200uA (MIN)
1 | 2mA
2 | 20mA
3 | 200mA (DEF)
4 | 2A
5 | 10A (MAX)

Example

The command below sets the range to 20mA for AC current measurement.

 :MEAS:CURR:AC 2

Related Commands

:MEASure MANU

:MEASure:CURRent:AC:RANGe?

:MEASure:CURRent:AC?


:MEASure:CURRent:AC:RANGe?

Syntax

:MEASure:CURRent:AC:RANGe?

Description

This command queries the range for AC current measurement.

Explanation

The corresponding relations between return values of queries and ranges are shown in the table below.

Parameter | Range
0 | 200uA
1 | 2mA
2 | 20mA
3 | 200mA
4 | 2A
5 | 10A

Return Format

The query returns 0, 1, 2, 3, 4 or 5.

Example

The query below returns 2 (the range for ACI measurement is set to 20mA).

 :MEAS:CURR:AC:RANG?

Related Commands

:MEASure MANU

:MEASure:CURRent:AC?

:MEASure:CURRent:AC


:MEASure:CURRent:AC?

Syntax

:MEASure:CURRent:AC?

Description

This command queries the AC current measurement value.

Explanation

When ACI measurement function is enabled currently, the command queries the AC current measurement value.

When ACI measurement function is disabled currently, the command enables ACI measurement function and queries the AC current measurement value.

Return Format

The query returns the current AC current measurement value in scientific notation and the default unit is A.

Example

The query below returns 1.736635E-06.

 :MEAS:CURR:AC?

Related Commands


:MEASure:CURRent:DC

Syntax

:MEASure:CURRent:DC {<range>|MIN|MAX|DEF}

Description

This command sets the range for DC current measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4|5 | 3

Explanation

The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:CURRent:DC:RANGe? command to query the current range setting.

Parameter | Range
0 | 200uA (MIN)
1 | 2mA
2 | 20mA
3 | 200mA (DEF)
4 | 2A
5 | 10A (MAX)

Example

The command below sets the range to 20mA for DC current measurement.

 :MEAS:CURR:DC 2

Related Commands

:MEASure MANU

:MEASure:CURRent:DC?

:MEASure:CURRent:DC:RANGe?


:MEASure:CURRent:DC:RANGe?

Syntax

:MEASure:CURRent:DC:RANGe?

Description

This command queries the range for DC current measurement.

Explanation

The corresponding relations between the return values of queries and ranges are as shown in the table below.

Parameter | Range
0 | 200uA
1 | 2mA
2 | 20mA
3 | 200mA
4 | 2A
5 | 10A

Return Format

The query returns 0, 1, 2, 3, 4 or 5.

Example

The query below returns 2 (the range for DCI measurement is set to 20mA).

 :MEAS:CURR:DC:RANG?

Related Commands

:MEASure MANU


:MEASure:CURRent:DC?

Syntax

:MEASure:CURRent:DC?

Description

This command queries the DC measurement value.

Explanation

When DCI measurement function is enabled currently, the command queries the DC current measurement value.

When DCI measurement function is disabled currently, the command enables DCI measurement function and queries the DC current measurement value.

Return Format

The query returns the current DC current measurement value in scientific notation and the default unit is A.

Example

The query below returns 4.818192E-01.

 :MEAS:CURR:DC?

Related Commands


:MEASure:DIODe?

Syntax

:MEASure:DIODe?

Description

This command queries the voltage between the two ends of the diode.

Explanation

The multimeter displays the voltage if the diode is on, otherwise displays "OPEN".

Return Format

The query returns the voltage between the two ends of the diode in scientific notation and the default unit is V.

Example

The query below returns 0.305300E+0.

 :MEAS:DIOD?


:MEASure:FREQuency

Syntax

:MEASure:FREQuency {<range>|MIN|MAX|DEF}

Description

This command sets the voltage range of the input signal under frequency measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4 | 2

Explanation

The measurable frequency range is from 3Hz to 1MHz. The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:FREQuency:RANGe? command to query the current range setting.

Parameter | Range
0 | 200mV (MIN)
1 | 2V
2 | 20V (DEF)
3 | 200V
4 | 750V (MAX)

Example

The command below sets the voltage range under frequency measurement to 200V.

 :MEAS:FREQ 3

Related Commands

:MEASure MANU

:MEASure:FREQuency?

:MEASure:FREQuency:RANGe?


:MEASure:FREQuency:RANGe?

Syntax

:MEASure:FREQuency:RANGe?

Description

This command queries the voltage range of input signal under frequency measurement.

Explanation

The corresponding relations between the return values of queries and ranges are as shown in the table below.

Parameter | Range
0 | 200mV
1 | 2V
2 | 20V
3 | 200V
4 | 750V

Return Format

The query returns 0, 1, 2, 3 or 4.

Example

The query below returns 3 (the voltage range under frequency measurement is set to 200V).

 :MEAS:FREQ:RANG?

Related Commands

:MEASure MANU

:MEASure:FREQuency?

:MEASure:FREQuency


:MEASure:FREQuency?

Syntax

:MEASure:FREQuency?

Description

This command queries the frequency measurement value.

Explanation

This command is not available in dual-display mode.

This command queries the measurement value if Freq measurement function is currently enabled.

This command enables Freq measurement function and queries the measurement value if Freq measurement function is disabled currently.

Return Format

The query returns the current frequency measurement value in scientific notation and the default unit is Hz.

Example

The query below returns 1.713957E+02.

 :MEAS:FREQ?

Related Commands


:MEASure:FRESistance

Syntax

:MEASure:FRESistance {<range>|MIN|MAX|DEF}

Description

This command sets the range for 4-wire resistance measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4|5|6 | 3

Explanation

The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:FRESistance:RANGe? command to query the current range setting.

Parameter | Range
0 | 200Ω (MIN)
1 | 2kΩ
2 | 20kΩ
3 | 200kΩ (DEF)
4 | 1MΩ
5 | 10MΩ
6 | 100MΩ (MAX)

Example

The command below sets the range to 10MΩ for 4-wire resistance measurement.

 :MEAS:FRES 5

Related Commands

:MEASure MANU

:MEASure:FRESistance?

:MEASure:FRESistance:RANGe?


:MEASure:FRESistance:RANGe?

Syntax

:MEASure:FRESistance:RANGe?

Description

This command queries the range for 4-wire resistance measurement.

Explanation

The corresponding relations between the return values and ranges are as shown in the table below.

Parameter | Range
0 | 200Ω
1 | 2kΩ
2 | 20kΩ
3 | 200kΩ
4 | 1MΩ
5 | 10MΩ
6 | 100MΩ

Return Format

The query returns 0, 1, 2, 3, 4, 5 or 6.

Example

The query below returns 5 (the range for 4-wire resistance measurement is set to 10MΩ).

 :MEAS:FRES:RANG?

Related Commands

:MEASure MANU

:MEASure:FRESistance?

:MEASure:FRESistance


:MEASure:FRESistance?

Syntax

:MEASure:FRESistance?

Description

This command queries the 4-wire resistance measurement value.

Explanation

This command queries the measurement value if 4-wire resistance measurement function is currently enabled.

This command enables 4-wire resistance measurement function and queries the measurement value if 4-wire resistance measurement function is disabled currently.

Return Format

The query returns the current 4-wire resistance measurement value in scientific notation and the default unit is Ω.

Example

The query below returns 4.804279E+07.

 :MEAS:FRES?

Related Commands

:MEASure:FRESistance

:MEASure:FRESistance:RANGe?


:MEASure:PERiod

Syntax

:MEASure:PERiod {<range>|MIN|MAX|DEF}

Description

This command sets the voltage range of the input signal under period measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4 | 2

Explanation

The measurable period range is from 1us to 0.33s. The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:PERiod:RANGe? command to query the current range setting.

Parameter | Range
0 | 200mV (MIN)
1 | 2V
2 | 20V (DEF)
3 | 200V
4 | 750V (MAX)

Example

The command below sets the voltage range under period measurement to 200V.

 :MEAS:PER 3

Related Commands

:MEASure MANU

:MEASure:PERiod?

:MEASure:PERiod:RANGe?


:MEASure:PERiod:RANGe?

Syntax

:MEASure:PERiod:RANGe?

Description

This command queries the voltage range of input signal under period measurement.

Explanation

The corresponding relations between return values of queries and ranges are as shown in the table below.

Parameter | Range
0 | 200mV
1 | 2V
2 | 20V
3 | 200V
4 | 750V

Return Format

The query returns 0, 1, 2, 3 or 4.

Example

The query below returns 3 (the voltage range under period measurement is set to 200V).

 :MEAS:PER:RANG?

Related Commands

:MEASure MANU

:MEASure:PERiod?

:MEASure:PERiod


:MEASure:PERiod?

Syntax

:MEASure:PERiod?

Description

This command queries the period measurement value.

Explanation

This command queries the measurement value if PERIOD measurement function is currently enabled.

This command enables PERIOD measurement function and queries the measurement value if PERIOD measurement function is disabled currently.

Return Format

The query returns the current period measurement value in scientific notation and the default unit is s.

Example

The query below returns 5.372210E-03.

 :MEAS:PER?

Related Commands


:MEASure:RESistance

Syntax

:MEASure:RESistance {<range>|MIN|MAX|DEF}

Description

This command sets the range for 2-wire resistance measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4|5|6 | 3

Explanation

The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:RESistance:RANGe? command to query the current range setting.

Parameter | Range
0 | 200Ω (MIN)
1 | 2kΩ
2 | 20kΩ
3 | 200kΩ (DEF)
4 | 1MΩ
5 | 10MΩ
6 | 100MΩ (MAX)

Example

The command below sets the range to 20kΩ for 2-wire resistance measurement.

 :MEAS:RES 2

Related Commands

:MEASure MANU

:MEASure:RESistance?

:MEASure:RESistance:RANGe?


:MEASure:RESistance:RANGe?

Syntax

:MEASure:RESistance:RANGe?

Description

This command queries the current range for 2-wire resistance measurement.

Explanation

The corresponding relations between the return values of queries and ranges are as shown in the table below.

Parameters | Range
0 | 200Ω
1 | 2kΩ
2 | 20kΩ
3 | 200kΩ
4 | 1MΩ
5 | 10MΩ
6 | 100MΩ

Return Format

The query below returns 0, 1, 2, 3, 4, 5 or 6.

Example

The query below returns 2 (the range for 2-wire resistance measurement is set to 20kΩ).

 :MEAS:RES:RANG?

Related Commands

:MEASure MANU

:MEASure:RESistance?

:MEASure:RESistance


:MEASure:RESistance?

Syntax

:MEASure:RESistance?

Description

This command queries the 2-wire resistance measurement value.

Explanation

This command queries the measurement value if 2WR measurement function is currently enabled.

This command enables 2WR measurement function and queries the measurement value if 2WR measurement function is disabled currently.

Return Format

The query returns the current 2-wire resistance measurement value in scientific notation and the default unit is Ω.

Example

The query below returns 1.830640E+05.

 :MEAS:RES?

Related Commands


:MEASure:VOLTage:AC

Syntax

:MEASure:VOLTage:AC {<range>|MIN|MAX|DEF}

Description

This command sets the range for AC voltage measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4 | 2

Explanation

The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:VOLTage:AC:RANGe? command to query the current range setting.

Parameter | Range
0 | 200mV (MIN)
1 | 2V
2 | 20V (DEF)
3 | 200V
4 | 750V (MAX)

Example

The command below sets the range to 200V for ACV measurement.

 :MEAS:VOLT:AC 3

Related Commands

:MEASure MANU

:MEASure:VOLTage:AC?

:MEASure:VOLTage:AC:RANGe?


:MEASure:VOLTage:AC:RANGe?

Syntax

:MEASure:VOLTage:AC:RANGe?

Description

This command queries the range for AC voltage measurement.

Explanation

The corresponding relations between the return values of queries and ranges are as shown in the table below.

Parameter | Range
0 | 200mV
1 | 2V
2 | 20V
3 | 200V
4 | 750V

Return Format

The query returns 0, 1, 2, 3 or 4.

Example

The query below returns 3 (the range for ACV measurement is set to 200V).

 :MEAS:VOLT:AC:RANG?

Related Commands

:MEASure MANU

:MEASure:VOLTage:AC?

:MEASure:VOLTage:AC


:MEASure:VOLTage:AC?

Syntax

:MEASure:VOLTage:AC?

Description

This command queries the AC voltage measurement value.

Explanation

This command queries the measurement value if ACV measurement function is currently enabled.

This command enables ACV measurement function and queries the measurement value if ACV measurement function is disabled currently.

Return Format

The query returns the current AC voltage measurement value in scientific notation and the default unit is V.

Example

The query below returns 3.498203 E-0 1.

 :MEAS:VOLT:AC?

Related Commands


:MEASure:VOLTage:DC

Syntax

:MEASure:VOLTage:DC {<range>|MIN|MAX|DEF}

Description

This command sets the range for DC voltage measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<range> | Discrete | 0|1|2|3|4 | 2

Explanation

The corresponding relations between the values of the parameter and ranges are as shown in the table below. Use the :MEASure:VOLTage:DC:RANGe? command to query the current range setting.

Parameter | Range
0 | 200mV (MIN)
1 | 2V
2 | 20V (DEF)
3 | 200V
4 | 1000V (MAX)

Example

The command below sets the range to 200V for DCV measurement.

 :MEAS:VOLT:DC 3

Related Commands

:MEASure

:MEASure:VOLTage:DC?


:MEASure:VOLTage:DC:IMPEdance

Syntax

:MEASure:VOLTage:DC:IMPEdance <impedance>

:MEASure:VOLTage:DC:IMPEdance?

Description

This command sets the DC impedance.

The query command queries the DC impedance.

Parameter

Name | Type | Range
<impedance> | Discrete | 10M|10G

Explanation

The default unit is Ω.

When 10M is selected, the DC input impedances on all ranges are 10MΩ.

When 10G is selected, the DC input impedances on 200mV, 2V and 20V ranges are >10GΩ and the DC input impedances on 200V and 1000V ranges are still 10MΩ.

Return Format

The query returns 10M or 10G.

Example

The command below sets the DC impedance to >10GΩ.

:MEAS:VOLT:DC:IMPE 10G

The query below returns 10G.

 :MEAS:VOLT:DC:IMPE?

Related Commands

:MEASure:VOLTage:DC?


:MEASure:VOLTage:DC:RANGe?

Syntax

:MEASure:VOLTage:DC:RANGe?

Description

This command queries the range for DC voltage measurement.

Explanation

The corresponding relations between the return values of queries and ranges are as shown in the table below.

Parameter | Range
0 | 200mV
1 | 2V
2 | 20V
3 | 200V
4 | 1000V

Return Format

The query returns 0, 1, 2, 3 or 4.

Example

The query below returns 3 (the range for DCV measurement is set to 200V).

 :MEAS:VOLT:DC:RANG?

Related Commands

:MEASure MANU

:MEASure:VOLTage:DC?


:MEASure:VOLTage:DC?

Syntax

:MEASure:VOLTage:DC?

Description

This command queries the DC voltage measurement value.

Explanation

This command queries the measurement value if DCV measurement function is currently enabled.

This command enables DCV measurement function and queries the measurement value if DCV measurement function is disabled currently.

Return Format

The query returns the current DC voltage measurement value in scientific notation and the default unit is V.

Example

The query below returns 8.492853E-0 1.

 :MEAS:VOLT:DC?

Related Commands


:MEASure?

Syntax

:MEASure?

Description

This command queries whether a new data is sampled under the current trigger setting.

Return Format

The query returns TRUE if new data is sampled, otherwise returns FALSE.


:RATE命令子系统

:RATE Command Subsystem

The commands below are used to set or query the measurement rate of the instrument under various measurement functions such as DCV, DCI, 2WR and 4WR.

:RATE:CURRent:DC

:RATE:FRESistance
:RATE:RESistance
:RATE:VOLTage:DC

Besides, in order to be compatible with RIGOL DM3000 and DM3058 command sets, DM3068 accepts the following commands but does not execute the actual operations.

:RATE:CURRent:AC

:RATE:SENSor

:RATE:VOLTage:AC


:RATE:CURRent:DC

Syntax

:RATE:CURRent:DC {F|M|S}

:RATE:CURRent:DC?

Description

This command sets the measurement rate for DC current measurement.

The query command queries the measurement rate for DC current measurement.

Parameter

Type | Range | Default Value
Discrete | F|M|S | S

Explanation

The corresponding relations between the values of the parameter and measurement rates are as shown in the table below1:

Parameter Value | Measurement Rate/s | Integral Time | Corresponding Setting of Instrument
F | 2500 (3000) | 400 (333) us | 0.02NPLC
M | 250 (300) | 4 (3.33) ms | 0.2NPLC
S | 0.5 (0.6) | 2 (1.67) s | 100NPLC

Note1: the integral time is related to the power frequency, frequencies ranging from 55 Hz to 66 Hz are treated as 60 Hz and other frequencies are treated as 50 Hz. In the table above, the parameters enclosed in the parentheses are parameters under 60 Hz power frequency.

Return Format

The query returns FAST, MEDIUM or SLOW.

Example

The command below sets the measurement rate to FAST for DC current measurement.

 :RATE:CURR:DC F

The query below returns FAST.

 :RATE:CURR:DC?


:RATE:FRESistance

Syntax

:RATE:FRESistance {F|M|S}

:RATE:FRESistance?

Description

This command sets the measurement rate for 4-wire resistance measurement.

The query command queries the measurement rate for 4-wire resistance measurement.

Parameter

Type | Range | Default Value
Discrete | F|M|S | S

Explanation

The corresponding relations between the values of the parameter and measurement rates are as shown in the table below1:

Parameter Value | Measurement Rate/s | Integral Time | Corresponding Setting of Instrument
F | 2500 (3000) | 400 (333) us | 0.02NPLC
M | 250 (300) | 4 (3.33) ms | 0.2NPLC
S | 0.5 (0.6) | 2 (1.67) s | 100NPLC

Note1: the integral time is related to the power frequency, frequencies ranging from 55 Hz to 66 Hz are treated as 60 Hz and other frequencies are treated as 50 Hz. In the table above, the parameters enclosed in the parentheses are parameters under 60 Hz power frequency.

Return Format

The query returns FAST, MEDIUM or SLOW.

Example

The command below sets the measurement rate to MEDIUM for 4-wire resistance measurement function.

 :RATE:FRES M

The query below returns MEDIUM.

 :RATE:FRES?


:RATE:RESistance

Syntax

:RATE:RESistance {F|M|S}

:RATE:RESistance?

Description

This command sets the measurement rate for 2-wire resistance measurement.

The query command queries the measurement rate for 2-wire resistance measurement.

Parameter

Type | Range | Default Value
Discrete | F|M|S | S

Explanation

The corresponding relations between the values of the parameter and measurement rates are as shown in the table below1:

Parameter Value | Measurement Rate/s | Integral Time | Corresponding Setting of Instrument
F | 2500 (3000) | 400 (333) us | 0.02NPLC
M | 250 (300) | 4 (3.33) ms | 0.2NPLC
S | 0.5 (0.6) | 2 (1.67) s | 100NPLC

Note1: the integral time is related to the power frequency, frequencies ranging from 55 Hz to 66 Hz are treated as 60 Hz and other frequencies are treated as 50 Hz. In the table above, the parameters enclosed in the parentheses are parameters under 60 Hz power frequency.

Return Format

The query returns FAST, MEDIUM or SLOW.

Example

The command below sets the measurement rate to MEDIUM for 2-wire resistance measurement.

 :RATE:RES M

The query below returns MEDIUM.

 :RATE:RES?


:RATE:VOLTage:DC

Syntax

:RATE:VOLTage:DC {F|M|S}

:RATE:VOLTage:DC?

Description

This command sets the measurement rate for DC voltage measurement.

The query command queries the measurement rate for DC voltage measurement.

Parameter

Type | Range | Default Value
Discrete | F|M|S | S

Explanation

The corresponding relations between the values of the parameter and measurement rates are as shown in the table below1:

Parameter Value | Measurement Rate/s | Integral Time | Corresponding Setting of Instrument
F | 2500 (3000) | 400 (333) us | 0.02NPLC
M | 250 (300) | 4 (3.33) ms | 0.2NPLC
S | 0.5 (0.6) | 2 (1.67) s | 100NPLC

Note1: the integral time is related to the power frequency, frequencies ranging from 55 Hz to 66 Hz are treated as 60 Hz and other frequencies are treated as 50 Hz. In the table above, the parameters enclosed in the parentheses are parameters under 60 Hz power frequency.

Return Format

The query returns FAST, MEDIUM or SLOW.

Example

The command below sets the measurement rate to FAST for DC voltage measurement.

 :RATE:VOLT:DC F

The query below returns FAST.

 :RATE:VOLT:DC?


:RATE:CURRent:AC

Syntax

:RATE:CURRent:AC {F|M|S}

:RATE:CURRent:AC?

Explanation

DM3068 only accepts this command but does not execute the actual operation.


:RATE:SENSor

Syntax

:RATE:SENSor {M|S}

:RATE:SENSor?

Explanation

DM3068 only accepts this command but does not execute the actual operation.


:RATE:VOLTage:AC

Syntax

:RATE:VOLTage:AC {F|M|S}

:RATE:VOLTage:AC?

Explanation

DM3068 only accepts this command but does not execute the actual operation.


:SYSTem命令子系统

:SYSTem Command Subsystem

:SYSTem:BEEPer
:SYSTem:BEEPer:STATe

:SYSTem:CLOCk?

:SYSTem:CONFigure:DEFault

:SYSTem:CONFigure:POWEron
:SYSTem:DISPlay:BRIGht

:SYSTem:DISPlay:CONTrast

:SYSTem:DISPlay:INVErt

:SYSTem:EDITion?
:SYSTem:FORMat:DECImal

:SYSTem:FORMat:SEPArate

:SYSTem:LANGuage


:SYSTem:BEEPer

Syntax

:SYSTem:BEEPer

Description

This command is used to test the beeper of the instrument.

Explanation

Enable the beeper before sending this command.

The beeper sounds once when the command is sent.

Related Command

:SYSTem:BEEPer:STATe


:SYSTem:BEEPer:STATe

Syntax

:SYSTem:BEEPer:STATe <bool>

:SYSTem:BEEPer:STATe?

Description

This command enables or disables the beeper.

The query command queries the status of the beeper.

Parameter

Name | Type | Range
<bool> | Bool | {{0|OFF}|{1|ON}}

Explanation

The beeper testing command :SYSTem:BEEPer is invalid if the beeper is disabled using this command.

Return Format

The query returns 1 if the beeper is enabled, otherwise returns 0.

Example

The command below disables the beeper.

 :SYST:BEEP:STAT OFF

The query below returns 0.

 :SYST:BEEP:STAT?

Related Command

:SYSTem:BEEPer


:SYSTem:CLOCk?

Syntax

:SYSTem:CLOCk?

Description

This command queries the system time of the multimeter.

Return Format

The query returns the current system time in HH:MM:SS format.

Example

The query below returns the current system time 13:25:08.

 :SYST:CLOC?


:SYSTem:CONFigure:DEFault

Syntax

:SYSTem:CONFigure:DEFault

Description

This command restores the instrument parameters to their default values.

Explanation

For default values of parameters, refer to User's Guide for DM3068.


:SYSTem:CONFigure:POWEron

Syntax

:SYSTem:CONF:POWEron {LAST|DEF}

Description

This command sets the parameter setting mode of the multimeter at power-on.

Parameter

Parameter Value | Power-on Status
LAST | The parameters use the last values at power-on.
DEF | The parameters use the default values at power-on.

Explanation

The new setting is valid at the next power-on after the power-on values setting is finished.

DC voltage measurement function is automatically selected at power-on no matter which mode (LAST or DEF) is selected.

Example

The command below sets the parameters to use the last values at power-on.

:SYST:CONF:POWE LAST


:SYSTem:DISPlay:BRIGht

Syntax

:SYSTem:DISPlay:BRIGht <value>

:SYSTem:DISPlay:BRIGht?

Description

This command sets the screen brightness of the multimeter.

The query command queries the screen brightness of the multimeter.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 0 to 32 | 22

Return Format

The query returns the screen brightness (any integer between 0 and 32, wherein, 0 represents the minimum brightness and 32 represents the maximum brightness) of the multimeter.

Example

The command below sets the screen brightness to 17.

 :SYST:DISP:BRIG 17

The query below returns 17.

 :SYST:DISP:BRIG?

Related Commands

:SYSTem:DISPlay:CONTrast

:SYSTem:DISPlay:INVErt


:SYSTem:DISPlay:CONTrast

Syntax

:SYSTem:DISPlay:CONTrast <value>

:SYSTem:DISPlay:CONTrast?

Description

This command sets the screen contrast of the multimeter.

The query command queries the screen contrast of the multimeter.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 0 to 32 | 19

Return Format

The query returns the screen contrast (any integer between 0 and 32, wherein, 0 represents the minimum contrast and 32 represents the maximum contrast) of the multimeter.

Example

The command below sets the screen contrast to 17.

 :SYST:DISP:CONT 17

The query below returns 17.

 :SYST:DISP:CONT?

Related Commands

:SYSTem:DISPlay:BRIGht

:SYSTem:DISPlay:INVErt


:SYSTem:DISPlay:INVErt

Syntax

:SYSTem:DISPlay:INVErt

Description

This command sets the multimeter screen to invert display.

Related Commands

:SYSTem:DISPlay:BRIGht

:SYSTem:DISPlay:CONTrast


:SYSTem:EDITion?

Syntax

:SYSTem:EDITion?

Description

This command queries the software version number of the multimeter.

Explanation

The return value of this command is the forth part (software version number of the instrument) of the return value of the *IDN? command.

Return Format

The query returns the software version number of the multimeter.

Example

The query below returns 01.01.00.01.01.00.

 :SYST:EDIT?

Related Commands

*IDN?

:SYSTem:SERIal?

:SYSTem:TYPE?


:SYSTem:FORMat:DECImal

Syntax

:SYSTem:FORMat:DECImal {COMMA|DOT}

:SYSTem:FORMat:DECImal?

Description

This command sets the display format of decimal point of the multimeter.

The query command queries the display format of decimal point of the multimeter.

Parameter

Parameter Value | Display Format
COMMA | Comma
DOT | Dot

Explanation

As shown in the table below, the display format of decimal point is related to the display format of data separator (:SYSTem:FORMat:SEPArate). This command may easily cause change of the display format of data separator, so please use it with care.

Decimal Point | Data Separator
Comma | Dot, none or space
Dot | Comma, none or space

Return Format

The query returns the current display format (COMMA or DOT) of decimal point.

Example

The command below sets the display format of decimal point to comma.

 :SYST:FORM:DECI COMMA

The query below returns COMMA.

 :SYST:FORM:DECI?

Related Command

:SYSTem:FORMat:SEPArate


:SYSTem:FORMat:SEPArate

Syntax

:SYSTem:FORMat:SEPArate {ON|NONE|SPACE}

:SYSTem:FORMat:SEPArate?

Description

This command sets the display format of data separator of the multimeter.

The query command queries the display format of data separator of the multimeter.

Parameter

Parameter Value | Display Format
ON | Comma or dot, depend on the display format of decimal point
NONE | None
SPACE | Space

Explanation

As shown in the table below, the display format of data separator is related to the display format of decimal point.

Decimal Point | Data Separator
Comma | Dot, none or space
Dot | Comma, none or space

Return Format

The query returns the current display format (ON, NONE or SPACE) of data separator.

Example

The command below sets the display format of data separator to space.

 :SYST:FORM:SEPA SPACE

The query below returns SPACE.

 :SYST:FORM:SEPA?

Related Command

:SYSTem:FORMat:DECImal


:SYSTem:LANGuage

Syntax

:SYSTem:LANGuage {CH|EN}

:SYSTem:LANGuage?

Description

This command sets the system language of the multimeter.

The query returns the system language of the multimeter.

Parameter

Parameter Value | Language
CH | Chinese
EN | English

Return Format

The query returns CHINESE if the current system language is Chinese and returns ENGLISH if the current system language is English.

Example

The command below sets the system language to English.

:SYST:LANG EN

The query below returns ENGLISH.

 :SYST:LANG?


:SYSTem:MACAddr?

Syntax

:SYSTem:MACAddr?

Description

This command queries the MAC address of the multimeter.

Return Format

The query returns the MAC address of the multimeter.

Example

The query below returns 00-12-23-45-67-89.

 :SYST:MACA?


:SYSTem:OPENtimes?

Syntax

:SYSTem:OPENtimes?

Description

This command queries the number of power-on of the instrument.

Return Format

The query returns an integer namely the current number of power-on of the instrument.

Example

The query below returns 67.

 :SYST:OPEN?


:SYSTem:SERIal?

Syntax

:SYSTem:SERIal?

Description

This command queries the serial number of the multimeter.

Explanation

The return value of this command is the third part (serial number of the instrument <serial number>) of the return value of the *IDN? command.

Return Format

The query returns the serial number of the multimeter.

Example

The query below returns DM3A020100823.

 :SYST:SERI?

Related Commands

*IDN?

:SYSTem:TYPE?

:SYSTem:EDITion?
SERIAL?（FLUKE）


:SYSTem:TYPE?

Syntax

:SYSTem:TYPE?

Description

This command queries the model number of the multimeter.

Explanation

The return value of this command is the second part (model number of the instrument <model>) of the return value of the *IDN? command.

Return Format

The query returns the model number of the multimeter.

Example

The query below returns DM3068 indicating that the instrument currently used is DM3068 digital multimeter.

:SYST:TYPE?

Related Commands

*IDN?

:SYSTem:SERIal?

:SYSTem:EDITion?


:TRIGger命令子系统

:TRIGger Command Subsystem

:TRIGger:AUTO:HOLD
:TRIGger:AUTO:HOLD:SENSitivity

:TRIGger:AUTO:INTErval

:TRIGger:EXT


:TRIGger:AUTO:HOLD

Syntax

:TRIGger:AUTO:HOLD <bool>

:TRIGger:AUTO:HOLD?

Description

This command enables or disables the reading hold function of the multimeter.

The query command queries whether the reading hold function is enabled.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 0|OFF

Explanation

This command is only available when the trigger source is AUTO.

Return Format

The query returns ON or OFF.

Example

The command below enables the reading hold function.

:TRIG:AUTO:HOLD ON

The query below returns ON.

 :TRIG:AUTO:HOLD?

Related Commands

:TRIGger:AUTO:HOLD:SENSitivity

:TRIGger:AUTO:INTErval

:TRIGger:SOURce


:TRIGger:AUTO:HOLD:SENSitivity

Syntax

:TRIGger:AUTO:HOLD:SENSitivity {<value>|MIN|MAX|DEF}

:TRIGger:AUTO:HOLD:SENSitivity?

Description

This command sets the sensitivity range of the reading hold function of the multimeter.

The query command queries the sensitivity range of the reading hold function of the multimeter.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Discrete | 0|1|2|3 | 1

Explanation

The corresponding relations between the values of the parameter and sensitivity ranges are as shown in the table below.

Parameter | Sensitivity Range | MIN | MAX | DEF
0 | 0.01% | √ |  |
1 | 0.1% |  |  | √
2 | 1% |  |  |
3 | 10% |  | √ |

Return Format

The query returns 0, 1, 2 or 3.

Example

The command below sets the sensitivity range of the reading hold function to 10%.

 :TRIG:AUTO:HOLD:SENS MAX

The query below returns 3.

 :TRIG:AUTO:HOLD:SENS?

Related Commands

:TRIGger:AUTO:HOLD
:TRIGger:AUTO:INTErval

:TRIGger:SOURce


:TRIGger:AUTO:INTErval

Syntax

:TRIGger:AUTO:INTErval {<value>|MIN|MAX|DEF}

:TRIGger:AUTO:INTErval?

Description

This command sets the delay time of auto trigger.

The query command queries the delay time of auto trigger.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Real | 0s to 3600s | 400us

Explanation

Note the relation and difference between this command and the TRIGger:DELay command in Compatible Agilent Command Set: both the two commands set the trigger delay time for the instrument; this command is only available when the trigger source is AUTO (refer to the :TRIGger:SOURce command) while the latter is applicable to all the trigger sources (BUS, IMM, EXT or INT, refer to the TRIGger:SOURce command).

Return Format

The query returns the delay time of auto trigger in scientific notation.

Example

The command below sets the delay time of auto trigger to 50ms.

 :TRIG:AUTO:INTE 0.05

The query below returns 5.00000007E-02.

 :TRIG:AUTO:INTE?

Related Commands

:TRIGger:SOURce
TRIGger:DELay （Agilent）

TRIGger:SOURce（Agilent）


:TRIGger:EXT

Syntax

:TRIGger:EXT {RISE|FALL}

:TRIGger:EXT?

Description

This command selects the edge type of external trigger.

The query command queries the edge type of external trigger.

Explanation

RISE represents rising edge and FALL represents falling edge. The multimeter triggers on specified edge.

This command is only available when the trigger source is EXT (refer to the :TRIGger:SOURce command).

Return Format

The query returns RISE or FALL.

Example

The command below sets the edge type of external trigger to RISE.

 :TRIG:EXT RISE

The query below returns RISE.

 :TRIG:EXT?

Related Command

:TRIGger:SOURce


:TRIGger:SINGle

Syntax

:TRIGger:SINGle {<value>|MIN|MAX|DEF}

:TRIGger:SINGle?

Description

This command sets the number of samples of single trigger.

The query command queries the number of samples of single trigger.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Integer | 1 to 50000 | 1

Explanation

1 The multimeter reads specified number of readings every time it receives a trigger signal.

2 Note the relation and difference between this command and the SAMPle:COUNt command in Compatible Agilent Command Set: both the two commands set the number of samples of single trigger; this command is only available when the trigger source is SINGLE (refer to the :TRIGger:SOURce command) while the latter is applicable to all the trigger sources (BUS, IMM, EXT or INT, refer to the TRIGger:SOURce command).

Return Format

The query returns any integer between 1 and 50000.

Example

The command below sets the number of samples of single trigger to 20.

 :TRIG:SING 20

The query below returns 20.

 :TRIG:SING?

Related Commands

:TRIGger:SINGle:TRIGgered

:TRIGger:SOURce

SAMPle:COUNt（Agilent）

TRIGger:SOURce（Agilent）


:TRIGger:SINGle:TRIGgered

Syntax

:TRIGger:SINGle:TRIGgered

Description

This command controls the multimeter to execute single trigger.

Explanation

This command equals to executing a manual trigger when operating the multimeter manually.

Related Commands


:TRIGger:SOURce

Syntax

:TRIGger:SOURce <source>

:TRIGger:SOURce?

Description

The command selects the type of trigger source.

The query command queries the type of trigger source.

Parameter

Name | Type | Range | Default
<source> | Discrete | AUTO|SINGLE|EXT | AUTO

Explanation

Parameter Value | Trigger Source
AUTO | Auto Trigger
SINGLE | Single Trigger
EXT | External Trigger

Return Format

The query returns AUTO, SINGLE or EXT.

Example

The command below sets the instrument to single trigger.

:TRIG:SOUR SINGLE

The query below returns SINGLE.

 :TRIG:SOUR?

Related Command

*TRG


:TRIGger:VMComplete

Syntax

:TRIGger:VMComplete {ON|OFF}

:TRIGger:VMComplete?

Description

The command enables or disables the [VM Comp] output terminal.

The query command queries whether the [VM Comp] output terminal is enabled.

Explanation

The multimeter outputs a negative pulse from the corresponding connector after each measurement when the [VM Comp] output terminal is enabled.

Return Format

The query returns ON or OFF.

Example

The command below enables the [VM Comp] output terminal.

:TRIG:VMC ON

The query below returns ON.

 :TRIG:VMC?


:UTILity命令子系统

:UTILity Command Subsystem

:UTILity:INTErface:GPIB:ADDRess

:UTILity:INTErface:LAN:AUTOip
:UTILity:INTErface:LAN:DHCP
:UTILity:INTErface:LAN:DNS

:UTILity:INTErface:LAN:GATEway
:UTILity:INTErface:LAN:IP
:UTILity:INTErface:LAN:MANUip
:UTILity:INTErface:LAN:MASK
:UTILity:INTErface:RS232:BAUD
:UTILity:INTErface:RS232:PARIty

Note: Make sure that the communication port is correctly connected before controlling the multimeter remotely through GPIB, LAN and RS232 interfaces, otherwise abnormity or error might occur.


:UTILity:INTErface:GPIB:ADDRess

Syntax

:UTILity:INTErface:GPIB:ADDRess <addr>

:UTILity:INTErface:GPIB:ADDRess?

Description

This command sets the GPIB address.

The query command queries the GPIB address.

Parameter

Name | Type | Range | Default Value
<addr> | Integer | 0 to 30 | 7

Return Format

The query returns any integer between 0 and 30.

Example

The command below sets the GPIB address to 9.

 :UTIL:INTE:GPIB:ADDR 9

The query below returns 9.

 :UTIL:INTE:GPIB:ADDR?


:UTILity:INTErface:LAN:AUTOip

Syntax

:UTILity:INTErface:LAN:AUTOip <bool>

:UTILity:INTErface:LAN:AUTOip?

Description

This command enables or disables Auto IP mode.

The query command queries the status of Auto IP.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 1|ON

Explanation

There are three IP configuration modes: DHCP, Auto IP and Manual IP;

The priority order (from high to low) of the configuration modes is DHCP, Auto IP and Manual IP when all the three configuration modes are ON.

The three IP configuration modes can not be all set to OFF at the same time.

To enable Auto IP, set DHCP to OFF (refer to the :UTILity:INTErface:LAN:DHCP command).

Return Format

The query returns ON or OFF.

Example

The command below disables Auto IP.

 :UTIL:INTE:LAN:AUTO 0

The query below returns OFF.

 :UTIL:INTE:LAN:AUTO?

Related Commands

:UTILity:INTErface:LAN:DHCP
:UTILity:INTErface:LAN:MANUip

:UTILity:INTErface:LAN:DNS


:UTILity:INTErface:LAN:DHCP

Syntax

:UTILity:INTErface:LAN:DHCP <bool>

:UTILity:INTErface:LAN:DHCP?

Description

This command enables or disables DHCP mode.

The query command returns the status of DHCP.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 1|ON

Explanation

There are three IP configuration modes: DHCP, Auto IP and Manual IP;

The priority order (from high to low) of the configuration modes is DHCP, Auto IP and Manual IP when all the three configuration modes are ON.

The three IP configuration modes can not be all set to OFF at the same time.

Return Format

The query returns ON or OFF.

Example

The command below disables DHCP.

 :UTIL:INTE:LAN:DHCP 0

The query below returns OFF.

 :UTIL:INTE:LAN:DHCP?

Related Commands

:UTILity:INTErface:LAN:AUTOip
:UTILity:INTErface:LAN:MANUip

:UTILity:INTErface:LAN:DNS


:UTILity:INTErface:LAN:DNS

Syntax

:UTILity:INTErface:LAN:DNS <ip_address>

:UTILity:INTErface:LAN:DNS?

Description

This command configures the DNS address of the LAN interface.

The query command queries the DNS address of the LAN interface.

Parameter

Name | Type | Range1
<ip_address> | ASCII Character String | 0.0.0.0 to 255.255.255.255

Note1: The valid DNS range is from 0.0.0.0 to 223.255.255.255 and the first length of number can not be 127 according to the TCP/IP protocol.

Explanation

Generally, users do not need to set the DNS address of the network, therefore, this parameter setting can be ignored.

Return Format

The query returns the current DNS address: 0.0.0.0 to 223.255.255.255 (except 127.nnn.nnn.nnn).

Related Commands


:UTILity:INTErface:LAN:GATEway

Syntax

:UTILity:INTErface:LAN:GATEway <ip_address>

:UTILity:INTErface:LAN:GATEway?

Description

This command configures the default gateway of the LAN interface.

The query command queries the default gateway of the LAN interface.

Parameter

Name | Type | Range1
<ip_address> | ASCII Character String | 0.0.0.0 to 255.255.255.255

Note1: The valid gateway range is from 0.0.0.0 to 223.255.255.255 and the first length of number can not be 127 according to the TCP/IP protocol.

Explanation

This command is only available when manual IP mode is enabled (refer to the :UTILity:INTErface:LAN:MANUip).

Return Format

The query returns the current default gateway: 0.0.0.0 to 223.255.255.255 (except 127.nnn.nnn.nnn).

Example

The command below sets the default gateway to 172.16.3.1.

 :UTIL:INTE:LAN:GATE 172.16.3.1

The query below returns 172.16.3.1.

 :UTIL:INTE:LAN:GATE?

Related Commands

:UTILity:INTErface:LAN:MANUip


:UTILity:INTErface:LAN:IP

Syntax

:UTILity:INTErface:LAN:IP <ip_address>

:UTILity:INTErface:LAN:IP?

Description

This command configures the IP address of the LAN interface.

The query command queries the IP address of the LAN interface.

Parameter

Name | Type | Range1
<ip_address> | ASCII Character String | 0.0.0.0 to 255.255.255.255

Note1: The valid IP address range is from 0.0.0.0 to 223.255.255.255 and the first length of number can not be 127 according to the TCP/IP protocol.

Explanation

This command is only available when manual IP mode is enabled (refer to the :UTILity:INTErface:LAN:MANUip command).

Please connect your multimeter to LAN successfully before using this command. If not, this command is invalid.

Return Format

The query returns the current IP address: 0.0.0.0 to 223.255.255.255 (except 127.nnn.nnn.nnn).

Example

The command below sets the IP address to 172.16.3.26.

 :UTIL:INTE:LAN:IP 172.16.3.26

The query below returns 172.16.3.26.

 :UTIL:INTE:LAN:IP?

Related Commands

:UTILity:INTErface:LAN:MANUip
:UTILity:INTErface:LAN:MASK
:UTILity:INTErface:LAN:GATEway

:UTILity:INTErface:LAN:DNS


:UTILity:INTErface:LAN:MANUip

Syntax

:UTILity:INTErface:LAN:MANUip <bool>

:UTILity:INTErface:LAN:MANUip?

Description

This command enables or disables manual IP mode.

The query command queries the status of manual IP.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 0|OFF

Explanation

There are three IP configuration modes: DHCP, Auto IP and Manual IP;

The priority order (from high to low) of the configuration modes is DHCP, Auto IP and Manual IP when all the three configuration modes are ON.

The three IP configuration modes can not be all set to OFF at the same time.

To enable Manual IP, set DHCP and Auto IP to OFF (refer to the :UTILity:INTErface:LAN:DHCP and :UTILity:INTErface:LAN:AUTOip commands).

Return Format

The query returns ON or OFF.

Example

The command below enables manual IP.

 :UTIL:INTE:LAN:MANU 1

The query below returns ON.

 :UTIL:INTE:LAN:MANU?

Related Commands

:UTILity:INTErface:LAN:AUTOip
:UTILity:INTErface:LAN:DHCP
:UTILity:INTErface:LAN:IP
:UTILity:INTErface:LAN:MASK
:UTILity:INTErface:LAN:GATEway

:UTILity:INTErface:LAN:DNS


:UTILity:INTErface:LAN:MASK

Syntax

:UTILity:INTErface:LAN:MASK <ip_address>

:UTILity:INTErface:LAN:MASK?

Description

This command configures the subnet mask of the LAN interface.

The query command queries the subnet mask of the LAN interface.

Parameter

Name | Type | Range
<ip_address> | ASCII Character String | 0.0.0.0 to 255.255.255.255

Explanation

This command is only available when manual IP mode is enabled (refer to the :UTILity:INTErface:LAN:MANUip command).

Return Format

The query returns the current subnet mask: 0.0.0.0 to 255.255.255.255.

Example

The command below sets the subnet mask to 255.255.255.0.

 :UTIL:INTE:LAN:MASK 255.255.255.0

The query below returns 255.255.255.0.

 :UTIL:INTE:LAN:MASK?

Related Commands

:UTILity:INTErface:LAN:MANUip
:UTILity:INTErface:LAN:IP
:UTILity:INTErface:LAN:GATEway

:UTILity:INTErface:LAN:DNS


:UTILity:INTErface:RS232:BAUD

Syntax

:UTILity:INTErface:RS232:BAUD <baud>

:UTILity:INTErface:RS232:BAUD?

Description

This command sets the baud rate of serial port (RS232) communication.

The query command queries the baud rate of serial port (RS232) communication.

Parameter

Name | Type | Range | Default Value
<baud> | Discrete | 1200|2400|4800|9600|19200|38400|57600|115200 | 9600

Return Format

The query returns 1200, 2400, 4800, 9600, 19200, 38400, 57600 or 115200.

Example

The command below sets the baud rate of serial port (RS232) communication to 19200.

 :UTIL:INTE:RS232:BAUD 19200

The query below returns 19200.

 :UTIL:INTE:RS232:BAUD?

Related Command

:UTILity:INTErface:RS232:PARIty


:UTILity:INTErface:RS232:PARIty

Syntax

:UTILity:INTErface:RS232:PARIty {NONE|ODD|EVEN}

:UTILity:INTErface:RS232:PARIty?

Description

This command sets the parity of serial port (RS232) communication.

The query command queries the parity of serial port (RS232) communication.

Parameter

Value | Parity
NONE | None
ODD | Odd Parity
EVEN | Even Parity

Return Format

The query returns the current parity setting of serial port (RS232) communication in "Parity Type + Data Bits" format: NONE8BITS, ODD7BITS or EVEN7BITS.

Example

The command below sets the parity of serial port (RS232) communication to ODD.

 :UTIL:INTE:RS232:PARI ODD

The query below returns ODD7BITS.

 :UTIL:INTE:RS232:PARI?

Related Command

:UTILity:INTErface:RS232:BAUD


兼容的Agilent命令集

Compatible Agilent Command Set

DM3068 is compatible with the following commands of Agilent34401A. Use the CMDSet command (namely CMDSet AGILENT) to select Agilent Command Set before using those commands.

FETCh?

INITiate

INPut:IMPedance:AUTO

READ?

ROUTe:TERMinals?

SAMPle:COUNt

CALCulate Command Subsystem

CONFigure Command Subsystem

DATA Command Subsystem

DISPlay Command Subsystem

MEASure Command Subsystem

[SENSe:] Command Subsystem

SYSTem Command Subsystem

TRIGger Command Subsystem


FETCh?

Syntax

FETCh?

Description

This command transfers readings stored in the multimeter's internal memory to the multimeter's output buffer.

Explanation

This command only transfers readings stored in the multimeter's internal memory but does not clear the internal memory. If there is no reading in internal memory, error message will be returned when this command is sent.


INITiate

Syntax

INITiate

Description

This command changes the state of the trigger system from "Idle" to "Wait-for-trigger".

Measurements will begin when the specified trigger condition are satisfied after this command is received. The readings are stored in the multimeter's internal memory.


INPut:IMPedance:AUTO

Syntax

INPut:IMPedance:AUTO <bool>

INPut:IMPedance:AUTO?

Description

This command enables or disables the auto mode of DC input impedance.

The query command queries the status of the auto mode of DC input impedance.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | OFF|0

Explanation

When auto mode is disabled (OFF|0), the DC input impedance is fixed at 10MΩ for all ranges of DCV measurement.

When auto mode is enabled (ON|1), the DC input impedance is set to >10GΩ for 200mV, 2V and 20V ranges and 10MΩ for 200V and 1000V ranges.

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below enables the auto mode of DC input impedance.

INP:IMP:AUTO ON

The query below returns 1.

 INP:IMP:AUTO?

Related Commands

CONFigure:VOLTage:DC

[SENSe:]VOLTage:DC:IMPedance:AUTO


READ?

Syntax

READ?

Description

This command changes the state of the trigger system from "Idle" to "Wait-for-trigger".

Measurements will begin when the specified trigger condition are satisfied after this command is received. The readings are sent in the multimeter's volatile memory and output buffer.


ROUTe:TERMinals?

Syntax

ROUTe:TERMinals?

Description

This command queries the input terminal (front or rear) selected by the multimeter.

Return Format

Limited by the input terminal of the instrument, this command can only return "FRON".


SAMPle:COUNt

Syntax

SAMPle:COUNt {<value>|MIN|MAX}

SAMPle:COUNt?

Description

This command sets the number of samples the multimeter takes per trigger.

The query command queries the number of samples the multimeter takes per trigger.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 1 to 50000 | 1

Explanation

1 Note the relation and difference between this command and the :TRIGger:SINGle {<value>|MIN|MAX} command in RIGOL Command Set: both the two commands set the number of samples of each trigger; this command is applicable to all the trigger sources (BUS, IMM, EXT or INT, refer to the TRIGger:SOURce command) while the latter is only available when the trigger source is SINGLE (refer to the :TRIGger:SOURce command).

2 You can also specify the number of triggers (the TRIGger:COUNt command). At this point, the total number of readings returned will be the product of the sample count and trigger count: Number of Readings = Sample Count × Trigger Count

Return Format

The query returns any integer between 1 and 50000.

Example

The command below sets the multimeter's sample count to 100.

 SAMP:COUN 100

The query below returns 100.

 SAMP:COUN?

Related Commands

TRIGger:COUNt

TRIGger:SOURce

:TRIGger:SINGle {<value>|MIN|MAX}（RIGOL）

:TRIGger:SOURce（RIGOL）


CALCulate命令子系统

CALCulate Command Subsystem

CALCulate:AVERage:AVERage?
CALCulate:AVERage:COUNt?
CALCulate:AVERage:MAXimum?
CALCulate:AVERage:MINimum?

CALCulate:DB:REFerence
CALCulate:DBM:REFerence
CALCulate:FUNCtion

CALCulate:LIMit:LOWer
CALCulate:LIMit:UPPer

CALCulate:NULL:OFFSet

CALCulate:STATe

Note: The NULL operation in Agilent Command Set corresponds to the REL operation in DM3068 Command Set and LIMIT operation to P/F operation.


CALCulate:AVERage:AVERage?

Syntax

CALCulate:AVERage:AVERage?

Description

This command queries the average of all readings since the statistic operations were enabled.

Explanation

Use the CALCulate:FUNCtion command to select AVERage operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the average in scientific notation.

Example

The query below returns 1.926062E+01.

 CALC:AVER:AVER?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:AVERage:COUNt?

Syntax

CALCulate:AVERage:COUNt?

Description

This command queries the number of readings taken since the statistic operations were enabled.

Explanation

Use the CALCulate:FUNCtion command to select AVERage operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the number of readings in scientific notation.

Example

The query below returns 1.200000E+01.

 CALC:AVER:COUN?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:AVERage:MAXimum?

Syntax

CALCulate:AVERage:MAXimum?

Description

This command queries the maximum value found during a statistic operation.

Explanation

Use the CALCulate:FUNCtion command to select AVERage operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the maximum value in scientific notation.

Example

The query below returns 2.026062E+03.

 CALC:AVER:MAX?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:AVERage:MINimum?

Syntax

CALCulate:AVERage:MINimum?

Description

This command queries the minimum value found during a statistic operation.

Explanation

Use the CALCulate:FUNCtion command to select AVERage operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the minimum value in scientific notation.

Example

The query below returns 1.826200E-03.

 CALC:AVER:MIN?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:DB:REFerence

Syntax

CALCulate:DB:REFerence {<value>|MIN|MAX}

CALCulate:DB:REFerence? [MIN|MAX]

Description

This command sets the reference value of dB operation.

The query command queries the reference value of dB operation.

Parameter

Name | Type | Range | Default Value
<value> | Real | -120dBm to 120dBm | 0dBm

Explanation

Use the CALCulate:FUNCtion command to select DB operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the currently set dB reference value in scientific notation.

Example

The command below sets the dB reference value to -5dBm.

 CALC:DB:REF -5

The query below returns -5.000000E+00.

 CALC:DB:REF?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:DBM:REFerence

Syntax

CALCulate:DBM:REFerence {<value>|MIN|MAX}

CALCulate:DBM:REFerence? [MIN|MAX]

Description

This command sets the dBm reference resistance.

The query command queries the dBm reference resistance.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 2 Ω to 8000 Ω | 600 Ω

Explanation

Use the CALCulate:FUNCtion command to select DBM operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the currently set dBm reference resistance in scientific notation.

Example

The command below sets the dBm reference resistance to 300Ω.

 CALC:DBM:REF 300

The query below returns 3.000000E+02.

 CALC:DBM:REF?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:FUNCtion

Syntax

CALCulate:FUNCtion {NULL|DB|DBM|AVERage|LIMit}

CALCulate:FUNCtion?

Description

This command selects the math operation.

The query command queries the math operation selected.

Parameter

Parameter Value | Operation Type
NULL | Null Operation (Relative Operation)
DB | dB Operation
DBM | dBm Operation
AVERage | Statistic Operations
LIMit | Limit Operation (P/F Operation)

Explanation

The NULL operation in Agilent Command Set corresponds to the relative operation (REL) in DM3068 Command Set and the LIMIT operation to P/F operation (no more repetition in the following part).

This command only selects math operation type for multimeter and does not enable the operation. After sending this command, you can enable the operation using the CALCulate:STATe ON command.

Return Format

The query returns NULL, DB, DBM, AVER or LIM.

Example

The command below selects DBM operation.

 CALC:FUNC DBM

The query below returns DBM.

 CALC:FUNC?

Related Command

CALCulate:STATe


CALCulate:LIMit:LOWer

Syntax

CALCulate:LIMit:LOWer {<value>|MIN|MAX}

CALCulate:LIMit:LOWer? [MIN|MAX]

Description

This command sets the lower limit of P/F operation.

The query command queries the current lower limit of P/F operation.

Parameter

Name | Type | Range | Default Value
<value> | Real | -110% to 110% of the maximum range of the measurement function currently selected | 0

Explanation

The lower limit can not be higher than the current upper limit (the CALCulate:LIMit:UPPer command).

The unit of the limit is determined by the current measurement function.

Use the CALCulate:FUNCtion command to select LIMit operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the current lower limit in scientific notation.

Example

The command below sets the lower limit of P/F operation to -5.

 CALC:LIM:LOW -5

The query below returns -5.000000E+00.

 CALC:LIM:LOW?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe

CALCulate:LIMit:UPPer


CALCulate:LIMit:UPPer

Syntax

CALCulate:LIMit:UPPer {<value>|MIN|MAX}

CALCulate:LIMit:UPPer? [MIN|MAX]

Description

This command sets the upper limit of P/F operation.

The query command queries the current upper limit of P/F operation.

Parameter

Name | Type | Range | Default Value
<value> | Real | -110% to 110% of the maximum range of the measurement function currently selected | 0

Explanation

The upper limit can not be lower than the current lower limit (the CALCulate:LIMit:LOWer command).

The unit of the limit is determined by the current measurement function.

Use the CALCulate:FUNCtion command to select LIMit operation and the CALCulate:STATe to enable the operation before using this command.

Return Format

The query returns the current upper limit in scientific notation.

Example

The command below sets the upper limit of P/F operation to 5.

 CALC:LIM:UPP 5

 The query below returns 5.000000E+00.

 CALC:LIM:UPP?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe

CALCulate:LIMit:LOWer


CALCulate:NULL:OFFSet

Syntax

CALCulate:NULL:OFFSet {<value>|MIN|MAX}

CALCulate:NULL:OFFSet? [MIN|MAX]

Description

This command sets the offset of NULL operation.

The query command queries the offset of NULL operation.

Parameter

Name | Type | Range | Default Value
<value> | Real | -110% to 110% of the maximum range of the measurement function currently selected | 0

Explanation

The unit of offset is determined by the measurement function. Use the CALCulate:FUNCtion command to select NULL operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the current offset of NULL operation in scientific notation.

Example

The command below sets the offset of NULL operation to -5.

 CALC:NULL:OFFS -5

The query below returns -5.000000E+00.

 CALC:NULL:OFFS?

Related Commands

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:STATe

Syntax

CALCulate:STATe <bool>

CALCulate:STATe?

Description

This command enables or disables the selected operation.

The query command queries whether the selected operation is enabled.

Parameter

Name | Type | Range
<bool> | Bool | {{0|OFF}|{1|ON}}

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below enables the currently selected math operation.

CALC:STAT ON

The query below returns 1.

 CALC:STAT?

Related Command

CALCulate:FUNCtion


CONFigure命令子系统

CONFigure Command Subsystem

CONFigure:CONTinuity

CONFigure:CURRent:AC

CONFigure:CURRent:DC


CONFigure:CONTinuity

Syntax

CONFigure:CONTinuity

Description

This command presets the continuity test and trigger parameters to default state for continuity test.

Explanation

This command only specifies parameters but does not initiate the measurement.

Example

The command below presets the multimeter for continuity test.

CONF:CONT

The query command CONFigure? returns "CONT" .

Related Command

CONFigure?


CONFigure:CURRent:AC

Syntax

CONFigure:CURRent:AC [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for AC current measurement.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200uA (MIN) 2mA 20mA 200mA 2A (DEF) 10A (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 61/2 bits | The resolution is fixed at 61/2 bits

Explanation

This command sets the range and resolution to their default values when this command are sent without parameters.

This command allows to set parameters with units and the unit is "A" by default if the parameters are set without unit.

This command only specifies parameters but does not initiate the measurement.

Example

The command below sets the range and resolution for AC current measurement to their default values.

 CONF:CURR:AC

The query command CONFigure? returns "CURR:AC 2.00000000E+00,2.00000000E-06".

Related Command

CONFigure?


CONFigure:CURRent:DC

Syntax

CONFigure:CURRent:DC [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for DC current measurement.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200uA (MIN) 2mA 20mA 200mA 2A (DEF) 10A (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when the command are sent without parameters. This command allows to set parameters with units and the unit is "A" by default if the parameters are set without unit.

This command only specifies parameters but does not initiate the measurement.

Example

The command below sets the range and resolution to 2A, 0.2uA for DC current measurement.

 CONF:CURR:DC 2,2.0E-7

The query command CONFigure? returns "CURR:DC 2.00000000E+00,2.00000000E-07" .

Related Command

CONFigure?


CONFigure:DIODe

Syntax

CONFigure:DIODe

Description

This command presets the diode measurement and trigger parameters to default state for diode measurement.

Explanation

This command only specifies parameters but does not initiate the measurement.

Example

The command below presets the multimeter for diode measurement.

CONF:DIOD

The query command CONFigure? returns "DIOD".

Related Command

CONFigure?


CONFigure:FREQuency

Syntax

CONFigure:FREQuency [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for frequency measurement.

Parameter

Name | Type | Range
<range> | Integer | 3Hz to 1MHz
<resolution> | Discrete | The resolution is fixed at 61/2 bits

Explanation

For frequency measurements, the multimeter uses one range for all inputs between 3Hz and 1MHz.

This command only specifies parameters but does not initiate the measurement.

Related Command

CONFigure?


CONFigure:FRESistance

Syntax

CONFigure:FRESistance [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for 4-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200 Ω (MIN) 2k Ω (DEF) 20k Ω 200k Ω 1M Ω 10M Ω 100M Ω (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when this command is sent without parameters and the unit is "Ω" by default.

This command only specifies parameters but does not initiate the measurement.

Example

The command below sets the range and resolution to 1M Ω, 0.1Ω for 4-wire resistance measurement.

 CONF:FRES 1.0E+06,0.1

The query command CONFigure? returns "FRES 1.00000000E+06,1.00000000E-01".

Related Command

CONFigure?


CONFigure:PERiod

Syntax

CONFigure:PERiod [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for period measurement.

Parameter

Name | Type | Range
<range> | Integer | 1us to 0.33s
<resolution> | Discrete | The resolution is fixed at 61/2 bits

Explanation

For period measurements, the multimeter uses one range for all inputs between 1us and 0.33s.

This command only specifies parameters but does not initiate the measurement.

Related Command

CONFigure?


CONFigure:RESistance

Syntax

CONFigure:RESistance [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for 2-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200 Ω (MIN) 2k Ω (DEF) 20k Ω 200k Ω 1M Ω 10M Ω 100M Ω (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when this command is sent without parameters and the unit is "Ω" by default.

This command only specifies parameters but does not initiate the measurement.

Example

The command below sets the range and resolution to 1MΩ, 0.1Ω for 2-wire resistance measurement.

 CONF:RES 1.0E+06,0.1

The query command CONFigure? returns "RES 1.00000000E+06,1.00000000E-01".

Related Command

CONFigure?


CONFigure:VOLTage:AC

Syntax

CONFigure:VOLTage:AC [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for AC voltage measurement.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200mV (MIN) 2V 20V (DEF) 200V 750V (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 61/2 bits | The resolution is fixed at 61/2 bits

Explanation

This command sets the range and resolution to their default values when this command is sent without parameters. This command allows to set parameters with units and the unit is "V" by default if the parameters are set without unit.

This command only specifies parameters but does not initiate the measurement.

Example

The command below sets the range and resolution to their default values for AC voltage measurement.

 CONF:VOLT:AC

The query command CONFigure? returns "VOLT:AC 2.00000000E+01,2.00000000E-05".

Related Command

CONFigure?


CONFigure:VOLTage:DC

Syntax

CONFigure:VOLTage:DC [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with specified range and resolution for DC voltage measurement.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200mV (MIN) 2V 20V (DEF) 200V 1000V (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when this command is sent without parameters. This command allows to set parameters with units and the unit is "V" by default if the parameters are set without unit.

This command only specifies parameters but does not initiate the measurement.

Example

The command below sets the range and resolution to 20V, 0.06mV for DC voltage measurement.

 CONF:VOLT:DC 20,6.0E-5

The query command CONFigure? returns "VOLT:DC 2.00000000E+01,6.00000000E-05".

Related Command

CONFigure?


CONFigure?

Syntax

CONFigure?

Description

This command queries the current configuration of the multimeter.

Explanation

This command does not initiate the measurement.

Return Format

The query returns the current configuration of the multimeter in the format of quoted character string.

Example

The query below returns "VOLT:DC 2.00000000E-01,2.00000000E-08".

 CONF?


DATA命令子系统

DATA Command Subsystem


DATA:FEED RDG_STORE,{"CALCulate"|""}

Syntax

DATA:FEED RDG_STORE,{"CALCulate"|" "}

Description

This command selects whether to store the readings loaded by the INITiate command to the internal memory of the multimeter.

Parameter

Value | Reading Storage Status
"CALCulate" | Store up to 512 readings in the internal memory of the multimeter when executing the INITiate command
" " | Do not store any reading when executing the INITiate command

Explanation

Limited by its working principle, DM3068 only accepts the command but does not execute the actual operation.

Related Commands

INITiate


DATA:FEED?

Syntax

DATA:FEED?

Description

This command queries the reading memory state.

Return Format

Limited by its working principle, DM3068 can only return "CALC".

Related Commands

INITiate


DATA:POINts?

Syntax

DATA:POINts?

Description

This command queries the number of readings stored in the internal memory of the multimeter.

Return Format

The query returns an integer namely the number of readings stored in the internal memory of the multimeter.

Related Commands

INITiate


DISPlay命令子系统

DISPlay Command Subsystem

DISPlay


DISPlay

Syntax

DISPlay <bool>

DISPlay?

Description

This command enables or disables the display of the multimeter.

The query command queries the status of the display of the multimeter.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | 1|ON

Return Format

The query returns the status of the display: 1 (ON) or 0 (OFF).

Example

The command below disables the display of the multimeter.

DISP OFF

The query below returns 0.

 DISP?

Related Commands


DISPlay:TEXT

Syntax

DISPlay:TEXT <string>

DISPlay:TEXT?

Description

This command displays the specified text on the display.

The query command queries the text displayed on the display.

Parameter

Name | Type | Range
<string> | ASCII Character String | Quoted character string

Explanation

The character string can not exceed 12 characters and can include lower case letters (a-z), upper case letters (A-Z), numbers (0-9) and special symbols (such as "@" and "#")

The text displayed can be cleared by the DISPlay:TEXT:CLEar command.

Return Format

The query returns the text displayed on the display in the format of quoted character string.

Example

The command below sets the multimeter to display "Waiting...".

 DISP:TEXT "Waiting..."

The query below returns Waiting...

 DISP:TEXT?

Related Commands

DISPlay

DISPlay:TEXT:CLEar


DISPlay:TEXT:CLEar

Syntax

DISPlay:TEXT CLEar

Description

This command clears the text displayed on the display using the DISPlay:TEXT command.

Related Commands

DISPlay

DISPlay:TEXT


MEASure命令子系统

MEASure Command Subsystem

The commands below preset the multimeter with specified range and resolution, trigger the corresponding measurement functions, send the readings to the buffer, then query and return the data in the output buffer.

MEASure:CONTinuity?

MEASure:CURRent:AC?

MEASure:CURRent:DC?

MEASure:DIODe?

MEASure:FREQuency?

MEASure:FRESistance?

MEASure:PERiod?

MEASure:RESistance?

MEASure:VOLTage:AC?

MEASure:VOLTage:DC?

Note: when using the MEASure commands for measurements, you can select the measurement functions, ranges and resolutions while other measurement parameters are their default values.


MEASure:CONTinuity?

Syntax

MEASure:CONTinuity?

Description

This command presets the continuity test parameters and trigger parameters to their default values and makes a continuity test. The readings are sent to the output buffer.

Explanation

The range of continuity test is fixed at 2kΩ.

Return Format

The query returns the data in the output buffer.

Related Command

CONFigure?


MEASure:CURRent:AC?

Syntax

MEASure:CURRent:AC? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes an AC current measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200uA (MIN) 2mA 20mA 200mA 2A (DEF) 10A (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 61/2 bits | The resolution is fixed at 61/2 bits

Explanation

This command sets the range and resolution to their default values and executes AC current measurement when this command is sent without parameters. This command allows to set parameters with unit and the unit is A by default when the parameters are set without unit.

Return Format

The query returns the reading in the output buffer.

Example

The command below sets the parameters of AC current measurement to their default values, triggers the multimeter to make measurement, loads a reading and sends it to the output buffer. The return value is 1.00000000e+00.

 MEAS:CURR:AC?

Related Command

CONFigure?


MEASure:CURRent:DC?

Syntax

MEASure:CURRent:DC? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a DC current measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200uA (MIN) 2mA 20mA 200mA 2A (DEF) 10A (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when this command is sent without parameters. This command allows to set parameters with unit and the unit is A by default if the parameters are set without unit.

Example

The command below sets the range and resolution of DC current measurement to 2A, 0.2uA, triggers the multimeter to make measurement, loads a reading and sends it to the buffer. The return value is 1.18115090e-02.

 MEAS:CURR:DC? 2,2.0E-7

Related Command

CONFigure?


MEASure:DIODe?

Syntax

MEASure:DIODe?

Description

This command presets the diode measurement and trigger parameters to their default values and makes a diode measurement. The readings are sent to the output buffer.

Explanation

The range of diode measurement is fixed at 2 V.

Return Format

The query returns the data in the output buffer.

Related Command

CONFigure?


MEASure:FREQuency?

Syntax

MEASure:FREQuency? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a frequency measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range
<range> | Integer | 3Hz to 1MHz
<resolution> | Discrete | The resolution is fixed at 61/2 bits

Explanation

For frequency measurement, the multimeter uses one range for all inputs between 3Hz and 1MHz.

Related Command

CONFigure?


MEASure:FRESistance?

Syntax

MEASure:FRESistance? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a 4-wire resistance measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200 Ω (MIN) 2k Ω (DEF) 20k Ω 200k Ω 1M Ω 10M Ω 100M Ω (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when this command is sent without parameters and the unit is Ω by default.

Example

The command below sets the range and resolution of 4-wire resistance measurement to 1M Ω, 0.1 Ω, triggers the multimeter to make measurement, loads a reading and sends it to the output buffer. The return value is 3.22710294e+05.

 MEAS:FRES? 1.0E+06,0.1

Related Command

CONFigure?


MEASure:PERiod?

Syntax

MEASure:PERiod? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a period measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range
<range> | Integer | 1us to 0.33s
<resolution> | Discrete | The resolution is fixed at 61/2 bits

Explanation

For period measurement, the multimeter uses one range for all inputs between 1us and 0.33s.

Related Command

CONFigure?


MEASure:RESistance?

Syntax

MEASure:RESistance? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a 2-wire resistance measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200 Ω (MIN) 2k Ω (DEF) 20k Ω 200k Ω 1M Ω 10M Ω 100M Ω (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when this command is sent without parameters and the unit is Ω by default.

Example

The command below sets the range and resolution of 2-wire resistance measurement to 1MΩ, 0.1Ω, triggers the multimeter to make measurement, loads a reading and sends it to the output buffer. The return value is 3.29400000e+05.

 MEAS:RES? 1.0E+06,0.1

Related Command

CONFigure?


MEASure:VOLTage:AC?

Syntax

MEASure:VOLTage:AC? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes an AC voltage measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200mV (MIN) 2V 20V (DEF) 200V 750V (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 61/2 bits | The resolution is fixed at 61/2 bits

Explanation

This command sets the range and resolution to their default values when this command is sent without parameters. This command allows to set parameters with unit and the unit is V by default if the parameters are set without unit.

Example

The command below sets the range and resolution for AC voltage measurement to their default values, triggers the multimeter to make measurement, loads a reading and sends it to the output buffer. The return value is 3.26802475e-03.

 MEAS:VOLT:AC?

Related Command

CONFigure?


MEASure:VOLTage:DC?

Syntax

MEASure:VOLTage:DC? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a DC voltage measurement with the specified range and resolution. The readings are sent to the output buffer.

Parameter

Name | Type | Range | Default Value
<range> | Discrete | 200mV (MIN) 2V 20V (DEF) 200V 1000V (MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range (DEF)
100PLC | 0.03ppm×Range (MIN)

This command sets the range and resolution to their default values when this command is sent without parameters. This command allows to set parameters with unit and the unit is V by default if the parameters are set without unit.

Example

The command below sets the range and resolution of DC voltage measurement to 20V, 0.06mV, triggers the multimeter to make measurement, loads a reading and sends it to the output buffer. The return value is 7.10648066e-03.

 MEAS:VOLT:DC? 20,6.0E-5

Related Command

CONFigure?


[SENSe:]命令子系统

[SENSe:] Command Subsystem

[SENSe:]CURRent:AC:RANGe
[SENSe:]CURRent:AC:RANGe:AUTO

[SENSe:]CURRent:AC:RESolution
[SENSe:]CURRent:DC:NPLCycles
[SENSe:]CURRent:DC:RANGe
[SENSe:]CURRent:DC:RANGe:AUTO
[SENSe:]CURRent:DC:RESolution
[SENSe:]DETector:BANDwidth
[SENSe:]FREQuency:APERture
[SENSe:]FREQuency:VOLTage:RANGe
[SENSe:]FREQuency:VOLTage:RANGe:AUTO
[SENSe:]FRESistance:NPLCycles
[SENSe:]FRESistance:RANGe
[SENSe:]FRESistance:RANGe:AUTO
[SENSe:]FRESistance:RESolution
[SENSe:]FUNCtion
[SENSe:]PERiod:APERture
[SENSe:]PERiod:VOLTage:RANGe
[SENSe:]PERiod:VOLTage:RANGe:AUTO

[SENSe:]RESistance:NPLCycles
[SENSe:]RESistance:RANGe
[SENSe:]RESistance:RANGe:AUTO
[SENSe:]RESistance:RESolution

[SENSe:]VOLTage:AC:RANGe
[SENSe:]VOLTage:AC:RANGe:AUTO
[SENSe:]VOLTage:AC:RESolution
[SENSe:]VOLTage:DC:NPLCycles
[SENSe:]VOLTage:DC:RANGe
[SENSe:]VOLTage:DC:RANGe:AUTO
[SENSe:]VOLTage:DC:RESolution
[SENSe:]ZERO:AUTO


[SENSe:]CURRent:AC:RANGe

Syntax

[SENSe:]CURRent:AC:RANGe {<range>|MIN|MAX}

[SENSe:]CURRent:AC:RANGe? [MIN|MAX]

Description

This command sets the range for AC current measurement.

The query command queries the range for AC current measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200uA (MIN) 2mA 20mA 200mA 2A 10A (MAX)

Explanation

This command allows to set the parameter with unit and the unit is A by default if the parameters are set without unit.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range to 200mA for AC current measurement.

 CURR:AC:RANG 0.2

The query below returns 2.00000000E-01.

 CURR:AC:RANG?

Related Commands

CONFigure:CURRent:AC

[SENSe:]CURRent:AC:RANGe:AUTO


[SENSe:]CURRent:AC:RANGe:AUTO

Syntax

[SENSe:]CURRent:AC:RANGe:AUTO <bool>

[SENSe:]CURRent:AC:RANGe:AUTO?

Description

This command enables or disables the auto range function of AC current measurement.

The query command queries the status of the auto range function of AC current measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of AC current measurement to auto.

CURR:AC:RANG:AUTO ON

The query below returns 1.

 CURR:AC:RANG:AUTO?

Related Commands

CONFigure:CURRent:AC

[SENSe:]CURRent:AC:RANGe


[SENSe:]CURRent:AC:RESolution

Syntax

[SENSe:]CURRent:AC:RESolution {<resolution>|MIN|MAX}

[SENSe:]CURRent:AC:RESolution? [MIN|MAX]

Description

This command sets the resolution for AC current measurement.

The query command queries the resolution for AC current measurement.

Parameter

Name | Type | Range | Default Value
<resolution> | Discrete | The resolution is fixed at 61/2 bits | The resolution is fixed at 61/2 bits

Explanation

The resolution of AC current measurement is fixed at 61/2 bits and actually, this command can be ignored.

Return Format

The query returns the current resolution in scientific notation.

Related Command

CONFigure:CURRent:AC


[SENSe:]CURRent:DC:NPLCycles

Syntax

[SENSe:]CURRent:DC:NPLCycles {<PLCs>|MIN|MAX}

[SENSe:]CURRent:DC:NPLCycles? [MIN|MAX]

Description

This command sets the integral time for DC current measurement in the number of Power Line Cycles.

The query command queries the integral time for DC current measurement.

Parameter

Name | Type | Range | Default Value
<PLCs> | Discrete | 0.006|0.02|0.06|0.2|1|2|10|100 | 10

Explanation

The default unit is PLC, wherein, 1PLC = 0.02s. As shown in the table below, the integral time is related to the resolution, wherein, 1ppm = 0.000001 and represents "one millionth of ".

Integral Time | Resolution
0.006PLC(MIN) | 6ppm×Range
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC(MAX) | 0.03ppm×Range

Return Format

The query returns the current multiple of PLC in scientific notation.

Example

The command below sets the integral time to 10PLC for DC current measurement.

 CURR:DC:NPLC 10

The query below returns 1.00000000E+01.

 CURR:DC:NPLC?

Related Command

CONFigure:CURRent:DC


[SENSe:]CURRent:DC:RANGe

Syntax

[SENSe:]CURRent:DC:RANGe {<range>|MIN|MAX}

[SENSe:]CURRent:DC:RANGe? [MIN|MAX]

Description

This command sets the range for DC current measurement.

The query command queries the range for DC current measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200uA (MIN) 2mA 20mA 200mA 2A 10A (MAX)

Explanation

This command allows to set the parameter with unit and the unit is A by default if the parameters are set without unit.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range to 200mA for DC current measurement.

 CURR:DC:RANG 0.2

The query below returns 2.00000000E-01.

 CURR:DC:RANG?

Related Commands

CONFigure:CURRent:DC

[SENSe:]CURRent:DC:RANGe:AUTO


[SENSe:]CURRent:DC:RANGe:AUTO

Syntax

[SENSe:]CURRent:DC:RANGe:AUTO <bool>

[SENSe:]CURRent:DC:RANGe:AUTO?

Description

This command enables or disables the auto range function of DC current measurement.

The query command queries the status of the auto range function of DC current measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of DC current measurement to auto.

CURR:DC:RANG:AUTO ON

The query below returns 1.

 CURR:DC:RANG:AUTO?

Related Commands

CONFigure:CURRent:DC

[SENSe:]CURRent:DC:RANGe


[SENSe:]CURRent:DC:RESolution

Syntax

[SENSe:]CURRent:DC:RESolution {<resolution>|MIN|MAX}

[SENSe:]CURRent:DC:RESolution? [MIN|MAX]

Description

This command sets the resolution for DC current measurement.

The query command queries the resolution for DC current measurement.

Parameter

Name | Type | Range | Default Value
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC | 0.03ppm×Range (MIN)

Return Format

The query returns the current resolution in scientific notation.

Example

The command below selects the minimum resolution (the current range is 200mA) for DC current measurement.

CURR:DC:RES MIN

The query below returns 6.00000000E-09, namely 0.03ppm×Range.

 CURR:DC:RES?

Related Command

CONFigure:CURRent:DC


[SENSe:]DETector:BANDwidth

Syntax

[SENSe:]DETector:BANDwidth {<bw>|MIN|MAX}

[SENSe:]DETector:BANDwidth? [MIN|MAX]

Description

This command selects the type of AC filter for the multimeter.

The query command queries the AC filter type currently selected.

Parameter

Name | Type | Range | Default Value
<bw> | Discrete | 3|20|200 | 20

Explanation

This command is applicable to AC voltage, AC current, frequency and period measurements.

DM3068 provides three types of AC filters: Slow, Medium and Fast. The corresponding relations between the values of the parameter and filter types are as shown in the table below.

Parameter Value | Filter Type | Filter Bandwidth
3 | Slow | 3Hz to 300kHz
20 | Medium | 20Hz to 300kHz
200 | Fast | 200Hz to 300kHz

Return Format

The query returns the current filter type in scientific notation.

Example

The command below selects fast filter.

 DET:BAND 200

The query below returns 2.00000000E+02.

 DET:BAND?


[SENSe:]FREQuency:APERture

Syntax

[SENSe:]FREQuency:APERture {<aperture>|MIN|MAX}

[SENSe:]FREQuency:APERture? [MIN|MAX]

Description

This command sets the aperture time for frequency measurement.

The query command queries the aperture time for frequency measurement.

Parameter

Name | Type | Range | Default Value
<aperture> | Discrete | 0.001|0.01|0.1|1 | 0.1

Explanation

The default unit is s. The corresponding relations between the values of the parameter and the aperture times are as shown in the table below.

Parameter Value | Aperture Time
0.001 | 1ms (MIN)
0.01 | 10ms
0.1 | 100ms
1 | 1s (MAX)

Return Format

The query returns the current aperture time in scientific notation.

Example

The command below sets the aperture time to 1s for frequency measurement.

 FREQ:APER 1

The query below returns 1.00000000E+00.

 FREQ:APER?

Related Command

CONFigure:FREQuency


[SENSe:]FREQuency:VOLTage:RANGe

Syntax

[SENSe:]FREQuency:VOLTage:RANGe {<range>|MIN|MAX}

[SENSe:]FREQuency:VOLTage:RANGe? [MIN|MAX]

Description

This command sets the range of the input voltage in frequency measurement.

The query command queries the range of the input voltage in frequency measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200mV (MIN) 2V 20V 200V 750V (MAX)

Explanation

This command allows to send parameter with unit. The unit is V by default if the parameters are set without unit when the command is sent.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range of the input voltage in frequency measurement to 200V.

 FREQ:VOLT:RANG 200

The query below returns 2.00000000E+02.

 FREQ:VOLT:RANG?

Related Commands


[SENSe:]FREQuency:VOLTage:RANGe:AUTO

Syntax

[SENSe:]FREQuency:VOLTage:RANGe:AUTO <bool>

[SENSe:]FREQuency:VOLTage:RANGe:AUTO?

Description

This command enables or disables the auto range function of the input voltage in frequency measurement.

The query command queries the status of the auto range function of the input voltage in frequency measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | OFF|0

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of the input voltage in frequency measurement to auto.

 FREQ:VOLT:RANG:AUTO ON

The query below returns 1.

 FREQ:VOLT:RANG:AUTO?

Related Commands


[SENSe:]FRESistance:NPLCycles

Syntax

[SENSe:]FRESistance:NPLCycles {<PLCs>|MIN|MAX}

[SENSe:]FRESistance:NPLCycles? [MIN|MAX]

Description

This command sets the integral time for 4-wire resistance measurement in the number of Power Line Cycles.

The query command queries the integral time for 4-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<PLCs> | Discrete | 0.006|0.02|0.06|0.2|1|2|10|100 | 10

Explanation

The default unit is PLC, wherein, 1PLC = 0.02s. As shown in the table below, the integral time is related to the resolution, wherein, 1ppm = 0.000001 and represents "one millionth of ".

Integral Time | Resolution
0.006PLC(MIN) | 6ppm×Range
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC(MAX) | 0.03ppm×Range

Return Format

The query returns the current multiple of PLC in scientific notation.

Example

The command below sets the integral time to 10PLC for 4-wire resistance measurement.

 FRES:NPLC 10

The query below returns 1.00000000E+01.

 FRES:NPLC?

Related Command

CONFigure:FRESistance


[SENSe:]FRESistance:RANGe

Syntax

[SENSe:]FRESistance:RANGe {<range>|MIN|MAX}

[SENSe:]FRESistance:RANGe? [MIN|MAX]

Description

This command sets the range for 4-wire resistance measurement.

The query command queries the range for 4-wire resistance measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200 Ω (MIN) 2k Ω 20k Ω 200k Ω 1M Ω 10M Ω 100M Ω (MAX)

Explanation

The default unit of the parameter is Ω.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range to 2kΩ for 4-wire resistance measurement.

 FRES:RANG 2000

The query below returns 2.00000000E+03.

 FRES:RANG?

Related Commands


[SENSe:]FRESistance:RANGe:AUTO

Syntax

[SENSe:]FRESistance:RANGe:AUTO <bool>

[SENSe:]FRESistance:RANGe:AUTO?

Description

This command enables or disables the auto range function of 4-wire resistance measurement.

The query command queries the status of the auto range function of 4-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of 4-wire resistance measurement to auto.

FRES:RANG:AUTO ON

The query below returns 1.

 FRES:RANG:AUTO?

Related Commands


[SENSe:]FRESistance:RESolution

Syntax

[SENSe:]FRESistance:RESolution {<resolution>|MIN|MAX}

[SENSe:]FRESistance:RESolution? [MIN|MAX]

Description

This command sets the resolution for 4-wire resistance measurement.

The query command queries the resolution for 4-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC | 0.03ppm×Range (MIN)

Return Format

The query returns the current resolution in scientific notation.

Example

The command below selects the minimum resolution (the current range is 2k Ω) for 4-wire resistance measurement.

FRES:RES MIN

The query below returns 6.00000000E-05, namely 0.03ppm×Range.

 FRES:RES?

Related Command

CONFigure:FRESistance


[SENSe:]FUNCtion

Syntax

[SENSe:]FUNCtion "<function>"

[SENSe:]FUNCtion?

Description

This command selects measurement function for the multimeter.

The query command queries the measurement function selected.

Parameter

Name | Type | Range
<function> | Discrete | Refer to the table below

Explanation

The corresponding relations between the values of the parameter and measurement functions are as shown in the table below. This command does not have a default value.

Parameter Value | Measurement Function | Parameter Value | Measurement Function
VOLTage:DC | DC Voltage | FRESistance | 4-wire Resistance
VOLTage:AC | AC Voltage | FREQency | Frequency
CURRent:DC | DC Current | PERiod | Period
CURRent:AC | AC Current | CONTinuity | Connectivity
RESistance | 2-wire Resistance | DIODe | Diode

Return Format

The query returns "VOLT", "VOLT:AC", "CURR", "CURR:AC", "RES", "FRES", "FREQ", "PER", "CONT" or "DIOD".

Example

The command below selects DC current measurement function.

 FUNC "CURR:DC" or FUNC 'CURR:DC'

The query below returns "CURR".

 FUNC?

Related Command

CONFigure Command Subsystem


[SENSe:]PERiod:APERture

Syntax

[SENSe:]PERiod:APERture {<aperture>|MIN|MAX}

[SENSe:]PERiod:APERture? [MIN|MAX]

Description

This command sets the aperture time for period measurement.

The query command queries the aperture time for period measurement.

Parameter

Name | Type | Range | Default Value
<aperture> | Discrete | 0.001|0.01|0.1|1 | 0.1

Explanation

The default unit is s. The corresponding relations between the values of the parameter and aperture times are as shown in the table below.

Parameter Value | Aperture Time
0.001 | 1ms (MIN)
0.01 | 10ms
0.1 | 100ms
1 | 1s (MAX)

Return Format

The query returns the current aperture time in scientific notation.

Example

The command below sets the aperture time to 1s for period measurement.

 PER:APER 1

The query below returns 1.00000000E+00.

 PER:APER?

Related Command

CONFigure:PERiod


[SENSe:]PERiod:VOLTage:RANGe

Syntax

[SENSe:]PERiod:VOLTage:RANGe {<range>|MIN|MAX}

[SENSe:]PERiod:VOLTage:RANGe? [MIN|MAX]

Description

This command sets the range of the input voltage in period measurement.

The query command queries the range of the input voltage in period measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200mV (MIN) 2V 20V 200V 750V (MAX)

Explanation

This command allows to send parameter with unit. The unit is V by default if the parameters are set without unit when the command is sent.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range of the input voltage in period measurement to 200V.

 PER:VOLT:RANG 200

The query below returns 2.00000000E+02.

 PER:VOLT:RANG?

Related Commands


[SENSe:]PERiod:VOLTage:RANGe:AUTO

Syntax

[SENSe:]PERiod:VOLTage:RANGe:AUTO <bool>

[SENSe:]PERiod:VOLTage:RANGe:AUTO?

Description

This command enables or disables the auto range function of the input voltage in period measurement.

The query command queries the status of the auto range function of the input voltage in period measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | OFF|0

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of the input voltage in period measurement to auto.

PER:VOLT:RANG:AUTO ON

The query below returns 1.

 PER:VOLT:RANG:AUTO?

Related Commands


[SENSe:]RESistance:NPLCycles

Syntax

[SENSe:]RESistance:NPLCycles {<PLCs>|MIN|MAX}

[SENSe:]RESistance:NPLCycles? [MIN|MAX]

Description

This command sets the integral time for 2-wire resistance measurement in the number of Power Line Cycles.

The query command queries the integral time for 2-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<PLCs> | Discrete | 0.006|0.02|0.06|0.2|1|2|10|100 | 10

Explanation

The default unit is PLC, wherein, 1PLC = 0.02s. As shown in the table below, the integral time is related to the resolution, wherein, 1ppm = 0.000001 and represents "one millionth of ".

Integral Time | Resolution
0.006PLC(MIN) | 6ppm×Range
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC(MAX) | 0.03ppm×Range

Return Format

The query returns the current multiple PLC in scientific notation.

Example

The command below sets the integral time to 10PLC for 2-wire resistance measurement.

 RES:NPLC 10

The query below returns 1.00000000E+01.

 RES:NPLC?

Related Command

CONFigure:RESistance


[SENSe:]RESistance:RANGe

Syntax

[SENSe:]RESistance:RANGe {<range>|MIN|MAX}

[SENSe:]RESistance:RANGe? [MIN|MAX]

Description

This command sets the range for 2-wire resistance measurement.

The query command queries the range for 2-wire resistance measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200 Ω (MIN) 2k Ω 20k Ω 200k Ω 1M Ω 10M Ω 100M Ω (MAX)

Explanation

The default unit of the parameter is Ω.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range to 2kΩ for 2-wire resistance measurement.

 RES:RANG 2000

 The query below returns 2.00000000E+03.

 RES:RANG?

Related Commands


[SENSe:]RESistance:RANGe:AUTO

Syntax

[SENSe:]RESistance:RANGe:AUTO <bool>

[SENSe:]RESistance:RANGe:AUTO?

Description

This command enables or disables the auto range function of 2-wire resistance measurement.

The query command queries the status of the auto range function of 2-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of 2-wire resistance measurement to auto.

RES:RANG:AUTO ON

The query below returns 1.

 RES:RANG:AUTO?

Related Commands


[SENSe:]RESistance:RESolution

Syntax

[SENSe:]RESistance:RESolution {<resolution>|MIN|MAX}

[SENSe:]RESistance:RESolution? [MIN|MAX]

Description

This command sets the resolution for 2-wire resistance measurement.

The query command queries the resolution for 2-wire resistance measurement.

Parameter

Name | Type | Range | Default Value
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC | 0.03ppm×Range (MIN)

Return Format

The query returns the current resolution in scientific notation.

Example

The command below selects the minimum resolution (the current range is 2k Ω) for 2-wire resistance measurement.

RES:RES MIN

The query below returns 6.00000000E-05, namely 0.03ppm×Range.

 RES:RES?

Related Command

CONFigure:RESistance


[SENSe:]VOLTage:AC:RANGe

Syntax

[SENSe:]VOLTage:AC:RANGe {<range>|MIN|MAX}

[SENSe:]VOLTage:AC:RANGe? [MIN|MAX]

Description

This command sets the range for AC voltage measurement.

The query command queries the range for AC voltage measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200mV (MIN) 2V 20V 200V 750V (MAX)

Explanation

This command allows to set the parameter with unit and the unit is V by default if the parameters are set without unit.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range to 200V for AC voltage measurement.

 VOLT:AC:RANG 200

The query below returns 2.00000000E+02.

 VOLT:AC:RANG?

Related Commands

CONFigure:VOLTage:AC

[SENSe:]VOLTage:AC:RANGe:AUTO


[SENSe:]VOLTage:AC:RANGe:AUTO

Syntax

[SENSe:]VOLTage:AC:RANGe:AUTO <bool>

[SENSe:]VOLTage:AC:RANGe:AUTO?

Description

This command enables or disables the auto range function of AC voltage measurement.

The query command queries the status of the auto range function of AC voltage measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of AC voltage measurement to auto.

VOLT:AC:RANG:AUTO ON

The query below returns 1.

 VOLT:AC:RANG:AUTO?

Related Commands

CONFigure:VOLTage:AC

[SENSe:]VOLTage:AC:RANGe


[SENSe:]VOLTage:AC:RESolution

Syntax

[SENSe:]VOLTage:AC:RESolution {<resolution>|MIN|MAX}

[SENSe:]VOLTage:AC:RESolution? [MIN|MAX]

Description

This command sets the resolution for AC voltage measurement.

The query command queries the resolution for AC voltage measurement.

Parameter

Name | Type | Range | Default Value
<resolution> | Discrete | The resolution is fixed at 61/2 bits | The resolution is fixed at 61/2 bits

Explanation

The resolution of AC voltage measurement is fixed at 61/2 bits and actually, this command can be ignored.

Return Format

The query returns the current resolution in scientific notation.

Related Command

CONFigure:VOLTage:AC


[SENSe:]VOLTage:DC:NPLCycles

Syntax

[SENSe:]VOLTage:DC:NPLCycles {<PLCs>|MIN|MAX}

[SENSe:]VOLTage:DC:NPLCycles? [MIN|MAX]

Description

This command sets the integral time for DC voltage measurement in the number of Power Line Cycles.

The query command queries the integral time for DC voltage measurement.

Parameter

Name | Type | Range | Default Value
<PLCs> | Discrete | 0.006|0.02|0.06|0.2|1|2|10|100 | 10

Explanation

The default unit is PLC, wherein, 1PLC = 0.02s. As shown in the table below, the integral time is related to the resolution, wherein, 1ppm = 0.000001 and represents "one millionth of ".

Integral Time | Resolution
0.006PLC(MIN) | 6ppm×Range
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC(MAX) | 0.03ppm×Range

Return Format

The query returns the current multiple of PLC in scientific notation.

Example

The command below sets the integral time to 10PLC for DC voltage measurement.

 VOLT:DC:NPLC 10

The query below returns 1.00000000E+01.

 VOLT:DC:NPLC?

Related Command

CONFigure:VOLTage:DC


[SENSe:]VOLTage:DC:RANGe

Syntax

[SENSe:]VOLTage:DC:RANGe {<range>|MIN|MAX}

[SENSe:]VOLTage:DC:RANGe? [MIN|MAX]

Description

This command sets the range for DC voltage measurement.

The query command queries the range for DC voltage measurement.

Parameter

Name | Type | Range
<range> | Discrete | 200mV (MIN) 2V 20V 200V 1000V (MAX)

Explanation

This command allows to set the parameter with unit and the unit is V by default if the parameters are set without unit.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range to 200V for DC voltage measurement.

 VOLT:DC:RANG 200

The query below returns 2.00000000E+02.

 VOLT:DC:RANG?

Related Commands


[SENSe:]VOLTage:DC:RANGe:AUTO

Syntax

[SENSe:]VOLTage:DC:RANGe:AUTO <bool>

[SENSe:]VOLTage:DC:RANGe:AUTO?

Description

This command enables or disables the auto range function of DC voltage measurement.

The query command queries the status of the auto range function of DC voltage measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Return Format

The query returns the current status of auto range: 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of DC voltage measurement to auto.

VOLT:DC:RANG:AUTO ON

The query below returns 1.

 VOLT:DC:RANG:AUTO?

Related Commands


[SENSe:]VOLTage:DC:RESolution

Syntax

[SENSe:]VOLTage:DC:RESolution {<resolution>|MIN|MAX}

[SENSe:]VOLTage:DC:RESolution? [MIN|MAX]

Description

This command sets the resolution for DC voltage measurement.

The query command queries the resolution for DC voltage measurement.

Parameter

Name | Type | Range | Default Value
<resolution> | Discrete | As shown in the table below | 0.1ppm×Range (10PLC Integral Time)1

Note1: 1ppm = 0.000001, represents "one millionth of"; 1PLC = 0.02s.

Explanation

The resolution is related to the integral time as shown in the table below.

Integral Time | Resolution
0.006PLC | 6ppm×Range (MAX)
0.02PLC | 3ppm×Range
0.06PLC | 1.5ppm×Range
0.2PLC | 0.7ppm×Range
1PLC | 0.3ppm×Range
2PLC | 0.2ppm×Range
10PLC | 0.1ppm×Range
100PLC | 0.03ppm×Range (MIN)

Return Format

The query returns the current resolution in scientific notation.

Example

The command below selects the minimum resolution (the current range is 200V) for DC voltage measurement.

 VOLT:DC:RES MIN

The query below returns 6.00000000E-06, namely 0.03ppm×range.

 VOLT:DC:RES?

Related Command

CONFigure:VOLTage:DC


[SENSe:]ZERO:AUTO

Syntax

[SENSe:]ZERO:AUTO <bool>

[SENSe:]ZERO:AUTO?

Description

This command enables or disables the auto zero function of the multimeter.

The query command queries the status of the auto zero function of the multimeter.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Explanation

The auto zero function is applicable to DCV, DCI, 2WR and 4WR measurement functions.

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below enables the auto zero function.

ZERO:AUTO ON

The query below returns 1.

 ZERO:AUTO ON?

Related Command

[SENSe:]FUNCtion


SYSTem命令子系统

SYSTem Command Subsystem


SYSTem:BEEPer

Syntax

SYSTem:BEEPer

Description

This command issues a single beep immediately and test the beeper.

Explanation

Enable the beeper before sending the command.

Related Command

SYSTem:BEEPer:STATe


SYSTem:BEEPer:STATe

Syntax

SYSTem:BEEPer:STATe <bool>

SYSTem:BEEPer:STATe?

Description

This command enables or disables the beeper of the multimeter.

The query command queries the status of the beeper.

Parameter

Name | Type | Range
<bool> | Bool | {{0|OFF}|{1|ON}}

Explanation

If the beeper is disabled using this command, the beeper testing command SYSTem:BEEPer is unavailable.

Return Format

The query returns 1 or 0.

Example

The command below disables the beeper.

SYST:BEEP:STAT OFF

The query below returns 0.

 SYST:BEEP:STAT?

Related Command

SYSTem:BEEPer


TRIGger命令子系统

TRIGger Command Subsystem

TRIGger:COUNt


TRIGger:COUNt

Syntax

TRIGger:COUNt {<value>|MIN|MAX|INF}

TRIGger:COUNt? [MIN|MAX]

Description

This command sets the number of triggers of the multimeter to any figure or infinite.

The query command queries the number of triggers of the multimeter.

Parameter

Name | Type | Range
<value> | Integer | 1 to 50000

Explanation

1 The multimeter returns to "Idle" state after executing the specified number of triggers.

2 When the parameter is set to INF, the multimeter executes triggers continuously without returning to "Idle" state.

3 You can also specify the number of samples (the SAMPle:COUNt command) per trigger. At this point, the total number of readings returned will be the product of the sample count and trigger count (Number of Readings = Sample Count × Trigger Count).

Return Format

The query returns the number of triggers in scientific notation.

Example

The command below sets the number of triggers to 10.

 TRIG:COUN 10

The query below returns 10.

 TRIG:COUN?

Related Commands

SAMPle:COUNt

TRIGger:SOURce


TRIGger:DELay

Syntax

TRIGger:DELay {<seconds>|MIN|MAX}

TRIGger:DELay? [MIN|MAX]

Description

This command sets the trigger delay time of the mutlimeter.

The query command queries the trigger delay time of the multimeter.

Parameter

Name | Type | Range | Default Value
<seconds> | Real | 1s to 3600s | Auto Delay Time 1

Note1: The auto delay time is determined by several parameters such as the measurement function, range, integral time and AC filter.

Explanation

Note the relation and difference between this command and the :TRIGger:AUTO:INTErval command in RIGOL Command Set: both the two commands set the trigger delay time; this command is applicable to all the trigger sources (BUS, IMM, EXT or INT, refer to the TRIGger:SOURce command) while the latter is only available when the trigger source is AUTO (refer to the :TRIGger:SOURce command).

Return Format

The query returns the trigger delay time in scientific notation.

Example

The command below sets the trigger delay time to 2s.

 TRIG:DEL 2

The query below returns 2.

 TRIG:DEL?

Related Commands

TRIGger:DELay:AUTO
TRIGger:SOURce

:TRIGger:AUTO:INTErval（RIGOL）

:TRIGger:SOURce（RIGOL）


TRIGger:DELay:AUTO

Syntax

TRIGger:DELay:AUTO <bool>

TRIGger:DELay:AUTO?

Description

This command enables or disables the auto setting mode of trigger delay time.

The query command queries the status of the auto setting mode of the trigger delay time.

Parameter

Name | Type | Range
<bool> | Bool | {{0|OFF}|{1|ON}}

Explanation

When auto trigger delay time is enabled, the delay time is determined by the measurement function, range and integral time.

Return Format

The query returns 0 (OFF) or 1 (ON).

Example

The command below enables auto trigger delay time.

TRIG:DEL:AUTO ON

The query below returns 1.

 TRIG:DEL:AUTO?

Related Commands

TRIGger:COUNt


TRIGger:SOURce

Syntax

TRIGger:SOURce <source>

TRIGger:SOURce?

Description

This command selects trigger source for the multimeter.

The query command queries the trigger source selected.

Parameter

Name | Type | Range
<source> | Discrete | BUS|IMMediate|EXTernal|INTernal

Explanation

The corresponding relations between the values of the parameter and trigger sources are as shown in the table below.

Parameter Value | Trigger Source | RIGOL Corresponding Parameter
BUS | Single Trigger | SINGLE
IMMediate | Auto Trigger | AUTO
EXTernal | External Trigger | EXT
INTernal | Level Trigger | ----

Return Format

The query returns the trigger source selected: BUS, IMM, EXT or INT.

Example

The command below sets the trigger source of the instrument to external trigger.

TRIG:SOUR EXT

The query below returns EXT.

 TRIG:SOUR?

Related Commands

TRIGger:COUNt


扩展的Agilent命令集

Expanded Agilent Command Set

DM3068 supports the following commands which are the expansion of the Agilent34401A commands by referring to the realizing method of Agilent34411A. Use the CMDSet command (namely CMDSet AGILENT) to select Agilent Command Set before using these commands.

SYSTem:COMMunicate:GPIB:ADDRess
UNIT:TEMPerature

ANYSensor Command Subsystem

CALCulate Command Subsystem
CONFigure Command Subsytem
MEASure Command Subsystem

[SENSe:] Command Subsystem

TRIGger Command Subsystem


SYSTem:COMMunicate:GPIB:ADDRess

Syntax

SYSTem:COMMunicate:GPIB:ADDRess <address>

SYSTem:COMMunicate:GPIB:ADDRess?

Description

This command sets the GPIB address.

The query command queries the GPIB address.

Parameter

Name | Type | Range | Default Value
<addr> | Integer | 0 to 30 | 7

Return Format

The query returns any integer between 0 and 30.

Example

The command below sets the GPIB address to 9.

 SYST:COMM:GPIB:ADDR 9

The query below returns 9.

 SYST:COMM:GPIB:ADDR?


UNIT:TEMPerature

Syntax

UNIT:TEMPerature <units>

UNIT:TEMPerature?

Description

This command sets the unit of temperature measurement.

Query the unit of temperature measurement.

Parameter

Name | Type | Range
<units> | Discrete | {C|F|K}

Explanation

C: abbreviation of Celsius. Set the unit to ℃.

F: abbreviation of Fahrenheit. Set the unit to ℉.

K: abbreviation of Kelvins. Set the unit to K.

Return Format

The query returns c, f or k.

Example

The command below sets the unit of temperature measurement to ℉.

 UNIT:TEMP F

The query below returns f.

 UNIT:TEMP?


ANYSensor命令子系统

ANYSensor Command Subsystem

ANYSensor:APPLy 1

ANYSensor:DONE?

ANYSensor:NAME

ANYSensor:POINt

ANYSensor:POINt:DELete

ANYSensor:POINt:EDIT

ANYSensor:POINt?

ANYSensor:TYPE

ANYSensor:UNIT


ANYSensor:APPLy 1

Syntax

ANYSensor:APPLy 1

Description

Validate the any sensor configuration.

Explanation

This command can validate the configuration only when it is sent after the configuration of the any sensor is finished. Otherwise, the configuration can not be validated and error will occur.


ANYSensor:DONE?

Syntax

ANYSensor:DONE?

Description

Query whether the configuration of the any sensor is finished.

Explanation

When the arithmetic type is set to interpolation (LINE), at least 2 pairs of measurement values and corresponding values should be contained in the data segment; when the arithmetic type is set to fitting (CURV), at least 5 pairs of measurement values and corresponding values should be contained in the data segment.

If the configuration is finished, you can send the ANYSensor:APPLy 1 command to validate the configuration. If the configuration is not finished, you have to wait until the configuration is finished and then send the command; otherwise, error will occur.

Return Format

The query returns 1 (finished) or 0 (not finished).

Example

The query below returns 1.

 ANYS:DONE?


ANYSensor:NAME

Syntax

ANYSensor:NAME <name>

ANYSensor:NAME?

Description

Set the name of the sensor.

Query the name of the sensor.

Parameter

Name | Type | Range
<name> | ASCII Character String | The length can not exceed 9 characters.

Explanation

<name> could be a character string consisting of English uppercase/lowercase letters and numbers and its length can not exceed 9 characters.

The name set by this command becomes valid only after finishing the configuration and sending the ANYSensor:APPLy 1 command.

Return Format

The query returns the name of the current sensor.

Example

The command below sets the name of the current sensor to sensor001.

 ANYS:NAME sensor001

The query below returns sensor001.

 ANYS:NAME?


ANYSensor:POINt

Syntax

ANYSensor:POINt <measure_value>,<correspond_value>,<math_mode>,<math_type>

Description

Add a point to the arithmetic curve.

Parameter

Name | Type | Range | Default (DEF)
<measure_value> | Real | Related to the type of the current sensor | --
<correspond_value> | Real | -- | --
<math_mode> | Discrete | ON|OFF|1|0|DEF | OFF|0
<math_type> | Discrete | LINE|CURV|DEF | LINE

Explanation

<measure_value>: measurement value. The unit and range are related to the type of the current sensor as shown in the table below.

Type | Range
DCV | -1100 V to 1100 V
DCI | -220 mA to 220 mA
2WR | 0 Ω to 110 MΩ
4WR | 0 Ω to 110 MΩ
FREQ | 0 Hz to 1100 kHz

<correspond_value>: corresponding value. The unit is related to the physical quantity under test and is the same with the unit defined by the ANYSensor:UNIT command.

<math_mode>: segment mode. When it is enabled, the arithmetic type specified in <math_type> is used starting from this point to the next point for which the segment mode is enabled.

<math_type>: arithmetic type. Interpolation (LINE, at least 2 pairs of measurement values and corresponding values should be contained in the data segment) and fitting (CURV, at least 5 pairs of measurement values and corresponding values should be contained in the data segment).

Example

The command below adds a 12 V, 0.5℃ point for which the segment mode is enabled and the arithmetic type is fitting.

ANYS:POIN 12,0.5,1,CURV


ANYSensor:POINt:DELete

Syntax

ANYSensor:POINt:DELete <measure_value>,<correspond_value>

Description

Delete the specified point on the arithmetic curve.

Parameter

Name | Type | Range
<measure_value> | Real | Measurement values of the points edited
<correspond_value> | Real | Corresponding values of the points edited

Explanation

<measure_value> and <correspond_value> must be values of the same point.

Example

The command below deletes a point.

 ANYS:POIN:DEL 12,0.5


ANYSensor:POINt:EDIT

Syntax

ANYSensor:POINt:EDIT <measure_value>,<correspond_value>,<math_mode>,<math_type>

Description

Modify the specified point on the arithmetic curve.

Parameter

Name | Type | Range | Default (DEF)
<measure_value> | Real | Measurement values of the points edited | --
<correspond_value> | Real | -- | --
<math_mode> | Discrete | ON|OFF|1|0|DEF | OFF|0
<math_type> | Discrete | LINE|CURV|DEF | LINE

Explanation

This command modifies the corresponding value, segment mode and arithmetic type corresponding to the specified measurement value on the arithmetic curve.

Example

The command below modifies the corresponding value, segment mode and arithmetic type corresponding to the measurement value 12 V.

ANYS:POIN:EDIT 12,1.1,1,LINE


ANYSensor:POINt?

Syntax

ANYSensor:POINt?

Description

Query the points currently edited.

Return Format

The query returns all the points currently edited in the format of 1:Measurement Value,Corresponding Value,Segment Mode,Arithmetic Type;2:Measurement Value,Corresponding Value,Segment Mode,Arithmetic Type;3:……;

Wherein, the Measurement Value and Corresponding Value are returned in scientific notation; the return value of Segment Mode is 0 or 1; the return value of Arithmetic Type is LINE or CURV.

Example

The query below returns 1:1.00000000E-03,1.00000000E+00,1,LINE;2:2.00000000E-03,2.00000000E+00,0,LINE;3:3.00000000E-03,3.00000000E+00,0,LINE;4:4.00000000E-03,4.00000000E+00,0,LINE;5:5.00000000E-03,5.00000000E+00,1,CURV;

 ANYS:POIN?


ANYSensor:TYPE

Syntax

ANYSensor:TYPE <type>

ANYSensor:TYPE?

Description

Set the sensor type.

Query the sensor type.

Parameter

Name | Type | Range | Default
<type> | Discrete | DCV|DCI|2WR|4WR|FREQ | DCV

Return Format

The query returns the current sensor type in character string.

Example

The command below sets the sensor type to DCI.

 ANYS:TYPE DCI

The query below returns DCI.

 ANYS:TYPE?


ANYSensor:UNIT

Syntax

ANYSensor:UNIT "<unit>"

ANYSensor:UNIT?

Description

Set the unit of the sensor.

Query the unit of the sensor.

Parameter

Name | Type | Range
<unit> | ASCII character string | The length can not exceed 2 characters

Explanation

The unit set by this command becomes valid only after finishing the configuration and sending the ANYSensor:APPLy 1 command.

Return Format

The query returns the unit of the current sensor.

Example

The command below sets the unit of the current sensor to mV.

 ANYS:UNIT "mV"

The query below returns "mV".

 ANYS:UNIT?


CALCulate命令子系统

CALCulate Command Subsystem

The expanded commands for Agilent34401A math operation commands are as follows:

CALCulate:AVERage:CLEar
CALCulate:AVERage:PTPeak?

CALCulate:AVERage:SDEViation?


CALCulate:AVERage:CLEar

Syntax

CALCulate:AVERage:CLEar

Description

This command clears all the results of statistic operations in the register.

Explanation

This command clears the maximum, minimum, average, count and standard deviation but does not clear the stored readings.

Related Commands

CALCulate:AVERage:AVERage?
CALCulate:AVERage:COUNt?
CALCulate:AVERage:MAXimum?
CALCulate:AVERage:MINimum?

CALCulate:AVERage:PTPeak?

CALCulate:AVERage:SDEViation?

CALCulate:STATe


CALCulate:AVERage:PTPeak?

Syntax

CALCulate:AVERage:PTPeak?

Description

This command queries the peak-peak value of all readings taken since the statistic operations were enabled.

Explanation

Use the CALCulate:FUNCtion command to select AVERage operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the peak-peak value of all readings taken since the statistic operations were enabled in scientific notation. The query returns 0 when there is no reading currently.

Example

The query below returns 1.841040E+00.

 CALC:AVER:PTP?

Related Commands

CALCulate:AVERage:CLEar
CALCulate:AVERage:COUNt?

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:AVERage:SDEViation?

Syntax

CALCulate:AVERage:SDEViation?

Description

This command queries the mean square deviation of all readings taken since the statistic operations were enabled.

Explanation

Use the CALCulate:FUNCtion command to select AVERage operation and the CALCulate:STATe command to enable the operation before using this command.

Return Format

The query returns the mean square deviation in scientific notation.

Example

The query below returns 1.926062E+01.

 CALC:AVER:SDEV?

Related Commands

CALCulate:AVERage:CLEar
CALCulate:FUNCtion

CALCulate:STATe

CALCulate:AVERage:COUNt?


CONFigure命令子系统

CONFigure Command Subsystem

CONFigure:CAPacitance

CONFigure:TEMPerature


CONFigure:CAPacitance

Syntax

CONFigure:CAPacitance [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with the specified range and resolution for capacitance measurement.

Parameter

Name | Type | Range | Default
<range> | Discrete | 2nF (MIN) 20nF 200nF 2uF (DEF) 20uF 200uF 2mF 20mF 100mF(MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 3 1/2 bits | The resolution is fixed at 3 1/2 bits

Explanation

This command sets the range and resolution to their default values when this command are sent without parameters. This command allows to set the parameter with unit and the default unit is F when the parameters are set without unit.

This command only specifies parameter but does not initiate the measurement.

Example

The command below sets the range and resolution for capacitance measurement of the multimeter to their default values.

CONF:C AP

The query command CONFigure? returns "CAP 2.00000000E-06,2.00000000E-10".

Related Command

CONFigure?


CONFigure:TEMPerature

Syntax

CONFigure:TEMPerature [{<probe_type>|DEF}[,{<type>|DEF} [,1 [,{<resolution>|MIN|MAX|DEF}]]]]

Description

This command configures the temperature measurement parameters of the multimeter using the specified parameters to execute the temperature measurement function.

Parameter

Name | Type | Range |  | Default (DEF)
<probe_type> | Discrete | {FRTD|RTD|FTHermistor|THERmistor|TC|ANY} |  | FRTD
<type> | Discrete | FRTD | {85|89|91|92} | 85
 |  | RTD | {85|89|91|92} | 85
 |  | FTHermistor | {2252|3000|5000|10000|30000} | 5000
 |  | THERmistor | {2252|3000|5000|10000|30000} | 5000
 |  | TC | {B|E|J|K|N|R|S|T} | B
<resolution> | Discrete | For DM3068, this parameter is invalid and DM3068 only receives this parameter. |  | --

Explanation

This command only specifies parameters but does not enable the measurement.

Example

CONF:TEMP DEF,DEF,1,DEF

The query below returns "TEMP FRTD,85,2.00000000E+02,2.00000000E-05".

 CONFigure?


MEASure命令子系统

MEASure Command Subsystem


MEASure:CAPacitance?

Syntax

MEASure:CAPacitance? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a capacitance measurement with the specified range and resolution. The reading is sent to the output buffer.

Parameter

Name | Type | Range | Default
<range> | Discrete | 2nF (MIN) 20nF 200nF 2uF (DEF) 20uF 200uF 2mF 2mF 100mF(MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 3 1/2 bits | The resolution is fixed at 3 1/2 bits

Explanation

This command sets the range and resolution to their default values and executes capacitance measurement when the parameters are set without unit.

Return Format

The query returns the reading in the output buffer.

Example

The command below sets the capacitance measurement parameters to their default values, triggers the multimeter to make measurement, loads one reading and sends it to the output buffer. The return value is 1.27216258e-11.

 MEAS:CAP?

Related Command

CONFigure?


MEASure:TEMPerature?

Syntax

MEASure:TEMPerature? [{<probe_type>|DEF}[,{<type>|DEF} [,1 [,{<resolution>|MIN|MAX|DEF}]]]]

Description

This command configures the temperature measurement parameters using the specified parameters and executes temperature measurement; then, sends the measurement reading to the output buffer.

Parameter

Name | Type | Range |  | Default (DEF)
<probe_type> | Discrete | {FRTD|RTD|FTHermistor|THERmistor|TC|ANY} |  | FRTD
<type> | Discrete | FRTD | {85|89|91|92} | 85
 |  | RTD | {85|89|91|92} | 85
 |  | FTHermistor | {2252|3000|5000|10000|30000} | 5000
 |  | THERmistor | {2252|3000|5000|10000|30000} | 5000
 |  | TC | {B|E|J|K|N|R|S|T} | B
<resolution> | Discrete | For DM3068, this parameter is invalid and DM3068 only receives this parameter. |  | --

Return Format

The query returns the reading in the output buffer in scientific notation.

Example

The command below returns 2.77216258e+01.

 MEAS:TEMP? DEF,DEF,1,DEF


[SENSe:]命令子系统

[SENSe:] Command Subsystem

[SENSe:]CAPacitance:NULL:STATe
[SENSe:]CAPacitance:NULL:VALue

[SENSe:]CAPacitance:RANGe
[SENSe:]CAPacitance:RANGe:AUTO
[SENSe:]CURRent:AC:BANDwidth
[SENSe:]CURRent:AC:NULL:STATe
[SENSe:]CURRent:AC:NULL:VALue
[SENSe:]CURRent:AC:PEAK:STATe

[SENSe:]CURRent:DC:APERture
[SENSe:]CURRent:DC:APERture:ENABled
[SENSe:]CURRent:DC:NULL:STATe
[SENSe:]CURRent:DC:NULL:VALue
[SENSe:]CURRent:DC:PEAK:STATe
[SENSe:]CURRent:DC:ZERO:AUTO

[SENSe:]FREQuency:APERture
[SENSe:]FREQuency:NULL:STATe
[SENSe:]FREQuency:NULL:VALue
[SENSe:]FREQuency:RANGe:LOWer

[SENSe:]FRESistance:APERture
[SENSe:]FRESistance:APERture:ENABled

[SENSe:]FRESistance:NULL:STATe
[SENSe:]FRESistance:NULL:VALue
[SENSe:]FRESistance:OCOMpensated

[SENSe:]PERiod:APERture
[SENSe:]PERiod:NULL:STATe
[SENSe:]PERiod:NULL:VALue
[SENSe:]PERiod:RANGe:LOWer

[SENSe:]RESistance:APERture
[SENSe:]RESistance:APERture:ENABled
[SENSe:]RESistance:NULL:STATe
[SENSe:]RESistance:NULL:VALue
[SENSe:]RESistance:OCOMpensated
[SENSe:]RESistance:ZERO:AUTO

[SENSe:]TEMPerature:NULL[:STATe]

[SENSe:]TEMPerature:NULL:VALue

[SENSe:]TEMPerature:TRANsducer:FRTD:RESistance[:REFerence]

[SENSe:]TEMPerature:TRANsducer:FRTD:TYPE

[SENSe:]TEMPerature:TRANsducer:FTHermistor:TYPE

[SENSe:]TEMPerature:TRANsducer:RTD:RESistance[:REFerence]

[SENSe:]TEMPerature:TRANsducer:RTD:TYPE

[SENSe:]TEMPerature:TRANsducer:THERmistor:TYPE

[SENSe:]TEMPerature:TRANsducer:TYPE

[SENSe:]VOLTage:AC:BANDwidth
[SENSe:]VOLTage:AC:NULL:STATe
[SENSe:]VOLTage:AC:NULL:VALue
[SENSe:]VOLTage:AC:PEAK:STATe

[SENSe:]VOLTage:DC:APERture
[SENSe:]VOLTage:DC:APERture:ENABled
[SENSe:]VOLTage:DC:IMPedance:AUTO
[SENSe:]VOLTage:DC:NULL:STATe
[SENSe:]VOLTage:DC:NULL:VALue


[SENSe:]CAPacitance:NULL:STATe

Syntax

[SENSe:]CAPacitance:NULL:STATe {ON|OFF}

[SENSe:]CAPacitance:NULL:STATe?

Description

This command enables or disables the null function for CAP measurement.

The query command queries the status of the null function for CAP measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for CAP measurement.

CAP:NULL:STAT OFF

The query below returns OFF.

 CAP:NULL:STAT?

Related Commands

CONFigure:CAPacitance

[SENSe:]CAPacitance:NULL:VALue


[SENSe:]CAPacitance:NULL:VALue

Syntax

[SENSe:]CAPacitance:NULL:VALue {<value>|MIN|MAX}

[SENSe:]CAPacitance:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for CAP measurement.

The query command queries the null value for CAP measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -1100mF to +1100mF | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to -1nF.

 CAP:NULL:VAL -1.0E-09

The query below returns -1.00000000E-09.

 CAP:NULL:VAL?

Related Commands

CONFigure:CAPacitance

[SENSe:]CAPacitance:NULL:STATe


[SENSe:]CAPacitance:RANGe

Syntax

[SENSe:]CAPacitance:RANGe {<range>|MIN|MAX}

[SENSe:]CAPacitance:RANGe? [MIN|MAX]

Description

This command sets the range for CAP measurement.

The query command queries the range for CAP measurement.

Parameter

Name | Type | Range
<range> | Discrete | 2nF (MIN) 20nF 200nF 2uF 20uF 200uF 2mF 20mF 100mF (MAX)

Explanation

This command allows to set the parameter with unit and the unit is F by default when the parameters are set without unit.

Return Format

The query returns the current range in scientific notation.

Example

The command below sets the range to 20mF for CAP measurement.

 CAP:RANG 20mF

The query below returns 2.00000000E-02.

 CAP:RANG?

Related Commands

CONFigure:CAPacitance

[SENSe:]CAPacitance:RANGe:AUTO


[SENSe:]CAPacitance:RANGe:AUTO

Syntax

[SENSe:]CAPacitance:RANGe:AUTO <bool>

[SENSe:]CAPacitance:RANGe:AUTO?

Description

This command enables or disables the auto range function of CAP measurement.

The query command queries the status of the auto range function of CAP measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | ON|1

Return Format

The query returns the current status of auto range: 1 (ON) or 0 (OFF).

Example

The command below sets the range setting of CAP measurement to auto.

CAP:RANG:AUTO ON

The query below returns 1.

 CAP:RANG:AUTO?

Related Commands

CONFigure:CAPacitance

[SENSe:]CAPacitance:RANGe


[SENSe:]CURRent:AC:BANDwidth

Syntax

[SENSe:]CURRent:AC:BANDwidth {<filter>|MIN|MAX|DEF}

[SENSe:]CURRent:AC:BANDwidth? [MIN|MAX]

Description

This command selects the type of AC filter for ACI measurement.

The query command queries the AC filter type currently selected.

Parameter

Name | Type | Range | Default Value (DEF)
<filter> | Discrete | 3|20|200 | 20

Explanation

DM3068 provides three types of AC filters: Slow, Medium and Fast. The corresponding relations between the values of the parameter and filter types are as shown in the table below.

Parameter Value | Filter Type | Filter Bandwidth
3 | Slow | 3Hz to 300kHz
20 | Medium | 20Hz to 300kHz
200 | Fast | 200Hz to 300kHz

Return Format

The query returns the lowest frequency (3.00000000E+00, 2.00000000E+01 or 2.00000000E+02) of the currently selected filter in scientific notation.

Example

The command below selects fast filter.

 CURR:AC:BAND 200

The query below returns 2.00000000E+02.

 CURR:AC:BAND?

Related Command

CONFigure:CURRent:AC


[SENSe:]CURRent:AC:NULL:STATe

Syntax

[SENSe:]CURRent:AC:NULL:STATe {ON|OFF}

[SENSe:]CURRent:AC:NULL:STATe?

Description

This command enables or disables the null function for ACI measurement.

The query command queries the status of the null function for ACI measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for ACI measurement.

CURR:AC:NULL:STAT OFF

The query below returns OFF.

 CURR:AC:NULL:STAT?

Related Commands

CONFigure:CURRent:AC

[SENSe:]CURRent:AC:NULL:VALue


[SENSe:]CURRent:AC:NULL:VALue

Syntax

[SENSe:]CURRent:AC:NULL:VALue {<value>|MIN|MAX}

[SENSe:]CURRent:AC:NULL:VALue? [{MIN|MAX}]

Description

This command sets a null value for ACI measurement.

The query command queries the null value for ACI measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -11A to +11A | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to -0.1.

 CURR:AC:NULL:VAL -0.1

The query below returns -1.00000000E-01.

 CURR:AC:NULL:VAL?

Related Command

CONFigure:CURRent:AC


[SENSe:]CURRent:AC:PEAK:STATe

Syntax

[SENSe:]CURRent:AC:PEAK:STATe {ON|OFF}

[SENSe:]CURRent:AC:PEAK:STATe?

Description

This command enables or disables the peak measurement function for ACI measurement.

The query command queries whether the peak measurement function for ACI measurement is enabled.

Explanation

The multimeter also measures the peak current during ac current measurement when the peak measurement is enabled (STATe = ON).

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below disables peak current measurement.

CURR:AC:PEAK:STAT OFF

The query below returns OFF.

 CURR:AC:PEAK:STAT?

Related Command

CONFigure:CURRent:AC


[SENSe:]CURRent:DC:APERture

Syntax

[SENSe:]CURRent:DC:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]CURRent:DC:APERture? [MIN|MAX]

Description

This command sets the integral time in aperture time for DCI measurement.

The query command queries the integral time for DCI measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<seconds> | Real | 100us to 1s | 100ms

Explanation

The default unit of the parameter is s.

This command provides precise integral time while the [SENSe:]CURRent:DC:NPLCycles command offers better power-line noise rejection characteristics (for values of NPLC greater than 1).

Return Format

The query returns the current integral time in scientific notation.

Example

The command below sets the integral time to its default value for DCI measurement.

CURR:DC:APER DEF

The query below returns 1.00000000E-01.

 CURR:DC:APER?

Related Commands

CONFigure:CURRent:DC

[SENSe:]CURRent:DC:APERture:ENABled


[SENSe:]CURRent:DC:APERture:ENABled

Syntax

[SENSe:]CURRent:DC:APERture:ENABled {ON|OFF}

[SENSe:]CURRent:DC:APERture:ENABled?

Description

This command enables or disables the aperture time mode of integral time (DCI measurement).

The query command queries whether the aperture time mode of integral time (DCI measurement) is enabled.

Return Format

The query returns 0 (OFF) or 1 (ON).

Example

The command below enables the aperture time mode of integral time (DCI measurement).

 CURR:DC:APER:ENAB ON

The query below returns 1.

 CURR:DC:APER:ENAB?

Related Commands

CONFigure:CURRent:DC

[SENSe:]CURRent:DC:APERture


[SENSe:]CURRent:DC:NULL:STATe

Syntax

[SENSe:]CURRent:DC:NULL:STATe {ON|OFF}

[SENSe:]CURRent:DC:NULL:STATe?

Description

This command enables or disables the null function for DCI measurement.

The query command queries the status of the null function for DCI measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for DCI measurement.

CURR:DC:NULL:STAT OFF

The query below returns OFF.

 CURR:DC:NULL:STAT?

Related Commands

CONFigure:CURRent:DC

[SENSe:]CURRent:DC:NULL:VALue


[SENSe:]CURRent:DC:NULL:VALue

Syntax

[SENSe:]CURRent:DC:NULL:VALue {<value>|MIN|MAX}

[SENSe:]CURRent:DC:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for DCI measurement.

The query command queries the null value for DCI measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -11A to +11A | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to -0.1.

 CURR:DC:NULL:VAL -0.1

The query below returns -1.00000000E-01.

 CURR:DC:NULL:VAL?

Related Command

CONFigure:CURRent:DC


[SENSe:]CURRent:DC:PEAK:STATe

Syntax

[SENSe:]CURRent:DC:PEAK:STATe {ON|OFF}

[SENSe:]CURRent:DC:PEAK:STATe?

Description

This command enables or disables the peak measurement function for DCI measurement.

The query command queries whether the peak measurement function for DCI measurement is enabled.

Explanation

The multimeter also measures the peak current during dc current measurement when the peak measurement is enabled (STATe = ON).

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below disables peak current measurement.

CURR:DC:PEAK:STAT OFF

The query below returns OFF.

 CURR:DC:PEAK:STAT?

Related Command

CONFigure:CURRent:DC


[SENSe:]CURRent:DC:ZERO:AUTO

Syntax

[SENSe:]CURRent:DC:ZERO:AUTO <mode>

[SENSe:]CURRent:DC:ZERO:AUTO?

Description

This command enables or disables the auto zero function for DCI measurement.

The query command queries whether the auto zero function for DCI measurement is enabled.

Parameter

Name | Type | Range
<mode> | Discrete | {{0|OFF}|{1|ON}|ONCE}

Explanation

When auto zero is enabled (ON|1), the multimeter internally disconnects the input signal following each measurement, and takes a zero reading. It then subtracts the zero reading from the preceding reading. This prevents offset voltages present on the instrument's input circuitry from affecting measurement accuracy.

When auto zero is disabled (OFF|0), the multimeter uses the last measured zero reading and subtracts it from each measurement. It takes a new zero reading each time you change the function, range, or integration time.

In single auto zero mode (ONCE), the multimeter takes one zero reading, and then sets auto zero to off. The zero reading taken is subtracted from all subsequent measurements.

Return Format

The query returns 1 (ON) or 0 (OFF|ONCE).

Example

The command below disables auto zero function.

CURR:DC:ZERO:AUTO OFF

The query below returns 0.

 CURR:DC:ZERO:AUTO?

Related Command

CONFigure:CURRent:DC


[SENSe:]FREQuency:APERture

Syntax

[SENSe:]FREQuency:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]FREQuency:APERture? [MIN|MAX]

Description

This command sets the aperture time for FREQ measurement.

The query command queries the aperture time for FREQ measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<seconds> | Discrete | 1ms|10ms|100ms|1s | 100ms

Explanation

This command sets the aperture time for both the FREQ measurement and the PERIOD measurement.

Return Format

The query returns the current aperture time in scientific notation.

Example

The command below sets the aperture time to its default value for FREQ measurement.

FREQ:APER DEF

The query below returns 1.00000000E-01.

 FREQ:APER?

Related Command

CONFigure:FREQuency


[SENSe:]FREQuency:NULL:STATe

Syntax

[SENSe:]FREQuency:NULL:STATe {ON|OFF}

[SENSe:]FREQuency:NULL:STATe?

Description

This command enables or disables the null function for FREQ measurement.

The query command queries the status of the null function for FREQ measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for FREQ measurement.

FREQ:NULL:STAT OFF

The query below returns OFF.

 FREQ:NULL:STAT?

Related Commands

CONFigure:FREQuency

[SENSe:]FREQuency:NULL:VALue


[SENSe:]FREQuency:NULL:VALue

Syntax

[SENSe:]FREQuency:NULL:VALue {<value>|MIN|MAX}

[SENSe:]FREQuency:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for FREQ measurement.

The query command queries the null value for FREQ measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -1.1MHz to +1.1MHz | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to 5Hz.

 FREQ:NULL:VAL 5

The query below returns 5.00000000E+00.

 FREQ:NULL:VAL?

Related Commands

CONFigure:FREQuency

[SENSe:]FREQuency:NULL:STATe


[SENSe:]FREQuency:RANGe:LOWer

Syntax

[SENSe:]FREQuency:RANGe:LOWer {<filter>}MIN|MAX|DEF}

[SENSe:]FREQuency:RANGe:LOWer? [MIN|MAX]

Description

This command selects the type of AC filter for FREQ measurement.

The query command queries the AC filter type currently selected.

Parameter

Name | Type | Range | Default Value (DEF)
<filter> | Discrete | 3|20|200 | 20

Explanation

This command sets the filter type of both the FREQ measurement and the PERIOD measurement.

DM3068 provides three types of AC filters: Slow, Medium and Fast. The corresponding relations between the values of the parameter and filter types are as shown in the table below. You can set the parameter to the lowest desired frequency and the instrument selects the appropriate filter. For example, the FREQ:RANG:LOW 15 command sets the lowest frequency to 15Hz and the instrument selects Slow filter (3Hz).

Parameter Value | Filter Type | Filter Bandwidth
3 | Slow | 3Hz to 300kHz
20 | Medium | 20Hz to 300kHz
200 | Fast | 200Hz to 300kHz

Return Format

The query returns the type (3, 20 or 200) of the current filter.

Example

The command below selects Medium filter(20Hz) for FREQ measurement.

FREQ:RANG:LOW 20

The query below returns 20.

 FREQ:RANG:LOW?

Related Command

CONFigure:FREQuency


[SENSe:]FRESistance:APERture

Syntax

[SENSe:]FRESistance:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]FRESistance:APERture? [MIN|MAX]

Description

This command sets the integral time in aperture time for 4WR measurement.

The query command queries the integral time for 4WR measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<seconds> | Real | 100us to 1s | 100ms

Explanation

The default unit of the parameter is s.

This command provides precise integral time while the [SENSe:]FRESistance:NPLCycles command offers better power-line noise rejection characteristics (for values of NPLC greater than 1).

Return Format

The query returns the current integral time in scientific notation.

Example

The command below sets the integral time to its default value for 4WR measurement.

FRES:APER DEF

The query below returns 1.00000000E-01.

 FRES:APER?

Related Commands

CONFigure:FRESistance

[SENSe:]FRESistance:APERture:ENABled


[SENSe:]FRESistance:APERture:ENABled

Syntax

[SENSe:]FRESistance:APERture:ENABled {ON|OFF}

[SENSe:]FRESistance:APERture:ENABled?

Description

This command enables or disables the aperture time mode of integral time (4WR measurement).

The query command queries whether the aperture time mode of integral time (4WR measurement) is enabled.

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below enables the aperture time mode of integral time (4WRmeasurement).

 FRES:APER:ENAB ON

The query below returns 1.

 FRES:APER:ENAB?

Related Commands

CONFigure:FRESistance

[SENSe:]FRESistance:APERture


[SENSe:]FRESistance:NULL:STATe

Syntax

[SENSe:]FRESistance:NULL:STATe {ON|OFF}

[SENSe:]FRESistance:NULL:STATe?

Description

This command enables or disables the null function for 4WR measurement.

The query command queries the status of the null function for 4WR measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for 4WR measurement.

FRES:NULL:STAT OFF

The query below returns OFF.

 FRES:NULL:STAT?

Related Commands

CONFigure:FRESistance

[SENSe:]FRESistance:NULL:VALue


[SENSe:]FRESistance:NULL:VALue

Syntax

[SENSe:]FRESistance:NULL:VALue {<value>|MIN|MAX}

[SENSe:]FRESistance:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for 4WR measurement.

The query command queries the null value for 4WR measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -1100MΩ to +1100MΩ | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to 2.

 F RES:NULL:VAL 2

The query below returns 2.00000000E+00.

 FRES:NULL:VAL?

Related Commands

CONFigure:FRESistance

[SENSe:]FRESistance:NULL:STATe


[SENSe:]FRESistance:OCOMpensated

Syntax

[SENSe:]FRESistance:OCOMpensated <bool>

[SENSe:]FRESistance:OCOMpensated?

Description

This command enables or disables offset compensation for 4WR measurement.

The query command queries whether the offset compensation for 4WR measurement is enabled.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | OFF|0

Explanation

OC (Offset Comp) setting is applicable to resistance measurements on the 200 Ω, 2 kΩ and 20 kΩ ranges.

Offset compensation removes the effects of small dc voltages in the circuit being measured.

After offset compensation is enabled, the multimeter applies two different currents on the resistance under test, measures the voltage variation of the resistance under the two currents and calculates the resistance by dividing the current variation using the voltage variation.

Return Format

The query returns 0 (OFF) or 1 (ON).

Example

The command below enables offset compensation for 4WR measurement.

FRES:OCOM ON

The query below returns 1.

 FRES:OCOM?

Related Command

CONFigure:FRESistance


[SENSe:]PERiod:APERture

Syntax

[SENSe:]PERiod:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]PERiod:APERture? [MIN|MAX]

Description

This command sets the aperture time for PERIOD measurement.

The query command queries the aperture time for PERIOD measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<seconds> | Discrete | 1ms|10ms|100ms|1s | 100ms

Explanation

This command sets the aperture time for both the FREQ measurement and the PERIOD measurement.

Return Format

The query returns the current aperture time in scientific notation.

Example

The command below sets the aperture time to its default value for PERIOD measurement.

PER:APER DEF

The query below returns 1.00000000E-01.

 PER:APER?

Related Command

CONFigure:PERiod


[SENSe:]PERiod:NULL:STATe

Syntax

[SENSe:]PERiod:NULL:STATe {ON|OFF}

[SENSe:]PERiod:NULL:STATe?

Description

This command enables or disables the null function for PERIOD measurement.

The query command queries the status of the null function for PERIOD measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for PERIOD measurement.

PER:NULL:STAT OFF

The query below returns OFF.

 PER:NULL:STAT?

Related Commands

CONFigure:PERiod

[SENSe:]PERiod:NULL:VALue


[SENSe:]PERiod:NULL:VALue

Syntax

[SENSe:]PERiod:NULL:VALue {<value>|MIN|MAX}

[SENSe:]PERiod:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for PERIOD measurement.

The query command queries the null value for PERIOD measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -0.36s to +0.36s | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to 1us.

 PER:NULL:VAL 1.0E-06

The query below returns 1.00000000E-06.

 PER:NULL:VAL?

Related Commands

CONFigure:PERiod

[SENSe:]PERiod:NULL:STATe


[SENSe:]PERiod:RANGe:LOWer

Syntax

[SENSe:]PERiod:RANGe:LOWer {<filter>}MIN|MAX|DEF}

[SENSe:]PERiod:RANGe:LOWer? [MIN|MA}]

Description

This command selects the type of AC filter for PERIOD measurement.

The query command queries the AC filter type currently selected.

Parameter

Name | Type | Range | Default Value (DEF)
<filter> | Discrete | 3|20|200 | 20

Explanation

This command sets the filter type of both the FREQ measurement and the PERIOD measurement.

DM3068 provides three types of AC filters: Slow, Medium and Fast. The corresponding relations between the values of the parameter and filter types are as shown in the table below. You can set the parameter to the lowest desired frequency and the instrument selects the appropriate filter. For example, the FREQ:RANG:LOW 15 command sets the lowest frequency to 15Hz and the instrument selects Slow filter (3Hz).

Parameter Value | Filter Type | Filter Bandwidth
3 | Slow | 3Hz to 300kHz
20 | Medium | 20Hz to 300kHz
200 | Fast | 200Hz to 300kHz

Return Format

The query returns the type (3, 20 or 200) of the current filter.

Example

The command below selects Medium filter(20Hz) for PERIOD measurement.

PER:RANG:LOW 20

The query below returns 20.

 PER:RANG:LOW?

Related Command

CONFigure:PERiod


[SENSe:]RESistance:APERture

Syntax

[SENSe:]RESistance:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]RESistance:APERture? [MIN|MAX]

Description

This command sets the integral time in aperture time for 2WR measurement.

The query command queries the integral time for 2WR measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<seconds> | Real | 100us to 1s | 100ms

Explanation

The default unit of the parameter is s.

This command provides precise integral time while the [SENSe:]RESistance:NPLCycles command offers better power-line noise rejection characteristics (for values of NPLC greater than 1).

Return Format

The query returns the current integral time in scientific notation.

Example

The command below sets the integral time to its default value for 2WR measurement.

RES:APER DEF

The query below returns 1.00000000E-01.

 RES:APER?

Related Commands

CONFigure:RESistance

[SENSe:]RESistance:APERture:ENABled


[SENSe:]RESistance:APERture:ENABled

Syntax

[SENSe:]RESistance:APERture:ENABled {ON|OFF}

[SENSe:]RESistance:APERture:ENABled?

Description

This command enables or disables the aperture time mode of integral time (2WR measurement).

The query command queries whether the aperture time mode of integral time (2WR measurement) is enabled.

Return Format

The query returns 0 (OFF) or 1 (ON).

Example

The command below enables the aperture time mode of integral time (2WR measurement).

 RES:APER:ENAB ON

The query below returns 1.

 RES:APER:ENAB?

Related Commands

CONFigure:RESistance

[SENSe:]RESistance:APERture


[SENSe:]RESistance:NULL:STATe

Syntax

[SENSe:]RESistance:NULL:STATe {ON|OFF}

[SENSe:]RESistance:NULL:STATe?

Description

This command enables or disables the null function for 2WR measurement.

The query command queries the status of the null function for 2WR measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for 2WR measurement.

RES:NULL:STAT OFF

The query below returns OFF.

 RES:NULL:STAT?

Related Commands

CONFigure:RESistance

[SENSe:]RESistance:NULL:VALue


[SENSe:]RESistance:NULL:VALue

Syntax

[SENSe:]RESistance:NULL:VALue {<value>|MIN|MAX}

[SENSe:]RESistance:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for 2WR measurement.

The query command queries the null value for 2WR measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -1100MΩ to +1100MΩ | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to 2.

 RES:NULL:VAL 2

The query below returns 2.00000000E+00.

 RES:NULL:VAL?

Related Commands

CONFigure:RESistance

[SENSe:]RESistance:NULL:STATe


[SENSe:]RESistance:OCOMpensated

Syntax

[SENSe:]RESistance:OCOMpensated <bool>

[SENSe:]RESistance:OCOMpensated?

Description

This command enables or disables offset compensation for 2WR measurement.

The query command queries whether the offset compensation for 2WR measurement is enabled.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {OFF|0|ON|1} | OFF|0

Explanation

OC (Offset Comp) setting is applicable to resistance measurements on 200 Ω, 2 kΩ and 20 kΩ ranges.

Offset compensation removes the effects of small dc voltages in the circuit being measured.

After offset compensation is enabled, the multimeter applies two different currents on the resistance under test, measures the voltage variation of the resistance under the two currents and divide the current variation using the voltage variation to calculate the resistance.

Return Format

The query returns 0 (OFF) or 1 (ON).

Example

The command below enables the offset compensation for 2WR measurement.

RES:OCOM ON

 The query below returns 1.

 RES:OCOM?

Related Command

CONFigure:RESistance


[SENSe:]RESistance:ZERO:AUTO

Syntax

[SENSe:]RESistance:ZERO:AUTO <mode>

[SENSe:]RESistance:ZERO:AUTO?

Description

This command enablesor disables the auto zero function of 2WR measurement.

The query command queries whether the auto zero function of 2WR measurement is enabled.

Parameter

Name | Type | Range
<mode> | Discrete | {{0|OFF}|{1|ON}|ONCE}

Explanation

When auto zero is enabled (ON|1), the multimeter internally disconnects the input signal following each measurement, and takes a zero reading. It then subtracts the zero reading from the preceding reading. This removes offset variations present on the instrument's input circuitry that might affect measurement accuracy.

When auto zero is disabled (OFF|0), the multimeter uses the last measured zero reading and subtracts it from each measurement. It takes a new zero reading each time you change the function, range, or integration time.

In single auto zero mode (ONCE), the multimeter takes one zero reading, and then sets auto zero to off. The zero reading taken is subtracted from all subsequent measurements.

Return Format

The query returns 1 (ON) or 0 (OFF|ONCE).

Example

The command below disables auto zero function.

RES:ZERO:AUTO OFF

The query below returns 0.

 RES:ZERO:AUTO?

Related Command

CONFigure:RESistance


[SENSe:]TEMPerature:NULL:STATe

Syntax

[SENSe:]TEMPerature:NULL[:STATe] {ON|OFF}

[SENSe:]TEMPerature:NULL[:STATe]?

Description

The command enables or disables the relative operation function of the temperature measurement function.

The query command queries the on/off status of the relative operation of the temperature measurement function.

Return Format

The query returns ON or OFF.

Example

The command below disables the relative operation function.

TEMP:NULL:STAT OFF

The query below returns OFF.

 TEMP:NULL:STAT?


[SENSe:]TEMPerature:NULL:VALue

Syntax

[SENSe:]TEMPerature:NULL:VALue {<value>|MIN|MAX}

[SENSe:]TEMPerature:NULL:VALue? [{MIN|MAX}]

Description

The command sets the preset value of the relative operation of the temperature measurement function.

The query command queries the preset value of the relative operation of the temperature measurement function.

Parameter

Name | Type | Range | Default
<value> | Real | Related to the type of the temperature sensor | 0

Explanation

This command sets the preset value of the measurement value (voltage or resistance). When relative operation is enabled, the multimeter first subtracts the preset value from the measurement value and then converts the result to temperature value using the internal conversion program.

The range of the preset value of relative operation is related to the type of the sensor.

Type | Range
FRTD | -110 MΩ to 110 MΩ
RTD | -110 MΩ to 110 MΩ
FTHermistor | -110 MΩ to 110 MΩ
THERmistor | -110 MΩ to 110 MΩ
TC | -1100 V to 1100 V

Return Format

The query returns the current preset value in scientific notation.

Example

The command below sets the preset value to 5 V (the type of the temperature sensor is TC).

 TEMP:NULL:VAL 5

The query below returns 5.00000000E+00.

 TEMP:NULL:VAL?

Related Commands

CONFigure:TEMPerature

[SENSe:]TEMPerature:NULL[:STATe]


[SENSe:]TEMPerature:TRANsduce r:FRTD:RESistance[:REFerence]

Syntax

[SENSe:]TEMPerature:TRANsducer:FRTD:RESistance[:REFerence] {<reference>|MIN|MAX|DEF}

[SENSe:]TEMPerature:TRANsducer:FRTD:RESistance[:REFerence]? [{MIN|MAX}]

Description

The command sets the rated resistance (R0) of 4-wire RTD.

The query returns the rated resistance (R0) of 4-wire RTD.

Parameter

Name | Type | Range | Default (DEF)
<reference> | Integer | 49 Ω to 2100 Ω | 100 Ω

Explanation

The rated resistance of RTD refers to the resistance at 0℃, namely R0.

This command affects the R0 values of both the RTD and FRTD.

Return Format

The query returns the current R0 value in scientific notation.

Example

The command below sets the rated resistance (R0) of 4-wire RTD to 200 Ω.

 TEMP:TRAN:FRTD:RES 200

The query below returns 2.00000000E+02.

 TEMP:TRAN:FRTD:RES?


[SENSe:]TEMPerature:TRANsducer:FRTD:TYPE

Syntax

[SENSe:]TEMPerature:TRANsducer:FRTD:TYPE <type>

[SENSe:]TEMPerature:TRANsducer:FRTD:TYPE?

Description

The command sets the FRTD type in temperature measurement.

The query command queries the FRTD type in temperature measurement.

Parameter

Name | Type | Range | Default
<type> | Discrete | {85|89|91|92} | 85

Explanation

This command affects both the RTD and FRTD types.

Return Format

The query returns the FRTD type (+85, +89, +91 or +92).

Example

The command below sets the FRTD type to 91.

 TEMP:TRAN:FRTD:TYPE 91

The query below returns +91.

 TEMP:TRAN:FRTD:TYPE?


[SENSe:]TEMPerature:TRANsducer:FTHermistor:TYPE

Syntax

[SENSe:]TEMPerature:TRANsducer:FTHermistor:TYPE <type>

[SENSe:]TEMPerature:TRANsducer:FTHermistor:TYPE?

Description

The command sets the FTHermistor type in temperature measurement.

The query command queries the FTHermistor type in temperature measurement.

Parameter

Name | Type | Range | Default
<type> | Discrete | {2252|3000|5000|10000|30000} | 5000

Explanation

This command affects both the THERmistor and FTHermistor types. DM3068 supports 2252 Ω, 3 kΩ, 5 kΩ, 10 kΩ and 30 kΩ.

Return Format

The query returns the current type (+2252, +3000, +5000, +10000 or +30000).

Example

The command below sets the FTHermistor type to 5000.

 TEMP:TRAN:FTH:TYPE 5000

The query below returns +5000.

 TEMP:TRAN:FTH:TYPE?


[SENSe:]TEMPerature:TRANsdu cer:RTD:RESistance[:REFerence]

Syntax

[SENSe:]TEMPerature:TRANsducer:RTD:RESistance[:REFerence] {<reference>|MIN|MAX|DEF}

[SENSe:]TEMPerature:TRANsducer:RTD:RESistance[:REFerence]? [{MIN|MAX}]

Description

The command sets the rated resistance (R0) of 2-wire RTD.

The query command queries the rated resistance (R0) of 2-wire RTD.

Parameter

Name | Type | Range | Default (DEF)
<reference> | Integer | 49 Ω to 2100 Ω | 100 Ω

Explanation

The rated resistance of RTD refers to the resistance at 0℃, namely R0.

This command affects the R0 values of both the RTD and FRTD.

Return Format

The query returns the current R0 value in scientific notation.

Example

The command below sets the rated resistance (R0) of 2-wire RTD to 200 Ω.

 TEMP:TRAN:RTD:RES 200

The query below returns 2.00000000E+02.

 TEMP:TRAN:RTD:RES?


[SENSe:]TEMPerature:TRANsducer:RTD:TYPE

Syntax

[SENSe:]TEMPerature:TRANsducer:RTD:TYPE <type>

[SENSe:]TEMPerature:TRANsducer:RTD:TYPE?

Description

The command sets the RTD type in temperature measurement.

The query command queries the RTD type in temperature measurement.

Parameter

Name | Type | Range | Default
<type> | Discrete | {85|89|91|92} | 85

Explanation

This command affects both the RTD and FRTD types.

Return Format

The query returns the RTD type (+85, +89, +91 or +92).

Example

The command below sets the RTD type to 91.

 TEMP:TRAN:RTD:TYPE 91

The query below returns +91.

 TEMP:TRAN:RTD:TYPE?


[SENSe:]TEMPerature:TRANsducer:THERmistor:TYPE

Syntax

[SENSe:]TEMPerature:TRANsducer:THERmistor:TYPE <type>

[SENSe:]TEMPerature:TRANsducer:THERmistor:TYPE?

Description

The command sets the THermistor type in temperature measurement.

The query command queries the THermistor type in temperature measurement.

Parameter

Name | Type | Range | Default (DEF)
<type> | Discrete | {2252|3000|5000|10000|30000} | 5000

Explanation

This command affects both the THERmistor and FTHermistor types. DM3068 supports 2252 Ω, 3 kΩ, 5 kΩ, 10 kΩ and 30 kΩ.

Return Format

The query returns the current type (+2252, +3000, +5000, +10000 or +30000).

Example

The command below sets the THermistor type to 5000.

 TEMP:TRAN:THER:TYPE 5000

The query below returns +5000.

 TEMP:TRAN:THER:TYPE?


[SENSe:]TEMPerature:TRANsducer:TYPE

Syntax

[SENSe:]TEMPerature:TRANsducer:TYPE <probe_type>

[SENSe:]TEMPerature:TRANsducer:TYPE?

Description

The command sets the sensor type in temperature measurement.

The query command queries the sensor type in temperature measurement.

Parameter

Name | Type | Range | Default
<probe_type> | Discrete | {FRTD|RTD|FTHermistor|THERmistor|TC|ANY} | ANY

Explanation

This command also sets the gate times of FREQ and PERIOD measurements.

When the instrument is resorted to factory setting (*RST ), the sensor type is ANY by default.

Return Format

The query returns the current sensor type (FRTD, RTD, FTH, THER, TC or ANY).

Example

The command below sets the sensor type in temperature measurement to FRTD.

 TEMP:TRAN:TYPE FRTD

The query below returns FRTD.

 TEMP:TRAN:TYPE?


[SENSe:]VOLTage:AC:BANDwidth

Syntax

[SENSe:]VOLTage:AC:BANDwidth {<filter>|MIN|MAX|DEF}

[SENSe:]VOLTage:AC:BANDwidth? [MIN|MAX]

Description

This command selects the type of AC filter for ACV measurement.

The query command queries the AC filter type currently selected.

Parameter

Name | Type | Range | Default Value (DEF)
<filter> | Discrete | 3|20|200 | 20

Explanation

DM3068 provides three types of AC filters: Slow, Medium and Fast. The corresponding relations between the values of the parameter and filter types are as shown in the table below.

Parameter Value | Filter Type | Filter Bandwidth
3 | Slow | 3Hz to 300kHz
20 | Medium | 20Hz to 300kHz
200 | Fast | 200Hz to 300kHz

Return Format

The query returns the lowest frequency (3.00000000E+00, 2.00000000E+01 or 2.00000000E+02) of the currently selected filter in scientific notation.

Example

The command below selects fast filter.

 VOLT:AC:BAND 200

The query below returns 2.00000000E+02.

 VOLT:AC:BAND?

Related Command

CONFigure:VOLTage:AC


[SENSe:]VOLTage:AC:NULL:STATe

Syntax

[SENSe:]VOLTage:AC:NULL:STATe {ON|OFF}

[SENSe:]VOLTage:AC:NULL:STATe?

Description

This command enables or disables the null function for ACV measurement.

The query command queries the status of the null function for ACV measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for ACV measurement.

VOLT:AC:NULL:STAT OFF

The query below returns OFF.

 VOLT:AC:NULL:STAT?

Related Command

CONFigure:VOLTage:AC

[SENSe:]VOLTage:AC:NULL:VALue


[SENSe:]VOLTage:AC:NULL:VALue

Syntax

[SENSe:]VOLTage:AC:NULL:VALue {<value>|MIN|MAX}

[SENSe:]VOLTage:AC:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for ACV measurement.

The query command queries the null value for ACV measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -825V to +825V | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to -0.5.

 VOLT:AC:NULL:VAL -0.5

The query below returns -5.00000000E-01.

 VOLT:AC:NULL:VAL?

Related Commands

CONFigure:VOLTage:AC

[SENSe:]VOLTage:AC:NULL:STATe


[SENSe:]VOLTage:AC:PEAK:STATe

Syntax

[SENSe:]VOLTage:AC:PEAK:STATe {ON|OFF}

[SENSe:]VOLTage:AC:PEAK:STATe?

Description

This command enables or disables the peak measurement function for ACV measurement.

The query command queries whether the peak measurement function for ACV measurement is enabled.

Explanation

The multimeter also measures the peak current during ac voltage measurement when the peak measurement is enabled (STATe = ON).

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below disables peak current measurement.

VOLT:AC:PEAK:STAT OFF

The query below returns OFF.

 VOLT:AC:PEAK:STAT?

Related Command

CONFigure:VOLTage:AC


[SENSe:]VOLTage:DC:APERture

Syntax

[SENSe:]VOLTage:DC:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]VOLTage:DC:APERture? [MIN|MAX]

Description

This command sets the integral time in aperture time for DCV measurement.

The query command queries the integral time for DCV measurement.

Parameter

Name | Type | Range | Default Value (DEF)
<seconds> | Real | 100us to 1s | 100ms

Explanation

The default unit of the parameter is s.

This command provides precise integral time while the [SENSe:]VOLTage:DC:NPLCycles command offers better power-line noise rejection characteristics (for values of NPLC greater than 1).

Return Format

The query returns the current integral time in scientific notation.

Example

The command below sets the integral time to its default value for DCV measurement.

VOLT:DC:APER DEF

The query below returns 1.00000000E-01.

 VOLT:DC:APER?

Related Commands


[SENSe:]VOLTage:DC:APERture:ENABle

[SENSe:]VOLTage:DC:APERture:ENABled

Syntax

[SENSe:]VOLTage:DC:APERture:ENABled {ON|OFF}

[SENSe:]VOLTage:DC:APERture:ENABled?

Description

This command enables or disables the aperture time mode of integral time (DCV measurement).

The query command queries whether the aperture time mode of integral time is enabled (DCV measurement).

Return Format

The query returns 0 (OFF) or1 (ON).

Example

The command below enables the aperture time mode of integral time (DCV measurement).

 VOLT:DC:APER:ENAB ON

The query below returns 1.

 VOLT:DC:APER:ENAB?

Related Commands


[SENSe:]VOLTage:DC:IMPedance:AUTO

Syntax

[SENSe:]VOLTage:DC:IMPedance:AUTO {<bool>}

[SENSe:]VOLTage:DC:IMPedance:AUTO?

Description

This command enables or disables the auto mode of input impedance for DCV measurement.

The query command queries the status of the auto mode of input impedance for DCV measurement.

Parameter

Name | Type | Range | Default Value
<bool> | Bool | {{0|OFF}|{1|ON}} | OFF|0

Explanation

When auto mode is disabled (OFF|0), the DC input impedance is fixed at 10MΩ for all ranges of DCV measurement.

When auto mode is enabled (ON|1), the DC input impedance is set to >10GΩ for 200mV, 2V and 20V ranges and 10MΩ for 200V and 1000V ranges.

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below enables the auto mode of DC input impedance.

VOLT:DC:IMP:AUTO ON

The query below returns 1.

 VOLT:DC:IMP:AUTO?

Related Commands


[SENSe:]VOLTage:DC:NULL:STATe

Syntax

[SENSe:]VOLTage:DC:NULL:STATe {ON|OFF}

[SENSe:]VOLTage:DC:NULL:STATe?

Description

This command enables or disables the null function for DCV measurement.

The query command queries the status of the null function for DCV measurement.

Return Format

The query returns ON or OFF.

Example

The command below disables the null function for DCV measurement.

VOLT:DC:NULL:STAT OFF

The query below returns OFF.

 VOLT:DC:NULL:STAT?

Related Commands


[SENSe:]VOLTage:DC:NULL:VALue

Syntax

[SENSe:]VOLTage:DC:NULL:VALue {<value>|MIN|MAX}

[SENSe:]VOLTage:DC:NULL:VALue? [MIN|MAX]

Description

This command sets a null value for DCV measurement.

The query command queries the null value for DCV measurement.

Parameter

Name | Type | Range | Default Value
<value> | Real | -1100V to +1100V | 0

Explanation

For DM3068, the range of the null value is -110% to +110% of the maximum range of the current measurement function.

Return Format

The query returns the current null value in scientific notation.

Example

The command below sets the null value to -0.5.

 VOLT:DC:NULL:VAL -0.5

The query below returns -5.00000000E-01.

 VOLT:DC:NULL:VAL?

Related Commands

CONFigure:VOLTage:DC

[SENSe:]VOLTage:DC:NULL:STATe


[SENSe:]VOLTage:DC:PEAK:STATe

Syntax

[SENSe:]VOLTage:DC:PEAK:STATe {ON|OFF}

[SENSe:]VOLTage:DC:PEAK:STATe?

Description

This command enables or disables the peak measurement function for DCV measurement.

The query command queries whether the peak measurement function for DCV measurement is enabled.

Explanation

The multimeter also measures the peak current during dc voltage measurement when the peak measurement is enabled (STATe = ON).

Return Format

The query returns 1 (ON) or 0 (OFF).

Example

The command below disables peak current measurement.

VOLT:DC:PEAK:STAT OFF

The query below returns OFF.

 VOLT:DC:PEAK:STAT?

Related Command

CONFigure:VOLTage:DC


[SENSe:]VOLTage:DC:ZERO:AUTO

Syntax

[SENSe:]VOLTage:DC:ZERO:AUTO <mode>

[SENSe:]VOLTage:DC:ZERO:AUTO?

Description

This command enables or disables the auto zero function of DCV measurement.

The query command queries whether the auto zero function of DCV measurement is enabled.

Parameter

Name | Type | Range
<mode> | Discrete | {{0|OFF}|{1|ON}|ONCE}

Explanation

When auto zero is enabled (ON|1), the multimeter internally disconnects the input signal following each measurement, and takes a zero reading. It then subtracts the zero reading from the preceding reading. This prevents offset voltages present on the instrument's input circuitry from affecting measurement accuracy.

When auto zero is disabled (OFF|0), the multimeter uses the last measured zero reading and subtracts it from each measurement. It takes a new zero reading each time you change the function, range, or integration time.

In single auto zero mode (ONCE), the multimeter takes one zero reading, and then sets auto zero to off. The zero reading taken is subtracted from all subsequent measurements.

Return Format

The query returns 1 (ON) or 0 (OFF|ONCE).

Example

The command below disables auto zero function.

VOLT:DC:ZERO:AUTO OFF

The query below returns 0.

 VOLT:DC:ZERO:AUTO?

Related Command

CONFigure:VOLTage:DC


TRIGger命令子系统

TRIGger Command Subsystem

The expanded commands for Agilent34401A trigger setting commands are as follows:

TRIGger:LEVel

TRIGger:SLOPe


TRIGger:LEVel

Syntax

TRIGger:LEVel {<level>|MIN|MAX|DEF}

TRIGger:LEVel?

Description

This command sets the level on which a trigger occurs when the trigger source is set to INTernal.

The query command queries the level.

Parameter

Name | Type | Range | Default Value (DEF)
<value> | Real | 0 to +110% of the selected range of current measurement function | 0

Explanation

The unit of the parameter depends on the measurement function selected currently.

This command is only available when the trigger source of the multimeter is "INTernal" (for details, refer to the TRIGger:SOURce command).

The multimeter triggers on the rising or falling edge of the input signal and acquires readings when the input level is beyond the specified trigger level.

Return Format

The query returns the trigger level in scientific notation.

Example

The command below sets the trigger level to the maximum.

TRIG:LEV MAX

The query below returns 2.20000000E-01.

 TRIG:LEV?

Related Commands


TRIGger:SLOPe

Syntax

TRIGger:SLOPe <slope>

TRIGger:SLOPe?

Description

This command selects trigger edge for the multimeter.

The query command queries trigger edge.

Parameter

Name | Type | Range | Default Value
<slope> | Discrete | {POSitive|NEGative} | NEG

Explanation

This command sets the trigger edge for both the "External Trigger" (use the TRIGger:SOURce command to select "EXTernal" as trigger source) and the "Level Trigger" (use the TRIGger:SOURce command to select "INTernal" as trigger source).

Return Format

The query returns the trigger edge setting: POS or NEG.

Example

The query below sets the trigger edge to Rising Edge.

 TRIG:SLOP POS

The query below returns POS.

 TRIG:SLOP?

Related Command

TRIGger:SOURce


兼容的Fluke命令系统

Compatible Fluke Command Set

DM3068 is compatible with the following Fluke commands. Use the CMDSet command (namely CMDSet FLUKE) to select Fluke Command Set before using these commands.

FORMAT

SERIAL?

TRIGGER

Function Commands and Queries

Function Modifier Commands and Queries

Range and Measurement Rate Commands and Queries

Measurement Queries

Compare Commands and Queries


FORMAT

Syntax

FORMAT <frmt>

FORMAT?

Description

This command sets the output format of measurement values.

The query command queries the output format of measurement values.

Parameter

Name | Type | Range
<frmt> | Discrete | 1|2

Explanation

When the parameter is 1, the measurement value is output without unit; and when the parameter is 2, the measurement value is output with unit. The corresponding relations between measurement functions and output units are as shown in the table below.

Measurement Function | Unit
DC Voltage | VDC
AC Voltage | VAC
DC Current | ADC
AC Current | AAC
Resistance | OHMS
Frequency | Hz
Diode | VDC
Continuity | OHMS

Limited by its working principle, DM3068 only accepts the command but does not execute the actual operation.

Return Format

The query returns 1 or 2.


SERIAL?

Syntax

SERIAL?

Description

This command queries the serial number of the multimeter.

Explanation

The return value of this command is the third part of the return value of the *IDN? command: Serial Number of the Instrument <serial number> (the same as the :SYSTem:SERIal? command).

Return Format

The query returns the serial number of the multimeter.

Example

The query below returns DM3A020100823.

SERIAL?

Related Commands

*IDN?

:SYSTem:SERIal? （RIGOL）


TRIGGER

Syntax

TRIGGER <type>

TRIGGER?

Description

This command selects trigger type (for information about trigger type, refer to Explanation)

The query command queries the trigger type of the multimeter.

Parameter

Name | Type | Range
<type> | Discrete | 1|2|3|4|5

Explanation

The values (1, 2, 3, 4, 5) of the parameter correspond to the 5 trigger types of FLUKE multimeter respectively. Wherein, when the parameter is 1, this command selects internal trigger and when the parameter is 2, 3, 4 or 5, this command selects external trigger with different configuration.

Limited by its working principle, DM3068 only supports 1.

Return Format

The query returns 1, 2, 3, 4 or 5. Limited by its working principle, DM3068 only returns 1.


功能命令与查询

Function Commands and Queries

The commands below are used to enable the basic measurement functions of the multimeter (the same as selecting the function buttons at the front panel).


AAC

Syntax

AAC

Description

This command enables AC current (ACI) measurement function.

Explanation

The query command FUNC returns AAC.

Related Command

FUNC


ADC

Syntax

ADC

Description

This command enables DC current (DCI) measurement function.

Explanation

The query command FUNC returns ADC.

Related Command

FUNC


CLR2

Syntax

CLR2

Description

This command clears the measurement values of the secondary measurement function and disable the secondary measurement function.

Note: For DM3068, the secondary measurement function only refers to the secondary function (frequency (FREQ) measurement) under ACV and ACI measurements.

Explanation

This command is only available when the secondary measurement function is enabled.


CONT

Syntax

CONT

Description

This command enables the continuity (CONT) measurement function.

Explanation

The query command FUNC returns CONT.

Related Command

FUNC


DIODE

Syntax

DIODE

Description

This command enables the diode (DIODE) measurement function.

Explanation

The query command FUNC returns DIODE.

Related Command

FUNC


FREQ

Syntax

FREQ

FREQ2

Description

This command enables the frequency (FREQ) measurement function.

Explanation

FREQ enables the frequency (FREQ) measurement function of the primary display; FREQ2, only available when ACV or ACI function is enabled, enables the frequency (FREQ) measurement function of the secondary display.

The query command FUNC returns FREQ.

Related Command

FUNC


FUNC

Syntax

FUNC1?

FUNC2?

Description

The commands queries the selected measurement function.

Explanation

The FUNC1? command queries the measurement functions that have been enabled; the FUNC2? command queries the secondary measurement functions that have been enabled.

The FUNC2? command causes execution error if no secondary function is currently enabled.

Note: For DM3068, the secondary measurement function only refers to the secondary function (frequency (FREQ) measurement function) under ACV and ACI measurement functions.

Returned Value

The query returns the command identifier of the currently selected measurement function.

FUNC1? returns AAC, ADC, CONT, DIODE, FREQ, OHMS, VAC or VDC.

FUNC2? returns FREQ.

Related Commands


OHMS

Syntax

OHMS

Description

This command enables the resistance (2WR) measurement function.

Explanation

The query command FUNC returns OHMS.

Related Command

FUNC


VAC

Syntax

VAC

Description

This command enables the AC voltage (ACV) measurement function.

Explanation

The query command FUNC returns VAC.

Related Command

FUNC


VDC

Syntax

VDC

Description

This command enables the DC voltage (DCV) measurement function.

Explanation

The query command FUNC returns VDC.

Related Command

FUNC


功能调节命令与查询

Function Modifier Commands and Queries

The commands below are used to enable the function modifiers of the multimeter. After the function modifiers are enabled, the measurement readings are modified accordingly before display. The function modifiers include: MIN, MAX, HOLD, dB, REL and COMP (the same as using the front panel of the instrument to execute math functions).


DB

Syntax

DB

Description

This command enables dB function modifier.

Explanation

This command is only available when DCV or ACV measurement function is enabled. After the modifier is enabled, the multimeter displays the readings with the unit dB. At this point, the query command MOD? returns 8.

Example

The command below enables DC voltage (DCV) measurement.

VDC

The command below enables dB function modifier. At this point, the display interface of the multimeter displays the reading as -57.774dB.

 DB

Related Commands

VAC
VDC

DBCLR

MOD?


DBCLR

Syntax

DBCLR

Description

This command disables dB function modifier.

Explanation

After executing this command, the multimeter displays the reading with normal unit (mV or V).

Example

The command below enables DC voltage (DCV) measurement.

 VDC

The command below enables dB function modifier. At this point, the display interface of the multimeter displays the reading as -57.774dB.

 DB

The command below disables dB function modifier. At this point, the display interface of the multimeter displays the reading as 0.9819mV.

 DBCLR

Related Command

DB


DBREF

Syntax

DBREF <value>

DBREF?

Description

This command sets the reference impedance of dB function modifier.

The query command queries the reference impedance of dB function modifier.

Parameter

Name | Type | Range | Default Value
<value> | Integer | 1 to 21 | 16

Explanation

The corresponding relations between the values of the parameter and reference impedances are as shown in the table below. The unit of reference impedance is Ω.

Parameter Value | Reference Impedance | Parameter Value | Reference Impedance
1 | 2 | 12 | 150
2 | 4 | 13 | 250
3 | 8 | 14 | 300
4 | 16 | 15 | 500
5 | 50 | 16 | 600
6 | 75 | 17 | 800
7 | 93 | 18 | 900
8 | 110 | 19 | 1000
9 | 124 | 20 | 1200
10 | 125 | 21 | 8000
11 | 135 |  |

Return Format

The query returns the reference impedance in scientific notation.

Example

The command below sets the reference impedance to 500Ω.

 DBREF 15

The query below returns the reference impedance: 5.000000E+02.

 DBREF?


HOLD

Syntax

HOLD

Description

This command enables the reading hold function modifier.

Explanation

If the multimeter is in reading hold mode when sending the command, a reading is displayed on the screen forcefully. After the reading hold function modifier is enabled, the multimeter can capture stable readings and keep them on the screen. At this point, the query command MOD? returns 12.

Related Commands

HOLDCLR
HOLDTHRESH

MOD?


HOLDCLR

Syntax

HOLDCLR

Description

This command disables the reading hold function modifier.

Related Command

HOLD


HOLDTHRESH

Syntax

HOLDTHRESH <threshold>

HOLDTHRESH?

Description

This command sets the sensitivity range of the reading hold function.

The query command queries the sensitivity range of the reading hold function.

Parameter

Name | Type | Range | Default Value
<threshold> | Discrete | 1|2|3|4 | 2

Explanation

The corresponding relations between the values of the parameter and sensitivity ranges are as shown in the table below.

Parameter | Sensitivity Range
1 | 0.01%
2 | 0.1%
3 | 1%
4 | 10%

Return Format

The query returns 1, 2, 3 or 4.

Example

The command below sets the sensitivity range of the reading hold function to 0.1%.

 HOLDTHRESH 2

The query below returns 2.

 HOLDTHRESH?

Related Command

HOLD


MAX

Syntax

MAX

Description

This command enables the MAX function modifier and the multimeter takes the current reading as the maximum.

Explanation

After the modifier is enabled, the multimeter starts statistic operation and always displays the maximum. In MAX mode, auto range is disabled. At this point, the query command MOD? returns 2.

Related Commands


MAXSET

Syntax

MAXSET <numeric value>

Description

This command sets the maximum for the MAX function modifier.

Parameter

Name | Type | Range
<numeric value> | Real | Greater than the last parameter value set and less than the +110% of the maximum range of the current measurement function

Explanation

This command is available after MAX function modifier is enabled. The parameter value set is displayed as the maximum until there is a reading that is greater than this value.

Auto range function is disabled.

Example

The command below sets the maximum to 5V.

 MAXSET 5

Related Command

MAX


MIN

Syntax

MIN

Description

This command enables the MIN function modifier and the multimeter takes the current reading as the minimum.

Explanation

After the modifier is enabled, the multimeter starts the statistic operation and always displays the minimum. In MIN mode, auto range function is disabled. At this point, the query command MOD? returns 1.

Related Commands


MINSET

Syntax

MINSET <numeric value>

Description

This command sets the minimum for the MIN function modifier.

Parameter

Name | Type | Range
<numeric value> | Real | Greater than the -110% of the maximum range of the current measurement function and less than the last parameter value set

Explanation

This command is available after MIN function modifier is enabled. The parameter value set is displayed as the minimum until there is a reading that is less than this value.

Auto range function is disabled.

Example

The command below sets the minimum to -5V.

 MINSET -5

Related Command

MIN


MMCLR

Syntax

MMCLR

Description

This command disables the MIN or MAX function modifier.

Related Commands


MOD?

Syntax

MOD?

Description

This command queries the modifier currently enabled.

Explanation

1 The corresponding relations between the return values and the modifiers are as shown in the table below.

Returned Value | 1 | 2 | 4 | 8 | 32 | 64
Modifier | MIN | MAX | HOLD | dB | REL | COMP

2 For information about whether the 6 modifiers mentioned above can be enabled at the same time, refer to the table below (Yes: can be enabled at the same time; No: can not be enabled at the same time).

---- | MIN | MAX | HOLD | dB | REL | COMP
MIN | ---- | No | Yes | No | Yes | No
MAX | No | ---- | Yes | No | Yes | No
HOLD | Yes | Yes | ---- | Yes | Yes | Yes
dB | No | No | Yes | ---- | Yes | Yes
REL | Yes | Yes | Yes | Yes | ---- | Yes
COMP | No | No | Yes | Yes | Yes | ----

Return Format

The query returns the number corresponding to the modifier currently enabled and returns the sum of the numbers corresponding to the modifiers if more than one modifier is enabled at the same time.

Example

The query below returns 33.

 MOD?

Related Commands

COMP


REL

Syntax

REL

Description

This command enables REL function modifier and the multimeter takes the current reading as the REL reference value.

Explanation

After the modifier is enabled, the multimeter displays the difference between each reading and the reference value. At this point, the query command MOD? returns 32.

Related Commands

MOD?


RELCLR

Syntax

RELCLR

Description

This command disables REL function modifier.

Related Commands

REL


RELSET

Syntax

RELSET <relative base>

RELSET?

Description

This command sets the reference value of REL function modifier.

The query command queries the reference value of REL function modifier.

Parameter

Name | Type | Range
<relative base> | Real | -110% to +110% of the maximum range of the measurement function currently selected

Explanation

This command is available after the REL function modifier is enabled; the parameter value set is the reference value and the multimeter displays the difference between each reading and this value.

Return Format

The query returns the reference value in scientific notation.

Example

The command below sets the reference value to 6V.

 RELSET 6

The query below returns the reference value: 6.000000E+00.

 RELSET?

Related Command

REL


量程与测量速率命令与查询

Range and Measurement Rate Commands and Queries

The commands below are used to set and query the range and measurement rate of the measurement function (the same as using the range and resolution selection buttons at the front panel of the instrument).


AUTO

Syntax

AUTO

AUTO?

Description

This command enables the auto range mode of the multimeter.

The query command queries whether the auto range mode is enabled.

Explanation

AUTO sets the multimeter to enter auto range mode on the primary display and execution error is generated if the auto range mode can not be selected (when diode/continuity measurement function is selected).

Return Format

The query returns 0 (OFF) or 1 (ON).

Example

The command below sets the multimeter to enter auto range mode.

AUTO

The query below returns 1.

AUTO?

Related Commands


FIXED

Syntax

FIXED

Description

This command sets the multimeter to exit auto range mode and enter manual range. The current range becomes the selected range.

Related Commands


RANGE

Syntax

RANGE <value range>

RANGE1?

RANGE2?

Description

This command sets the range for the measurement function on the primary display.

The query commands query the current range setting.

Parameter

Name | Type | Range
<value range> | Discrete | 1|2|3|4|5|6|7|8|9

Explanation

1 RANGE1? queries the range presently selected on the primary display; RANGE2? queries the range presently selected on the secondary display and if the secondary display is inactive, an execution error is generated.

2 The corresponding relations between the values of the parameter and ranges under different measurement functions are as shown in the table below.

Parameter Value | DCV | ACV/FREQ/PERIOD | 2WR/4WR | ACI | DCI | CAP
1 | 200mV | 200mV | 200Ω | 200uA | 200uA | 2nF
2 | 2V | 2V | 2kΩ | 2mA | 2mA | 20nF
3 | 20V | 20V | 20kΩ | 20mA | 20mA | 200nF
4 | 200V | 200V | 200kΩ | 200mA | 200mA | 2uF
5 | 1000V | 750V | 2MΩ | 2A | 2A | 20uF
6 | ---- | ---- | 20MΩ | 10A | 10A | 200uF
7 | ---- | ---- | 100MΩ | ---- | ---- | 2mF
8 | ---- | ---- | ---- | ---- | ---- | 20mF
9 | ---- | ---- | ---- | ---- | ---- | 100mF

Return Format

The query returns 1, 2, 3, 4, 5, 6, 7, 8 or 9.

Example

The command below sets the range to 20V for DC voltage measurement.

RANGE 3

The query below returns 3.

RANGE1?

Related Commands


RATE

Syntax

RATE <speed>

RATE?

Description

This command sets the measurement rate of the multimeter.

The query command queries the measurement rate of the multimeter.

Parameter

Name | Type | Range
<speed> | Discrete | S|M|F

Explanation

This command is only available for the DC voltage, DC current and resistance measurement functions of DM3068. The corresponding relations between the values of the parameter and measurement rates are as shown in the table below1:

Parameter Value | Measurement Rate/s | Integral Time | Instrument Setting
F | 2500 (3000) | 400 (333) us | 0.02NPLC
M | 250 (300) | 4 (3.33) ms | 0.2NPLC
S | 0.5 (0.6) | 2 (1.67) s | 100NPLC

Note1: the integral time is related to the power frequency, frequencies ranging from 55 Hz to 66 Hz are treated as 60 Hz and other ranges are treated as 50 Hz. In the table above, the parameter enclosed in the parentheses are parameters under 60 Hz power frequency.

Return Format

The query returns F, M or S.

Example

The command below sets the measurement rate to Fast.

 RATE F

The query below returns F.

 RATE?

Related Commands


测量查询

Measurement Queries

The commands below are used to query the measurement results on the primary and secondary displays.


MEAS

Syntax

MEAS?

MEAS1?

MEAS2?

Description

The commands query the measurement values of the multimeter.

Explanation

The MEAS? command queries the measurement values of the multimeter. The query returns two values if the primary and secondary displays are all on and returns the value on the primary display if only the primary display is on.

The MEAS1? command queries the measurement value on the primary display after the next trigged measurement is complete.

The MEAS2? command queries the measurement value on the secondary display after the next trigged measurement is complete. Execution error is generated if the secondary display is turned off.

Return Format

The query returns the measurement values of the multimeter in scientific notation. The query returns two values separated by comma if the primary and secondary displays are all on.

Example

The query below returns 3.002827E-03 (ACV measurement is currently enabled on the primary display and the secondary display is turned off).

MEAS?

Related Command

VAL


VAL

Syntax

VAL?

VAL1?

VAL2?

Description

The commands query the measurement values of the multimeter.

Explanation

The VAL? command queries the measurement values of the multimeter. The query returns two values if the primary and secondary displays are all on and returns the value on the primary display if only the primary display is on.

The VAL1? command queries the value on the primary display. If the main display is blank, the next triggered measurement is returned.

The VAL2? command queries the measurement value on the secondary display. If the secondary display is blank, the next triggered measurement is returned. If the secondary display is turned off, an execution error is generated .

Return Format

The query returns the measurement values of the multimeter in scientific notation. The query returns two values separated by comma if the primary and secondary displays are all on.

Example

The query below returns 3.010355E-03 (ACV measurement is enabled on the main display and the secondary display is turned off).

VAL?

Related Command

MEAS


比对命令与查询

Compare Commands and Queries

The commands below are used to compare the measurement value with the specified range to determine whether the value is higher than, lower than or within the specified range.


COMP

Syntax

COMP

COMP?

Description

This command enables the COMP function modifier.

The query command queries the last compare result.

Explanation

After the modifier is enabled, the multimeter switches to dual-display mode with the primary display displaying the measurement reading and the secondary display displaying the compare result.

The reading hold function is enabled automatically (use the HOLDCLR command to disable the reading hold function). At this point, the query command MOD? returns 68.

Return Format

The query returns the last compare result:

Returns HI if the measurement reading is above the upper limit of the compare range;

Returns LO if the measurement reading is below the lower limit of the compare range;

Returns PASS if the measurement reading is within the compare range;

Returns — if the measurement has not been finished.

Related Commands

COMPCLR
COMPHI
COMPLO

HOLD
HOLDCLR

MOD?


COMPCLR

Syntax

COMPCLR

Description

The command disables the COMP function modifier. The instrument exits the reading hold function at the same time if reading hold is currently enabled.

Related Command

COMP


COMPHI

Syntax

COMPHI <high value>

Description

The command sets the upper limit of the COMP function modifier.

Parameter

Name | Type | Range
<high value> | Real | Greater then the preset lower limit and less than the +110% of the maximum range of the measurement function currently selected

Explanation

Take the parameter value set as the upper limit of the compare.

Example

The command below sets the upper limit to 5V.

 COMPHI 5

Related Commands


COMPLO

Syntax

COMPLO <low value>

Description

The command sets the lower limit of the COMP function modifier.

Parameter

Name | Type | Range
<low value> | Real | Greater than the -110% of the maximum range of the measurement function currently selected and less than the preset upper limit

Explanation

Take the parameter value set as the lower limit of the compare.

Example

The command below sets the lower limit to -5V.

 COMPLO -5

Related Commands


编程示例

Programming Demos

This chapter lists some programming demos to illustrate how to use commands to realize the common functions of the multimeter in the development environments of Visual C++ 6.0 and Visual Basic 6.0 and LabVIEW 8.6. All demos are based on VISA (Virtual Instrument Software Architecture).

VISA is an API (Application Programming Interface) for controlling instruments. It is convenient for users to develop testing applications which are independent of the types of instrument and interface. Note the "VISA" mentioned here is NI (National Instrument)-VISA. NI-VISA is an API written by NI based on VISA standards. You can use NI-VISA to realize the communication between the multimeter and the PC via instrument buses such as USB. As VISA has defined a set of software commands, users can control the instrument without understanding the working state of the interface bus. For more details, please refer to NI-VISA.

The topics of this chapter:

Programming Preparations

Visual C++ 6.0 Programming Demo

Visual Basic 6.0 Programming Demo

LabVIEW 8.6 Programming Demo


编程准备

Programming Preparations

1. First make sure your computer has installed the VISA library of NI (download it from http://www.ni.com). Here, the default installation path is C:\Program Files\IVI Foundation\VISA.

2. Here, the USB interface of the multimeter is used to communicate with the PC and please use the USB data cable to connect the USB Device interface at the rear panel of the multimeter to the USB interface of the PC. You can also use LAN, RS232 or GPIB to communicate with PC. Note that the end mark of the command sent through RS232 interface is "\r\n".

3. After successful connection, turn on the instrument. A "Found New Hardware Wizard" dialog box appears on the PC at the first connection. Please follow the instructions to install the "USB Test and Measurement Device".

By now, the preparations for programming are finished. In the following part, detailed introductions are given about the programming demos in the Visual C++ 6.0, Visual Basic 6.0 and LabVIEW 8.6 development environment.


Visual C++ 6.0 编程示例

Visual C++ 6.0 Programming Demo

Enter the Visual C++6.0 programming environment and follow the steps below:

1. Build a MFC project based on dialog box.

2. Open the Link tab in Project→Settings and add visa32.lib to the Object/library modules manually.

3. Open the Directories tab in Tools→Options.

Select Include files in Show directories for and double-click the blank in Directories to add the path of Include: C:\Program Files\IVI Foundation\VISA\WinNT\include.

Select Library files in Show directories for and double-click the blank in Directories to add the path of Lib: C:\Program Files\IVI Foundation\VISA\WinNT\lib\msc.

Note: at present, VISA library has been added.

4. Add the Text, Edit and Button controls as shown in the figure below.

5. Add the control variables.

Open the Member Variables tab in View→ClassWizard and add the following variables:

Instrument ID Selection Box: IDC_CBResourceName

Instrument ID: IDC_CBResourceName

Refresh: IDC_REFRESH

Command: IDC_CMD_TEXT

Disconnect the connection: ID_CLOSE

Send: ID_SEND

Read: IDC_READ

Clear: IDC_CLR

Return Data: IDC_RETURN_TEXT

DCV Function: IDC_DCV

Read DCV Measurement Value: IDC_DCVRd

ACV Function: IDC_ACV

DC I Function: IDC_DCI

The Secondary Function FREQ: IDC_2NDFREQ

Disable the Secondary Function: IDC_2NDCLR

Connection State: IDC_STATE_TEXT

6. Encapsulate the read and write operations of VISA.

1) Write Operation

//Write command to instrument

void CDemoDlg::sendToDEVICE(CString strCmd)

{

int count=0;

count = strlen(strCmd);

char *charCmd = new char[count+2];

for(int i = 0;i <count;i++)

{

charCmd[i]=strCmd[i];

}

charCmd[count]='\n';

charCmd[count+1]='\0';

unsigned long error = 0;

error = viVPrintf(g_VisaIO,charCmd,0);

if(error < 0)

{

MessageBox("Communication has been cut off!!");

}

else

{}

}

2) Read Operation

//Read data from instrument

CString CDemoDlg::ReadFromDEVICE()

{

CString strReturn="";

char tempstr[256];

viScanf(g_VisaIO,"%t",tempstr);

strReturn = tempstr;

return strReturn;

}

7. Add the control notification handler codes.

1) Choose an instrument

//Connect the instrument

void CDemoDlg::OnSelchangeCBResourceName()

{

// TODO: Add your control notification handler code here

updateData(true);

int intIndex;

intIndex = m_ResourceName.GetCurSel();

m_ResourceName.GetLBText(intIndex,g_RsrcName);

unsigned long lFuncReturn = 0;

CString cstrIDNReturn = "";

char* charTemp;

charTemp = new char[26];

if(m_StateDisplay == "Connected")

{

viClose(g_VisaIO);

}

else

{}

lFuncReturn = viOpen(g_rsrcManager,g_RsrcName,0,0,&g_VisaIO);

m_valueResourceName = g_RsrcName;

if(lFuncReturn >= 0)

{

sendToDEVICE("*idn?");

cstrIDNReturn = ReadFromDEVICE();

strncpy(charTemp,cstrIDNReturn,25);

charTemp[25]='\0';

charTemp=strupr(charTemp);

CString cstrTemp=charTemp;

if(cstrTemp == "RIGOL TECHNOLOGIES,DM3068")

{

sendToDEVICE("cmdset RIGOL");

m_StateDisplay = "Connected";

m_btclose.EnableWindow(true);
m_btsend.EnableWindow(true);
m_btread.EnableWindow(true);
m_btclr.EnableWindow(true);
m_btdcv.EnableWindow(true);
m_btdci.EnableWindow(true);
m_btdcvrd.EnableWindow(true);
m_bt2ndclr.EnableWindow(true);

}
else
{
viClose(g_VisaIO);
m_StateDisplay = "Unconnected";
MessageBox(" RIGOL DM3068！");

m_btclose.EnableWindow(false);
m_btsend.EnableWindow(false);
m_btread.EnableWindow(false);
m_btclr.EnableWindow(false);
m_btdcv.EnableWindow(false);
m_btdci.EnableWindow(false);
m_btdcvrd.EnableWindow(false);
m_bt2ndclr.EnableWindow(false);
}
UpdateData(false);
}
else
{
m_StateDisplay = "Unconnected";
}

}

2) Refresh the connection

//Refresh the connection

void CDemoDlg::OnRefresh()

{

// TODO: Add your control notification handler code here

int intItemcount = 0;

intItemcount=m_ResourceName.GetCount();

for(int i=0; i < intItemcount; i++)

m_ResourceName.DeleteString(0);

UpdateData(false);

m_valueResourceName = "";

ConnectToDEVICE();

}

3) Disconnect the connection

//Disconnect the connection

void CDemoDlg::OnClose()

{

CDialog::OnClose();

// TODO: Add your message handler code here and/or call default

int intFuncReturn = 0;

UpdateData(true);

if(m_StateDisplay == "Connected")

{

intFuncReturn = viClose(g_VisaIO);

if(intFuncReturn >= 0)

{

m_StateDisplay = "Unconnected";

UpdateData(false);

}

else

{

MessageBox("Device unconnected!");

}

}

else

{}

m_valueResourceName = "";

UpdateData(false);

}

4) Send the command

//Send

void CDemoDlg::OnSend()

{

// TODO: Add your control notification handler code here

UpdateData(true);

CString cmd =m_CmdText;

sendToDEVICE(cmd);

}

5) Read the return value of the command

//Read

void CDemoDlg::OnRead()

{

// TODO: Add your control notification handler code here

m_ReturnText = ReadFromDEVICE();

UpdateData(false);

}

6) Clear the return value

//Clear the data from the return data dialog

void CDemoDlg::OnClr()

{

// TODO: Add your control notification handler code here

m_ReturnText = "";

UpdateData(false);

}

7) Switch to DCV function

// Switch to DCV

void CDemoDlg::OnDcv()

{

// TODO: Add your control notification handler code here

sendToDEVICE(":FUNCTION:VOLTAGE:DC");

}

8) Switch to DCV function and return the current reading

// Switch to DCV and return its reading

void CDemoDlg::OnDCVRd()

{

// TODO: Add your control notification handler code here

sendToDEVICE(":FUNCTION:VOLTAGE:DC");

sleep(200);

sendToDEVICE(":MEASURE:VOLTAGE:DC?");

m_ReturnText = ReadFromDEVICE();

UpdateData(false);

}

9) Switch to ACV function

// Switch to ACV

void CDemoDlg::OnAcv()

{

// TODO: Add your control notification handler code here

sendToDEVICE(":FUNCTION:VOLTAGE:AC");

}

10) Switch to DCI function

// Switch to DCI

void CDemoDlg::OnDci()

{

// TODO: Add your control notification handler code here

sendToDEVICE(":FUNCTION:CURRENT:DC");

}

11) Enable the secondary measurement function —FREQ function

// Enable the secondary function, FREQ

void CDemoDlg::On2ndfreq()

{

// TODO: Add your control notification handler code here

sendToDEVICE(":FUNCTION2:FREQ");

}

12) Disable the secondary measurement function and clear the return value.

//Close the Secondary Function and clear the return data

void CDemoDlg::On2ndclr()

{

// TODO: Add your control notification handler code here

sendToDEVICE(":FUNCTION2:CLEAR");

m_ReturnText = "";

UpdateData(false);

}

8. Execution Result

1) Click "Choose a device" to search for multimeter resources;

2) Input "*IDN?" in the "Command" edit box;

3) Click "Send" to write the command into the multimeter;

4) Click "Read" to read the return value.

The execution result is as shown in the figure below.


Visual Basic 6.0 编程示例

Visual Basic 6.0 Programming Demo

Enter the Visual Basic 6.0 programming environment and follow the steps below:

1. Build a standard application program project (Standard EXE).

2. Open Project→Add File… and add USB_Func.bas and VISA_FUNBox.bas. The two modules contain all VISA functions and constant statements to the project.

Then add the Declare Sub Sleep Lib "kernel32" (ByVal dwMilliseconds As Long) statement into the USB_Func.bas, or create a new module to declare the Sleep function.

3. Add the Text, Edit and Button controls as shown in the figure below.

4. Encapsulate the write and read operations of VISA.

1) Write Operation

'Write Operation

Public Function Device_Send(cmd As String)

Dim err As Long

Dim cmdstr As String

cmdstr = cmd + Chr$(10)

err = viVPrintf(g_lVisaIO, cmdstr, 0)

If (err < VI_SUCCESS) Then

If CurrentLang = English Then

MsgBox "Cann't Connect to Device", 48, "System Message"

Else

MsgBox "Device unconnected", 48, "Message"

End If

End If

End Function

2) Read Operation

Read Operation

Public Function ReadDeviceData() As String

Dim strTemp As String * 256

Dim strReturn As String

Dim strZero As String

Dim intNpos As Integer

Call viVScanf(g_lVisaIO, "%t", strTemp)

strZero = Chr(0)

intNpos = InStr(strTemp, strZero)

strReturn = Left(strTemp, intNpos - 1)

ReadDeviceData = strReturn

End Function

5. Add the control event codes

1) Choose a device

'Choose a device

Private Sub CobDevName_Click()

g_strCurrentDevice = CobDevName.Text

Dim intFuncReturn As Long

Dim strReturn As String

Dim strTemp As String

viClose (g_lVisaIO)

intFuncReturn = viOpen(g_lrsrcManager, g_strCurrentDevice, 0, 5000, g_lVisaIO)

If intFuncReturn >= 0 Then

Device_Send ("*idn?")

strReturn = ReadDeviceData

strTemp = UCase(Left(strReturn, 25))

If strTemp = "RIGOL TECHNOLOGIES,DM3068" Then

Device_Send ("CMDSET RIGOL")

With Form1

.Picture1.BackColor = &HFF00&

CmdSend.Enabled = True

CmdClose.Enabled = True

CmdRead.Enabled = True

CmdCLR.Enabled = True

CmdDCV.Enabled = True

CmdDCI.Enabled = True

CmdDCVRd.Enabled = True

Cmd2NDCLR.Enabled = True

End With

Else

viClose (g_lVisaIO)

With Form1

.Picture1.BackColor = &HFF&

End With

MsgBox "Not RIGOL DM3068！", 48, "Message"

CmdSend.Enabled = False

CmdClose.Enabled = False

CmdRead.Enabled = False

CmdCLR.Enabled = False

CmdDCV.Enabled = False

CmdDCI.Enabled = False

Cmd2NDCLR.Enabled = False

End If

Else

With Form1

.Picture1.BackColor = &HFF&

End With

End If

End Sub

2) Refresh the connection

'Refresh the connection

Private Sub CmdRefresh_Click()

With Form1

.CobDevName.Clear

End With

Device_Init

End Sub

3) Disconnect the connection

'Disconnect the connection

Private Sub CmdClose_Click()

If Form1.Picture1.BackColor = &HFF& Then

MsgBox "Device unconnected！", 48, "Message" '

Else

Dim intFuncReturn As Integer

intFuncReturn = viClose(g_lVisaIO)

If intFuncReturn >= 0 Then

With Form1

.Picture1.BackColor = &HFF&

End With

Else

MsgBox "Device unconnected！", 48, "Message"

End If

End If

End Sub

4) Send the command

'Write the command to the instrument

Private Sub CmdSend_Click()

Dim strCmd As String

strCmd = TextCmd.Text

Device_Send (strCmd)

End Sub

5) Read the return value

'Read the return value from the instrument

Private Sub CmdRead_Click()

TextReturn.Text = ReadDeviceData

End Sub

6) Clear the return value

'Clear the data from the return data dialog

Private Sub CmdCLR_Click()

TextReturn.Text = ""

End Sub

7) Switch to DCV measurement

'Switch to DCV measurement function

Private Sub CmdDCV_Click()

Device_Send (":function:voltage:dc")

End Sub

8) Switch to DCV measurement and return the current reading

'Switch to DCV measurement function and read current reading

Private Sub CmdDCV_Click()

Device_Send (":function:voltage:dc")

Sleep (200)

Device_Send (":measure:voltage:dc?")

TextReturn.Text = ReadDeviceData

End Sub

9) Switch to ACV measurement

'Switch to ACV measurement function

Private Sub CmdACV_Click()

Device_Send (":function:volt:ac")

End Sub

10) Switch to DCI measurement

'Switch to DCI measurement function

Private Sub CmdDCI_Click()

Device_Send (":function:current:dc")

End Sub

11) Enable FREQ measurement of the secondary measurement function

'Enable FREQ function on the secondary display

Private Sub Cmd2NDFREQ_Click()

Dim strReturn As String

Device_Send (":function2:freq")

End Sub

12) Disable the secondary measurement function and clear the return value

' Close the 2ND measurement function and clear the data from the return data dialog

Private Sub Cmd2NDCLR_Click()

Device_Send (":function2:clear")

TextReturn.Text = ""

End Sub

6. Execution result

1) Click "Choose a device" to search for multimeter resources;

2) Input "*IDN?" in the "Command" edit box;

3) Click "Send" to write the command into the multimeter;

4) Click "Read" to read the return value.

The execution result is as shown in the figure below:


LabVIEW 8.6 编程示例

LabVIEW 8.6 Programming Demo

Enter the Labview 8.6 programming environment and follow the steps below:

1. Create the event structure

2. Add the events

3. Instrument connection codes

4. Disconnect the connection

5. Send operation

6. Read operation

7. Switch to DCV function

8. Switch to DCV function and return the current reading

9. Switch to ACV function

10. Switch to DCI function

11. Enable the secondary measurement function FREQ

12. Disable the secondary measurement function and clear the return data dialog

13. Execution result


命令速查A-Z

Command Quick Reference A-Z

Common Command Set

RIGOL Command Set

Compatible Agilent Command Set

Expanded Agilent Command Set

Compatible Fluke Command Set


通用命令集

Common command Set

*CLS
*ESE
*ESR?
*IDN?
*OPC？

*OPC
*PSC

*RST
*SRE
*STB?
*TRG

*TST?

*WAI

C
CMDSet

S

STATus:OPERation:CONDition?
STATus:OPERation:ENABle

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?
STATus:QUEStionable:ENABle

STATus:QUEStionable[:EVENt]?


RIGOL命令集

RIGOL Command Set

C

:CALCulate:DB:REFErence
:CALCulate:DB:STATe

:CALCulate:DB?

:CALCulate:DBM:REFErence

:CALCulate:DBM:STATe

:CALCulate:DBM?
:CALCulate:FUNCtion

:CALCulate:PF:LOWEr

:CALCulate:PF:STATe

:CALCulate:PF:UPPEr

:CALCulate:PF?
:CALCulate:REL:OFFSet
:CALCulate:REL:STATe

:CALCulate:STATistic:AVERage?
:CALCulate:STATistic:COUNt?

:CALCulate:STATistic:MAX?

:CALCulate:STATistic:MIN?
:CALCulate:STATistic:STATe

F

:FUNCtion2:CLEar

:FUNCtion2:FREQuency

:FUNCtion2:ON?

:FUNCtion2:VALUe1?
:FUNCtion2:VALUe2?

:FUNCtion2?
:FUNCtion:CAPacitance

:FUNCtion:CONTinuity

:FUNCtion:CURRent:AC

:FUNCtion:CURRent:DC

:FUNCtion:DIODe

:FUNCtion:FREQuency
:FUNCtion:FRESistance

:FUNCtion:PERiod
:FUNCtion:RESistance

:FUNCtion:VOLTage:AC

:FUNCtion:VOLTage:DC

:FUNCtion?

M

:MEASure

:MEASure:CAPacitance
:MEASure:CAPacitance:RANGe?

:MEASure:CAPacitance?

:MEASure:CONTinuity

:MEASure:CONTinuity?

:MEASure:CURRent:AC
:MEASure:CURRent:AC:RANGe?

:MEASure:CURRent:AC?

:MEASure:CURRent:DC
:MEASure:CURRent:DC:RANGe?

:MEASure:CURRent:DC?

:MEASure:DIODe?

:MEASure:FREQuency
:MEASure:FREQuency:RANGe?

:MEASure:FREQuency?

:MEASure:FRESistance

:MEASure:FRESistance:RANGe?

:MEASure:FRESistance?

:MEASure:PERiod
:MEASure:PERiod:RANGe?

:MEASure:PERiod?

:MEASure:RESistance
:MEASure:RESistance:RANGe?

:MEASure:RESistance?

:MEASure:VOLTage:AC
:MEASure:VOLTage:AC:RANGe?

:MEASure:VOLTage:AC?

:MEASure:VOLTage:DC
:MEASure:VOLTage:DC:IMPEdance

:MEASure:VOLTage:DC:RANGe?

:MEASure:VOLTage:DC?

:MEASure?

R

:RATE:CURRent:AC

:RATE:CURRent:DC

:RATE:FRESistance
:RATE:RESistance
:RATE:SENSor

:RATE:VOLTage:AC

:RATE:VOLTage:DC

S

:SYSTem:BEEPer
:SYSTem:BEEPer:STATe

:SYSTem:CLOCk?

:SYSTem:CONFigure:DEFault

:SYSTem:CONFigure:POWEron
:SYSTem:DISPlay:BRIGht

:SYSTem:DISPlay:CONTrast

:SYSTem:DISPlay:INVErt

:SYSTem:EDITion?
:SYSTem:FORMat:DECImal

:SYSTem:FORMat:SEPArate

:SYSTem:LANGuage

:SYSTem:MACAddr?
:SYSTem:OPENtimes?
:SYSTem:SERIal?
:SYSTem:TYPE?

T

:TRIGger:AUTO:HOLD
:TRIGger:AUTO:HOLD:SENSitivity

:TRIGger:AUTO:INTErval

:TRIGger:EXT

:TRIGger:SINGle
:TRIGger:SINGle:TRIGgered

:TRIGger:SOURce
:TRIGger:VMComplete

U

:UTILity:INTErface:GPIB:ADDRess

:UTILity:INTErface:LAN:AUTOip
:UTILity:INTErface:LAN:DHCP
:UTILity:INTErface:LAN:DNS

:UTILity:INTErface:LAN:GATEway
:UTILity:INTErface:LAN:IP
:UTILity:INTErface:LAN:MANUip
:UTILity:INTErface:LAN:MASK
:UTILity:INTErface:RS232:BAUD
:UTILity:INTErface:RS232:PARIty


兼容的Agilent命令集

Compatible Agilent Command Set

C

CALCulate:AVERage:AVERage?
CALCulate:AVERage:COUNt?
CALCulate:AVERage:MAXimum?
CALCulate:AVERage:MINimum?

CALCulate:DB:REFerence
CALCulate:DBM:REFerence
CALCulate:FUNCtion

CALCulate:LIMit:LOWer
CALCulate:LIMit:UPPer

CALCulate:NULL:OFFSet

CALCulate:STATe

CONFigure:CONTinuity

CONFigure:CURRent:AC

CONFigure:CURRent:DC

CONFigure:DIODe
CONFigure:FREQuency
CONFigure:FRESistance
CONFigure:PERiod
CONFigure:RESistance
CONFigure:VOLTage:AC

CONFigure:VOLTage:DC
CONFigure?

D

DATA:FEED RDG_STORE,{"CALCulate"|""}
DATA:FEED?
DATA:POINts?

DISPlay

DISPlay:TEXT
DISPlay:TEXT:CLEar

F

FETCh?

I

INITiate

INPut:IMPedance:AUTO

M

MEASure:CONTinuity?

MEASure:CURRent:AC?

MEASure:CURRent:DC?

MEASure:DIODe?

MEASure:FREQuency?

MEASure:FRESistance?

MEASure:PERiod?

MEASure:RESistance?

MEASure:VOLTage:AC?

MEASure:VOLTage:DC?

R

READ?

ROUTe:TERMinals

S

SAMPle:COUNt

SYSTem:BEEPer
SYSTem:BEEPer:STATe

S

[SENSe:]CURRent:AC:RANGe
[SENSe:]CURRent:AC:RANGe:AUTO

[SENSe:]CURRent:AC:RESolution
[SENSe:]CURRent:DC:NPLCycles
[SENSe:]CURRent:DC:RANGe
[SENSe:]CURRent:DC:RANGe:AUTO
[SENSe:]CURRent:DC:RESolution
[SENSe:]DETector:BANDwidth
[SENSe:]FREQuency:APERture
[SENSe:]FREQuency:VOLTage:RANGe
[SENSe:]FREQuency:VOLTage:RANGe:AUTO
[SENSe:]FRESistance:NPLCycles
[SENSe:]FRESistance:RANGe
[SENSe:]FRESistance:RANGe:AUTO
[SENSe:]FRESistance:RESolution
[SENSe:]FUNCtion
[SENSe:]PERiod:APERture
[SENSe:]PERiod:VOLTage:RANGe
[SENSe:]PERiod:VOLTage:RANGe:AUTO

[SENSe:]RESistance:NPLCycles
[SENSe:]RESistance:RANGe
[SENSe:]RESistance:RANGe:AUTO
[SENSe:]RESistance:RESolution

[SENSe:]VOLTage:AC:RANGe
[SENSe:]VOLTage:AC:RANGe:AUTO
[SENSe:]VOLTage:AC:RESolution
[SENSe:]VOLTage:DC:NPLCycles
[SENSe:]VOLTage:DC:RANGe
[SENSe:]VOLTage:DC:RANGe:AUTO
[SENSe:]VOLTage:DC:RESolution
[SENSe:]ZERO:AUTO

T

TRIGger:COUNt


扩展的Agilent命令集

Expanded Agilent Command Set

A

ANYSensor:APPLy 1

ANYSensor:DONE?

ANYSensor:NAME

ANYSensor:POINt

ANYSensor:POINt:DELete

ANYSensor:POINt:EDIT

ANYSensor:POINt?

ANYSensor:TYPE

ANYSensor:UNIT

C

CALCulate:AVERage:CLEar
CALCulate:AVERage:PTPeak?

CALCulate:AVERage:SDEViation?

CONFigure:CAPacitance
CONFigure:TEMPerature

M

MEASure:CAPacitance?
MEASure:TEMPerature?

S

[SENSe:]CAPacitance:NULL:STATe
[SENSe:]CAPacitance:NULL:VALue

[SENSe:]CAPacitance:RANGe
[SENSe:]CAPacitance:RANGe:AUTO
[SENSe:]CURRent:AC:BANDwidth
[SENSe:]CURRent:AC:NULL:STATe
[SENSe:]CURRent:AC:NULL:VALue
[SENSe:]CURRent:AC:PEAK:STATe

[SENSe:]CURRent:DC:APERture
[SENSe:]CURRent:DC:APERture:ENABled
[SENSe:]CURRent:DC:NULL:STATe
[SENSe:]CURRent:DC:NULL:VALue
[SENSe:]CURRent:DC:PEAK:STATe
[SENSe:]CURRent:DC:ZERO:AUTO

[SENSe:]FREQuency:APERture
[SENSe:]FREQuency:NULL:STATe
[SENSe:]FREQuency:NULL:VALue
[SENSe:]FREQuency:RANGe:LOWer

[SENSe:]FRESistance:APERture
[SENSe:]FRESistance:APERture:ENABled

[SENSe:]FRESistance:NULL:STATe
[SENSe:]FRESistance:NULL:VALue
[SENSe:]FRESistance:OCOMpensated

[SENSe:]PERiod:APERture
[SENSe:]PERiod:NULL:STATe
[SENSe:]PERiod:NULL:VALue
[SENSe:]PERiod:RANGe:LOWer

[SENSe:]RESistance:APERture
[SENSe:]RESistance:APERture:ENABled
[SENSe:]RESistance:NULL:STATe
[SENSe:]RESistance:NULL:VALue
[SENSe:]RESistance:OCOMpensated
[SENSe:]RESistance:ZERO:AUTO

[SENSe:]TEMPerature:NULL[:STATe]

[SENSe:]TEMPerature:NULL:VALue

[SENSe:]TEMPerature:TRANsducer:FRTD:RESistance[:REFerence]

[SENSe:]TEMPerature:TRANsducer:FRTD:TYPE

[SENSe:]TEMPerature:TRANsducer:FTHermistor:TYPE

[SENSe:]TEMPerature:TRANsducer:RTD:RESistance[:REFerence]

[SENSe:]TEMPerature:TRANsducer:RTD:TYPE

[SENSe:]TEMPerature:TRANsducer:THERmistor:TYPE

[SENSe:]TEMPerature:TRANsducer:TYPE

[SENSe:]VOLTage:AC:BANDwidth
[SENSe:]VOLTage:AC:NULL:STATe
[SENSe:]VOLTage:AC:NULL:VALue
[SENSe:]VOLTage:AC:PEAK:STATe

[SENSe:]VOLTage:DC:APERture
[SENSe:]VOLTage:DC:APERture:ENABled
[SENSe:]VOLTage:DC:IMPedance:AUTO
[SENSe:]VOLTage:DC:NULL:STATe
[SENSe:]VOLTage:DC:NULL:VALue

[SENSe:]VOLTage:DC:PEAK:STATe
[SENSe:]VOLTage:DC:ZERO:AUTO

SYSTem:COMMunicate:GPIB:ADDRess

T

TRIGger:LEVel

TRIGger:SLOPe

U
UNIT:TEMPerature


兼容的Fluke命令集

Compatible Fluke Command Set

A

AAC
ADC

AUTO

C
CLR2
COMP
COMPCLR
COMPHI
COMPLO

CONT

D
 DB
DBCLR
DIODE

DBREF

F
 FIXED
FORMAT

FREQ
FUNC

H
 HOLD
HOLDCLR
HOLDTHRESH

M

MAX
MAXSET
MEAS
MIN
MINSET
MMCLR
MOD?

O

OHMS

R

RANGE
RATE

REL
RELCLR
RELSET

S

SERIAL?

T

TRIGGER

V

VAC
VAL

VDC


附录

Appendix

This part lists those commands in Agilent34401A Command Set and Fluke45 Command Set that are not compatible with DM3068.

1. Incompatible Agilent34401A Commands

 //DM3068 does not have the measurement function

MEASure:VOLTage:DC:RATio? {<range>|MIN|MAX|DEF},{<resolution>|MIN|MAX|DEF}
CONFigure:VOLTage:DC:RATio {<range>|MIN|MAX|DEF},{<resolution>|MIN|MAX|DEF}
[SENSe:]FUNCtion "VOLTage:DC:RATio"

//The calibration commands do not need compatibility
CALibration?
CALibration:COUNt?
CALibration:SECure:CODE <new code>
CALibration:SECure:STATe {OFF|ON},<code>
CALibration:SECure:STATe?
CALibration:STRing <quoted string>
CALibration:STRing?
CALibration:VALue <value>

2. Incompatible Fluke45 Commands

//DM3068 does not have the measurement functions

AAC2
AACDC*
ADC2
DBPOWER

DIODE2
OHMS2
VAC2
VACDC*
VDC2

//Special commands
^C (CNTRL C)
LOCS
LWLS

REMS
RWLS


联系我们

Contact Us

If you have any problem or requirement when using our products or this manual, please contact RIGOL.

E-mail: service@rigol.com

Website: www.rigol.com


CONFigure:CAPacitance

Syntax

CONFigure:CAPacitance [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets the multimeter with the specified range and resolution for capacitance measurement.

Parameter

Name | Type | Range | Default
<range> | Discrete | 2nF (MIN) 20nF 200nF 2uF (DEF) 20uF 200uF 2mF 2mF 100mF(MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 3 1/2 bits | The resolution is fixed at 3 1/2 bits

Explanation

1. This command sets the range and resolution to their default values when this command are sent without parameters. This command allows to set the parameter with unit and the default unit is "F" when the parameters are set without unit.

2. This command only specifies parameter but does not initiate the measurement.

Example

The command below sets the range and resolution for capacitance measurement of the multimeter to their default values.

CONF:C AP

The query command CONFigure? returns "CAP 2.00000000E-06,2.00000000E-10".

Related Command

CONFigure?


MEASure:CAPacitance?

Syntax

MEASure:CAPacitance? [{<range>|MIN|MAX|DEF}[,{<resolution>|MIN|MAX|DEF}]]

Description

This command presets and makes a capacitance measurement with the specified range and resolution. The reading is sent to the output buffer.

Parameter

Name | Type | Range | Default
<range> | Discrete | 2nF (MIN) 20nF 200nF 2uF (DEF) 20uF 200uF 2mF 2mF 100mF(MAX) AUTO (Auto Range) | AUTO (Auto Range)
<resolution> | Discrete | The resolution is fixed at 3 1/2 bits | The resolution is fixed at 3 1/2 bits

Explanation

This command sets the range and resolution to their default values and executes capacitance measurement when the parameters are set without unit.

Return Format

The query returns the reading in the output buffer.

Example

The command below sets the capacitance measurement parameters to their default values, triggers the multimeter to make measurement, loads one reading and sends it to the output buffer. The return value is "1.27216258e-11".

 MEAS:CAP?

Related Command

CONFigure?