DG4000系列函数/任意波形发生器

RIGOL

编程手册

DG4000系列函数/任意波形发生器

本手册用于指导用户使用SCPI命令通过远程接口（USB或LAN）编程控制 RIGOL DG4000系列函数/任意波形发生器。

本手册主要内容：

SCPI 简介

命令系统

编程实例

命令速查

软件版本：

00.01.12

软件升级可能更改或增加产品功能，请关注 RIGOL 网站获取最新版本手册或联系 RIGOL 升级软件。

声明：

本公司产品受中国及其它国家和地区的专利（包括已取得的和正在申请的专利）保护。

本公司保留改变规格及价格的权利。

本手册提供的信息取代以往出版的所有资料。

本手册提供的信息如有变更，恕不另行通知。

对于本手册可能包含的错误，或因手册所提供的信息及演绎的功能，以及因使用本手册而导致的任何偶然或继发的损失，RIGOL 概不负责。

未经 RIGOL 事先书面许可，不得影印、复制或改编本手册的任何部分。

如您在使用此产品或本手册的过程中有任何问题或需求，可与 RIGOL 联系：

电子邮箱：service@rigol.com

网址：www.rigol.com

©2011 北京普源精电科技有限公司版权所有。

2015年08月 文档编号：PGB04008-1110


SCPI简介

SCPI (Standard Commands for Programmable Instrument) 是IEEE 488.2上的可程控仪器标准指令集。

本章内容包括：

命令格式

符号说明

参数类型

命令缩写


命令格式

SCPI 命令为树状层次结构，包括多个子系统，每个子系统由一个根关键字和一个或数个层次关键字构成。命令行通常以冒号“:”开始；关键字之间用冒号“:”分隔，关键字后面跟随可选的参数设置；命令行后面添加问号“?”，表示查询；命令和参数以“空格”分开。

例如：

:COUPling:AMPL:DEViation <deviation>
:COUPling:AMPL:DEViation?

COUPling是命令的根关键字，AMPL和DEViation分别是第二级和第 三级关键字。命令行以冒号“:”开始，同时将各级关键字分开，<deviation>表示可设置的参数；问号“?”表示查询；命令:COUPling:AMPL:DEViation和参数<deviation>之间用“空格”分开。

在一些带参数的命令中，通常用逗号“,”分隔多个参数，例如：

:MMEMory:COPY <directory_name>,<file_name>


符号说明

下面四种符号不是 SCPI 命令中的内容，不随命令发送，但是通常用于辅助说明命令中的参数。

大括号 { }

大括号中的参数是可选项，可以不设置，也可以设置一次或多次。例如：

[:TRACe]:DATA[:DATA] VOLATILE,<value>{,<value>}命令中，{,<value>}中的浮点电压值可以省略，也可以设置一个或多个电压值。

竖线 |

竖线用于分隔多个参数选项，发送命令时必须选择其中一个参数。例如：

:DISPlay:SAVer[:STATe] ON|OFF 命令中，可选择的命令参数为“ON”或“OFF”。

三角括号 < >

三角括号中的参数必须用一个有效值来替换。例如：

以:DISPlay:BRIGhtness 10 的形式发送:DISPlay:BRIGhtness <brightness>|MINimum|MAXimum 命令 。

方括号 [ ]

方括号中的内容（参数或关键字）是可省略的。如果省略参数，仪器将该参数设置为默认值。例如：

对于[:SOURce<n>]:MOD[:STATe]?命令，

发送下面四条命令的效果是一样的：

:MOD?

:MOD:STATe?

:SOURce1:MOD?

:SOURce1:MOD:STATe?


参数类型

本手册介绍的命令中所含的参数可以分为以下 6种类型：布尔、关键字、整型、连续实型、离散、ASCII 字符串。

布尔

参数取值为“ON”或“OFF”。例如：

:DISPlay:SAVer[:STATe] ON|OFF

关键字

参数取值为所列举的值。例如：

[:SOURce<n>]:BURSt:GATE:POLarity NORMal|INVerted

参数为“NORMal”或“INVerted”。

整型

除非另有说明，参数在有效值范围内可以取任意整数值。注意，此时请不要设置参数为小数格式，否则将出现异常。例如：

:OUTPut[<n>]:LOAD <ohms>|INFinity|MINimum|MAXimum

参数<ohms>可取1到10000范围内的任一整数。

连续实型

参数在有效值范围内按精度要求（通常默认精度为小数点以后取六位有效值），可以任意进行取值。例如：

[:SOURce<n>]:MOD:AM[:DEPTh] <depth>|MINimum|MAXimum

参数<depth>可设置为0至120 之间的任意实数。

离散

参数只能取指定的数值，并且这些数值不是连续的。例如：

[:SOURce<n>]:MOD[:STATe] ON|OFF

参数<n>只能取1或2。

ASCII字符串

参数取值为 ASCII 字符的组合。例如：

:MMEMory:MDIRectory <dir_name>

参数<dir_name>为字符串形式。

说明：在DG4000命令系统中，部分命令带有MAXimum和MINimum参数。例如：

[:SOURce<n>]:MOD:ASKey :AMPLitude <amplitude>|MINimum|MAXimum
[:SOURce<n>]:MOD:ASKey:AMPLitude? [MINimum|MAXimum]

1. 设置命令以MAXimum 为参数表示以最大值设置指定的信号源参数；

2. 设置命令以MINimum 为参数表示以最小值设置指定的信号源参数；

3. 查询命令以MAXimum 为参数表示查询指定的信号源参数的最大值；

4. 查询命令以MINimum 为参数表示查询指定的信号源参数的最小值。


命令缩写

所有命令对大小写不敏感，你可以全部采用大写或小写。但是如果要缩写，必须输完命令格式中的所有大写字母，例如：

:SYSTem:COMMunicate:USB:INFormation?

可缩写成：

:SYST:COMM:USB:INF?


DG5000系列命令集系统

命令系统

本章按照字母A-Z顺序分别介绍DG4000系列命令系统。

COUNter命令子系统

COUPling命令子系统

DISPlay命令子系统

:HCOPy:SDUMp:DATA?

IEEE 488.2公用命令

MEMory命令子系统

MMEMory命令子系统

OUTPut命令子系统

PA命令子系统

SOURce命令子系统

SYSTem命令子系统

TRACe命令子系统

说明：本命令集中，涉及频率、幅度等参数设置的命令，允许带单位发送命令。各参数支持的单位及缺省单位如下表所示：

参数 | 支持单位 | 缺省单位
频率 | MHZ/KHZ/HZ/UHZ | HZ
幅度 | VPP/MVPP/VRMS /MVRMS/DBM | VPP/VRMS/DBM （取决于当前被设置参数）
偏移/高电平/低电平 | V/MV | V
时间 | MS/KS/S/US/NS | S
相位 | ° | °
占空比/调制深度等 | % | %

● MHZ等同于mHz。

● MVPP等同于mVpp、MVRMS等同于mVrms、MV等同于mV。

● MS等同于ms。

注意：对于命令中参数范围的说明，本手册以DG4162型号为例。


COUNter Command Subsystem

COUNter命令子系统

:COUNter:ATTenuation 1X|10X
:COUNter:ATTenuation?

:COUNter:AUTO

:COUNter:COUPing AC|DC
:COUNter:COUPing?

:COUNter:GATEtime AUTO|USER1|USER2|USER3|USER4|USER5|USER6
:COUNter:GATEtime?

:COUNter:HF ON|OFF

:COUNter:HF?

:COUNter:IMPedance 50|1M
:COUNter:IMPedance?

:COUNter:LEVE <value>|MINimum|MAXimum
:COUNter:LEVE? [MINimum|MAXimum]

:COUNter:MEASure?
:COUNter:SENSitive <value>|MINimum|MAXimum
:COUNter:SENSitive? [MINimum|MAXimum]

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?
:COUNter:STATIstics:CLEAr
:COUNter:STATIstics:DISPlay DIGITAL|CURVE
:COUNter:STATIstics:DISPlay?

:COUNter:STATIstics[:STATe] ON|OFF
:COUNter:STATIstics[:STATe]?


:COUNter:ATTenuation

命令格式

:COUNter:ATTenuation 1X|10X
:COUNter:ATTenuation?

功能描述

设置频率计的衰减系数为X1或X10。

查询频率计的衰减系数。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | 1X|10X | 1X

返回格式

返回 1X 或 10X。

举例

下面的命令设置衰减系数为X10：

:COUNter:ATTenuation 10X

下面的查询返回10X。

:COUNter:ATTenuation?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUNter:A UTO

命令格式

:COUNter:AUTO

功能描述

发送该命令，仪器自动设置频率计的闸门时间。

说明

该命令仅当频率计功能打开时可用。

该命令与命令:COUNter:GATEtime AUTO 功能相同。

举例

下面的命令自动设置频率计的闸门时间：

:COUNter:AUTO

相关命令

:COUNter:GATEtime AUTO|USER1|USER2|USER3|USER4|USER5|USER6
:COUNter:GATEtime?

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUNter:COUPing

命令格式

:COUNter:COUPing AC|DC
:COUNter:COUPing?

功能描述

设置频率计的耦合类型为AC或DC。

查询频率计的耦合类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | AC|DC | AC

返回格式

返回 AC 或 DC。

举例

下面的命令设置耦合类型为DC：

:COUNter:COUPing DC

下面的查询返回 DC。

:COUNter:COUPing?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUNter:GATEtime

命令格式

:COUNter:GATEtime AUTO|USER1|USER2|USER3|USER4|USER5|USER6
:COUNter:GATEtime?

功能描述

设置频率计的闸门时间。

查询频率计的闸门时间。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | AUTO|USER1|USER2|USER3|USER4|USER5|USER6 | USER1

说明

各参数对应的闸门时间值如下表所示：

AUTO | AUTO
USER1 | 1 ms
USER2 | 10 ms
USER3 | 100 ms
USER4 | 1 s
USER5 | 10 s
USER6 | >10 s

返回格式

查询返回AUTO、USER1、USER2、USER3、USER4、USER5或USER6。

举例

下面的命令设置频率计的闸门时间为10 ms：

:COUNter:GATEtime USER2

下面的查询返回 USER2。

:COUNter:GATEtime?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?

:COUNter:AUTO


:COUN ter:HF

命令格式

:COUNter:HF ON|OFF

:COUNter:HF?

功能描述

打开或关闭频率计的高频抑制功能。

查询频率计的高频抑制是否打开。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

返回格式

查询返回ON或OFF。

举例

下面的命令打开频率计的高频抑制功能：

:COUNter:HF ON

下面的查询返回 ON。

:COUNter:HF?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUNter:IMPedance

命令格式

:COUNter:IMPedance 50|1M
:COUNter:IMPedance?

功能描述

设置频率计的输入阻抗为 50 Ω 或 1 MΩ。

查询频率计的输入阻抗。

参数

名称 | 类型 | 范围 | 默认值
—— | 离散型 | 50 Ω|1 MΩ | 1 MΩ

返回格式

返回 50 或1M。

举例

下面的命令设置输入阻抗为50 Ω：

:COUNter:IMPedance 50

下面的查询返回 50。

:COUNter:IMPedance?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUNter:LEVE

命令格式

:COUNter:LEVE <value>|MINimum|MAXimum
:COUNter:LEVE? [MINimum|MAXimum]

功能描述

设置频率计的触发电平。

查询频率计的触发电平。

参数

名称 | 类型 | 范围 | 默认值
<value> | 连续实型 | -2.5 V至2.5 V | 0 V

返回格式

查询以科学计数形式返回触发电平。

举例

下面的命令设置触发电平为2 V：

:COUNter:LEVE 2

下面的查询返回 2.000000E+00。

:COUNter:LEVE?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUNter:MEASure

命令格式

:COUNter:MEASure?

功能描述

查询频率计当前的测量结果。

返回格式

以“频率,周期,占空比,正脉宽,负脉宽”形式返回各参数的测量结果，其中，每个参数以科学计数形式表示。

举例

下面的查询返回1.000099993E+03,9.999000134E-04,1.422600068E+01,1.422537019E-04,8.576463115E-04：

:COUNter:MEASure?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUN ter:SENSitive

命令格式

:COUNter:SENSitive <value>|MINimum|MAXimum
:COUNter:SENSitive? [MINimum|MAXimum]

功能描述

设置频率计的触发灵敏度。

查询频率计的触发灵敏度。

参数

名称 | 类型 | 范围 | 默认值
<value> | 连续实型 | 0%至 100% | 50%

返回格式

查询以科学计数形式返回触发灵敏度。

举例

下面的命令设置触发灵敏度为60%：

:COUNter:SENSitive 60

下面的查询返回 6.000000E+01。

:COUNter:SENSitive?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


:COUNter[:STATe]

命令格式

:COUNter[:STATe] ON|OFF

:COUNter[:STATe]?

功能描述

打开或关闭频率计功能。

查询频率计功能的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

返回格式

返回ON（频率计开启时）或OFF（频率计关闭时）。

举例

下面的命令开启频率计功能：

:COU Nter:STATe ON

下面的查询返回ON。

:COUNter:STATe?


:COUNte r:STATIstics:CLEAr

命令格式

:COUNter:STATIstics:CLEAr

功能描述

清除当前的统计结果。

说明

该命令仅在统计功能打开时可用（请使用:COUNter:STATIstics[:STATe] ON|OFF打开统计功能）。

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?

:COUNter:STATIstics[:STATe] ON|OFF
:COUNter:STATIstics[:STATe]?


:COUNter:STATIstics:DISPlay

命令格式

:COUNter:STATIstics:DISPlay DIGITAL|CURVE
:COUNter:STATIstics:DISPlay?

功能描述

选择频率计测量结果统计功能的显示类型为数字（DIGITAL）或动态曲线 （CURVE）。

查询频率计测量结果统计功能的显示类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | DIGITAL|CURVE | DIGITAL

返回格式

查询返回DIGITAL或CURVE。

举例

下面的命令选择统计功能的显示形式为动态曲线：

:COUNter:STATIstics:DISPlay CURVE

下面的查询返回CURVE。

:COUNter:STATIstics:DISPlay?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?

:COUNter:STATIstics[:STATe] ON|OFF
:COUNter:STATIstics[:STATe]?


:COUNter:STATIstics

:COUNter:STATIstics[:STATe]

命令格式

:COUNter:STATIstics[:STATe] ON|OFF
:COUNter:STATIstics[:STATe]?

功能描述

打开或关闭频率计的测量结果统计功能。

查询频率计测量结果统计功能的开关状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

返回格式

查询返回ON或OFF。

举例

下面的命令打开频率计的测量结果统计功能：

:COUNter:STATIstics:STATe ON

下面的查询返回ON。

:COUNter:STATIstics:STATe?

相关命令

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?


COUPling Subsystem

COU Pling 命令子系统

:COUPling:AMPL:DEViation <deviation>
:COUPling:AMPL:DEViation?

:COUPling:AMPL[:STATe] ON|OFF
:COUPling:AMPL[:STATe]?

:COUPling:CHannel:BASE CH1|CH2
:COUPling:CHannel:BASE?

:COUPling:FREQuency:DEViation <deviation>
:COUPling:FREQuency:DEViation?
:COUPling:FREQuency[:STATe] ON|OFF
:COUPling:FREQuency[:STATe]?

:COUPling:PHASe:DEViation <deviation>
:COUPling:PHASe:DEViation?
:COUPling:PHASe[:STATe] ON|OFF
:COUPling:PHASe[:STATe]?

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?


:COUPling:AMPL:DEViation

命令格式

:COUPling:AMPL:DEViation <deviation>
:COUPling:AMPL:DEViation?

功能描述

设置幅度耦合的幅度差。

查询幅度差值。

参数

名称 | 类型 | 范围 | 默认值
<deviation> | 连续实型 | 0 Vpp 至 20 Vpp | 0 Vpp

返回格式

查询以科学计数形式返回当前的幅度差。

举例

下面的命令将 幅度差设置为 500 mVpp：

:COUPling:AMPL:DEViation 0.5

下面的查询返回5.000000E-01。

:COUPling:AMPL:DEViation?

相关命令

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?

:COUPling:AMPL[:STATe] ON|OFF
:COUPling:AMPL[:STATe]?


:COUPling:AMPL[:STATe]

命令格式

:COUPling:AMPL[:STATe] ON|OFF
:COUPling:AMPL[:STATe]?

功能描述

打开或关闭幅度耦合功能。

查询幅度耦合功能的开关状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

您也可以使用:COUPling[:STATe] ON|OFF 命令同时打开或关闭频率耦合、相位耦合和幅度耦合功能 。

返回格式

查询返回 ON 或 OFF。

举例

下面的命令打开幅度耦合：

:COUPling:AMPL:STATe ON

下面的查询返回ON。

:COUPling:AMPL:STATe?

相关命令

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?

:COUPling:AMPL:DEViation <deviation>
:COUPling:AMPL:DEViation?


:COUPling:CHannel:BASE

命令格式

:COUPling:CHannel:BASE CH1|CH2

:COUPling:CHannel:BASE?

功能描述

设置耦合基准通道为 CH1或CH2。

查询当前的耦合基准通道。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | CH1|CH2 | CH1

说明

1. 该命令仅在耦合功能关闭时有效(请使用:COUPling[:STATe] ON|OFF 命令关闭耦合功能)。

2. 当频率、相位或幅度耦合功能打开时，在耦合基准通道的频率、相位和幅度左侧会对应显示一个绿色“*”标记。

返回格式

查询返回 CH1 或 CH2。

举例

下面的命令将耦合基准通道设置为 CH2：

:COUPling:CHannel:BASE CH2

下面的查询返回 CH2。

:COUPling:CHannel:BASE?

相关命令


:COUPling:FREQuency:DEViation

命令格式

:COUPling:FREQuency:DEViation <deviation>

:COUPling:FREQuency:DEViation?

功能描述

设置频率耦合的频率差。

查询频率差值。

参数

名称 | 类型 | 范围 | 默认值
<deviation> | 连续实型 | 0 μHz 至 160 MHz | 0 μHz

返回格式

查询以科学计数形式返回当前的频率差。

举例

下面的命令将频率差设置为 100 Hz：

:COUPling:FREQuency:DEViation 100

下面的查询返回1.000000E+02。

:COUPling:FREQuency:DEViation?

相关命令

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?

:COUPling:FREQuency[:STATe] ON|OFF
:COUPling:FREQuency[:STATe]?


:COUPling:FREQuency[:STATe]

命令格式

:COUPling:FREQuency[:STATe] ON|OFF
:COUPling:FREQuency[:STATe]?

功能描述

打开或关闭频率耦合功能。

查询频率耦合功能的开关状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

您也可以使用:COUPling[:STATe] ON|OFF 命令同时打开或关闭频率耦合、相位耦合和幅度耦合功能 。

返回格式

查询返回ON或OFF。

举例

下面的命令打开 频率耦合：

:COUPling:FREQuency:STATe ON

下面的查询返回ON。

:COUPling:FREQuency:STATe?

相关命令

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?

:COUPling:FREQuency:DEViation <deviation>
:COUPling:FREQuency:DEViation?


:COUPling:PHASe:DEViation

命令格式

:COUPling:PHASe:DEViation <deviation>

:COUPling:PHASe:DEViation?

功能描述

设置相位耦合的相位差。

查询相位差值。

参数

名称 | 类型 | 范围 | 默认值
<deviation> | 连续实型 | 0°至 360° | 0°

返回格式

查询以科学计数形式返回当前的相位差。

举例

下面的命令将相位差设置为 10°：

:COUPling:PHASe:DEViation 10

下面的查询返回1.000000E+01。

:COUPling:PHASe:DEViation?

相关命令

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?

:COUPling:PHASe[:STATe] ON|OFF
:COUPling:PHASe[:STATe]?


:COUPling:PHASe[:STATe]

命令格式

:COUPling:PHASe[:STATe] ON|OFF
:COUPling:PHASe[:STATe]?

功能描述

打开或关闭相位耦合功能。

查询相位耦合功能的开关状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

您也可以使用:COUPling[:STATe] ON|OFF 命令同时打开或关闭频率耦合、相位耦合和幅度耦合功能 。

返回格式

查询返回 ON 或 OFF。

举例

下面的命令打开相位耦合：

:COUPling:PHASe:STATe ON

下面的查询返回 ON。

:COUPling:PHASe:STATe?

相关命令

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?


:COUPling[:STATe]

命令格式

:COUPling[:STATe] ON|OFF

:COUPling[:STATe]?

功能描述

打开或关闭通道的频率耦合、相位耦合和幅度耦合功能。

查询返回三种耦合功能的开关状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

您也可以使用对应的命令分别打开或关闭频率耦合 、相位耦合和幅度耦合功能（见本页相关命令）。

返回格式

查询返回三种耦合功能的开关状态，格式为 FREQ:OFF,PHASE:OFF,AMPL:OFF。

举例

下面的命令开启三种耦合功能：

:COUPling:STATe ON

下面的查询返回 FREQ:ON,PHASE:ON,AMPL:ON。

:COUPling:STATe?

相关命令

:COUPling:AMPL[:STATe] ON|OFF
:COUPling:AMPL[:STATe]?

:COUPling:FREQuency[:STATe] ON|OFF
:COUPling:FREQuency[:STATe]?

:COUPling:PHASe[:STATe] ON|OFF
:COUPling:PHASe[:STATe]?


DISPlay Subsystem

DISPlay 命令子系统

:DISPlay:BRIGhtness <brightness>|MINimum|MAXimum
:DISPlay:BRIGhtness? [MINimum|MAXimum]


:DISPlay:BRIGhtness

命令格式

:DISPlay:BRIGhtness <brightness>|MINimum|MAXimum

:DISPlay:BRIGhtness? [MINimum|MAXimum]

功能描述

设置屏幕亮度。

查询亮度设置。

参数

名称 | 类型 | 范围 | 默认值
<brightness> | 离散型 | 1%至100% | 50%

说明

该设置保存在非易失性存储器中，不受恢复出厂值（*RST）的影响。

返回格式

以百分比的形式返回当前亮度设置。

举例

下面的命令设置亮度为80%：

:DISPlay:BRIGhtness 80

下面的查询返回 80%。

:DISPlay:BRIGhtness?


:DISPlay:SAVer:IMMediate

命令格式

:DISPlay:SAVer:IMMediate

功能描述

立即进入屏幕保护状态。

举例

发送下面的命令，仪器立即进入屏幕保护状态：

:DISPlay:SAVer:IMMediate

相关命令

:DISPlay:SAVer[:STATe] ON|OFF
:DISPlay:SAVer[:STATe]?


:DISPlay:SAVer[:STATe]

命令格式

:DISPlay:SAVer[:STATe] ON|OFF

:DISPlay:SAVer[:STATe]?

功能描述

启用或禁用屏幕保护模式。

查询屏幕保护的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | ON

说明

启用屏幕保护功能时，若停止操作仪器满 15 分钟，仪器自动进入屏幕保护状态。

返回格式

查询返回ON或OFF。

举例

下面的命令打开屏幕保护功能：

:DISPlay:SAVer:STATe ON

下面的查询返回 ON。

:DISPlay:SAVer:STATe?

相关命令

:DISPlay:SAVer:IMMediate


:HCOPy:SDUMp:DATA?

命令格式

:HCOPy:SDUMp:DATA?

功能描述

查询前面板显示屏图像（屏幕截图）。

返回格式

返回一个确定长度的二进制数据块，该数据块包含图像，且以#开头，如#9001152054BM6......，其中，“#”后的“9”表示“9”后面的9个字符（001152054）用来表示数据长度。


IEEE 488.2

IEEE 488.2 公用命令

*IDN?

*RCL USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

*RST

*SAV USER1|USER2|USER3|USER4|USER5|USER6|USER7|USER8|USER9|USER10

*TRG


*IDN?

命令格式

*IDN?

功能描述

查询仪器的ID字符串。

返回格式

以字符串形式返回厂商、型号、序列号和版本号，各信息以逗号分隔。

举例

下面的命令查询仪器的ID，返回Rigol Technologies,DG4162,DG41620000,00.01.02。

*IDN?


*RCL

命令格式

*RCL USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

功能描述

调用非易失存储器中指定存储位置的状态文件。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | USER1|USER2|USER3|USER4|USER5| USER6|USER7|USER8|USER9|USER10 | USER1

说明

该命令仅在指定的存储位置已经存在数据时有效。

该命令仅将指定存储位置的文件读取至仪器。

举例

下面的命令读取USER2中的状态文件：

*RCL USER2

相关命令

*SAV USER1|USER2|USER3|USER4|USER5|USER6|USER7|USER8|USER9|USER10


*RST

命令格式

*RST

功能描述

将仪器恢复到出厂默认状态。


*SAV

命令格式

*SAV USER1|USER2|USER3|USER4|USER5|USER6|USER7|USER8|USER9|USER10

功能描述

将当前的仪器状态保存到非易失存储器的指定存储位置。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | USER1|USER2|USER3|USER4|USER5| USER6|USER7|USER8|USER9|USER10 | USER1

说明

若指定的存储位置已经存在数据，当前的仪器状态直接覆盖原数据，仪器不会给出提示信息。

举例

下面的命令将当前的仪器状态保存至USER2：

*SAV USER2

相关命令

*RCL USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10


*TRG

命令格式

*TRG

功能描述

触发仪器产生一次输出。

说明

该命令仅在Sweep或Burst打开（参考[:SOURce<n>]:SWEep:STATe ON|OFF 或[:SOURce<n>]:BURSt[:STATe] ON|OFF 命令）且触发源为手动时有效（参考[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual 或[:SOURce<n>]:BURSt:TRIGger:SOURce INTernal|EXTernal|MANual 命令）。

相关命令

[:SOURce<n>]:SWEep:STATe ON|OFF
[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:BURSt[:STATe] ON|OFF
[:SOURce<n>]:BURSt:TRIGger:SOURce INTernal|EXTernal|MANual


MEMory Subsystem

MEMory 命令子系统

:MEMory:STATe:DELete USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

:MEMory:STATe:LOCK USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10,ON|OFF
:MEMory:STATe:LOCK? USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

:MEMory:STATe:VALid? USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10


:MEMory:STATe:DELete

命令格式

:MEMory:STATe:DELete USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

功能描述

删除指定存储位置的状态文件。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | USER1|USER2|USER3|USER4|USER5| USER6|USER7|USER8|USER9|USER10 | USER1

说明

该命令仅当指定存储位置已存储有效的状态文件时有效。

相关命令

:MEMory:STATe:VALid? USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10


:MEMory:STA Te:LOCK

命令格式

:MEMory:STATe:LOCK USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10,ON|OFF
:MEMory:STATe:LOCK? USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

功能描述

锁定或解锁指定存储位置的文件。

查询指定存储位置的文件是否锁定。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | USER1|USER2|USER3|USER4|USER5| USER6|USER7|USER8|USER9|USER10 | USER1
—— | 布尔型 | ON|OFF | OFF

说明

指定位置的文件被锁定，表示该文件为只读文件。用户不可修改、重命名该文件，也不可重新在指定存储位置保存其它文件。

返回格式

返回 ON 或 OFF。

举例

下面的命令将 USER2 的存储文件锁定：

:MEMory:STATe:LOCK USER2,ON

下面的查询返回 ON。

:MEMory:STATe:LOCK? USER2


:MEMory:STATe:VALid?

命令格式

:MEMory:STATe:VALid? USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

功能描述

查询指定的存储位置是否已存储有效的状态文件。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | USER1|USER2|USER3|USER4|USER5| USER6|USER7|USER8|USER9|USER10 | USER1

返回格式

返回 1（有效）或 0（无效）。

举例

下面的查询返回1。

:MEMory:STATe:VALid? USER1


MMEMory Subsystem

MMEMory 命令子系统

:MMEMory:CATalog?
:MMEMory:CDIRectory <directory_name>
:MMEMory:CDIRectory?
:MMEMory:COPY <directory_name>,<file_name>

:MMEMory:DELete <file_name>
:MMEMory:LOAD <file_name>
:MMEMory:MDIRectory <dir_name>

:MMEMory:RDIRectory?
:MMEMory:STORe <file_name>

"

注意：MMEMory 命令子系统仅适用于外部存储器。若 DG4000 当前未连接U盘，发送 MMEMory 命令子系统任一命令时，仪器将提示“远程命令错误”。


:M MEMory:CATalog?

命令格式

:MMEMory:CATalog?

功能描述

查询当前路径下所有文件和文件夹。

说明

该命令仅适用于外部存储器。

返回格式

格式：{已用空间,剩余空间,"大小,属性,名称"…}。其中，已用空间和剩余空间单位为“Byte”。文件属性显示为空，文件夹属性显示为DIR。例如：

196608,1073004544,"4000,,000.RAF","1364,,3333.RSF","1364,,2222.RSF","1365,DIR,ABCD"


:MMEMory:CDIRectory

命令格式

:MMEMory:CDIRectory <directory_name>

:MMEMory:CDIRectory?

功能描述

将当前路径修改为<directory_name>指定的路径。

查询以字符串形式返回当前路径。

参数

名称 | 类型 | 范围 | 默认值
<directory_name> | ASCII字符 | 带双引号的字符串，长度限制在300 个字符内 | ——

说明

该命令 仅适用于外部存储器。若所设置的路径不存在，则提示“远程命令错误”。

返回格式

以带双引号的字符串返回当前路径。

举例

下面的命令设置当前路径为D:\rigol：

:MMEMory:CDIRectory "D:\rigol"

下面的查询返回"D:\rigol"。

:MMEMory:CDIRectory?


:MMEMory:COPY

命令格式

:MMEMory:COPY <directory_name>,<file_name>

功能描述

将当前路径下由<file_name>指定的文件复制到<directory_name>指定的路径（非当前路径）下。

参数

名称 | 类型 | 范围 | 默认值
<directory_name> | ASCII字符 | 带双引号的字符串，长度限制在300 个字符内 | ——
<file_name> | ASCII字符 | 带双引号的字符串（包含后缀），长度限制在40字符内 | ——

说明

该命令仅适用于外部存储器。

<file_name>指定的文件必须为当前路径下的文件（可使用 :MMEMory:CDIRectory <directory_name> 命令修改当前路径）。

若<file_name>指定的文件或<directory_name>指定的路径不存在，则提示“远程命令错误”。

举例

下面的命令将当前路径下的rigol1.RAF文件复制到路径D:\rigol之下。

:MMEMory:COPY "D:\rigol","rigol1.RAF"


:MMEMory:DELete

命令格式

:MMEMory:DELete <file_name>

功能描述

删除当前路径下由<file_name>指定的文件或文件夹。

参数

名称 | 类型 | 范围 | 默认值
<file_name> | ASCII字符 | 带双引号的字符串（包含后缀），长度限制在40字符内 | ——

说明

该命令仅适用于外部存储器。若<file_name>指定的文件不存在，则提示“远程命令错误”。

举例

下面的命令删除当前路径下文件名为 rigol1.RAF的文件。

:MMEMory:DELete "rigol1.RAF"


:MMEMory:LOAD

命令格式

:MMEMory:LOAD <file_name>

功能描述

加载当前路径下由<file_name>指定的文件。

参数

名称 | 类型 | 范围 | 默认值
<file_name> | ASCII字符 | 带双引号的字符串（包含后缀），长度限制在40字符内 | ——

说明

该命令仅适用于外部存储器。

若<file_name>指定的文件不存在，则提示“远程命令错误”。

可加载文件类型：状态文件（.RSF） 和任意波文件（.RAF）。

任意波文件被加载到当前通道。

举例

下面的命令加载当前路径下文件名为 rigol1.RAF 的文件。

:MMEMory:LOAD "rigol1.RAF"


:MMEMory:MDIRectory

命令格式

:MMEMory:MDIRectory <dir_name>

功能描述

在当前路径下以<dir_name>指定的文件名创建一个文件夹。

参数

名称 | 类型 | 范围 | 默认值
<dir_name> | ASCII字符 | 带双引号的字符串，长度限制在40 个字符内 | ——

说明

该命令仅适用于外部存储器。若指定文件名已存在，提示“远程命令错误”。

举例

下面的命令在当前路径下创建一个以rigol1命名的文件夹：

:MMEMory:MDIRectory "rigol1"


:MMEMory:RDIRectory?

命令格式

:MMEMory:RDIRectory?

功能描述

查询当前可用盘符（不适用于C盘）。

说明

该命令仅适用于外部存储器。

返回格式

格式："1,"D:""（当前已插入U盘）。


:MMEMory:STORe

命令格式

:MMEMory:STORe <file_name>

功能描述

以<file_name>指定的文件名将文件存储到当前路径下。

参数

名称 | 类型 | 范围 | 默认值
<file_name> | ASCII字符 | 带双引号的字符串（包含后缀），长度限制在40字符内 | ——

说明

该命令仅适用于外部存储器。若<file_name>指定的文件不存在，则提示“远程命令错误”。

可 存储的文件类型：状态文件（.RSF）、任意波文件（.RAF）。

存储任意波文件时，仪器只存储当前通道的数据。

举例

下面的命令将counter.RSF文件存储到当前路径下。

:MMEM ory:STORe "counter.RSF"


OUTPut Subsystem

OUTPut 命令子系统

:OUTPut[<n>]命令，用于设置与控制通道的输出参数与状态。<n>表示通道的标号，取值为1或2，若该参数缺省，则默认对通道1 进行操作。

:OUTPut[<n>]:IMPedance <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:IMPedance? [MINimum|MAXimum]

:OUTPut[<n>]:LOAD <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:LOAD? [MINimum|MAXimum]

:OUTPut[<n>]:NOISe:SCALe <percent>|MINimum|MAXimum
:OUTPut[<n>]:NOISe:SCALe? [MINimum|MAXimum]

:OUTPut[<n>]:NOISe[:STATe] ON|OFF
:OUTPut[<n>]:NOISe[:STATe]?

:OUTPut[<n>]:POLarity NORMal|INVerted
:OUTPut[<n>]:POLarity?

:OUTPut[<n>][:STATe] ON|OFF
:OUTPut[<n>][:STATe]?

:OUTPut[<n>]:SYNC:POLarity POSitive|NEGative
:OUTPut[<n>]:SYNC:POLarity?

:OUTPut[<n>]:SYNC[:STATe] ON|OFF
:OUTPut[<n>]:SYNC[:STATe]?


:OUTPut[<n>]:IMPedance

命令格式

:OUTPut[<n>]:IMPedance <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:IMPedance? [MINimum|MAXimum]

功能描述

设置前面板[Output1]或[Output2]连接器的输出阻抗 ，单位默认为Ω。

查询[Output1]或[Output2]连接器的输出阻抗。

参数

名称 | 类型 | 范围 | 默认值
<ohms> | 整型 | 1 Ω至 10000 Ω | 50 Ω

说明

默认设置：INFinity（高阻）

该命令与如下命令完全兼容：

:OUTPut[<n>]:LOAD <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:LOAD? [MINimum|MAXimum]

返回格式

查询返回具体阻抗值或者INFINITY（高阻）。

举例

下面的命令将[Output2]连接器的输出阻抗设置为100 Ω。

:OUTP ut2:IMPedance 100

下面的查询返回 100。

:OUTPut2:IMPedance?

相关命令

:OUTPut[<n>]:LOAD <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:LOAD? [MINimum|MAXimum]


:OUTPut[<n>]:LOAD

命令格式

:OUTPut[<n>]:LOAD <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:LOAD? [MINimum|MAXimum]

功能描述

设置前面板[Output1]或[Output2]连接器的输出阻抗，单位默认为Ω。

查询[Output1]或[Output2]连接器的输出阻抗。

参数

名称 | 类型 | 范围 | 默认值
<ohms> | 整型 | 1 Ω 至 10000 Ω | 50 Ω

说明

默认设置：INFinity（高阻）

该命令与如下命令完全兼容：

:OUTPut[<n>]:IMPedance <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:IMPedance? [MINimum|MAXimum]

返回格式

查询返回具体阻抗值或者INFINITY（高阻）。

举例

下面的命令将[Output2]连接器的输出阻抗设置为100 Ω。

:OUTPut2:LOAD 100

下面的查询返回 100。

:OUTPut2:LOAD?

相关命令

:OUTPut[<n>]:IMPedance <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:IMPedance? [MINimum|MAXimum]


:OUTPut[<n>]:NOIS e:SCALe

命令格式

:OUTPut[<n>]:NOISe:SCALe <percent>|MINimum|MAXimum
:OUTPut[<n>]:NOISe:SCALe? [MINimum|MAXimum]

功能描述

设置在[Output1]或[Output2]连接器上叠加的噪声的比例。

查询在[Output1]或[Output2]连接器上叠加的噪声的比例。

参数

名称 | 类型 | 范围 | 默认值
<percent> | 连续实型 | 0%至50% | 10%

返回格式

以科学计数形式返回当前的噪声比例。

举例

下面的命令将[Output2]连接器的噪声比例设置为15%：

:OUTPut2:NOISe:SCALe 15

下面的查询返回 1.500000E+01。

:OUTPut2:NOISe:SCALe?


:OUTPut[<n>]:NOISe[:STATe]

命令格式

:OUTPut[<n>]:NOISe[:STATe] ON|OFF
:OUTPut[<n>]:NOISe[:STATe]?

功能描述

启用或禁用[Output1]或[Output2]连接器上的 噪声叠加功能。

查询[Output1]或[Output2]连接器上的 噪声叠加状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | ON

返回格式

查询返回ON或OFF。

举例

下面的命令启用[Output1]连接器上的 噪声叠加：

:OUTPut:NOISe ON

下面的查询返回O N:

:OUTPut:NOISe?


:OUTPut[<n>]:POLarity

命令格式

:OUTPut[<n>]:POLarity NORMal|INVerted

:OUTPut[<n>]:POLarity?

功能描述

设置[Output1]或[Output2]连接器的输出极性。

查询[Output1]或[Output2]连接器的输出极性。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | NORMal|INVerted | NORMal（常规）

说明

输出极性为反相 （INVerted）时，波形相对于偏移电压进行反相。

波形反相后：任何偏移电压都不变；在用户界面中观察到的波形不反相；与波形相关的同步信号也不反相。

返回格式

返回NORMAL或INVERTED。

举例

下面的命令将[Output1]连接器的输出极性设置为反相。

:OUTPut1:POLarity INVerted

查询返回INVERTED。

:OUTPut1:POLarity?


:OUTPut[<n>][:STATe]

命令格式

:OUTPut[<n>][:STATe] ON|OFF

:OUTPut[<n>][:STATe]?

功能描述

启用或禁用前面板[Output1]或[Output2]连接器的输出。

查询[Output1]或[Output2]连接器的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

返回格式

查询返回ON或OFF。

举例

下面的命令启用[Output1]连接器：

:OUTPut ON

下面的查询返回ON。

:OUTPut?


:OUTPut[<n>]:SYNC:POLarity

命令格式

:OUTPut[<n>]:SYNC:POLarity POSitive|NEGative

:OUTPut[<n>]:SYNC:POLarity?

功能描述

设置[Sync1]或[Sync2]连接器的输出极性。

查询[Sync1]或[Sync2]连接器的输出极性。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | POSitive|NEGative | POSitive

返回格式

返回POS或NEG。

举例

下面的命令将[Sync2]连接器的输出极性设置为负极性 ：

:OUTPut2:SYNC:POLarity NEGative

下面的查询返回NEG。

:OUTPut2:SYNC:POLarity?


:OUTPut[<n>]:SYNC[:STATe]

命令格式

:OUTPut[<n>]:SYNC[:STATe] ON|OFF

:OUTPut[<n>]:SYNC[:STATe]?

功能描述

启用或禁用[Sync1]或[Sync2]连接器上的同步信号。

查询返回ON或OFF。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | ON

说明

在禁用同步信号时，[Sync1]或[Sync2]连接器上的输出电平是逻辑低电平。

返回格式

查询返回ON或OFF。

举例

下面的命令禁用[Sync1]连接器上的同步信号：

:OUTPut:SYNC O FF

下面的查询返回O FF:

:OUTPut:SYNC?


PA Subsystem

PA命令子系统

:PA命令用来设置和查询使用外部功放（PA）时的相关信息。包括设置和查询PA开关状态，增益，输出极性和偏置以及保存PA的工作状态到仪器内部存储器中。

:PA:GAIN 1X|10X

:PA:GAIN?

:PA:OFFSet[:STATe] ON|OFF

:PA:OFFSet[:STATe]?

:PA:OFFSet:VALUe <value>|MINimum|MAXimum

:PA:OFFSet:VALUe? [MINimum|MAXimum]

:PA:OUTPut:POLarity NORMal|INVerted

:PA:OUTPut:POLarity?

:PA:SAVE

:PA[:STATe] ON|OFF

:PA[:STATe]?


:PA:GAIN

命令格式

:PA:GAIN 1X|10X

:PA:GAIN?

功能描述

选择在功放输出端信号放大的增益为1X或10X。

查询功放输出端信号放大的增益。

参数

名称 | 类型 | 范围 | 默认值
1X|10X | 离散型 | 1X|10X | 1X

说明

1X表示无增益输出，10X表示将信号放大10倍后输出。

返回格式

返回1X或10X。

举例

下面的命令选择在功放输出端信号放大的增益为10X。

:PA:GAIN 10X

下面的命令查询返回10X。

:PA:GAIN?


:PA:OFFSet[:STATe]

命令格式

:PA:OFFSet[:STATe] ON|OFF

:PA:OFFSet[:STATe]?

功能描述

打开或关闭在功放输出端的输出偏置。

查询在功放输出端输出偏置的开关状态。

参数

名称 | 类型 | 范围 | 默认值
ON|OFF | 布尔型 | ON|OFF | OFF

说明

您可以发送:PA:OFFSet:VALUe命令设置在功放输出端的输出偏移量。

返回格式

返回ON或OFF。

举例

下面的命令打开在功放输出端的输出偏置。

:PA:OFFSet:STATe ON

下面的命令查询返回ON。

:PA:OFFSet:STATe?


:PA:OFFSet:VALUe

命令格式

:PA:OFFSet:VALUe <value>|MINimum|MAXimum

:PA:OFFSet:VALUe? [MINimum|MAXimum]

功能描述

设置功放输出端的输出偏移量。

查询功放输出端的输出偏移量。

参数

名称 | 类型 | 范围 | 默认值
<value> | 实型 | -12V至12V | 0V

说明

您可以发送:PA:OFFSet:[STATe]命令打开或关闭在功放输出端的输出偏置。

返回格式

以科学计数形式返回输出偏移量，有效位数为7位，如1.234500E+00，表示输出偏移量为1.2345V。

举例

下面的命令设置在功放输出端的输出偏移量为1.2345V。

:PA:OFFSet:VALUe 1.2345

下面的命令查询返回1.234500E+00。

:PA:OFFSet:VALUe?


:PA:OUTPut:POLarity

命令格式

:PA:OUTPut:POLarity NORMal|INVerted

:PA:OUTPut:POLarity?

功能描述

选择功放输出端信号的输出极性为常规（NORMal）或反相（INVerted）。

查询功放输出端信号的输出极性。

参数

名称 | 类型 | 范围 | 默认值
NORMal|INVerted | 离散型 | NORMal|INVerted | NORMal

说明

功放输出端信号的输出极性是指在功放的输出端信号为常规（NORMal）输出或反相（INVerted）输出。常规模式下，输出正常信号；反相模式下，将信号反相后输出。

返回格式

返回NORMAL或INVERTED。

举例

下面的命令选择功放输出端信号的输出极性为常规。

:PA:OUTPut:POLarity NORMal

下面的命令查询返回NORMAL。

:PA:OUTPut:POLarity?


:PA:SAVE

命令格式

:PA:SAVE

功能描述

保存PA当前的工作状态到仪器内部存储器中。

说明

下次打开PA时，将自动调用上次保存的工作状态。


:PA[:STATe]

命令格式

:PA[:STATe] ON|OFF

:PA[:STATe]?

功能描述

打开或关闭外部功放。

查询外部功放的开关状态。

参数

名称 | 类型 | 范围 | 默认值
ON|OFF | 布尔型 | ON|OFF | OFF

说明

打开外部功放时，PA将输入信号（即信号发生器的输出信号）进行功率放大并输出，关闭外部功放时，PA无输出。

返回格式

返回ON或OFF。

举例

下面的命令打开外部功放。

:PA:STATe ON

下面的命令查询返回ON。

:PA:STATe?


SOURce Subsystem

SOURce 命令子系统

[:SOURce<n>]命令，用于设置基本波、任意波、谐波、调制（Mod）、扫频（Sweep）以及脉冲串（Burst）输出信号的相关参数。<n>的取值为1或2，表示相应的通道，缺省时默认对通道1 进行操作。

包括如下类别：

[:SOURce<n>]:APPLy

[:SOURce<n>]:BURSt

[:SOURce<n>]:FREQuency

[:SOURce<n>]:FUNCtion

[:SOURce<n>]:HARMonic

[:SOURce<n>]:MARKer

[:SOURce<n>]:MOD

[:SOURce<n>]:PERiod

[:SOURce<n>]:PHASe

[:SOURce<n>]:PULSe

[:SOURce<n>]:SWEep

[:SOURce<n>]:VOLTage


SOURce APPLy

[:SOURce<n>]:APPLy

[:SOURce<n>]:APPLy:CUSTom[<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy:HARMonic [<freq>[,<amp>[,<offset>[,<phase>]]]]

[:SOURce<n>]:APPLy:NOISe [<amp>[,<offset>]]

[:SOURce<n>]:APPLy:PULSe [<freq>[,<amp>[,<offset>[,<delay>]]]]

[:SOURce<n>]:APPLy:RAMP [<freq>[,<amp>[,<offset>[,<phase>]]]]

[:SOURce<n>]:APPLy:SINusoid [<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy:SQUare [<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy:USER [<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy?


[:SOURce<n>]:APPLy:CUSTom

命令格式

[:SOURce<n>]:APPLy:CUSTom [<freq>[,<amp>[,<offset>[,<phase>]]]]

功能描述

以指定参数（频率、幅度、DC偏移和起始相位 ）输出用户自定义波形。

参数

名称 | 类型 | 范围 1 | 默认值
<freq> | 连续实型 | 1 μHz至40 MHz | 1 kHz
<amp> | 连续实型 | —— | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC
<phase> | 连续实型 | 0°至360° | 0°

注 1：对于不同的型号，各参数的取值范围不同。此外，<amp>受阻抗和频率/周期设置的限制，<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。 此处指 DG4162在阻抗为“高阻”时的范围。

举例

下面的命令输出自定义波形，自定义波形的频率为100 Hz、幅度为2.5 Vpp、DC偏移为0.5 VDC、起始相位为90°：

:APPLy:CUSTom 100,2.5,0.5,90


[:SOURce<n>]:APPLy:HARMonic

命令格式

[:SOURce<n>]:APPLy:HARMonic [<freq>[,<amp>[,<offset>[,<phase>]]]]

功能描述

输出一个具有指定频率、振幅、DC偏移和起始相位的谐波。

参数

名称 | 类型 | 范围 1 | 默认值
<freq> | 连续实型 | 1 μHz至80 MHz | 1 kHz
<amp> | 连续实型 | —— | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC
<phase> | 连续实型 | 0°至360° | 0°

注1 ：对于不同的型号，各参数的取值范围不同。此外，<amp>受阻抗和频率/周期设置的限制，<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。

此处指 DG4162在阻抗为“高阻”，谐波次数为“2”时的范围 。

举例

下面的命令设置谐波的频率为100 Hz、幅度为2.5Vpp、DC偏移为0.5 VDC、起始相位为90°：

:APPLy:HARMonic 100,2.5,0.5,90


[:SOURce<n>]:APPLy:NOISe

命令格式

[:SOURce<n>]:APPLy:NOISe [<amp>[,<offset>]]

功能描述

输出一个具有指定的幅度和DC偏移的噪声波。

参数

名称 | 类型 | 范围 1 | 默认值
<amp> | 连续实型 | 0 Vpp至10 Vpp（50 Ω） | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC

注 1：<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。

举例

下面的命令设置噪声的幅度为2.5 Vpp、DC偏移为0.5 VDC：

:APPLy:NOISe 2.5,0.5


[:SOURce<n>]:APPLy:PULSe

命令格式

[:SOURce<n>]:APPLy:PULSe [<freq>[,<amp>[,<offset>[,<delay>]]]]

功能描述

输出一个具有指定频率、振幅、DC偏移和延时的脉冲波。

参数

名称 | 类型 | 范围 1 | 默认值
<freq> | 连续实型 | 1 μHz 至 40 MHz | 1 kHz
<amp> | 连续实型 | —— | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC
<delay> | 连续实型 | 0 ns 至 脉冲周期 | 0 ns

注 1：对于不同的型号，各参数的取值范围不同。此外，<amp>受阻抗和频率/周期设置的限制，<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。

此处指 DG4162在阻抗为“高阻”时的范围。

举例

下面的命令设置脉冲波的频率为100 Hz、幅度为2.5Vpp、DC偏移为0.5 VDC、延时为5 ms：

:APPLy:PULSe 100,2.5,0.5,0.005


[:SOURce<n>]:APPLy:RAMP

命令格式

[:SOURce<n>]:APPLy:RAMP [<freq>[,<amp>[,<offset>[,<phase>]]]]

功能描述

输出一个具有指定频率、振幅、DC偏移和起始相位的锯齿波。

参数

名称 | 类型 | 范围 1 | 默认值
<freq> | 连续实型 | 1 μHz至4 MHz | 1 kHz
<amp> | 连续实型 | —— | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC
<phase> | 连续实型 | 0°至360° | 0°

注 1：对于不同的型号，各参数的取值范围不同。此外，<amp>受阻抗和频率/周期设置的限制，<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。 此处指 DG4162在阻抗为“高阻”时的范围。

举例

下面的命令设置锯齿波的频率为100 Hz、幅度为2.5Vpp、DC偏移为0.5 VDC、起始相位为90°：

:APPLy:RAMP 100,2.5,0.5,90


[:SOURce<n>]:APPLy:SINusoid

命令格式

[:SOURce<n>]:APPLy:SINusoid [<freq>[,<amp>[,<offset>[,<phase>]]]]

功能描述

输出一个具有指定频率、振幅、DC偏移和起始相位的正弦波。

参数

名称 | 类型 | 范围 1 | 默认值
<freq> | 连续实型 | 1 μHz至160 MHz | 1 kHz
<amp> | 连续实型 | —— | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC
<phase> | 连续实型 | 0°至360° | 0°

注 1：对于不同的型号，各参数的取值范围不同。此外，<amp>受阻抗和频率/周期设置的限制，<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。 此处指 DG4162在阻抗为“高阻”时的范围。

举例

下面的命令设置正弦波的频率为100 Hz、幅度为2.5Vpp、DC偏移为0.5 VDC、起始相位为90°：

:APPLy:SINusoid 100,2.5,0.5,90


[:SOURce<n>]:APPLy:SQUare

命令格式

[:SOURce<n>]:APPLy:SQUare [<freq>[,<amp>[,<offset>[,<phase>]]]]

功能描述

输出一个具有指定频率、振幅、DC偏移和起始相位的方波。

参数

名称 | 类型 | 范围 1 | 默认值
<freq> | 连续实型 | 1 μHz至50 MHz | 1 kHz
<amp> | 连续实型 | —— | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC
<phase> | 连续实型 | 0°至360° | 0°

注 1：对于不同的型号，各参数的取值范围不同。此外，<amp>受阻抗和频率/周期设置的限制，<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。 此处指 DG4162在阻抗为“高阻”时的范围。

举例

下面的命令设置方波的频率为100 Hz、幅度为2.5 Vpp、DC偏移为0.5 VDC、起始相位为90°：

:APPLy:SQUare 100,2.5,0.5,90


[:SOURce<n>]:APPLy:USER

命令格式

[:SOURce<n>]:APPLy:USER [<freq>[,<amp>[,<offset>[,<phase>]]]]

功能描述

输出一个具有指定频率、振幅、DC偏移和起始相位的任意波。

参数

名称 | 类型 | 范围 1 | 默认值
<freq> | 连续实型 | 1 μHz至40 MHz | 1 kHz
<amp> | 连续实型 | —— | 5 Vpp
<offset> | 连续实型 | —— | 0 VDC
<phase> | 连续实型 | 0°至360° | 0°

注 1：对于不同的型号，各参数的取值范围不同。此外，<amp>受阻抗和频率/周期设置的限制，<offset>受阻抗和幅度/高电平设置的限制，详见本产品用户手册。 此处指 DG4162在阻抗为“高阻”时的范围。

说明

若当前任意波为DC，直接提取偏移参数修改DC偏移，频率、幅度和相位参数丢弃。

举例

下面的命令设置任意波的频率为100 Hz、幅度为2.5 Vpp、DC偏移为0.5 VDC、起始相位为90°：

:APPLy:USER 100,2.5,0.5,90


[:SOURce<n>]:APPLy?

命令格式

[:SOURce<n>]:APPLy?

功能描述

查询函数发生器的当前配置。

返回格式

返回一个带引号的字符串，返回格式 为"波形名称，频率，幅度，偏移，起始相位/延时" 。

对应没有的项用“DEF”代替，例如："NOISE,DEF,5.000000E+00,0.000000E+00,DEF"。


[:SOURce<n>]:BURSt

[:SOURce<n>]:BURSt:GATE:POLarity NORMal|INVerted
[:SOURce<n>]:BURSt:GATE:POLarity?

[:SOURce<n>]:BURSt:INTernal:PERiod <period>|MINimum|MAXimum
[:SOURce<n>]:BURSt:INTernal:PERiod? [MINimum|MAXimum]

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity
[:SOURce<n>]:BURSt:MODE?
[:SOURce<n>]:BURSt:NCYCles <cycles>|MINimum|MAXimum
[:SOURce<n>]:BURSt:NCYCles? [MINimum|MAXimum]

[:SOURce<n>]:BURSt:PHASe <phase>|MINimum|MAXimum
[:SOURce<n>]:BURSt:PHASe? [MINimum|MAXimum]

[:SOURce<n>]:BURSt[:STATe] ON|OFF
[:SOURce<n>]:BURSt[:STATe]?
[:SOURce<n>]:BURSt:TDELay <delay>|MINimum|MAXimum
[:SOURce<n>]:BURSt:TDELay? [MINimum|MAXimum]

[:SOURce<n>]:BURSt:TRIGger[:IMMediate]
[:SOURce<n>]:BURSt:TRIGger:SLOPe POSitive|NEGative
[:SOURce<n>]:BURSt:TRIGger:SLOPe?

[:SOURce<n>]:BURSt:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:BURSt:TRIGger:SOURce?

[:SOURce<n>]:BURSt:TRIGger:TRIGOut OFF|POSitive|NEGative
[:SOURce<n>]:BURSt:TRIGger:TRIGOut?


[:SOURce<n>]:BURSt:GATE:POLarity

命令格式

[:SOURce<n>]:BURSt:GATE:POLarity NORMal|INVerted

[:SOURce<n>]:BURSt:GATE:POLarity?

功能描述

选择当后面板[Mod/FSK/Trig]连接器上的门控信号为高电平或低电平时输出脉冲串。

查询极性设置。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | NORMal|INVerted | NORMal

说明

该命令仅在门控Burst模式下有效。

返回格式

返回NORM或INV。

举例

下面的命令设置极性为负极性，即当后面板[Mod/FSK/Trig]连接器上的门控信号为低电平时，仪器输出脉冲串：

:BURSt:GATE:POLarity INVerted

下面的查询返回 INV。

:BURSt:GATE:POLarity?

相关命令

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity
[:SOURce<n>]:BURSt:MODE?


[:SOURce<n>]:BURSt:INTernal:PERiod

命令格式

[:SOURce<n>]:BURSt:INTernal:PERiod <period>|MINimum|MAXimum

[:SOURce<n>]:BURSt:INTernal:PERiod? [MINimum|MAXimum]

功能描述

设置 Burst脉冲串周期（从一个N循环脉冲串开始到下一个脉冲串开始的时间），单位默认为“s”。

查询 Burst脉冲串周期。

参数

名称 | 类型 | 范围 | 默认值
<period> | 连续实型 | ≥ 1 μs + 波形周期 1 × 脉冲串个数 | 10 ms

注1 ：波形周期为脉冲串函数（正弦波、方波等）的周期。

说明

该命令仅适用于内部触发 N 循环脉冲串模式。

若设置的脉冲串周期过小，信号发生器将自动增加该周期以允许指定数量的循环输出。

返回格式

以科学计数形式返回周期值。

举例

下面的命令设置脉冲串周期为0.5 s：

:BURS t:INTernal:PERiod 0.5

下面的查询返回5.000000E-01。

:BURSt:INTernal:PERiod?

相关命令

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity
[:SOURce<n>]:BURSt:MODE?


[:SOURce<n>]:BURSt:MODE

命令格式

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity

[:SOURce<n>]:BURSt:MODE?

功能描述

选择脉冲串类型 为N 循环、门控或无限。

查询脉冲串类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | TRIGgered|GATed|INFinity | TRIGgered

返回格式

返回TRIG、GAT或INF。

举例

下面的命令将脉冲串类型设置为门控：

:SOURce:BURSt:MODE GATed

下面的查询返回：GAT。

:SOURce:BURSt:MODE?


[:SOURce<n>]:BURSt:NCYCles

命令格式

[:SOURce<n>]:BURSt:NCYCles <cycles>|MINimum|MAXimum

[:SOURce<n>]:BURSt:NCYCles? [MINimum|MAXimum]

功能描述

设置脉冲串循环数。

查询脉冲串循环数。

参数

名称 | 类型 | 范围 | 默认值
<cycles> | 整型 | 1 至 1 000 000（外部或手动触发） 1 至 500 000（内部触发） | 1

说明

该命令仅在 N 循环模式下有效。

返回格式

返回一个整数。

举例

下面的命令设置脉冲串的循环数为100：

:BURSt:NCYCles 100

下面的查询返回：100。

:BURSt:NCYCles?

相关命令

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity
[:SOURce<n>]:BURSt:MODE?


[:SOURce<n>]:BURSt:PHASe

命令格式

[:SOURce<n>]:BURSt:PHASe <phase>|MINimum|MAXimum

[:SOURce<n>]:BURSt:PHASe? [MINimum|MAXimum]

功能描述

设置脉冲串起始相位，单位默认为 “°”。

查询脉冲串的起始相位。

参数

名称 | 类型 | 范围 | 默认值
<phase> | 连续实型 | 0°至 360° | 0°

说明

对于正弦波、方波、锯齿波，0°是波形正向通过 0 V（或 DC 偏移值）的点。

对于任意波形，0°是第一个波形点。

对于脉冲波和噪声波无效。

返回格式

以科学计数形式返回相位值。

举例

下面的命令设置起始相位为 10°：

:BURS t:PHASe 10

下面查询返回1.000000E+01。

:BURSt:PHASe?


[:SOURce<n>]:BURSt[:STATe]

命令格式

[:SOURce<n>]:BURSt[:STATe] ON|OFF

[:SOURce<n>]:BURSt[:STATe]?

功能描述

打开或关闭Burst 功能。

查询 Burst 功能状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

启用Burst时，Sweep或Mod功能将自动关闭（如果当前已打开） 。

返回格式

返回ON或OFF。

举例

下面的命令打开Burst 功能：

:BURS t ON

下面的查询返回ON。

:BURSt?


[:SOURce<n>]:BURSt:TDELay

命令格式

[:SOURce<n>]:BURSt:TDELay <delay>|MINimum|MAXimum

[:SOURce<n>]:BURSt:TDELay? [MINimum|MAXimum]

功能描述

设置信号发生器从接收到触发信号到开始输出 N循环（或无限）脉冲串之间的时间，单位默认为“s”。

查询脉冲串延时。

参数

名称 | 类型 | 范围1 | 默认值
<delay> | 连续实型 | 0 s 至 85 s | 0 s

注1：使用内部触发源时，N循环脉冲串的延时还受载波周期、脉冲周期和循环数的限制。

说明

该命令在 N 循环和无限脉冲串模式下有效。

返回格式

以科学计数形式返回时间值。

举例

下面的命令设置延时为2.5 s:

:BURS t:TDELay 2.5

下面的查询返回2.500000E+00。

:BURSt:TDELay?

相关命令

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity
[:SOURce<n>]:BURSt:MODE?


[:SOURce<n>]:BURSt:TRIGger[:IMMediate]

命令格式

[:SOURce<n>]:BURSt:TRIGger[:IMMediate]

功能描述

使仪器立即触发。

说明

该命令仅在触发源为手动模式时有效。


[:SOURce<n>]:BURSt:TRIGger:SLOPe

命令格式

[:SOURce<n>]:BURSt:TRIGger:SLOPe POSitive|NEGative

[:SOURce<n>]:BURSt:TRIGger:SLOPe?

功能描述

选择信号发生器在外部触发信号的上升沿或下降沿时启动脉冲串输出。

查询外部触发信号的边沿类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | POSitive|NEGative | POSitive

说明

该命令仅在外部触发源时有效。

返回格式

返回POS或NEG。

举例

下面的查询返回NEG。

:BURS:TRIG:SLOP NEG

相关命令

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity
[:SOURce<n>]:BURSt:MODE?


[:SOURce<n>]:BURSt:TRIGger:SOURce

命令格式

[:SOURce<n>]:BURSt:TRIGger:SOURce INTernal|EXTernal|MANual

[:SOURce<n>]:BURSt:TRIGger:SOURce?

功能描述

设置 Burst 触发源类型 为内部、外部或手动。

查询 Burst 触发源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal|MANual | INTernal

返回格式

返回INT、EXT或MAN。

举例

下面的命令选择手动触发源：

:BURSt:TRIGger:SOURce MANual

下面的查询返回MAN。

:BURSt:TRIGger:SOURce?


[:SOURce<n>]:BURSt:TRIGger:TRIGOut

命令格式

[:SOURce<n>]:BURSt:TRIGger:TRIGOut OFF|POSitive|NEGative

[:SOURce<n>]:BURSt:TRIGger:TRIGOut?

功能描述

指定触发输出信号的边沿类型。

查询触发输出信号的边沿类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | OFF|POSitive|NEGative | OFF

说明

触发源为内部或手动模式时有效。

返回格式

返回OFF、POS或NEG。

举例

下面的命令设置触发输出信号的边沿类型为上升沿：

:BURSt:TRIGger:TRIGout POSitive

下面的查询返回 POS。

:BURSt:TRIGger:TRIGout POSitive

相关命令

[:SOURce<n>]:BURSt:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:BURSt:TRIGger:SOURce?


[:SOURce<n>]:FREQuency

[:SOURce<n>]:FREQuency:CENTer <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:CENTer? [MINimum|MAXimum]

[:SOURce<n>]:FREQuency[:FIXed] <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency[:FIXed]? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:SPAN <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:SPAN? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STARt <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STARt? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STOP <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STOP? [MINimum|MAXimum]


[:SOURce<n>]:FREQuency:CENTer

命令格式

[:SOURce<n>]:FREQuency:CENTer <frequency>|MINimum|MAXimum

[:SOURce<n>]:FREQuency:CENTer? [MINimum|MAXimum]

功能描述

设置扫频的中心频率，单位默认为“Hz”。

查询扫频的中心频率。

参数

名称 | 类型 | 范围1 | 默认值
<frequency> | 连续实型 | 见如下注释 | 550 Hz

注1 ：不同扫频波形对应的中心频率范围不同 ：

正弦波：1 μHz至 160 MHz

方波：1 μHz至 50 MHz

锯齿波：1 μHz至 4 MHz

任意波：1 μHz至 40 MHz（内置波形DC除外）

说明

扫频模式下，起始频率、终止频率、中心频率和频率跨度相互关联，满足如下关系：

中心频率=（︱起始频率 + 终止频率︱）/2
频率跨度= 终止频率 - 起始频率

返回格式

以科学计数形式返回中心频率值。

举例

下面的命令设置中心频率为600 Hz。

:FREQ uency:CENTer 600

下面的查询返回6.000000E+02。

:FREQuency:CENTer?

相关命令

[:SOURce<n>]:FREQuency:SPAN <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:SPAN? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STARt <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STARt? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STOP <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STOP? [MINimum|MAXimum]


[:SOURce<n>]:FREQuency[:FIXed]

命令格式

[:SOURce<n>]:FREQuency[:FIXed] <frequency>|MINimum|MAXimum

[:SOURce<n>]:FREQuency[:FIXed]? [MINimum|MAXimum]

功能描述

设置基本波的频率，单位默认为“Hz”。

查询基本波的频率。

参数

名称 | 类型 | 范围1 | 默认值
<frequency> | 连续实型 | 见如下注释 | 1 kHz

注1 ：不同波形对应的频率范围不同 ：

正弦波：1 μHz至 160 MHz

方波：1 μHz至 50 MHz

锯齿波：1 μHz至 4 MHz

脉冲：1 μHz至 40 MHz

任意波：1 μHz至 40 MHz

谐波：1 μHz至 80 MHz

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置频率为1.5kHz。

:FREQ uency 1500

下面的查询返回 1.500000E+03。

:FREQuency?


[:SOURce<n>]:FREQuency:SPAN

命令格式

[:SOURce<n>]:FREQuency:SPAN <frequency>|MINimum|MAXimum

[:SOURce<n>]:FREQuency:SPAN? [MINimum|MAXimum]

功能描述

设置扫频的频率跨度，单位默认为“Hz”。

查询频率跨度。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 请参考用户手册的说明 | 900 Hz

说明

扫频模式下，起始频率、终止频率、中心频率和频率跨度相互关联，满足如下关系：

中心频率=（︱起始频率 + 终止频率︱）/2
频率跨度= 终止频率 - 起始频率

返回格式

以科学计数形式返回频率跨度值。

举例

下面的命令设置频率跨度为1100 Hz。

:FREQuency:SPAN 1100

下面的查询返回 1.100000E+03。

:FREQuency:SPAN?

相关命令

[:SOURce<n>]:FREQuency:CENTer <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:CENTer? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STARt <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STARt? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STOP <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STOP? [MINimum|MAXimum]


[:SOURce<n>]:FREQuency:STARt

命令格式

[:SOURce<n>]:FREQuency:STARt <frequency>|MINimum|MAXimum

[:SOURce<n>]:FREQuency:STARt? [MINimum|MAXimum]

功能描述

设置扫频的起始频率，单位默认为“Hz”。

查询扫频的起始频率值。

参数

名称 | 类型 | 范围1 | 默认值
<frequency> | 连续实型 | 见如下注释 | 100 Hz

注1 ：不同扫频波形对应的起始频率范围不同 ：

正弦波：1 μHz至 160 MHz

方波：1 μHz至 50 MHz

锯齿波：1 μHz至 4 MHz

任意波：1 μHz至 40 MHz（内置波形DC除外）

说明

扫频模式下，起始频率、终止频率、中心频率和频率跨度相互关联，满足如下关系：

中心频率=（︱起始频率 + 终止频率︱）/2
频率跨度= 终止频率 - 起始频率

返回格式

以科学计数形式返回起始频率值。

举例

下面的命令设置起始频率为500 Hz。

:FREQuency:STARt 500

下面的查询返回 5.000000E+02。

:FREQuency:STARt?

相关命令

[:SOURce<n>]:FREQuency:CENTer <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:CENTer? [MINimum|MAXimum]

[:SOURce<n>]:FREQuency:SPAN <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:SPAN? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STOP <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STOP? [MINimum|MAXimum]


[:SOURce<n>]:FREQuency:STOP

命令格式

[:SOURce<n>]:FREQuency:STOP <frequency>|MINimum|MAXimum

[:SOURce<n>]:FREQuency:STOP? [MINimum|MAXimum]

功能描述

设置扫频的终止频率，单位默认为“Hz”。

查询扫频的终止频率值。

参数

名称 | 类型 | 范围1 | 默认值
<frequency> | 连续实型 | 见如下注释 | 1 kHz

注1 ：不同扫频波形对应的终止频率范围不同 ：

正弦波：1 μHz至 160 MHz

方波：1 μHz至 50 MHz

锯齿波：1 μHz至 4 MHz

任意波：1 μHz至 40 MHz（内置波形DC除外）

说明

扫频模式下，起始频率、终止频率、中心频率和频率跨度相互关联，满足如下关系：

中心频率=（︱起始频率 + 终止频率︱）/2
频率跨度= 终止频率 - 起始频率

返回格式

以科学计数形式返回终止频率值。

举例

下面的命令设置终止频率为5 kHz。

:FREQuency:STOP 5000

下面的查询返回 5.000000E+03。

:FREQuency:STOP?

相关命令

[:SOURce<n>]:FREQuency:CENTer <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:CENTer? [MINimum|MAXimum]

[:SOURce<n>]:FREQuency:SPAN <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:SPAN? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STARt <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STARt? [MINimum|MAXimum]


SOURce FUNCtion

[:SOURce<n>]:FUNCtion

[:SOURce<n>]:FUNCtion:ARB:STEP

[:SOURce<n>]:FUNCtion:RAMP:SYMMetry <symmetry>|MINimum|MAXimum
[:SOURce<n>]:FUNCtion:RAMP:SYMMetry? [MINimum|MAXimum]

[:SOURce<n>]:FUNCtion[:SHAPe] <wave>
[:SOURce<n>]:FUNCtion[:SHAPe]?

[:SOURce<n>]:FUNCtion:SQUare:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:FUNCtion:SQUare:DCYCle? [MINimum|MAXimum]


[:SOURce<n>]:FUNCtion:ARB:STEP

命令格式

[:SOURce<n>]:FUNCtion:ARB:STEP

功能描述

打开任意波的逐点输出模式。

说明

逐点输出模式下，信号发生器自动根据波形长度（16,384）和采样率计算输出信号的频率（30.517578125 kHz）。信号发生器固定以该频率逐个输出波形点。逐点输出模式可以防止重要的波形点丢失。

该命令仅在任意波功能打开时有效。


[:SOURce<n>]:FUNCtion:RAMP:SYMMetry

命令格式

[:SOURce<n>]:FUNCtion:RAMP:SYMMetry <symmetry>|MINimum|MAXimum

[:SOURce<n>]:FUNCtion:RAMP:SYMMetry? [MINimum|MAXimum]

功能描述

设置锯齿波的对称性，以%表示。

查询锯齿波的对称性。

参数

名称 | 类型 | 范围 | 默认值
<symmetry> | 连续实型 | 0%至100% | 50%

返回格式

以科学计数形式返回对称性。

举例

下面的命令将锯齿波的对称性设置为80%。

:FUNCtion:RAMP:SYMMetry 80

下面的查询返回 8.000000E+01。

:FUNCtion:RAMP:SYMMetry?


[:SOURce<n>]:FUNCtion[:SHAPe]

命令格式

[:SOURce<n>]:FUNCtion[:SHAPe] <wave>

[:SOURce<n>]:FUNCtion[:SHAPe]?

功能描述

选择波形。

查询当前选择的波形。

参数

名称 类型 范围 默认值
<wave> 关键字

SINusoid|SQUare|RAMP|PULSe|NOISe|USER|HARMonic|CUSTom|DC|ABSSINE|ABSSINEHALF|AMPALT|ATTALT|GAUSSPULSE|NEGRAMP|

NPULSE|PPULSE|SINETRA|SINEVER|STAIRDN|STAIRUD|STAIRUP|TRAPEZIA|BANDLIMITED|BUTTERWORTH|CHEBYSHEV1|CHEBYSHEV2|

COMBIN|CPULSE|CWPULSE|DAMPEDOSC|DUALTONE|GAMMA|GATEVIBR|LFMPULSE|MCNOSIE|NIMHDISCHARGE|PAHCUR|QUAKE|RADAR|

RIPPLE|ROUNDHALF|ROUNDPM|STEPRESP|SWINGOSC|TV|VOICE|THREEAM|THREEFM|THREEPM|THREEPWM|THREEPFM|CARDIAC|EOG|

EEG|EMG|PULSILOGRAM|RESSPEED|LFPULSE|TENS1|TENS2|TENS3|IGNITION|ISO167502SP|ISO167502VR|ISO76372TP1|ISO76372TP2A|

ISO76372TP2B|ISO76372TP3A|ISO76372TP3B|ISO76372TP4|ISO76372TP5A|ISO76372TP5B|SCR|SURGE|AIRY|BESSELJ|BESSELY|CAUCHY|

CUBIC|DIRICHLET|ERF|ERFC|ERFCINV|ERFINV|EXPFALL|EXPRISE|GAUSS|HAVERSINE|LAGUERRE|LAPLACE|LEGEND|LOG|LOGNORMAL|

LORENTZ|MAXWELL|RAYLEIGH|VERSIERA|WEIBULL|X2DATA|COSH|COSINT|COT|COTHCON|COTHPRO|CSCCON|CSCPRO|CSCHCON|

CSCHPRO|RECIPCON|RECIPPRO|SECCON|SECPRO|SECH|SINC|SINH|SININT|SQRT|TAN|TANH|ACOS|ACOSH|ACOTCON|ACOTPRO|

ACOTHCON|ACOTHPRO|ACSCCON|ACSCPRO|ACSCHCON|ACSCHPRO|ASECCON|ASECPRO|ASECH|ASIN|ASINH|ATAN|ATANH|BARLETT|

BARTHANN|BLACKMAN|BLACKMANH|BOHMANWIN|BOXCAR|CHEBWIN|FLATTOPWIN|HAMMING|HANNING|KAISER|NUTTALLWIN|

PARZENWIN|TAYLORWIN|TRIANG|TUKEYWIN

SINusoid

说明

若仪器当前没有打开调制、扫频和脉冲串模式，该命令选择仪器输出的波形。

若仪器当前打开调制、扫频或脉冲串模式，该命令选择对应功能的载波波形。

若发送:FUNCtion DC 命令,仪器将自动关闭调制、扫频或脉冲串（当前已打开）。

返回格式

返回SIN、SQU、RAMP、PULSE、NOISE、HARMONIC、CUSTOM；

选中除SINusoid|SQUare|RAMP|PULSe|NOISe|USER|HARMonic|CUSTom|之外的波形时，返回值与上表中对应的参数一致；

注意：若当前选中USER（ 任意波）时，查询返回任意波当前选中的内置波形对应的返回值。

举例

下面的命令选中方波：

:FUNCtion SQUare

下面的查询返回SQU。

:FUNCtion?


[:SOURce<n>]:FUNCtion:SQUare:DCYCle

命令格式

[:SOURce<n>]:FUNCtion:SQUare:DCYCle <percent>|MINimum|MAXimum

[:SOURce<n>]:FUNCtion:SQUare:DCYCle? [MINimum|MAXimum]

功能描述

设置方波占空比，以%表示。

查询方波的占空比。

参数

名称 | 类型 | 范围1 | 默认值
<percent> | 连续实型 | 见下面注释 | 50%

注1：占空比的范围受“频率/周期”设置的限制。

频率 ≤ 10 MHz：20％至80％

10 MHz < 频率 ≤ 40 MHz：40％至60％

频率 > 40 MHz：50％（固定）

返回格式

以科学计数形式返回占空比。

举例

下面的命令将方波的占空比设置为80%。

:FUNCtion:SQUare:DCYCle 80% 或 :FUNCtion:SQUare:DCYCle 80

下面的查询返回 8.000000E+01。

:FUNCtion:SQUare:DCYCle?


[:SOURce<n>]:HARMonic

[:SOURce<n>]:HARMonic:AMPL <sn>,<value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:AMPL? <sn>[,MINimum|MAXimum]

[:SOURce<n>]:HARMonic:ORDEr <value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:ORDEr? [MINimum|MAXimum]

[:SOURce<n>]:HARMonic:PHASe <sn>,<value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:PHASe? <sn>[,MINimum|MAXimum]

[:SOURce<n>]:HARMonic:TYPe EVEN|ODD|ALL|USER
[:SOURce<n>]:HARMonic:TYPe?

[:SOURce<n>]:HARMonic:USER <user>
[:SOURce<n>]:HARMonic:USER?


[:SOURce<n>]:HARMonic:AMPL

命令格式

[:SOURce<n>]:HARMonic:AMPL <sn>,<value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:AMPL? <sn>[,MINimum|MAXimum]

功能描述

设置指定次谐波的幅度。

查询指定次谐波的幅度。

参数

名称 | 类型 | 范围 | 默认值
<sn> | 整型 | 2 至 16 | 2
<value> | 整型 | 受阻抗与频率设置的限制，请参考用户手册 | 1.2647 Vpp

返回格式

以科学计数形式返回 指定次谐波的幅度值。

举例

下面的命令设置第2次谐波的幅度为2.5 Vpp。

:HARMonic:AMPL 2,2.5

下面的查询返回 2.500000E+00。

:HARMonic:AMPL? 2


[:SOURce<n>]:HARMonic:ORD Er

命令格式

[:SOURce<n>]:HARMonic:ORDEr <value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:ORDEr? [MINimum|MAXimum]

功能描述

设置谐波次数。

查询谐波次数。

参数

名称 | 类型 | 范围1 | 默认值
<value> | 整型 | 见下面的注释 | 2

注1：2 至 仪器最大输出频率÷基波频率，且为整数，最大值为16。

返回格式

以科学计数形式返回谐波次数。

举例

下面的命令设置谐波次数为7：

:HARMonic:ORDEr 7

下面的查询返回 7.000000E+00。

:HARMonic:ORDEr?


[:SOURce<n>]:HARM onic:PHASe

命令格式

[:SOURce<n>]:HARMonic:PHASe <sn>,<value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:PHASe? <sn>[,MINimum|MAXimum]

功能描述

设置指定次谐波的相位。

查询指定次谐波的相位。

参数

名称 | 类型 | 范围 | 默认值
<sn> | 整型 | 2 至 16 | 2
<value> | 整型 | 0°至 360° | 0°

返回格式

以科学计数形式返回 指定次谐波的相位值。

举例

下面的命令设置第2次谐波的相位为90°。

:HARMonic:PHASe 2,90

下面的查询返回 9.000000E+01。

:HARMonic:PHASe? 2


[:SOURce<n>]:HARMonic:TYPe

命令格式

[:SOURce<n>]:HARMonic:TYPe EVEN|ODD|ALL|USER
[:SOURce<n>]:HARMonic:TYPe?

功能描述

选择谐波类型为偶次、奇次、全部或自定义。

查询谐波类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | EVEN|ODD|ALL|USER | EVEN

返回格式

返回EVEN、ODD、ALL或USER。

举例

下面的命令设置谐波类型为奇次：

:HARMonic:TYPe ODD

下面的查询返回ODD。

:HARMonic:TYPe?


[:SOURce<n>]:HARMonic:TYPe

[:SOURce<n>]:HARMonic:USER

命令格式

[:SOURce<n>]:HARMonic:USER <user>
[:SOURce<n>]:HARMonic:USER?

功能描述

设置指定通道的自定义谐波输出。

查询指定通道的自定义谐波输出。

参数

名称 | 类型 | 范围 | 默认值
<n> | 离散型 | 1|2 | 1
<user> | ASCII字符串 | X000000000000000至X111111111111111 | X000000000000000

说明

在自定义谐波（[:SOURce<n>]:HARMonic:TYPe）中，用户可自定义输出谐波的次数，最高次数为16。使用16位二进制数据分别代表16次谐波的输出状态，最左侧的位表示基波，固定为X，不允许修改，后面的15位从左到右依次对应2次谐波到16次谐波。1表示打开相应次谐波的输出，0表示关闭相应次谐波的输出。例如：将16位数据设置为X001000000000001，表示输出基波和4次、16次谐波。

省略[:SOURce<n>]时，默认设置CH1的相关参数。

返回格式

返回X000000000000000至X111111111111111之间的一个字符串，如X001000000000001。

举例

下面的命令设置CH1的自定义谐波输出基波和4次、16次谐波。

:HARMonic:USER X001000000000001

下面的命令查询返回X001000000000001。

:HARMonic:USER?


[:SOURce<n>]:MARKer

[:SOURce<n>]:MARKer:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MARKer:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MARKer[:STATE] ON|OFF
[:SOURce<n>]:MARKer[:STATe]?


[:SOURce<n>]:MARKer:FREQuency

命令格式

[:SOURce<n>]:MARKer:FREQuency <frequency>|MINimum|MAXimum

[:SOURce<n>]:MARKer:FREQuency? [MINimum|MAXimum]

功能描述

设置标记频率，单位默认为“Hz”。

查询标记频率值。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 受“起始频率”和“终止频率”限制 | 550 Hz

返回格式

以科学计数形式返回频率值。

举例

下面的命令将标记的频率设置为800 Hz：

:MARK er:FREQuency 800

下面的查询返回8.000000E+02。

:MARKer:FREQuency?


[:SOURce<n>]:MARKer[:STATe]

命令格式

[:SOURce<n>]:MARKer[:STATe] ON|OFF

[:SOURce<n>]:MARKer[:STATe]?

功能描述

打开或关闭扫频的频率 标记功能。

查询频率标记功能的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

步进扫频方式时，频率标记功能不可用。

返回格式

返回ON或OFF。

举例

下面的命令打开扫频的频率标记功能：

:MARKer ON

下面的查询返回ON。

:MARKer?


SOURCe MOD

[:SOURce<n>]:MOD

[:SOURce<n>]:MOD[:STATe] ON|OFF
[:SOURce<n>]:MOD[:STATe]?

[:SOURce<n>]:MOD:TYPe AM|FM|PM|ASK|FSK|PSK|PWM|BPSK|QPSK|3FSK|4FSK|OSK
[:SOURce<n>]:MOD:TYPe?

AM

[:SOURce<n>]:MOD:AM[:DEPTh] <depth>|MINimum|MAXimum
[:SOURce<n>]:MOD:AM[:DEPTh]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:AM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:AM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:AM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:AM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:AM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:AM:SOURce?

FM

[:SOURce<n>]:MOD:FM[:DEViation] <deviation>|MINimum|MAXimum
[:SOURce<n>]:MOD:FM[:DEViation]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:FM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:FM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:FM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:FM:SOURce?

PM

[:SOURce<n>]:MOD:PM[:DEViation] <deviation>|MINimum|MAXimum
[:SOURce<n>]:MOD:PM[:DEViation]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:PM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:PM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:PM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PM:SOURce?

ASK

[:SOURce<n>]:MOD:ASKey :AMPLitude <amplitude>|MINimum|MAXimum
[:SOURce<n>]:MOD:ASKey:AMPLitude? [MINimum|MAXimum]

[:SOURce<n>]:MOD:ASKey:INTernal[:RATE] <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:ASKey:INTernal[:RATE]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:ASKey:POLarity POSitive|NEGative
[:SOURce<n>]:MOD:ASKey:POLarity?

[:SOURce<n>]:MOD:ASKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:ASKey:SOURce?

FSK

[:SOURce<n>]:MOD:FSKey[:FREQuency] <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:FSKey[:FREQuency]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:FSKey:INTernal:RATE? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FSKey:POLarity POSitive|NEGative
[:SOURce<n>]:MOD:FSKey:POLarity?

[:SOURce<n>]:MOD:FSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:FSKey:SOURce?

PSK

[:SOURce<n>]:MOD:PSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:PSKey:INTernal:RATE? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PSKey:PHASe <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:PSKey:PHASe? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PSKey:POLarity POSitive|NEGative
[:SOURce<n>]:MOD:PSKey:POLarity?

[:SOURce<n>]:MOD:PSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PSKey:SOURce?

BPSK

[:SOURce<n>]:MOD:BPSKey:DATA 01|10|PN15|PN21
[:SOURce<n>]:MOD:BPSKey:DATA?

[:SOURce<n>]:MOD:BPSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:BPSKey:INTernal:RATE? [MINimum|MAXimum]
[:SOURce<n>]:MOD:BPSKey:PHASe <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:BPSKey:PHASe? [MINimum|MAXimum]

QPSK

[:SOURce<n>]:MOD:QPSKey:DATA PN15|PN21
[:SOURce<n>]:MOD:QPSKey:DATA?

[:SOURce<n>]:MOD:QPSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:INTernal:RATE? [MINimum|MAXimum]
[:SOURce<n>]:MOD:QPSKey:PHASe1 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe1? [MINimum|MAXimum]
[:SOURce<n>]:MOD:QPSKey:PHASe2 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe2? [MINimum|MAXimum]
[:SOURce<n>]:MOD:QPSKey:PHASe3 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe3? [MINimum|MAXimum]

3FSK

[:SOURce<n>]:MOD:3FSKey[:FREQuency] <n>,<frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:3FSKey[:FREQuency]? <n>[,MINimum|MAXimum]

[:SOURce<n>]:MOD:3FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:3FSKey:INTernal:RATE? [MINimum|MAXimum]

4FSK

[:SOURce<n>]:MOD:4FSKey[:FREQuency] <n>,<frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:4FSKey[:FREQuency]? <n>[,MINimum|MAXimum]

[:SOURce<n>]:MOD:4FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:4FSKey:INTernal:RATE? [MINimum|MAXimum]

OSK

[:SOURce<n>]:MOD:OSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:OSKey:INTernal:RATE? [MINimum|MAXimum]

[:SOURce<n>]:MOD:OSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:OSKey:SOURce?
[:SOURce<n>]:MOD:OSKey:TIME <time>|MINimum|MAXimum
[:SOURce<n>]:MOD:OSKey:TIME? [MINimum|MAXimum]

PWM

[:SOURce<n>]:MOD:PWM[:DEViation]:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:MOD:PWM[:DEViation]:DCYCle? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PWM[:DEViation][:WIDTh] <deviation>|MINimum|MAXimum
[:SOURce<n>]:MOD:PWM[:DEViation][:WIDTh]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PWM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:PWM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PWM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:PWM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:PWM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PWM:SOURce?


[:SOURce<n>]:MOD[:STATe]

命令格式

[:SOURce<n>]:MOD[:STATe] ON|OFF

[:SOURce<n>]:MOD[:STATe]?

功能描述

打开或关闭调制功能。

查询调制功能的开关状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

启用Mod时，Sweep或Burst功能将自动关闭（如果当前已打开）。

返回格式

返回ON或OFF。

举例

下面的命令打开调制功能：

:MOD ON

下面的查询返回ON。

:MOD?


[:SOURce<n>]:MOD:TYPe

命令格式

[:SOURce<n>]:MOD:TYPe AM|FM|PM|ASK|FSK|PSK|PWM|BPSK|QPSK|3FSK|4FSK|OSK

[:SOURce<n>]:MOD:TYPe?

功能描述

选择调制方式。

查询调制方式。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | AM|FM|PM|ASK|FSK|PSK|PWM|BPSK|QPSK|3FSK|4FSK|OSK | AM

说明

PWM 调制只在 Pulse 已打开时有效。

OSK 调制只在 Sine 已打开时有效。

返回格式

返回 AM、FM、PM、ASK、FSK、PSK、PWM、BPSK、QPSK、3FSK、4FSK或OSK。

举例

下面的命令选择FSK调制：

:MOD:TYPe FSK

下面的查询返回FSK。

:MOD:TYPe?


[:SOURce<n>]:MOD:AM[:DEPTh]

命令格式

[:SOURce<n>]:MOD:AM[:DEPTh] <depth>|MINimum|MAXimum

[:SOURce<n>]:MOD:AM[:DEPTh]? [MINimum|MAXimum]

功能描述

以百分比形式设置 AM 调制深度 。

查询 AM 调制深度 。

参数

名称 | 类型 | 范围 | 默认值
<depth> | 连续实型 | 0%至 120% | 100%

说明

<depth>可设置范围为 0%至 120%，支持不带%设置。

0%时，输出振幅是指定值的一半。

100%时，输出振幅等于指定的值。

大于100%时，仪器的输出不会超过10 Vpp（负载为50 Ω）。

返回格式

以科学计数形式返回调制深度值。

举例

下面的命令设置调制深度为80%：

:MOD:AM 80

下面的查询返回8.000000E+01。

:MOD:AM?


[:SOURce<n>]:MOD:AM:INTernal:FREQuency

命令格式

[:SOURce<n>]:MOD:AM:INTernal:FREQuency <frequency>|MINimum|MAXimum

[:SOURce<n>]:MOD:AM:INTernal:FREQuency? [MINimum|MAXimum]

功能描述

设置 AM调制波的频率，单位默认为“Hz”。

查询 AM调制波的频率。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 2 mHz 至 50 kHz | 100 Hz

说明

该命令仅在选择内部调制源时可用。

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置调制波的频率为25 Hz。

:MOD:AM:INT ernal:FREQuency 25

下面的查询返回2.500000E+01。

:MOD:AM:INTernal:FREQuency?

相关命令

[:SOURce<n>]:MOD:AM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:AM:SOURce?


[:SOURce<n>]:MOD:AM:INTernal:FUNCtion

命令格式

[:SOURce<n>]:MOD:AM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:AM:INTernal:FUNCtion?

功能描述

选择 AM 调制波形。

查询 AM 调制波形。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER | SINusoid

说明

该命令仅在选择内部调制源时可用。

返回格式

返回 SIN、SQU、TRI、RAMP、NRAM、NOIS或USER。

举例

下面的命令选择方波为调制波形：

:MOD:AM:INTernal:FUNCtion SQUare

下面的查询返回SQU。

:MOD:AM:INTernal:FUNCtion?

相关命令

[:SOURce<n>]:MOD:AM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:AM:SOURce?


[:SOURce<n>]:MOD:AM:SOURce

命令格式

[:SOURce<n>]:MOD:AM:SOURce INTernal|EXTernal

[:SOURce<n>]:MOD:AM:SOURce?

功能描述

选择 AM 调制源类型 为内部（INTernal）或外部 （EXTernal）。

查询 AM 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:AM:SOURce EXTernal

下面的查询返回EXT。

:MOD:AM:SOURce?


[:SOURce<n>]:MOD:FM[:DEViation]

命令格式

[:SOURce<n>]:MOD:FM[:DEViation] <deviation>|MINimum|MAXimum

[:SOURce<n>]:MOD:FM[:DEViation]? [MINimum|MAXimum]

功能描述

设置 FM调制 的频率偏差，单位默认为“Hz”。

查询 FM调制 的频率偏差。

参数

名称 | 类型 | 范围 | 默认值
<deviation> | 连续实型 | 见本页的“说明” | 1 kHz

说明

频率偏差<deviation>应满足以下条件：

● 小于或等于载波频率。

● 频率偏差 + 载波频率 ≤ 当前载波频率上限 + 1 kHz。

返回格式

查询以科学计数形式返回偏差数值。

举例

下面的命令设置频率偏差为800 Hz：

:MOD:FM 800

下面的查询返回 8.000000E+02。

:MOD:FM?


[:SOURce<n>]:MOD:FM:INTernal:FREQuency

命令格式

[:SOURce<n>]:MOD:FM:INTernal:FREQuency <frequency>|MINimum|MAXimum

[:SOURce<n>]:MOD:FM:INTernal:FREQuency? [MINimum|MAXimum]

功能描述

设置 FM调制波的频率，单位默认为“Hz”。

查询 FM调制波的频率。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 2 mHz 至 50 kHz | 100 Hz

说明

该命令仅在选择内部调制源时可用。

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置调制波的频率为25 Hz。

:MOD:FM:INTernal:FREQuency 25

下面的查询返回2.500000E+01。

:MOD:FM:INTernal:FREQuency?

相关命令

[:SOURce<n>]:MOD:FM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:FM:SOURce?


[:SOURce<n>]:MOD:FM:INTernal:FUNCtion

命令格式

[:SOURce<n>]:MOD:FM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:FM:INTernal:FUNCtion?

功能描述

选择 FM 调制波形。

查询 FM 调制波形。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER | SINusoid

说明

该命令仅在选择内部调制源时可用。

返回格式

返回 SIN、SQU、TRI、RAMP、NRAM、NOIS或USER。

举例

下面的命令选择方波为调制波形：

:MOD:FM:INTernal:FUNCtion SQUare

下面的查询返回SQU。

:MOD:FM:INTernal:FUNCtion?

相关命令

[:SOURce<n>]:MOD:FM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:FM:SOURce?


[:SOURce<n>]:MOD:FM:SOURce

命令格式

[:SOURce<n>]:MOD:FM:SOURce INTernal|EXTernal

[:SOURce<n>]:MOD:FM:SOURce?

功能描述

选择FM 调制源类型为内部（INTernal）或外部 （EXTernal）。

查询FM 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:FM:SOURce EXTernal

下面的查询返回EXT。

:MOD:FM:SOURce?


[:SOURce<n>]:MOD:PM[:DEViation]

命令格式

[:SOURce<n>]:MOD:PM[:DEViation] <deviation>|MINimum|MAXimum

[:SOURce<n>]:MOD:PM[:DEViation]? [MINimum|MAXimum]

功能描述

设置 PM 调制的 相位偏差，单位默认为“°”。

查询 PM 调制的 相位偏差。

参数

名称 | 类型 | 范围 | 默认值
<deviation> | 连续实型 | 0°至360° | 90°

返回格式

查询以科学计数形式返回相位偏差值。

举例

下面的命令设置相位偏差为180°：

:MOD:PM 180

下面的查询返回 1.800000E+02。

:MOD:PM?


[:SOURce<n>]:MOD:PM:INTernal:FREQuency

命令格式

[:SOURce<n>]:MOD:PM:INTernal:FREQuency <frequency>|MINimum|MAXimum

[:SOURce<n>]:MOD:PM:INTernal:FREQuency?

功能描述

设置 PM调制波的频率，单位默认为“Hz”。

查询 PM调制波的频率。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 2 mHz 至 50 kHz | 100 Hz

说明

该命令仅在选择内部调制源时可用。

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置调制波的频率为25 Hz。

:MOD:PM:INTernal:FREQuency 25

下面的查询返回2.500000E+01。

:MOD:PM:INTernal:FREQuency?

相关命令

[:SOURce<n>]:MOD:PM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PM:SOURce?


[:SOURce<n>]:MOD:PM:INTernal:FUNCtion

命令格式

[:SOURce<n>]:MOD:PM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:PM:INTernal:FUNCtion?

功能描述

选择 PM 调制波形。

查询 PM 调制波形。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER | SINusoid

说明

该命令仅在选择内部调制源时可用。

返回格式

返回 SIN、SQU、TRI、RAMP、NRAM、NOIS或USER。

举例

下面的命令选择方波为调制波形：

:MOD:PM:INTernal:FUNCtion SQUare

下面的查询返回SQU。

:MOD:PM:INTernal:FUNCtion?

相关命令

[:SOURce<n>]:MOD:PM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PM:SOURce?


[:SOURce<n>]:MOD:PM:SOURce

命令格式

[:SOURce<n>]:MOD:PM:SOURce INTernal|EXTernal

[:SOURce<n>]:MOD:PM:SOURce?

功能描述

选择PM 调制源类型为内部（INTernal）或外部 （EXTernal）。

查询 PM 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:PM:SOURce EXTernal

下面的查询返回EXT。

:MOD:PM:SOURce?


[:SOURce<n>]:MOD:ASKey:AMPLitude

命令格式

[:SOURce<n>]:MOD:ASKey:AMPLitude <amplitude>|MINimum|MAXimum

[:SOURce<n>]:MOD:ASKey:AMPLitude? [MINimum|MAXimum]

功能描述

设置 ASK调制波的幅度，单位默认为“Vpp”。

查询 ASK调制波的幅度。

参数

名称 | 类型 | 范围 | 默认值
<amplitude> | 连续实型 | 0 Vpp至 10 Vpp（高阻） | 2 Vpp

返回格式

以科学计数形式返回幅度值。

举例

下面的命令设置调制波的幅度为 2.5 Vpp：

:MOD:ASK ey:AMPLitude 2.5

下面的查询返回2.500000E+00。

:MOD:ASKey:AMPLitude?


[:SOURce<n>]:MOD:ASK ey:INTernal[:RATE]

命令格式

[:SOURce<n>]:MOD:ASKey:INTernal[:RATE] <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:ASKey:INTernal[:RATE]? [MINimum|MAXimum]

功能描述

设置 ASK速率，单位默认为“Hz”。

查询 ASK速率。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 2 mHz 至 1 MHz | 100 Hz

说明

该命令仅在选择内部调制源时可用。

返回格式

以科学计数形式返回速率值。

举例

下面的命令设置ASK速率为500 Hz。

:MOD:ASKey:INTernal 500

下面的查询返回 5.000000E+02。

:MOD:ASKey:INTernal?

相关命令

[:SOURce<n>]:MOD:ASKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:ASKey:SOURce?


[:SOURce<n>]:MOD:ASKey:POLarity

命令格式

[:SOURce<n>]:MOD:ASKey:POLarity POSitive|NEGative

[:SOURce<n>]:MOD:ASKey:POLarity?

功能描述

选择由调制波的正极性或负极性控制幅度输出。

查询ASK调制极性。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | POSitive|NEGative | POSitive

返回格式

返回POS或NEG。

举例

下面的命令设置由调制波的负极性控制幅度输出：

:MOD:ASKey:POLarity NEGative

下面的查询返回NEG。

:MOD:ASKey:POLarity?


[:SOURce<n>]:MOD:ASKey:SOURce

命令格式

[:SOURce<n>]:MOD:ASKey:SOURce INTernal|EXTernal

[:SOURce<n>]:MOD:ASKey:SOURce?

功能描述

选择 ASK 调制源类型为内部（INTernal）或外部 （EXTernal）。

查询 ASK 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:ASKey:SOURce EXTernal

下面的查询返回EXT。

:MOD:ASKey:SOURce?


[:SOURce<n>]:MOD:FSKey[:FREQ uency]

命令格式

[:SOURce<n>]:MOD:FSKey[:FREQ uency] <frequency>|MINimum|MAXimum

[:SOURce<n>]:MOD:FSKey[:FREQuency]? [MINimum|MAXimum]

功能描述

设置 FSK跳跃频率。

查询 FSK跳跃频率 。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 见本页“说明” | 100 Hz

说明

载波波形不同，可设置的频率范围<frequency>不同：

正弦波：1 μHz至160 MHz

方波：1 μHz至 50 MHz

锯齿波：1 μHz至 4 MHz

任意波：1 μHz至40 MHz（内置波形DC除外）

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置FSK跳跃频率为300 Hz：

:MOD:FSKey 300

下面的查询返回 3.000000E+02。

:MOD:FSKey?


[:SOURce<n>]:MOD:FSKey:INTernal:RATE

命令格式

[:SOURce<n>]:MOD:FSKey:INTernal:RATE <rate>|MINimum|MAXimum

[:SOURce<n>]:MOD:FSKey:INTernal:RATE? [MINimum|MAXimum]

功能描述

设置F SK速率，单位默认为“Hz”。

查询 FSK速率。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 2 mHz 至 1 MHz | 100 Hz

说明

该命令仅在选择内部调制源时可用。

返回格式

以科学计数形式返回速率值。

举例

下面的命令设置FSK速率为150 Hz。

:MOD:FSKey:INTernal:RATE 150

下面的查询返回1.500000E+02。

:MOD:FSKey:INTernal:RATE?

相关命令


[:SOURce<n>]:MOD:FSKey:POLarity

命令格式

[:SOURce<n>]:MOD:FSKey:POLarity POSitive|NEGative

[:SOURce<n>]:MOD:FSKey:POLarity?

功能描述

选择由调制波的正极性或负极性控制频率输出。

查询 F SK调制极性。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | POSitive|NEGative | POSitive

返回格式

返回POS或NEG。

举例

下面的命令设置由调制波的负极性控制相位输出：

:MOD:FSKey:POLarity NEGative

下面的查询返回NEG。

:MOD:FSKey:POLarity?


[:SOURce<n>]:MOD:FSKey:SOURce

命令格式

[:SOURce<n>]:MOD:FSKey:SOURce INTernal|EXTernal

[:SOURce<n>]:MOD:FSKey:SOURce?

功能描述

选择 FSK 调制源类型为内部（INTernal）或外部 （EXTernal）。

查询 FSK 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:FSKey:SOURce EXTernal

下面的查询返回EXT。

:MOD:FSKey:SOURce?


[:SOURce<n>]:MOD:PSKey:INTernal:RATE

命令格式

[:SOURce<n>]:MOD:PSKey:INTernal:RATE <rate>|MINimum|MAXimum

[:SOURce<n>]:MOD:PSKey:INTernal:RATE? [MINimum|MAXimum]

功能描述

设置 PSK速率，单位默认为“Hz”。

查询 PSK速率。

参数

名称 | 类型 | 范围 | 默认值
<rate> | 连续实型 | 2 mHz 至 1 MHz | 100 Hz

说明

该命令仅在选择内部调制源时可用。

返回格式

以科学计数形式返回速率值。

举例

下面的命令设置PSK速率为150 Hz。

:MOD:PSKey:INTernal:RATE 150

下面的查询返回1.500000E+02。

:MOD:PSKey:INTernal:RATE?

相关命令

[:SOURce<n>]:MOD:PSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PSKey:SOURce?


[:SOURce<n>]:MOD:PSKey:PHASe

命令格式

[:SOURce<n>]:MOD:PSKey:PHASe <phase>|MINimum|MAXimum

[:SOURce<n>]:MOD:PSKey:PHASe [MINimum|MAXimum]

功能描述

设置 PSK 调制波的相位。

查询 PSK 调制波的相位。

参数

名称 | 类型 | 范围 | 默认值
<phase> | 连续实型 | 0°至360° | 180°

返回格式

以科学计数形式返回相位值。

举例

下面的命令设置PSK 调制波的相位为90°：

:MOD:PSKey:PHASe 90

下面的查询返回 9.000000E+01。

:MOD:PSKey:PHASe?


[:SOURce<n>]:MOD:PSKey:POLarity

命令格式

[:SOURce<n>]:MOD:PSKey:POLarity POSitive|NEGative

[:SOURce<n>]:MOD:PSKey:POLarity?

功能描述

选择由调制波的正极性或负极性控制相位输出。

查询 P SK调制极性。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | POSitive|NEGative | POSitive

返回格式

返回POS或NEG。

举例

下面的命令设置由调制波的负极性控制相位输出：

:MOD:PSKey:POLarity NEGative

下面的查询返回NEG。

:MOD:PSKey:POLarity?


[:SOURce<n>]:MOD:PSKey:SOURce

命令格式

[:SOURce<n>]:MOD:PSKey:SOURce INTernal|EXTernal

[:SOURce<n>]:MOD:PSKey:SOURce?

功能描述

选择 PSK 调制源类型为内部（INTernal）或外部 （EXTernal）。

查询 PSK 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:PSKey:SOURce EXTernal

下面的查询返回EXT。

:MOD:PSKey:SOURce?


[:SOURce<n>]:MOD:BPSKey:DATA

命令格式

[:SOURce<n>]:MOD:BPSKey:DATA 01|10|PN15|PN21
[:SOURce<n>]:MOD:BPSKey:DATA?

功能描述

设置BPSK 调制的调制源。

查询 B PSK 调制的调制源。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | 01|10|PN15|PN21 | PN15

返回格式

返回01、10、PN15或PN21。

举例

下面的命令设置调制源为PN21：

:MOD:BPSKey:DATA PN21

下面的查询返回 PN21。

:MOD:BPSKey:DATA?


[:SOURce<n>]:MOD:BPSKey:INTernal:RATE

命令格式

[:SOURce<n>]:MOD:BPSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:BPSKey:INTernal:RATE? [MINimum|MAXimum]

功能描述

设置BPSK 速率。

查询 BPSK 速率。

参数

名称 | 类型 | 范围 | 默认值
<rate> | 连续实型 | 2 mHz 至 1 MHz | 100 Hz

返回格式

以科学计数形式返回速率值。

举例

下面的命令设置BPSK速率为150 Hz。

:MOD:BPSKey:INTernal:RATE 150

下面的查询返回1.500000E+02。

:MOD:BPSKey:INTernal:RATE?


[:SOURce<n>]:MOD:BPSKey:PHASe

命令格式

[:SOURce<n>]:MOD:BPSKey:PHASe <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:BPSKey:PHASe? [MINimum|MAXimum]

功能描述

设置 BPSK 相位。

查询 BPSK 相位。

参数

名称 | 类型 | 范围 | 默认值
<phase> | 连续实型 | 0°至360° | 180°

返回格式

以科学计数形式返回相位值。

举例

下面的命令设置BPSK 相位为90°：

:MOD:BPSKey:PHASe 90

下面的查询返回 9.000000E+01。

:MOD:BPSKey:PHASe?


[:SOURce<n>]:MOD:QPSKey:DATA

命令格式

[:SOURce<n>]:MOD:QPSKey:DATA PN15|PN21
[:SOURce<n>]:MOD:QPSKey:DATA?

功能描述

设置QPSK 调制的调制源。

查询 Q PSK 调制的调制源。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | PN15|PN21 | PN15

返回格式

返回PN15或PN21。

举例

下面的命令设置调制源为PN21：

:MOD:QPSKey:DATA PN21

下面的查询返回 PN21。

:MOD:QPSKey:DATA?


[:SOURce<n>]:MOD:QPSKey:INTernal:RATE

命令格式

[:SOURce<n>]:MOD:QPSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:INTernal:RATE? [MINimum|MAXimum]

功能描述

设置QPSK 速率。

查询 QPSK 速率。

参数

名称 | 类型 | 范围 | 默认值
<rate> | 连续实型 | 2 mHz 至 1 MHz | 100 Hz

返回格式

以科学计数形式返回速率值。

举例

下面的命令设置QPSK速率为150 Hz。

:MOD:QPSKey:INTernal:RATE 150

下面的查询返回1.500000E+02。

:MOD:QPSKey:INTernal:RATE?


[:SOURce<n>]:MOD:Q PSKey:PHASe1

命令格式

[:SOURce<n>]:MOD:QPSKey:PHASe1 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe1? [MINimum|MAXimum]

功能描述

设置 QPSK 调制 相位 1。

查询 QPSK调制 相位 1。

参数

名称 | 类型 | 范围 | 默认值
<phase> | 连续实型 | 0°至360° | 45°

返回格式

以科学计数形式返回相位值。

举例

下面的命令设置QPSK调制相位 1为90°：

:MOD:QPSKey:PHASe1 90

下面的查询返回 9.000000E+01。

:MOD:QPSKey:PHASe1?


[:SOURce<n>]:MOD:Q PSKey:PHASe2

命令格式

[:SOURce<n>]:MOD:QPSKey:PHASe2 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe2? [MINimum|MAXimum]

功能描述

设置 QPSK调制 相位 2。

查询 QPSK调制 相位 2。

参数

名称 | 类型 | 范围 | 默认值
<phase> | 连续实型 | 0°至360° | 135°

返回格式

以科学计数形式返回相位值。

举例

下面的命令设置QPSK调制相位 2为180°：

:MOD:QPSKey:PHASe2 180

下面的查询返回 1.800000E+02。

:MOD:QPSKey:PHASe2?


[:SOURce<n>]:MOD:Q PSKey:PHASe3

命令格式

[:SOURce<n>]:MOD:QPSKey:PHASe3 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe3? [MINimum|MAXimum]

功能描述

设置 QPSK调制 相位 3。

查询 QPSK调制 相位 3。

参数

名称 | 类型 | 范围 | 默认值
<phase> | 连续实型 | 0°至360° | 225°

返回格式

以科学计数形式返回相位值。

举例

下面的命令设置QPSK调制相位3为280°：

:MOD:QPSKey:PHASe3 280

下面的查询返回 2.800000E+02。

:MOD:QPSKey:PHASe3?


[:SOURce<n>]:MOD:3FSKe y[:FREQuency]

命令格式

[:SOURce<n>]:MOD:3FSKey[:FREQuency] <n>,<frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:3FSKey[:FREQuency]? <n>[,MINimum|MAXimum]

功能描述

设置 3FSK 调制 的跳跃频率。

查询 3FSK 调制 的跳跃频率。

参数

名称 | 类型 | 范围 | 默认值
<n> | 整型 | 1至2 | 1
<frequency> | 连续实型 | 见本页“说明” | 100 Hz

说明

载波波形不同，可设置的频率范围<frequency>不同：

正弦波：1 μHz至160 MHz

方波：1 μHz至 50 MHz

锯齿波：1 μHz至 4 MHz

任意波：1 μHz至40 MHz（内置波形DC除外）

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置3FSK跳跃频率1为300 Hz：

:MOD:3FSKey 1, 300

下面的查询返回 3.000000E+02。

:MOD:3FSKey? 1


[:SOURce<n>]:MOD:3FSKey:INTernal:RATE

命令格式

[:SOURce<n>]:MOD:3FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:3FSKey:INTernal:RATE? [MINimum|MAXimum]

功能描述

设置3FSK 键控频率。

查询 3FSK 键控频率。

参数

名称 | 类型 | 范围 | 默认值
<rate> | 连续实型 | 2 mHz 至 1 MHz | 100 Hz

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置3FSK键控频率为150 Hz。

:MOD:3FSKey:INTernal:RATE 150

下面的查询返回1.500000E+02。

:MOD:3FSKey:INTernal:RATE?


[:SOURce<n>]:MOD:4FSKe y[:FREQuency]

命令格式

[:SOURce<n>]:MOD:4FSKey[:FREQuency] <n>,<frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:4FSKey[:FREQuency]? <n>[,MINimum|MAXimum]

功能描述

设置 4FSK 调制 的跳跃频率。

查询 4FSK 调制 的跳跃频率。

参数

名称 | 类型 | 范围 | 默认值
<n> | 整型 | 1至3 | 1
<frequency> | 连续实型 | 见本页“说明” | 100 Hz

说明

载波波形不同，可设置的频率范围<frequency>不同：

正弦波：1 μHz至160 MHz

方波：1 μHz至 50 MHz

锯齿波：1 μHz至 4 MHz

任意波：1 μHz至40 MHz（内置波形DC除外）

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置4FSK跳跃频率1为300 Hz：

:MOD:4FSKey 1, 300

下面的查询返回 3.000000E+02。

:MOD:4FSKey? 1


[:SOURce<n>]:MOD:4FSKey:INTernal:RATE

命令格式

[:SOURce<n>]:MOD:4FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:4FSKey:INTernal:RATE? [MINimum|MAXimum]

功能描述

设置4FSK 键控频率。

查询 4FSK 键控频率。

参数

名称 | 类型 | 范围 | 默认值
<rate> | 连续实型 | 2 mHz 至 1 MHz | 100 Hz

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置4FSK键控频率为150 Hz。

:MOD:4FSKey:INTernal:RATE 150

下面的查询返回1.500000E+02。

:MOD:4FSKey:INTernal:RATE?


[:SOURce<n>]:MOD:OSKey:INTernal:RATE

命令格式

[:SOURce<n>]:MOD:OSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:OSKey:INTernal:RATE? [MINimum|MAXimum]

功能描述

设置 OSK键控频率，单位默认为“Hz”。

查询 OSK键控频率。

参数

名称 | 类型 | 范围 | 默认值
<rate> | 连续实型 | 2 mHz 至 1 MHz | 1 kHz

说明

该命令仅在选择内部调制源时可用。

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置OSK键控频率为500 Hz。

:MOD:OSKey:INTernal:RATE 500

下面的查询返回 5.000000E+02。

:MOD:OSKey:INTernal:RATE?

相关命令

[:SOURce<n>]:MOD:OSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:OSKey:SOURce?


[:SOURce<n>]:MOD:OSKey:SOURce

命令格式

[:SOURce<n>]:MOD:OSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:OSKey:SOURce?

功能描述

选择 OSK 调制源类型为内部（INTernal）或外部 （EXTernal）。

查询 OSK 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:OSKey:SOURce EXTernal

下面的查询返回EXT。

:MOD:OSKey:SOURce?


[:SOURce<n>]:MOD:OSKey:TIME

命令格式

[:SOURce<n>]:MOD:OSKey:TIME <time>|MINimum|MAXimum
[:SOURce<n>]:MOD:OSKey:TIME? [MINimum|MAXimum]

功能描述

设置 OSK 调制 的震荡周期。

查询 OSK 调制 的震荡周期。

参数

名称 | 类型 | 范围1 | 默认值
<time> | 连续实型 | 8 ns至200 s | 100 μs

注1：震荡周期的可设置范围受当前的键控频率限制。

返回格式

以科学计数形式返回周期值。

举例

下面的命令设置OSK震荡周期为150 μs：

:MOD:OSKey:TIME 0.00015

下面的查询返回 1.500000E-04。

:MOD:OSKey:TIME?


[:SOURce<n>]:MOD:PWM[:DEViation]:DCYCle

命令格式

[:SOURce<n>]:MOD:PWM[:DEViation]:DCYCle <percent>|MINimum|MAXimum

[:SOURce<n>]:MOD:PWM[:DEViation]:DCYCle? [MINimum|MAXimum]

功能描述

设置PWM调制的占空比偏差。

查询PWM调制的占空比偏差。

参数

名称 | 类型 | 范围 | 默认值
<percent> | 连续实型 | 0%至50% | 20%

说明

占空比偏差<percent>满足下列条件：

不能超过当前脉冲的占空比。

受到最小占空比和当前边沿时间的限制。

返回格式

以科学计数形式返回占空比偏差值。

举例

下面的命令设置占空比偏差为45%：

:MOD:PWM:DCYC le 45%

下面的查询返回4.500000E+01。

:MOD:PWM:DCYCle?


[:SOURce<n>]:MOD:PWM[:DEViation][:WIDTh]

命令格式

[:SOURce<n>]:MOD:PWM[:DEViation][:WIDTh] <deviation>|MINimum|MAXimum

[:SOURce<n>]:MOD:PWM[:DEViation][:WIDTh]? [MINimum|MAXimum]

功能描述

设置PWM调制的脉宽偏差 。

查询PWM调制的脉宽偏差 。

参数

名称 | 类型 | 范围 | 默认值
<deviation> | 连续实型 | 0 ns至500 ks | 200 μs

说明

脉宽偏差<deviation>满足下列条件：

脉宽偏差不能超过当前的脉冲宽度。

脉宽偏差受到最小脉冲宽度和当前边沿时间设置的限制。

返回格式

以科学计数形式返回当前脉宽偏差。

举例

下面的命令设置脉宽偏差为10 μs：

:MOD:PWM 0.00001

下面的查询返回 1.000000E-05。

:MOD:PWM?


[:SOURce<n>]:MOD:PWM:INTernal:FREQuency

命令格式

[:SOURce<n>]:MOD:PWM:INTernal:FREQuency <frequency>|MINimum|MAXimum

[:SOURce<n>]:MOD:PWM:INTernal:FREQuency?

功能描述

设置 PWM调制波的频率。

查询 PWM调制波的频率。

参数

名称 | 类型 | 范围 | 默认值
<frequency> | 连续实型 | 2 mHz至50 kHz | 100 Hz

返回格式

以科学计数形式返回频率值。

举例

下面的命令设置PWM调制波的频率为300 Hz：

:MOD:PWM:INTernal:FREQuency 300

下面的查询返回 3.000000E+02。

:MOD:PWM:INTernal:FREQuency?


[:SOURce<n>]:MOD:PWM:INTernal:FUNCtion

命令格式

[:SOURce<n>]:MOD:PWM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:PWM:INTernal:FUNCtion?

功能描述

选择PWM 调制波形。

查询 PWM 调制波形。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER | SINusoid

说明

该命令仅在选择内部调制源时可用。

返回格式

返回 SIN、SQU、TRI、RAMP、NRAM、NOIS或USER。

举例

下面的命令选择方波为调制波形：

:MOD:PWM:INTernal:FUNCtion SQUare

下面的查询返回SQU。

:MOD:PWM:INTernal:FUNCtion?

相关命令

[:SOURce<n>]:MOD:PWM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PWM:SOURce?


[:SOURce<n>]:MOD:PWM:SOURce

命令格式

[:SOURce<n>]:MOD:PWM:SOURce INTernal|EXTernal

[:SOURce<n>]:MOD:PWM:SOURce?

功能描述

选择 PWM调制源类型为内部（INTernal）或外部 （EXTernal）。

查询 PWM 调制源类型 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

返回格式

返回INT或EXT。

举例

下面的命令设置调制源类型为外部：

:MOD:PWM:SOURce EXTernal

下面的查询返回EXT。

:MOD:PWM:SOURce?


[:SOURce<n>]:PERiod

[:SOURce<n>]:PERiod[:FIXed] <period>
[:SOURce<n>]:PERiod[:FIXed]?


[:SOURce<n>]:PERiod[:FIXed]

命令格式

[:SOURce<n>]:PERiod[:FIXed] <period>

[:SOURce<n>]:PERiod[:FIXed]?

功能描述

设置基本波的周期，单位默认为“s”。

查询基本波的周期。

参数

名称 | 类型 | 范围 | 默认值
<period> | 连续实型 | 见本页“说明” | 1 ms

说明

不同波形对应的周期范围不同。

正弦波：6.2 ns至 1.0000 Ms

方波：20.0 ns至 1.0000 Ms

锯齿波：250.0 ns至 1.0000 Ms

脉冲波：25.0 ns至 1.0000 Ms

任意波：2 5.0 ns 至1.0000 Ms

谐波：12.5 ns 至1.0000 Ms

返回格式

以科学计数形式返回周期值。

举例

下面的命令设置周期为100 ms。

:PER iod 0.1

下面的查询返回1.000000E-01。

:PERiod?


[:SOURce<n>]:PHASe

[:SOURce<n>]:PHASe[:ADJust] <phase>|MINimum|MAXimum
[:SOURce<n>]:PHASe[:ADJust]? [MINimum|MAXimum]

[:SOURce<n>]:PHASE:INITiate


[:SOURce<n>]:PHASe[:ADJust]

命令格式

[:SOURce<n>]:PHASe[:ADJust] <phase>|MINimum|MAXimum

[:SOURce<n>]:PHASe[:ADJust]? [MINimum|MAXimum]

功能描述

设置基本波的起始相位。

查询起始相位。

参数

名称 | 类型 | 范围 | 默认值
<phase> | 连续实型 | 0° 至 360° | 0°

返回格式

以科学计数形式返回相位值。

举例

下面的命令设置起始相位为90°：

:PHASe 90

下面的查询返回 9.000000E+01。

:PHASe?


[:SOURce<n>]:PHASe:INITiate

命令格式

[:SOURce<n>]:PHASe:INITiate

功能描述

执行同相位操作。

说明

在两个通道中，任一通道处于调制模式时，此设置无效。


SOURCe PULSe

[:SOURce<n>]:PULSe

[:SOURce<n>]:PULSe:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:PULSe:DCYCle? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:DELay <delay>|MINimum|MAXimum
[:SOURce<n>]:PULSe:DELay? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:HOLD WIDTh|DUTY
[:SOURce<n>]:PULSe:HOLD?

[:SOURce<n>]:PULSe:TRANsition[:LEADing] <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:TRANsition[:LEADing]? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:TRANsition:TRAiling <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:TRANsition:TRAiling? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:WIDTh <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:WIDTh? [MINimum|MAXimum]


[:SOURce<n>]:PULSe:DCYCle

命令格式

[:SOURce<n>]:PULSe:DCYCle <percent>|MINimum|MAXimum

[:SOURce<n>]:PULSe:DCYCle? [MINimum|MAXimum]

功能描述

设置脉冲占空比，以%表示。

查询脉冲占空比。

参数

名称 | 类型 | 范围 | 默认值
<percent> | 连续实型 | 见本页的“说明” | 50%

说明

与脉宽相关联，修改其中一个参数将自动修改另一个参数。

脉冲占空比受“最小脉冲宽度（4 ns）”和“脉冲周期”限制：

脉冲占空比 ≥ 100 × 最小脉冲宽度 ÷ 脉冲周期

脉冲占空比 ≤ 100 ×（1 - 2 × 最小脉冲宽度 ÷ 脉冲周期）

返回格式

以科学计数形式返回占空比数值。

举例

下面的命令将脉冲的占空比设置为60%：

:PULS e:DCYCle 60

下面的查询返回6.000000E+01。

:PULSe:DCYCle?

相关命令

[:SOURce<n>]:PULSe:HOLD WIDTh|DUTY
[:SOURce<n>]:PULSe:HOLD?

[:SOURce<n>]:PULSe:WIDTh <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:WIDTh? [MINimum|MAXimum]


[:SOURce<n>]:PULSe:DELay

命令格式

[:SOURce<n>]:PULSe:DELay <delay>|MINimum|MAXimum

[:SOURce<n>]:PULSe:DELay? [MINimum|MAXimum]

功能描述

设置脉冲延时时间，单位默认为“s”。

查询脉冲的延时时间

参数

名称 | 类型 | 范围 | 默认值
<delay> | 连续实型 | 0 ns 至 脉冲周期 | 0 ns

返回格式

以科学计数形式返回脉冲延时。

举例

下面的命令将脉冲的延时时间设置为8 ms：

:PULS e:DELay 0.008

下面的查询返回8.000000E-03。

:PULSe:DELay?


[:SOURce<n>]:PULSe:HOLD

命令格式

[:SOURce<n>]:PULSe:HOLD WIDTh|DUTY

[:SOURce<n>]:PULSe:HOLD?

功能描述

选中脉冲波的脉宽或占空比 。

查询当前选中的脉冲波参数。

参数

名称 | 类型 | 范围 | 默认值
—— | 离散型 | WIDTh|DUTY | DUTY

说明

脉冲占空比与脉宽相关联，修改其中一个参数将自动修改另一个参数。

返回格式

返回WIDT或DUTY。

举例

下面的命令选中脉宽：

:PULSe:HOLD WIDTh

下面的查询返回WIDT。

:PULSe:HOLD?

相关命令

[:SOURce<n>]:PULSe:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:PULSe:DCYCle? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:WIDTh <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:WIDTh? [MINimum|MAXimum]


[:SOURce<n>]:PULSe:TRANsition[:LEADing]

命令格式

[:SOURce<n>]:PULSe:TRANsition[:LEADing] <seconds>|MINimum|MAXimum

[:SOURce<n>]:PULSe:TRANsition[:LEADing]? [MINimum|MAXimum]

功能描述

设置脉冲上升沿时间，单位默认为“s”。

查询脉冲的上升沿时间。

参数

名称 | 类型 | 范围 | 默认值
<seconds> | 连续实型 | 见本页“说明” | 1.9531 μs

说明

可设置范围受当前指定的脉宽限制，限制关系为满足不等式：上升/下降沿时间 ≤ 0.625 × 脉宽

当所设置的数值超出限定值，DG4000自动调整边沿时间以适应指定的脉宽。

返回格式

以科学计数形式返回时间值，单位默认为“s”。

举例

下面的命令设置上升沿时间为10 μs：

:PULSe:TRANsition 0.00001

下面的查询返回1.000000E-05。

:PULSe:TRANsition?


[:SOURce<n>]:PULSe:TRANsition:TRAiling

命令格式

[:SOURce<n>]:PULSe:TRANsition:TRAiling <seconds>|MINimum|MAXimum

[:SOURce<n>]:PULSe:TRANsition:TRAiling? [MINimum|MAXimum]

功能描述

设置脉冲下降沿时间，单位默认为“s”。

查询脉冲的下降沿时间。

参数

名称 | 类型 | 范围 | 默认值
<seconds> | 连续实型 | 见本页“说明” | 1.9531 μs

说明

可设置范围受当前指定的脉宽限制，限制关系为满足不等式：上升/下降沿时间 ≤ 0.625 × 脉宽

当所设置的数值超出限定值，DG4000自动调整边沿时间以适应指定的脉宽。

返回格式

以科学计数形式返回时间值，单位默认为“s”。

举例

下面的命令设置下降沿时间为10 μs：

:PULSe:TRANsition:TRAiling 0.00001

下面的查询返回 1.000000E-05。

:PULSe:TRANsition:TRAiling?


[:SOURce<n>]:PULSe:WIDTh

命令格式

[:SOURce<n>]:PULSe:WIDTh <seconds>|MINimum|MAXimum

[:SOURce<n>]:PULSe:WIDTh? [MINimum|MAXimum]

功能描述

设置脉冲的脉宽，单位默认为“s”。

查询脉冲的脉宽。

参数

名称 | 类型 | 范围 | 默认值
<seconds> | 连续实型 | 见本页“说明” | 500 μs

说明

与占空比相关联，修改其中一个参数将自动修改另一个参数。

受“最小脉冲宽度（4 ns）”和“脉冲周期”的限制。

脉冲宽度 ≥ 最小脉冲宽度

脉冲宽度 ≤ 脉冲周期 - 2 × 最小脉冲宽度

返回格式

以科学计数形式返回脉宽值。

举例

下面的命令将脉冲的脉宽设置为600 μs：

:PULSe:WIDTh 0.0006

下面的查询返回 6.000000E-04。

:PULSe:WIDTh?

相关命令

[:SOURce<n>]:PULSe:HOLD WIDTh|DUTY
[:SOURce<n>]:PULSe:HOLD?

[:SOURce<n>]:PULSe:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:PULSe:DCYCle? [MINimum|MAXimum]


SOURCe SWEep

[:SOURce<n>]:SWEep

[:SOURce<n>]:SWEep:HTIMe:STARt <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:HTIMe:STARt? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:HTIMe:STOP <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:HTIMe:STOP? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:RTIMe <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:RTIMe? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:SPACing LINear|LOGarithmic|STEp
[:SOURce<n>]:SWEep:SPACing?

[:SOURce<n>]:SWEep:STATe ON|OFF
[:SOURce<n>]:SWEep:STATe?

[:SOURce<n>] :SWEep:STEP <steps>|MINimum|MAXimum

[:SOURce<n>] :SWEep:STEP? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:TIME <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:TIME? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:TRIGger[:IMMediate]

[:SOURce<n>]:SWEep:TRIGger:SLOPe POSitive|NEGative
[:SOURce<n>]:SWEep:TRIGger:SLOPe?

[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:SWEep:TRIGger:SOURce?

[:SOURce<n>]:SWEep:TRIGger:TRIGOut OFF|POSitive|NEGative
[:SOURce<n>]:SWEep:TRIGger:TRIGOut?


[:SOURce<n>]:SWEep:HTIMe:STARt

命令格式

[:SOURce<n>]:SWEep:HTIMe:STARt <seconds>|MINimum|MAXimum

[:SOURce<n>]:SWEep:HTIMe:STARt? [MINimum|MAXimum]

功能描述

设置扫频的起始保持时间，单位默认为“s”。

查询扫频的起始保持时间。

参数

名称 | 类型 | 范围 | 默认值
<seconds> | 连续实型 | 0 s 至 300 s | 0 s

返回格式

以科学计数形式返回时间值。

举例

下面的命令设置起始保持时间为1 s：

:SWEep:HTIMe:STARt 1

查询返回1.000000E+00。

:SWEep:HTIMe:STARt?


[:SOURce<n>]:SWEep:HTIMe:STOP

命令格式

[:SOURce<n>]:SWEep:HTIMe:STOP <seconds>|MINimum|MAXimum

[:SOURce<n>]:SWEep:HTIMe:STOP? [MINimum|MAXimum]

功能描述

设置扫频的终止保持时间，单位默认为“s”。

查询扫频的终止保持时间。

参数

名称 | 类型 | 范围 | 默认值
<seconds> | 连续实型 | 0 s 至 300 s | 0 s

返回格式

以科学计数形式返回时间值。

举例

下面的命令设置终止保持时间为1 s：

:SWEep:HTIMe:STOP 1

查询返回1.000000E+00。

:SWEep:HTIMe:STOP?


[:SOURce<n>]:SWEep:RTIMe

命令格式

[:SOURce<n>]:SWEep:RTIMe <seconds>|MINimum|MAXimum

[:SOURce<n>]:SWEep:RTIMe? [MINimum|MAXimum]

功能描述

设置扫频的返回时间，单位默认为“s”。

查询扫频的返回时间。

参数

名称 | 类型 | 范围 | 默认值
<seconds> | 连续实型 | 0 s 至 300 s | 0 s

返回格式

以科学计数形式返回时间值。

举例

下面的命令设置返回时间为5 s：

:SWEep:RTIMe 5

查询返回 5.000000E+00。

:SWEep:RTIMe?


[:SOURce<n>]:SWEep:SPACing

命令格式

[:SOURce<n>]:SWEep:SPACing LINear|LOGarithmic|STEp

[:SOURce<n>]:SWEep:SPACing?

功能描述

选择扫频类型为线性（LINear）、对数 （LOGarithmic）或步进 （STEp）。

查询扫频类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | LINear|LOGarithmic|STEp | LINear

返回格式

返回 LIN、LOG或STE。

举例

下面的命令选择对数扫频：

:SWEep:SPACing LOGarithmic

查询返回 LOG。

:SWEep:SPACing?


[:SOURce<n>]:SWEep:STATe

命令格式

[:SOURce<n>]:SWEep:STATe ON|OFF

[:SOURce<n>]:SWEep:STATe?

功能描述

打开或关闭扫频功能。

查询扫频功能的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

启用Sweep后，Mod和Burst功能将自动关闭（如果当前已打开）。

返回格式

返回OFF或ON。

举例

下面的命令打开扫频功能：

:SWE ep:STATe ON

下面的查询返回ON。

:SWEep:STATe?


[:SOURce<n>]:SWEep:STEP

命令格式

[:SOURce<n>]:SWEep:STEP <steps>|MINimum|MAXimum

[:SOURce<n>]:SWEep:STEP? [MINimum|MAXimum]

功能描述

设置步进扫频的步进数。

查询步进扫频的步进数。

参数

名称 | 类型 | 范围 | 默认值
<steps> | 整型 | 2 至 2048 | 2

返回格式

以科学计数形式返回步进数。

举例

下面的命令设置步进数为5：

:SWEep:STEP 5

查询返回 5.000000E+00。

:SWEep:STEP?


[:SOURce<n>]:SWEep:TIME

命令格式

[:SOURce<n>]:SWEep:TIME <seconds>|MINimum|MAXimum

[:SOURce<n>]:SWEep:TIME? [MINimum|MAXimum]

功能描述

设置扫频时间，单位默认为“s”。

查询扫频时间。

参数

名称 | 类型 | 范围 | 默认值
<seconds> | 连续实型 | 1 ms至300 s | 1 s

返回格式

以科学计数形式返回时间值。

举例

下面的命令设置扫频时间为 5 s：

:SWE ep:TIME 5

下面的查询返回5.000000E+00。

:SWEep:TIME?


[:SOURce<n>]:SWEep:TRIGger[:IMMediate]

命令格式

[:SOURce<n>]:SWEep:TRIGger[:IMMediate]

功能描述

使仪器立即触发。

说明

该命令仅在触发源为手动模式时有效。

相关命令

[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:SWEep:TRIGger:SOURce?


[:SOURce<n>]:SWEep:TRIGger:SLOPe

命令格式

[:SOURce<n>]:SWEep:TRIGger:SLOPe POSitive|NEGative

[:SOURce<n>]:SWEep:TRIGger:SLOPe?

功能描述

选择信号发生器在外部触发信号的上升沿（POSitive）或下降沿 （NEGative）时启动扫频输出。

查询扫频输出的外部触发信号的边沿类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | POSitive|NEGative | POSitive

说明

该命令仅在外部触发源时有效。

返回格式

返回POS或NEG。

举例

下面的命令设置边沿类型为下降沿 ：

:SWEep:TRIGger:SLOPe NEGative

下面的查询返回NEG。

:SWEep:TRIGger:SLOPe?

相关命令

[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:SWEep:TRIGger:SOURce?


[:SOURce<n>]:SWEep:TRIGger:SOURce

命令格式

[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual

[:SOURce<n>]:SWEep:TRIGger:SOURce?

功能描述

选择扫频触发源的类型为内部（INTernal）、外部（EXTernal）或手动（MANual）。

查询扫频触发源的类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal|MANual | INTernal

返回格式

返回INT、EXT 或MAN。

举例

下面的命令设置触发源类型为手动 ：

:SWEep:TRIGger:SOURce MANual

下面的查询返回MAN。

:SWEep:TRIGger:SOURce?


[:SOURce<n>]:SWEep:TRIGger:TRIGOut

命令格式

[:SOURce<n>]:SWEep:TRIGger:TRIGOut OFF|POSitive|NEGative

[:SOURce<n>]:SWEep:TRIGger:TRIGOut?

功能描述

设置扫频触发输出的边沿类型为上升沿（POSitive）或下降沿（NEGative），或关闭触发输出信号（OFF）。

查询扫频触发输出的边沿类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | OFF|POSitive|NEGative | OFF

说明

触发源为内部或手动模式时有效。

返回格式

返回OFF，POS或NEG。

举例

下面的命令设置输出下降沿 ：

:SWEep:TRIGger:TRIGout NEGative

下面的查询返回NEG。

:SWEep:TRIGger:TRIGout?

相关命令

[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:SWEep:TRIGger:SOURce?


[:SOURce<n>]:VOLTage

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate][:AMPLitude] <amplitude>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate][:AMPLitude]? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:OFFSet <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:OFFSet? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage:UNIT VPP|VRMS|DBM
[:SOURce<n>]:VOLTage:UNIT?


[:SOURce<n>]:VOLTage[:LEVel][:IMMediate][:AMPLitude]

命令格式

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate][:AMPLitude] <amplitude>|MINimum|MAXimum

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate][:AMPLitude]? [MINimum|MAXimum]

功能描述

设置基本波的幅度，单位默认为“Vpp”。

查询基本波的幅度值。

参数

名称 | 类型 | 范围 | 默认值
<amplitude> | 连续实型 | 见本页“说明” | 5 Vpp

说明

幅度范围受“阻抗”和“频率/周期”设置的限制，请参见本产品用户手册。

返回格式

以科学计数形式返回幅度值。

举例

下面的命令设置幅度为2.5 Vpp：

:VOLT age 2.5

下面的查询返回2.500000E+00。

:VOLTage?


[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH

命令格式

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH <voltage>|MINimum|MAXimum

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH? [MINimum|MAXimum]

功能描述

设置基本波的高电平，单位默认为“V”。

查询基本波的高电平。

参数

名称 | 类型 | 范围 | 默认值
<voltage> | 连续实型 | 当前的低电平 至 10 V（高阻）/5 V（50 Ω） | 2.5 V

返回格式

以科学计数形式返回高电平值。

举例

下面的命令将高电平设置为 5 V：

:VOLT age:HIGH 5

下面的查询返回5.000000E+00。

:VOLTage:HIGH?

相关命令

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW? [MINimum|MAXimum]


[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW

命令格式

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW <voltage>|MINimum|MAXimum

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW? [MINimum|MAXimum]

功能描述

设置基本波的低电平，单位默认为“V”。

查询基本波的低电平。

参数

名称 | 类型 | 范围 | 默认值
<voltage> | 连续实型 | -10 V（高阻）/-5 V（50 Ω）至 当前的高电平 | -2.5 V

返回格式

以科学计数形式返回低电平值。

举例

下面的命令将低电平设置为-5 V：

:VOLTage:LOW -5

下面的查询返回-5.000000E+00。

:VOLTage:LOW?

相关命令

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH? [MINimum|MAXimum]


[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:OFFSet

命令格式

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:OFFSet <voltage>|MINimum|MAXimum

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:OFFSet? [MINimum|MAXimum]

功能描述

设置直流偏移电压，单位默认为“VDC”。

查询直流偏移电压值。

参数

名称 | 类型 | 范围 | 默认值
<voltage> | 连续实型 | 见本页“说明” | 0 VDC

说明

偏移范围受“阻抗”和“幅度/高电平”设置的限制，请参见本产品用户手册。

返回格式

以科学计数形式返回偏移电压值。

举例

下面的命令设置偏移电压为100 mVDC：

:VOLT age:OFFSet 0.1

下面的查询返回1.000000E-01。

:VOLTage:OFFSet?


[:SOURce<n>]:VOLTage:UNIT

命令格式

[:SOURce<n>]:VOLTage:UNIT VPP|VRMS|DBM

[:SOURce<n>]:VOLTage:UNIT?

功能描述

设置幅度的单位为 VPP、VRMS 或 DBM。

查询幅度的单位。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | VPP|VRMS|DBM | VPP

说明

当阻抗为“高阻”时，DBM 不可用。

返回格式

返回VPP、VRMS或DBM。

举例

下面的命令设置幅度的单位为 VRMS：

:VOLTage:UNIT VRMS

下面的查询返回 VRMS。

:VOLTage:UNIT?


SYSTem

SYSTem 命令子系统

:SYSTem:BEEPer[:IMMediate]

:SYSTem:BEEPer:STATe ON|OFF
:SYSTem:BEEPer:STATe?

:SYSTem:COMMunicate:LAN:AUTOip[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:AUTOip[:STATe]?

:SYSTem:COMMunicate:LAN:DHCP[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:DHCP[:STATe]?

:SYSTem:COMMunicate:LAN:DNS <address>
:SYSTem:COMMunicate:LAN:DNS?

:SYSTem:COMMunicate:LAN:GATEway <address>
:SYSTem:COMMunicate:LAN:GATEway?

:SYSTem:COMMunicate:LAN:IPADdress <ip_addr>
:SYSTem:COMMunicate:LAN:IPADdress?

:SYSTem:COMMunicate:LAN:MAC?

:SYSTem:COMMunicate:LAN:SMASk <mask>
:SYSTem:COMMunicate:LAN:SMASk?

:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:STATic[:STATe]?

:SYSTem:COMMunicate:USB:INFormation?

:SYSTem:COMMunicate:USB[:SELF]:CLASs COMPuter|PRINter
:SYSTem:COMMunicate:USB[:SELF]:CLASs?

:SYSTem:CSCopy CH1|CH2,CH2|CH1

:SYSTem:CWCopy CH1|CH2,CH2|CH1

:SYSTem:ERRor?

:SYSTem:KLOCk[:STATe] ON|OFF
:SYSTem:KLOCk[:STATe]?

:SYSTem:LANGuage ENGLish|SCHinese
:SYSTem:LANGuage?

:SYSTem:POWeron DEFault|LAST
:SYSTem:POWeron?

:SYSTem:POWSet AUTO|USER
:SYSTem:POWSet?

:SYSTem:PRESet DEFault|USER1|USER2|USER3|USER4|USER5|USER6|USER7|USER8|USER9|USER10

:SYSTem:RESTART

:SYSTem:ROSCillator:SOURce INTernal|EXTernal
:SYSTem:ROSCillator:SOURce?

:SYSTem:SHUTDOWN

:SYSTem:VERSion?


:SYSTem:BEEPer[:IMMediate]

命令格式

:SYSTem:BEEPer[:IMMediate]

功能描述

蜂鸣器立即产生一次蜂鸣。

说明

该命令仅在蜂鸣器已打开时（参考:SYSTem:BEEPer:STATe ON|OFF 命令）有效。

相关命令

:SYSTem:BEEPer:STATe ON|OFF
:SYSTem:BEEPer:STATe?


:SYSTem:BEEPer:STATe

命令格式

:SYSTem:BEEPer:STATe ON|OFF

:SYSTem:BEEPer:STATe?

功能描述

打开或关闭蜂鸣器。

查询蜂鸣器的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | ON

返回格式

返回ON或OFF。

举例

下面的命令打开蜂鸣器：

:SYST em:BEEPer:STATe ON

下面的查询返回ON。

:SYSTem:BEEPer:STATe?


:SYSTem:COMMunicate:LAN:AUTOip[:STATe]

命令格式

:SYSTem:COMMunicate:LAN:AUTOip[:STATe] ON|OFF

:SYSTem:COMMunicate:LAN:AUTOip[:STATe]?

功能描述

打开或关闭自动IP模式（AUTOIP）。

查询 AUTOIP 模式的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | ON

返回格式

返回ON或OFF。

举例

下面的命令打开AUTOIP 模式 ：

:SYST em:COMMunicate:LAN:AUTOip ON

下面的查询返回ON。

:SYSTem:COMMunicate:LAN:AUTOip?


:SYSTem:COMMunicate:LAN:DHCP[:STATe]

命令格式

:SYSTem:COMMunicate:LAN:DHCP[:STATe] ON|OFF

:SYSTem:COMMunicate:LAN:DHCP[:STATe]?

功能描述

打开或关闭动态IP模式（DHCP）。

查询动态IP模式（DHCP）状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | ON

说明

该模式下，由当前网络中的DHCP服务器向信号发生器分配IP地址等网络参数。

返回格式

返回ON或OFF。

举例

下面的命令打开DHCP模式 ：

:SYSTem:COMMunicate:LAN:DHCP ON

下面的查询返回ON。

:SYSTem:COMMunicate:LAN:DHCP?


:SYSTem:COMMunicate:LAN:DNS

命令格式

:SYSTem:COMMunicate:LAN:DNS <address>

:SYSTem:COMMunicate:LAN:DNS?

功能描述

为信号发生器设置 DNS 地址。

查询DNS地址。

参数

名称 | 类型 | 范围1 | 默认值
<address> | ASCII字符串 | 0.0.0.0至255.255.255.255 | ——

注1：根据TCP/IP协议，DNS的有效范围为0.0.0.0至223.255.255.255且第一段数值不能为127。

说明

该命令仅在手动 IP 模式打开（参考:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF 命令）时可用。

该设置仅在仪器已正确连接至LAN时有效。

一般说来，用户不需要设置网络中的域名服务器地址，因此该参数设置可以忽略。

返回格式

查询命令返回当前域名服务器地址，格式为nnn.nnn.nnn.nnn。

举例

下面的命令将DNS地址设置为202.106.46.151。

:SYST em:COMMunicate:LAN:DNS 202.106.46.151

下面的查询返回202.106.46.151。

:SYSTem:COMMunicate:LAN:DNS?

相关命令

:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:STATic[:STATe]?


:SYSTem:COMMunicate:LAN:GATEway

命令格式

:SYSTem:COMMunicate:LAN:GATEway <address>

:SYSTem:COMMunicate:LAN:GATEway?

功能描述

为信号发生器设置默认网关。

查询默认网关。

参数

名称 | 类型 | 范围1 | 默认值
<address> | ASCII 字符串 | 0.0.0.0至255.255.255.255 | ——

注1：根据TCP/IP协议， 默认网关的有效范围为0.0.0.0至223.255.255.255 且第一段数值不能为127。

说明

该命令仅在手动 IP 模式打开（参考:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF 命令）时可用。

该设置仅在仪器已正确连接至LAN时有效。

返回格式

查询命令返回当前默认网关，格式为nnn.nnn.nnn.nnn。

举例

下面的命令将默认网关设置为172.16.3.1。

:SYSTem:COMMunicate:LAN:GATEway 172.16.3.1

下面的查询返回 172.16.3.1。

:SYST em:COMMunicate:LAN:GATEway?


:SYSTem:COMMunicate:LAN:IPADdress

命令格式

:SYSTem:COMMunicate:LAN:IPADdress <ip_addr>

:SYSTem:COMMunicate:LAN:IPADdress?

功能描述

为信号发生器设置 IP 地址。

查询IP地址。

参数

名称 | 类型 | 范围1 | 默认值
<ip_addr> | ASCII字符串 | 0.0.0.0至255.255.255.255 | ——

注1：根据TCP/IP协议，DNS的有效范围为0.0.0.0至223.255.255.255且第一段数值不能为127。

说明

该命令仅在手动 IP 模式打开（参考:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF 命令）时可用。

该设置仅在仪器已正确连接至LAN时有效。

返回格式

查询命令返回当前 IP 地址，格式为nnn.nnn.nnn.nnn。

举例

下面的命令将 IP 地址设置为172.16.3.145。

:SYSTem:COMMunicate:LAN:IPADdress 172.16.3.145

下面的查询返回 172.16.3.145。

:SYSTem:COMMunicate:LAN:IPADdress?

相关命令

:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:STATic[:STATe]?


:SYSTem:COMMunicate:LAN:MAC?

命令格式

:SYSTem:COMMunicate:LAN:MAC?

功能描述

查询MAC地址。

返回格式

返回MAC地址，如：00-14-0E-42-12-CF。


:SYSTem:COMMunicate:LAN:SMASk

命令格式

:SYSTem:COMMunicate:LAN:SMASk <mask>

:SYSTem:COMMunicate:LAN:SMASk?

功能描述

为信号发生器设置子网掩码。

查询子网掩码。

参数

名称 | 类型 | 范围 | 默认值
<mask> | ASCII字符串 | 0.0.0.0至255.255.255.255 | ——

说明

该命令仅在手动 IP 模式打开（参考:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF 命令）时可用。

该设置仅在仪器已正确连接至LAN时有效。

返回格式

查询命令返回当前子网掩码，格式为nnn.nnn.nnn.nnn。

举例

下面的命令将子网掩码设置为255.255.255.0。

:SYSTem:COMMunicate:LAN:SMASk 255.255.255.0

下面的查询返回 255.255.255.0。

:SYSTem:COMMunicate:LAN:SMASk?

相关命令

:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:STATic[:STATe]?


:SYSTem:COMMunicate:LAN:STATic[:STATe]

命令格式

:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF

:SYSTem:COMMunicate:LAN:STATic[:STATe]?

功能描述

打开或关闭手动 IP模式（ManualIP）。

查询返 ManualIP模式 的状态。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

该模式下，由用户自定义信号发生器的 IP 地址等网络参数。

返回格式

返回ON或OFF。

举例

下面的命令打开ManualIP 模式。

:SYSTem:COMMunicate:LAN:STATic ON

下面的查询返回ON。

:SYSTem:COMMunicate:LAN:STATic?


:SYSTem:COMMunicate:USB:INFormation?

命令格式

:SYSTem:COMMunicate:USB:INFormation?

功能描述

查询USB信息。

返回格式

以字符串形式返回USB信息，如：:USB0::0X1AB1::0X0640::DG41620000::INSTR。


:SYSTem:COMMunicate:USB[:SELF]:CLASs

命令格式

:SYSTem:COMMunicate:USB[:SELF]:CLASs COMPuter|PRINter

:SYSTem:COMMunicate:USB[:SELF]:CLASs?

功能描述

设置 USB Device 接口连接的仪器类型为计算机（COMPuter）或打印机（PRINter）。

查询 USB Device 接口连接的仪器类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | COMPuter|PRINter | COMPuter

说明

DG4000在其后面板提供一个USB Device接口。该接口可以连接计算机（COMPuter）以实现远程控制，或连接打印机（PRINter）以打印屏幕 内容。

返回格式

返回 COMP或 PRIN。

举例

下面的命令将仪器类型设置为计算机（COMPuter）。

:SYSTem:COMMunicate:USB:CLASs COMPuter

下面的查询返回COMP。

:SYSTem:COMMunicate:USB:CLASs?


:SYSTem:CSCopy

命令格式

:SYSTem:CSCopy CH1,CH2|CH2,CH1

功能描述

将CH1（CH2）的配置 状态复制到CH2（CH1） 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | CH1,CH2|CH2,CH1 | CH1,CH2

说明

DG4000支持两个通道间的状态或波形复制功能，即将其中一个通道的状态（参数和输出配置）或任意波形参数复制到另一个通道，或交换两个通道的状态。

状态包括通道的波形（易失波形除外）和波形参数（频率、幅度等）、功能（调制、扫频、脉冲串等）、输出配置（同步、阻抗、极性等）。

耦合状态下不能复制。

举例

下面的命令将 CH1的配置 状态复制到CH2。

:SYST em:CSCopy CH1,CH2


:SYSTem:C WCopy

命令格式

:SYSTem:CWCopy CH1|CH2,CH2|CH1

功能描述

将CH1（CH2）的 任意波数据（不包括波形的参数）复制到CH2（CH1） 。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | CH1,CH2|CH2,CH1 | CH1,CH2

说明

DG4000支持两个通道间的状态或波形复制功能，即将其中一个通道的状态（参数和输出配置）或任意波形参数复制到另一个通道，或交换两个通道的状态。

波形复制仅在两个通道都选择任意波时有效。

耦合状态下不能复制。

举例

下面的命令将 CH1的波形复制到CH2。

:SYSTem:CWCopy CH1,CH2


:SYSTem:ERRor?

命令格式

:SYSTem:ERRor?

功能描述

查询错误事件队列。

返回格式

返回错误事件信息，例如：-113, "Undefined header; keyword cannot be found"。

如果没有错误，则返回：0, "No Error"。


:SYSTem:KLOCk

命令格式

:SYSTem:KLOCk[:STATe] ON|OFF

:SYSTem:KLOCk[:STATe]?

功能描述

远程锁定或解锁前面板。

查询前面板是否处于远程锁定模式。

参数

名称 | 类型 | 范围 | 默认值
—— | 布尔型 | ON|OFF | OFF

说明

前面板的远程锁定模式默认为关闭（OFF），屏幕右上角显示“ [image] ”图标 ，按 Burst 键返回本地操作模式。

前面板远程锁定模式打开时，屏幕右上角显示“ [image] ”图标，按 Burst 键无法返回本地操作模式。

返回格式

返回ON或OFF。

举例

下面的命令打开远程锁定模式。

:SYST em:KLOCk ON

下面的查询返回ON。

:SYSTem:KLOCk?


:SYSTem:LANGuage

命令格式

:SYSTem:LANGuage ENGLish|SCHinese

:SYSTem:LANGuage?

功能描述

设置系统语言为英文（ENGLish）或简体中文 （SCHinese）。

查询系统语言的类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | ENGLish|SCHinese | ENGLish

返回格式

返回ENG或SCH。

举例

下面的命令将系统语言设置为英文。

:SYSTem:LANGuage ENGLish

下面的查询返回 ENGL。

:SYSTem:LANGuage?


:SYSTem:POWeron

命令格式

:SYSTem:POWeron DEFault|LASt

:SYSTem:POWeron?

功能描述

选择在开机时仪器将要使用的配置为默认值（DEFault）或上次值 （LASt）。

查询仪器开机使用的配置类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | DEFault|LASt | DEFault（默认值）

返回格式

返回DEFAULT或LAST。

举例

下面的命令将开机使用的配置类型设置为上次值（LASt） 。

:SYSTem:POWeron LASt

下面的查询返回LAST。

:SYSTem:POWeron?


:SYSTem:POW Set

命令格式

:SYSTem:POWSet AUTO|USER
:SYSTem:POWSet?

功能描述

选择通电时的开机方式为自动(AUTO)或手动(USER)。

查询通电时的开机方式。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | AUTO|USER | AUTO

说明

自动（AUTO）：上电后，仪器自动开机。

手动（USER）：上电后，按下前面板电源开关，仪器开机。

返回格式

返回 AUTO 或 USER。

举例

下面的命令将开机方式设置为手动(USER)。

:SYSTem:POWSet USER

下面的查询返回 USER。

:SYSTem:POWSet?


:SYSTem:P RESet

命令格式

:SYSTem:PRESet DEFault|USER1|USER2|USER3|USER4|USER5|USER6|USER7|USER8|USER9|USER10

功能描述

将系统恢复到出厂默认状态（DEFault）或用户预设状态（USER1、USER2、USER3、USER4、USER5、USER6、USER7、USER8、USER9或USER10）。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | DEFault|USER1|USER2|USER3|USER4|USER5| USER6|USER7|USER8|USER9|USER10 | DEFault

说明

若恢复系统至用户预设状态，该命令仅当指定的存储位置已存储有效的状态文件时有效。

举例

下面的命令将系统恢复到出厂默认状态。

:SYSTem:PRESet DEFault


:SYSTem:RESTART

命令格式

:SYSTem:RESTART

功能描述

重新启动仪器。


:SYSTem:ROSCillator:SOURce

命令格式

:SYSTem:ROSCillator:SOURce INTernal|EXTernal

:SYSTem:ROSCillator:SOURce?

功能描述

设置参考时钟源的类型为内部（INTernal）或外部 （EXTernal） 。

查询参考时钟源的类型。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | INTernal|EXTernal | INTernal

说明

DG4000提供内部10MHz的时钟源，也接受从后面板 [10MHz In/Out] 输入的外部时钟源，还可以从 [10MHz In/Out] 连接器输出时钟源，供其他设备使用。

返回格式

返回INT或EXT。

举例

下面的命令设置参考时钟源类型为外部(该设置在系统检测到外部时钟源时生效)。

:SYSTem:ROSCillator:SOURce EXTernal

下面的查询返回EXT。

:SYSTem:ROSCillator:SOURce?


:SYSTem:SHUTDOWN

命令格式

:SYSTem:SHUTDOWN

功能描述

关机。


:SYSTem:VERSion?

命令格式

:SYSTem:VERSion?

功能描述

查询并返回SCPI版本信息。

返回格式

返回SCPI版本信息，如：1999.0。


TRACe Subsystem

TRACe 命令子系统

[:TRACe]:DATA:DAC16 VOLATILE,<flag>,<binary_block_data>

[:TRACe]:DATA:DAC VOLATILE,[<binary_block_data>|<value>,<value>,<value>...]

[:TRACe]:DATA[:DATA] VOLATILE,<value>{,<value>}

[:TRACe]:DATA:POINts:INTerpolate LINear|OFF
[:TRACe]:DATA:POINts:INTerpolate?

[:TRACe]:DATA:POINts VOLATILE,<value>|MINimum|MAXimum

[:TRACe]:DATA:POINts? VOLATILE[,MINimum|MAXimum]

[:TRACe]:DATA:VALue? VOLATILE,<point>

[:TRACe]:DATA:VALue VOLATILE,<point>,<data>

[:TRACe]:DATA:LOAD? VOLATILE

[:TRACe]:DATA:LOAD? <num>


[:TRACe]:DATA:DAC16

命令格式

[:TRACe]:DATA:DAC16 VOLATILE,<flag>,<binary_block_data>

功能描述

下载大波表到DDRII中。

说明

该命令由两部分构成，一部分为命令字符串，包括“[:TRACe]:DATA:DAC16 VOLATILE,<flag>,”，另一部分为二进制数据，包括“<binary_block_data>”。

<flag>表示数据传输的状态，可设置为CON或END——CON 表示本数据包后还有数据包；END 表示本数据包为最后一个数据包，数据发送结束。

<binary_block_data>表示要 下载的二进制数据，其范围为0000至3FFF，数据长度必须为16 kpts（32 kBytes）。

二进制数据块之前用#号开头。

例如：发送命令:DATA:DAC16 VOLATILE,CON,#532768二进制数

#号之后的5表示数据长度信息32768共占5个字符；32768表示后续二进制数的字节数 。每个波形点占两个字节，所以字节数必须为偶数。

若收到的命令<flag>为END时,仪器自动切换到任意波输出。

若需要下载的波表总长度为16 kpts，且一次性下载至仪器时，用户可以在仪器本地编辑数据。否则不支持本地编辑。


[:TRACe]:DATA:DAC

命令格式

[:TRACe]:DATA:DAC VOLATILE,[<binary_block_data>|<value>,<value>,<value>...]

功能描述

将二进制数据块或十进制DAC值下载到易失性存储器中。

说明

<binary_block_data>为要下载的二进制数据，其范围为0000至3FFF，数据长度为4 Bytes（2 pts）至32768 Bytes（16 kpts）。二进制数据块以#号开头。

例如：发送命令:DATA:DAC VOLATILE,#516384二进制数

#号之后的5表示数据长度信息16384共占5个字符；16384表示后续二进制数的字节数。每个波形点占两个字节，所以字节数必须为偶数。

<value>,<value>,<value>...表示要下载的十进制DAC值。当不以#开头时，则可以用字符串的形式发送十进制DAC值。

例如：发送命令:DATA:DAC VOLATILE,0,16383,8192,0,16383

共发送了5个数据点。

对于点数不足16384的数据，仪器会自动用均匀插值的方式扩展为16384个点。

发送该命令后，仪器自动切换当前通道输出易失波形，同时修改插值方式和可编辑点数。使用该命令下发的数据允许在仪器本地进行编辑。


[:TRACe]:DATA[:DATA]

命令格式

[:TRACe]:DATA[:DATA] VOLATILE,<value>{,<value>}

功能描述

将浮点电压值下载到易失性存储器中，浮点数范围-1到+1，数据长度不超过512 kpts。

参数

名称 | 类型 | 范围 | 默认值
<value> | 连续实型 | -1~1 | ——

说明

每次可以下载1到16384（16k）个点。

-1和1分别与波形的最大值和最小值对应（假设偏移为0）。例如：若幅度设置为5 Vpp，则1对应于2.5 V，-1对应于-2.5 V。

该命令会覆盖易失性存储器中的上一个波形（不生成错误）。

发送该命令后，仪器自动切换当前通道输出易失波形，同时修改插值方式和可编辑点数。使用该命令下发的数据允许在仪器本地进行编辑。

举例

下面的命令下载4个点（-0.5，-0.25，0.25，0.5）到易失性存储器：

:DATA VOLATILE,-0.5,-0.25,0.25,0.5


[:TRACe]:DATA:POINts:INTerpolate

命令格式

[:TRACe]:DATA:POINts:INTerpolate LINear|OFF
[:TRACe]:DATA:POINts:INTerpolate?

功能描述

设置在波形的定义点之间的插值方式。

查询插值方式。

参数

名称 | 类型 | 范围 | 默认值
—— | 关键字 | LINear|OFF | OFF

说明

LINear：线性插值，波形编辑器会用一条直线将两个定义的点连接起来；

OFF：关闭插值方式，波形编辑器将在两点之间保持恒定的电压电平并建立一个阶梯状的波形。

仅当当前输出为易失波形时才可以修改插值类型。

返回格式

返回LINEAR 或 OFF。

举例

下面的命令选择线性插值方式。

:DATA:POINts:INTerpolate LINear

下面的查询返回 LINEAR。

:DATA:POINts:INTerpolate?


[:TRACe]:DATA:POINts?

命令格式

[:TRACe]:DATA:POINts VOLATILE,<value>|MINimum|MAXimum

[:TRACe]:DATA:POINts? VOLATILE[,MINimum|MAXimum]

功能描述

设置编辑波形的初始化点数。

查询编辑波形的初始化点数。

参数

名称 | 类型 | 范围 | 默认值
<value> | 整型 | 2至16384 | ——

说明

该命令自动将当前输出更改为易失波形，并将易失波形初始化为0。

发送该命令后，您可以使用[:TRACe]:DATA:VALue VOLATILE,<point>,<data>命令修改指定点的电压。

返回格式

返回 2 至 16384之间的一个整数 。


[:TRACe]:DATA:VALue?

命令格式

[:TRACe]:DATA:VALue? VOLATILE,<point>

功能描述

查询易失空间中某个点的十进制整数值。

参数

名称 | 类型 | 范围 | 默认值
<point> | 整型 | 1至16384 | ——

说明

该命令仅当当前输出为易失波形时有效。

返回格式

返回一个十进制数值。

举例

下面的命令查询点1的十进制整数值，返回 0。

:DATA:VALue? VOLATILE,1


[:TRACe]:DATA:VALue

命令格式

[:TRACe]:DATA:VALue VOLATILE,<point>,<data>

功能描述

修改易失空间中某个点的十进制整数值。

参数

名称 | 类型 | 范围 | 默认值
<point> | 整型 | 1至16384 | ——
<data> | 整型 | 0至16383 | ——

说明

该命令仅当当前输出为易失波形时有效。

举例

下面的命令将点1修改成10：

:DATA:VALue VOLATILE,1,10

下面的查询返回10。

:DATA:VALue? VOLATILE,1

相关命令

[:TRACe]:DATA:VALue? VOLATILE,<points>


[:TRACe]:DATA:LOAD?

命令格式

[:TRACe]:DATA:LOAD? VOLATILE

[:TRACe]:DATA:LOAD? <num>

功能描述

查询易失性存储器中任意波数据包的个数。

读取易失性存储器中的指定的数据包。

说明

首先发送[:TRACe]:DATA:LOAD? VOLATILE 命令，来获取总数据包的个数，返回一个十进制数值。

然后发送[:TRACe]:DATA:LOAD? <num>命令读取第 num个数据包的数据，其中，num的范围为1至数据包个数值。


编程实例

本章列举了在 Visual C++ 6.0、Visual Basic 6.0和LabVIEW 8.6开发环境中如何使用命令实现信号发生器常用功能的编程实例。这些实例都是基于NI（National Instrument）-VISA（Virtual Instrument Software Architecture）库编程实现的。

NI-VISA是美国国家仪器有限公司根据VISA标准编写的应用程序接口。您可以使用NI-VISA通过USB等仪器总线实现信号发生器与PC的通信。VISA定义了一套软件命令，用户无需了解接口总线如何工作，就可以对仪器进行控制。具体细节可参考NI-VISA的帮助。

本章内容包括：

编程准备

Visual C++ 6.0 编程实例

Visual Basic 6.0 编程实例

LabVIEW 8.6 编程实例


编程准备

首先确认您的电脑上是否已经安装NI的VISA库（可到NI网站下载http://www.ni.com/visa/）。本文中默认安装路径为：C:\Program Files\IVI Foundation\VISA。

本文应用信号发生器的USB Device接口与PC通信。请使用USB数据线将信号发生器后面板的USB Device接口与PC的USB 接口相连。

信号发生器首次与PC正确连接后，接通仪器电源，此时PC上将弹出“硬件更新向导”对话框，请按照向导的提示安装“USB Test and Measurement Device (IVI)”（安装步骤如下）。

1. 选择“从列表或指定位置安装（高级）”；

2. 点击“下一步”；

3. 选择“不要搜索。我要自己选择要安装的驱动程序”；

4. 点击“下一步”；

5. 选择“USB Test and Measurement Device (IVI)”；

6. 点击“下一步”；

7. 安装过程结束后，点击“完成”。

至此，编程准备工作结束。下面将详细介绍在Visual C++ 6.0，Visual Basic 6.0和LabVIEW 8.6开发环境中的编程实例。


Visual C++ 6.0 编程实例

进入 Visual C++6.0 编程环境，按照下列步骤操作：

1. 建立一个基于对话框的 MFC 的工程。

2. 打开 Project→Settings 中的Link选项卡，在Object/library modules中手动添加visa32.lib。

3. 打开 Tools→Options 中的Directories 选项卡。

在 Show directories for中选择Include files，双击Directories选框中 红色箭头处，添加Include的路径：C:\Program Files\IVI Foundation\VISA\WinNT\include。

在 Show directories for中选择Library files，双击Directories选框中 红色箭头处，添加Lib的路径：C:\Program Files\IVI Foundation\VISA\WinNT\lib\msc。

注：至此，VISA库添加完毕。

4. 添加 Text、Edit和Button 控件。布局如下所示：

5. 添加控件变量。

打开 View→ClassWizard的Member Variables 选项卡，添加下述三个变量：

仪器地址CString m_strInstrAddr

命令CString m_strCommand

返回值CString m_strResult

6. 封装 VISA 的读和写操作。

1) 对 VISA 的写操作进行封装便于操作。

bool CDemoForDGDlg::InstrWrite(CString strAddr, CString strContent) //Write //operation

{

ViSession defaultRM,instr;

ViStatus status;

ViUInt32 retCount;

char * SendBuf = NULL;

char * SendAddr = NULL;

bool bWriteOK = false;

CString str;

// Change the address's data style from CString to char*

SendAddr = strAddr.GetBuffer(strAddr.GetLength());

strcpy(SendAddr,strAddr);

strAddr.ReleaseBuffer();

// Change the command's data style from CString to char*

SendBuf = strContent.GetBuffer(strContent.GetLength());

strcpy(SendBuf,strContent);

strContent.ReleaseBuffer();

//open a VISA resource

status = viOpenDefaultRM(&defaultRM);

if (status < VI_SUCCESS)

{

AfxMessageBox("No VISA resource was opened!");

return false;

}

status = viOpen(defaultRM, SendAddr, VI_NULL, VI_NULL, &instr);

//Write command to the instrument

status = viWrite(instr, (unsigned char *)SendBuf, strlen(SendBuf), &retCount);

//Close the system

status = viClose(instr);

status = viClose(defaultRM);

return bWriteOK;

}

2) 对 VISA 的读操作进行封装便于操作。

bool CDemoForDGDlg::InstrRead(CString strAddr, CString *pstrResult) //Read //operation

{

ViSession defaultRM,instr;

ViStatus status;

ViUInt32 retCount;

char * SendAddr = NULL;

unsigned char RecBuf[MAX_REC_SIZE];

bool bReadOK = false;

CString str;

// Change the address's data style from CString to char*

SendAddr = strAddr.GetBuffer(strAddr.GetLength());

strcpy(SendAddr,strAddr);

strAddr.ReleaseBuffer();

memset(RecBuf,0,MAX_REC_SIZE);

//Open a VISA resource

status = viOpenDefaultRM(&defaultRM);

if (status < VI_SUCCESS)

{

// Error Initializing VISA...exiting

AfxMessageBox("No VISA resource was opened!");

return false;

}

//Open the instrument

status = viOpen(defaultRM, SendAddr, VI_NULL, VI_NULL, &instr);

//Read from the instrument

status = viRead(instr, RecBuf, MAX_REC_SIZE, &retCount);

//close the system

status = viClose(instr);

status = viClose(defaultRM);

(*pstrResult).Format("%s",RecBuf);

return bReadOK;

}

7. 增加控件消息响应代码。

1) 连接仪器

void CDemoForDGDlg::OnBtConnectInstr() // Connect to the instrument

{

// TODO: Add your control notification handler code here

ViStatus status;

ViSession defaultRM;

ViString expr = "?*";

ViPFindList findList = new unsigned long;

ViPUInt32 retcnt = new unsigned long;

ViChar instrDesc[1000];

CString strSrc = "";

CString strInstr = "";

unsigned long i = 0;

bool bFindDG = false;

status = viOpenDefaultRM(&defaultRM);

if (status < VI_SUCCESS)

{

// Error Initializing VISA...exiting

MessageBox("No VISA instrument was opened ! ");

return ;

}

memset(instrDesc,0,1000);

// Find resource

status = viFindRsrc(defaultRM,expr,findList, retcnt, instrDesc);

for (i = 0;i < (*retcnt);i++)

{

// Get instrument name

strSrc.Format("%s",instrDesc);

InstrWrite(strSrc,"*IDN?");

::Sleep(200);

InstrRead(strSrc,&strInstr);

// If the instrument(resource) belongs to the DG series then jump out //from the loop

strInstr.MakeUpper();

if (strInstr.Find("DG") >= 0)

{

bFindDG = true;

m_strInstrAddr = strSrc;

break;

}

//Find next instrument

status = viFindNext(*findList,instrDesc);

}

if (bFindDG == false)

{

MessageBox("Didn’t find any DG!");

}

UpdateData(false);

}

2) 写操作

void CDemoForDGDlg::OnBtWrite() //Write operation

{

// TODO: Add your control notification handler code here

UpdateData(true);

if (m_strInstrAddr.IsEmpty())

{

MessageBox("Please connect to the instrument first!");

}

InstrWrite(m_strInstrAddr,m_strCommand);

m_strResult.Empty();

UpdateData(false);

}

3) 读操作

void CDemoForDGDlg::OnBtRead() //Read operation

{

// TODO: Add your control notification handler code here

UpdateData(true);

InstrRead(m_strInstrAddr,&m_strResult);

UpdateData(false);

}

8. 运行结果。

1) 点击“Connect”寻找信号发生器；

2) 在“Command”编辑框中输入“*IDN?”；

3) 点击“Write”将命令写入信号发生器中；

4) 点击“Read”读取返回值。

运行结果如下图所示。


Visual Basic 6.0 编程实例

进入 Visual Basic 6.0 编程环境，按照下列步骤操作：

1. 建立一个标准应用程序工程（Standard EXE）。

2. 打开 Project→Add File…，添加visa32.bas到工程中，visa32.bas模块包含了所有VISA 库中的函数和常数声明。

随后增加 Declare Sub Sleep Lib "kernel32" (ByVal dwMilliseconds As Long)声明语句到visa32.bas中，也可以新建模块来声明Sleep 函数。

3. 添加 Text、Edit和Button 控件。布局如下所示

4. 封装 VISA 的读和写操作

1) 对 VISA 的写操作进行封装便于操作。

'-----------------------------------------------------------

'Function Name：InstrWrite

'Function： Send command to the instrument

'Input： rsrcName,instrument(resource) name

strCmd,Command

'-----------------------------------------------------------

Public Sub InstrWrite(rsrcName As String, strCmd As String)

Dim status As Long

Dim dfltRM As Long

Dim sesn As Long

Dim rSize As Long

'Initialize the system

status = viOpenDefaultRM(dfltRM)

'Failed to initialize the system

If (status < VI_SUCCESS) Then

MsgBox " No VISA resource was opened！"

Exit Sub

End If

‘Open the VISA instrument

status = viOpen(dfltRM, rsrcName, VI_NULL, VI_NULL, sesn)

'Failed to open the instrument

If (status < VI_SUCCESS) Then

MsgBox "Failed to open the instrument！"

Exit Sub

End If

'Write command to the instrument

status = viWrite(sesn, strCmd, Len(strCmd), rSize)

'Failed to write to the instrument

If (status < VI_SUCCESS) Then

MsgBox " Faild to write to the instrument！"

Exit Sub

End If

'Close the system

status = viClose(sesn)

status = viClose(dfltRM)

End Sub

2) 对 VISA 的读操作进行封装便于操作。

'-----------------------------------------------------------

'Function Name：InstrRead

'Function： Read the return value from the instrument

'Input： rsrcName,Resource name

'Return：The string gotten from the instrument

'-----------------------------------------------------------

Public Function InstrRead(rsrcName As String) As String

Dim status As Long

Dim dfltRM As Long

Dim sesn As Long

Dim strTemp0 As String * 256

Dim strTemp1 As String

Dim rSize As Long

'Begin by initializing the system

status = viOpenDefaultRM(dfltRM)

'Initial failed

If (status < VI_SUCCESS) Then

MsgBox " Failed to open the instrument! "

Exit Function

End If

'Open the instrument

status = viOpen(dfltRM, rsrcName, VI_NULL, VI_NULL, sesn)

'Open instrument failed

If (status < VI_SUCCESS) Then

MsgBox " Failed to open the instrument! "

Exit Function

End If

' Read from the instrument

stasus = viRead(sesn, strTemp0, 256, rSize)

' Read failed

If (status < VI_SUCCESS) Then

MsgBox " Failed to read from the instrument! "

Exit Function

End If

'Close the system

status = viClose(sesn)

status = viClose(dfltRM)

' Remove the space at the end of the string

strTemp1 = Left(strTemp0, rSize)

InstrRead = strTemp1

End Function

5. 增加控件事件代码

1) 连接仪器

' Connect to the instrument

Private Sub CmdConnect_Click()

Const MAX_CNT = 200

Dim status As Long

Dim dfltRM As Long

Dim sesn As Long

Dim fList As Long

Dim buffer As String * MAX_CNT, Desc As String * 256

Dim nList As Long, retCount As Long

Dim rsrcName(19) As String * VI_FIND_BUFLEN, instrDesc As String * VI_FIND_BUFLEN

Dim i, j As Long

Dim strRet As String

Dim bFindDG As Boolean

‘Initialize the system

status = viOpenDefaultRM(dfltRM)

' Initialize failed

If (status < VI_SUCCESS) Then

MsgBox " No VISA resource was opened ！"

Exit Sub

End If

' Find instrument resource

Call viFindRsrc(dfltRM, "USB?*INSTR", fList, nList, rsrcName(0))

' Get the list of the instrument(resource)

strRet = ""

bFindDG = False

For i = 0 To nList - 1

' Get the instrument name

InstrWrite rsrcName(i), "*IDN?"

Sleep 200

strRet = InstrRead(rsrcName(i))

' Continue to switch the resource until find a DG instrument

strRet = UCase(strRet)

j = InStr(strRet, "DG")

If (j >= 0) Then

bFindDG = True

Exit For

End If

Call viFindNext(fList + i - 1, rsrcName(i))

Next i

'Dispaly

If (bFindDG = True) Then

TxtInsAddr.Text = rsrcName(i)

Else

TxtInsAddr.Text = ""

End If

End Sub

2) 写操作

'Write the command to the instrument

Private Sub CmdWrite_Click()

If (TxtInsAddr.Text = "") Then

MsgBox ("Please write the instrument address！")

End If

InstrWrite TxtInsAddr.Text, TxtCommand.Text

End Sub

3) 读操作

'Read the return value from the instrument

Private Sub CmdRead_Click()

Dim strTemp As String

strTemp = InstrRead(TxtInsAddr.Text)

TxtReturn.Text = strTemp

End Sub

6. 运行结果

1) 点击“Connect”寻找信号发生器；

2) 在“Command”编辑框中输入“*IDN?”；

3) 点击“Write”将命令写入信号发生器中；

4) 点击“Read”读取返回值。

运行结果如下图所示：


LabVIEW 8.6 编程实例

进入 Labview 8.6 编程环境，按照下列步骤操作：

1. 创建事件结构

2. 添加事件（包括读操作，写操作，连接仪器和退出）

3. 连接仪器

4. 写操作（包括出错判断）

5. 读操作（包括出错处理）

6. 退出

7. 运行结果


命令速查 A-Z

*IDN?

*RCL USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

*RST

*SAV USER1|USER2|USER3|USER4|USER5|USER6|USER7|USER8|USER9|USER10

*TRG

C

:COUNter:ATTenuation 1X|10X
:COUNter:ATTenuation?

:COUNter:AUTO

:COUNter:COUPing AC|DC
:COUNter:COUPing?

:COUNter:GATEtime AUTO|USER1|USER2|USER3|USER4|USER5|USER6
:COUNter:GATEtime?

:COUNter:HF ON|OFF

:COUNter:HF?

:COUNter:IMPedance 50|1M
:COUNter:IMPedance?

:COUNter:LEVE <value>|MINimum|MAXimum
:COUNter:LEVE? [MINimum|MAXimum]

:COUNter:MEASure?
:COUNter:SENSitive <value>|MINimum|MAXimum
:COUNter:SENSitive? [MINimum|MAXimum]

:COUNter[:STATe] ON|OFF
:COUNter[:STATe]?
:COUNter:STATIstics:CLEAr
:COUNter:STATIstics:DISPlay DIGITAL|CURVE
:COUNter:STATIstics:DISPlay?

:COUNter:STATIstics[:STATe] ON|OFF
:COUNter:STATIstics[:STATe]?

:COUPling:AMPL:DEViation <deviation>
:COUPling:AMPL:DEViation?

:COUPling:AMPL[:STATe] ON|OFF
:COUPling:AMPL[:STATe]?

:COUPling:CHannel:BASE CH1|CH2
:COUPling:CHannel:BASE?

:COUPling:FREQuency:DEViation <deviation>
:COUPling:FREQuency:DEViation?
:COUPling:FREQuency[:STATe] ON|OFF
:COUPling:FREQuency[:STATe]?

:COUPling:PHASe:DEViation <deviation>
:COUPling:PHASe:DEViation?
:COUPling:PHASe[:STATe] ON|OFF
:COUPling:PHASe[:STATe]?

:COUPling[:STATe] ON|OFF
:COUPling[:STATe]?

D

:DISPlay:BRIGhtness <brightness>|MINimum|MAXimum
:DISPlay:BRIGhtness? [MINimum|MAXimum]

:DISPlay:SAVer:IMMediate
:DISPlay:SAVer[:STATe] ON|OFF
:DISPlay:SAVer[:STATe]?

H

:HCOPy:SDUMp:DATA?

M

:MEMory:STATe:DELete USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

:MEMory:STATe:LOCK USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10,ON|OFF
:MEMory:STATe:LOCK? USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

:MEMory:STATe:VALid? USER1|USER2|USER3|USER4|USER5|USER|6USER7|USER8|USER9|USER10

:MMEMory:CATalog?
:MMEMory:CDIRectory <directory_name>
:MMEMory:CDIRectory?
:MMEMory:COPY <directory_name>,<file_name>

:MMEMory:DELete <file_name>
:MMEMory:LOAD <file_name>
:MMEMory:MDIRectory <dir_name>

:MMEMory:RDIRectory?
:MMEMory:STORe <file_name>

O

:OUTPut[<n>]:IMPedance <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:IMPedance? [MINimum|MAXimum]

:OUTPut[<n>]:LOAD <ohms>|INFinity|MINimum|MAXimum

:OUTPut[<n>]:LOAD? [MINimum|MAXimum]

:OUTPut[<n>]:NOISe:SCALe <percent>|MINimum|MAXimum
:OUTPut[<n>]:NOISe:SCALe? [MINimum|MAXimum]

:OUTPut[<n>]:NOISe[:STATe] ON|OFF
:OUTPut[<n>]:NOISe[:STATe]?

:OUTPut[<n>]:POLarity NORMal|INVerted
:OUTPut[<n>]:POLarity?

:OUTPut[<n>][:STATe] ON|OFF
:OUTPut[<n>][:STATe]?

:OUTPut[<n>]:SYNC:POLarity POSitive|NEGative
:OUTPut[<n>]:SYNC:POLarity?

:OUTPut[<n>]:SYNC[:STATe] ON|OFF
:OUTPut[<n>]:SYNC[:STATe]?

P

:PA:GAIN 1X|10X

:PA:GAIN?

:PA:OFFSet[:STATe] ON|OFF

:PA:OFFSet[:STATe]?

:PA:OFFSet:VALUe <value>|MINimum|MAXimum

:PA:OFFSet:VALUe? [MINimum|MAXimum]

:PA:OUTPut:POLarity NORMal|INVerted

:PA:OUTPut:POLarity?

:PA:SAVE

:PA[:STATe] ON|OFF

:PA[:STATe]?

S

[:SOURce<n>]:APPLy:CUSTom[<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy:HARMonic [<freq>[,<amp>[,<offset>[,<phase>]]]]

[:SOURce<n>]:APPLy:NOISe [<amp>[,<offset>]]

[:SOURce<n>]:APPLy:PULSe [<freq>[,<amp>[,<offset>[,<delay>]]]]

[:SOURce<n>]:APPLy:RAMP [<freq>[,<amp>[,<offset>[,<phase>]]]]

[:SOURce<n>]:APPLy:SINusoid [<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy:SQUare [<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy:USER [<freq>[,<amp>[,<offset>[,<phase>]]]]
[:SOURce<n>]:APPLy?

[:SOURce<n>]:BURSt:GATE:POLarity NORMal|INVerted
[:SOURce<n>]:BURSt:GATE:POLarity?

[:SOURce<n>]:BURSt:INTernal:PERiod <period>|MINimum|MAXimum
[:SOURce<n>]:BURSt:INTernal:PERiod? [MINimum|MAXimum]

[:SOURce<n>]:BURSt:MODE TRIGgered|GATed|INFinity
[:SOURce<n>]:BURSt:MODE?
[:SOURce<n>]:BURSt:NCYCles <cycles>|MINimum|MAXimum
[:SOURce<n>]:BURSt:NCYCles? [MINimum|MAXimum]

[:SOURce<n>]:BURSt:PHASe <phase>|MINimum|MAXimum
[:SOURce<n>]:BURSt:PHASe? [MINimum|MAXimum]

[:SOURce<n>]:BURSt[:STATe] ON|OFF
[:SOURce<n>]:BURSt[:STATe]?
[:SOURce<n>]:BURSt:TDELay <delay>|MINimum|MAXimum
[:SOURce<n>]:BURSt:TDELay? [MINimum|MAXimum]

[:SOURce<n>]:BURSt:TRIGger[:IMMediate]
[:SOURce<n>]:BURSt:TRIGger:SLOPe POSitive|NEGative
[:SOURce<n>]:BURSt:TRIGger:SLOPe?

[:SOURce<n>]:BURSt:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:BURSt:TRIGger:SOURce?

[:SOURce<n>]:BURSt:TRIGger:TRIGOut OFF|POSitive|NEGative
[:SOURce<n>]:BURSt:TRIGger:TRIGOut?

[:SOURce<n>]:FREQuency:CENTer <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:CENTer? [MINimum|MAXimum]

[:SOURce<n>]:FREQuency[:FIXed] <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency[:FIXed]? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:SPAN <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:SPAN? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STARt <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STARt? [MINimum|MAXimum]
[:SOURce<n>]:FREQuency:STOP <frequency>|MINimum|MAXimum
[:SOURce<n>]:FREQuency:STOP? [MINimum|MAXimum]

[:SOURce<n>]:FUNCtion:ARB:STEP

[:SOURce<n>]:FUNCtion:RAMP:SYMMetry <symmetry>|MINimum|MAXimum
[:SOURce<n>]:FUNCtion:RAMP:SYMMetry? [MINimum|MAXimum]

[:SOURce<n>]:FUNCtion[:SHAPe] <wave>
[:SOURce<n>]:FUNCtion[:SHAPe]?

[:SOURce<n>]:FUNCtion:SQUare:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:FUNCtion:SQUare:DCYCle? [MINimum|MAXimum]

[:SOURce<n>]:HARMonic:AMPL <sn>,<value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:AMPL? <sn>[,MINimum|MAXimum]

[:SOURce<n>]:HARMonic:ORDEr <value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:ORDEr? [MINimum|MAXimum]

[:SOURce<n>]:HARMonic:PHASe <sn>,<value>|MINimum|MAXimum
[:SOURce<n>]:HARMonic:PHASe? <sn>[,MINimum|MAXimum]

[:SOURce<n>]:HARMonic:TYPe EVEN|ODD|ALL|USER
[:SOURce<n>]:HARMonic:TYPe?

[:SOURce<n>]:HARMonic:USER <user>
[:SOURce<n>]:HARMonic:USER?

[:SOURce<n>]:MARKer:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MARKer:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MARKer[:STATE] ON|OFF
[:SOURce<n>]:MARKer[:STATe]?

[:SOURce<n>]:MOD[:STATe] ON|OFF
[:SOURce<n>]:MOD[:STATe]?

[:SOURce<n>]:MOD:TYPe AM|FM|PM|ASK|FSK|PSK|PWM|BPSK|QPSK|3FSK|4FSK|OSK
[:SOURce<n>]:MOD:TYPe?

[:SOURce<n>]:MOD:AM[:DEPTh] <depth>|MINimum|MAXimum
[:SOURce<n>]:MOD:AM[:DEPTh]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:AM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:AM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:AM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:AM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:AM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:AM:SOURce?

[:SOURce<n>]:MOD:FM[:DEViation] <deviation>|MINimum|MAXimum
[:SOURce<n>]:MOD:FM[:DEViation]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:FM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:FM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:FM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:FM:SOURce?

[:SOURce<n>]:MOD:PM[:DEViation] <deviation>|MINimum|MAXimum
[:SOURce<n>]:MOD:PM[:DEViation]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:PM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:PM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:PM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PM:SOURce?

[:SOURce<n>]:MOD:ASKey:AMPLitude <amplitude>|MINimum|MAXimum
[:SOURce<n>]:MOD:ASKey:AMPLitude? [MINimum|MAXimum]

[:SOURce<n>]:MOD:ASKey:INTernal[:RATE] <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:ASKey:INTernal[:RATE]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:ASKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:ASKey:SOURce?

[:SOURce<n>]:MOD:ASKey:POLarity POSitive|NEGative
[:SOURce<n>]:MOD:ASKey:POLarity?

[:SOURce<n>]:MOD:FSKey[:FREQuency] <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:FSKey[:FREQuency]? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:FSKey:INTernal:RATE? [MINimum|MAXimum]

[:SOURce<n>]:MOD:FSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:FSKey:SOURce?

[:SOURce<n>]:MOD:FSKey:POLarity POSitive|NEGative
[:SOURce<n>]:MOD:FSKey:POLarity?

[:SOURce<n>]:MOD:PSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:PSKey:INTernal:RATE? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PSKey:PHASe <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:PSKey:PHASe? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PSKey:POLarity POSitive|NEGative
[:SOURce<n>]:MOD:PSKey:POLarity?

[:SOURce<n>]:MOD:PSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PSKey:SOURce?

[:SOURce<n>]:MOD:BPSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:BPSKey:INTernal:RATE? [MINimum|MAXimum]
[:SOURce<n>]:MOD:BPSKey:PHASe <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:BPSKey:PHASe? [MINimum|MAXimum]
[:SOURce<n>]:MOD:BPSKey:DATA 01|10|PN15|PN21
[:SOURce<n>]:MOD:BPSKey:DATA?

[:SOURce<n>]:MOD:QPSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:INTernal:RATE? [MINimum|MAXimum]
[:SOURce<n>]:MOD:QPSKey:PHASe1 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe1? [MINimum|MAXimum]
[:SOURce<n>]:MOD:QPSKey:PHASe2 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe2? [MINimum|MAXimum]
[:SOURce<n>]:MOD:QPSKey:PHASe3 <phase>|MINimum|MAXimum
[:SOURce<n>]:MOD:QPSKey:PHASe3? [MINimum|MAXimum]
[:SOURce<n>]:MOD:QPSKey:DATA PN15|PN21
[:SOURce<n>]:MOD:QPSKey:DATA?

[:SOURce<n>]:MOD:3FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:3FSKey:INTernal:RATE? [MINimum|MAXimum]
[:SOURce<n>]:MOD:3FSKey[:FREQuency] <n>,<frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:3FSKey[:FREQuency]? <n>[,MINimum|MAXimum]

[:SOURce<n>]:MOD:4FSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:4FSKey:INTernal:RATE? [MINimum|MAXimum]
[:SOURce<n>]:MOD:4FSKey[:FREQuency] <n>,<frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:4FSKey[:FREQuency]? <n>[,MINimum|MAXimum]

[:SOURce<n>]:MOD:OSKey:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:OSKey:SOURce?
[:SOURce<n>]:MOD:OSKey:INTernal:RATE <rate>|MINimum|MAXimum
[:SOURce<n>]:MOD:OSKey:INTernal:RATE? [MINimum|MAXimum]
[:SOURce<n>]:MOD:OSKey:TIME <time>|MINimum|MAXimum
[:SOURce<n>]:MOD:OSKey:TIME? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PWM:INTernal:FREQuency <frequency>|MINimum|MAXimum
[:SOURce<n>]:MOD:PWM:INTernal:FREQuency? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PWM:INTernal:FUNCtion SINusoid|SQUare|TRIangle|RAMP|NRAMp|NOISe|USER

[:SOURce<n>]:MOD:PWM:INTernal:FUNCtion?

[:SOURce<n>]:MOD:PWM:SOURce INTernal|EXTernal
[:SOURce<n>]:MOD:PWM:SOURce?

[:SOURce<n>]:MOD:PWM[:DEViation]:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:MOD:PWM[:DEViation]:DCYCle? [MINimum|MAXimum]

[:SOURce<n>]:MOD:PWM[:DEViation][:WIDTh] <deviation>|MINimum|MAXimum
[:SOURce<n>]:MOD:PWM[:DEViation][:WIDTh]? [MINimum|MAXimum]

[:SOURce<n>]:PERiod[:FIXed] <period>
[:SOURce<n>]:PERiod[:FIXed]?

[:SOURce<n>]:PHASe[:ADJust] <phase>|MINimum|MAXimum
[:SOURce<n>]:PHASe[:ADJust]? [MINimum|MAXimum]

[:SOURce<n>]:PHASE:INITiate

[:SOURce<n>]:PULSe:DCYCle <percent>|MINimum|MAXimum
[:SOURce<n>]:PULSe:DCYCle? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:DELay <delay>|MINimum|MAXimum
[:SOURce<n>]:PULSe:DELay? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:HOLD WIDTh|DUTY
[:SOURce<n>]:PULSe:HOLD?

[:SOURce<n>]:PULSe:TRANsition[:LEADing] <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:TRANsition[:LEADing]? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:TRANsition:TRAiling <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:TRANsition:TRAiling? [MINimum|MAXimum]

[:SOURce<n>]:PULSe:WIDTh <seconds>|MINimum|MAXimum
[:SOURce<n>]:PULSe:WIDTh? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:HTIMe:STARt <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:HTIMe:STARt? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:HTIMe:STOP <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:HTIMe:STOP? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:RTIMe <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:RTIMe? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:SPACing LINear|LOGarithmic|STEp
[:SOURce<n>]:SWEep:SPACing?

[:SOURce<n>]:SWEep:STATe ON|OFF
[:SOURce<n>]:SWEep:STATe?

[:SOURce<n>]:SWEep:STEP <steps>|MINimum|MAXimum

[:SOURce<n>]:SWEep:STEP? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:TIME <seconds>|MINimum|MAXimum
[:SOURce<n>]:SWEep:TIME? [MINimum|MAXimum]

[:SOURce<n>]:SWEep:TRIGger[:IMMediate]

[:SOURce<n>]:SWEep:TRIGger:SLOPe POSitive|NEGative
[:SOURce<n>]:SWEep:TRIGger:SLOPe?

[:SOURce<n>]:SWEep:TRIGger:SOURce INTernal|EXTernal|MANual
[:SOURce<n>]:SWEep:TRIGger:SOURce?

[:SOURce<n>]:SWEep:TRIGger:TRIGOut OFF|POSitive|NEGative
[:SOURce<n>]:SWEep:TRIGger:TRIGOut?

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate][:AMPLitude] <amplitude>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate][:AMPLitude]? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:HIGH? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:LOW? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:OFFSet <voltage>|MINimum|MAXimum
[:SOURce<n>]:VOLTage[:LEVel][:IMMediate]:OFFSet? [MINimum|MAXimum]

[:SOURce<n>]:VOLTage:UNIT VPP|VRMS|DBM
[:SOURce<n>]:VOLTage:UNIT?

:SYSTem:BEEPer[:IMMediate]

:SYSTem:BEEPer:STATe ON|OFF
:SYSTem:BEEPer:STATe?

:SYSTem:COMMunicate:LAN:AUTOip[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:AUTOip[:STATe]?

:SYSTem:COMMunicate:LAN:DHCP[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:DHCP[:STATe]?

:SYSTem:COMMunicate:LAN:DNS <address>
:SYSTem:COMMunicate:LAN:DNS?

:SYSTem:COMMunicate:LAN:GATEway <address>
:SYSTem:COMMunicate:LAN:GATEway?

:SYSTem:COMMunicate:LAN:IPADdress <ip_addr>
:SYSTem:COMMunicate:LAN:IPADdress?

:SYSTem:COMMunicate:LAN:MAC?

:SYSTem:COMMunicate:LAN:SMASk <mask>
:SYSTem:COMMunicate:LAN:SMASk?

:SYSTem:COMMunicate:LAN:STATic[:STATe] ON|OFF
:SYSTem:COMMunicate:LAN:STATic[:STATe]?

:SYSTem:COMMunicate:USB:INFormation?

:SYSTem:COMMunicate:USB[:SELF]:CLASs COMPuter|PRINter
:SYSTem:COMMunicate:USB[:SELF]:CLASs?

:SYSTem:CSCopy CH1|CH2,CH2|CH1

:SYSTem:CWCopy CH1|CH2,CH2|CH1

:SYSTem:ERRor?

:SYSTem:KLOCk[:STATe] ON|OFF
:SYSTem:KLOCk[:STATe]?

:SYSTem:LANGuage ENGLish|SCHinese
:SYSTem:LANGuage?

:SYSTem:POWeron DEFault|LAST
:SYSTem:POWeron?

:SYSTem:POWSet AUTO|USER
:SYSTem:POWSet?

:SYSTem:PRESet DEFault|USER1|USER2|USER3|USER4|USER5|USER6|USER7|USER8|USER9|USER10

:SYSTem:RESTART

:SYSTem:ROSCillator:SOURce INTernal|EXTernal
:SYSTem:ROSCillator:SOURce?

:SYSTem:SHUTDOWN

:SYSTem:VERSion?

T

[:TRACe]:DATA:DAC16 VOLATILE,<flag>,<binary_block_data>

[:TRACe]:DATA:DAC VOLATILE,[<binary_block_data>|<value>,<value>,<value>...]

[:TRACe]:DATA[:DATA] VOLATILE,<value>{,<value>}

[:TRACe]:DATA:POINts:INTerpolate LINear|OFF
[:TRACe]:DATA:POINts:INTerpolate?

[:TRACe]:DATA:POINts VOLATILE,<value>|MINimum|MAXimum

[:TRACe]:DATA:POINts? VOLATILE[,MINimum|MAXimum]

[:TRACe]:DATA:VALue? VOLATILE,<point>

[:TRACe]:DATA:VALue VOLATILE,<point>,<data>

[:TRACe]:DATA:LOAD? VOLATILE

[:TRACe]:DATA:LOAD? <num>